Christian Schwaderer | 3 Aug 08:45 2015

After Java Update eXist doesn't start anymore

Dear all,

last week I updated to Java 8 Update 51 (Build 1.8.0_51-b16). Now eXist doesn't start anymore. (OS is
Windows 7 64 bit.)

Executing start.jar leads to only one thing: Some seconds after clicking on it, I have a new process in my
list: "javaw.exe *32  37.248 K  Java(TM) Platform SE binary". Another few seconds later, this process
is gone again. Besides from that, nothing happens. No entry in any log in
EXIST_HOME/webapp/WEB-INF/logs. Nothing.

I've tried eXist 2.2 and also 3.0RC1 - to no avail. Re-installing didn't help either. The installtion (and
un-installing) process runs through normally, though.

What do you recommend me to do? Try downgrading Java?

Thanks in advance and best regards,
mountainbiker | 31 Jul 09:00 2015

How would you scrape web pages with dynamic content?

Is there a good way to scrape web pages with dynamic content coming from
JQuery AJAX and Apache SSI?

Currently, I am having to read the starting page with httpclient:get,
parsing for the dynamic calls, make the the calls for this additional
dynamic data (again with httpclient:get), and then reassemble all the
retrieved parts.

View this message in context:
Sent from the exist-open mailing list archive at

Ted Hickox | 30 Jul 19:34 2015

I posted a video about XMLHttpRequest

As a thank you for all your assistance, I posted a video to show everyone how to use XMLHttpRequest.  I hope this will make eXist the preferred database software.

Exist-open mailing list
Exist-open <at>
Paterson, Duncan | 30 Jul 14:50 2015

Index not being used

Dear list, 

I m not sure whats going on here. I have a TEI file at:

the collection.xconf is at

    <index xmlns:tei="">
        <!--TEI for wsc_persons-->
            <text qname="tei:note"/>
            <create qname="tei:person" type="xs:string"/>
            <create qname="tei:persName" type="xs:string"/>
            <create qname="tei:orgName" type="xs:string"/>
            <create qname="tei:placeName" type="xs:string"/>
            <create qname="tei:listBibl" type="xs:string"/>
            <create qname="tei:title" type="xs:string"/>
            <create qname="tei:idno" type="xs:string"/>
            <create qname=" <at> n" type="xs:string"/>
            <create qname="tei:date" type="xs:string"/>

eXide reports the following error when I perform a reindex. 

which is odd, but looking at monex the index is there and populated.

yet when i run queries against the files in the collection the index isn’t used. This is on eXist-2.2.
i tried with both old and new range but no luck. I ran a number of queries but none uses any indexes, here is short test one.

xquery version "3.0";

declare namespace tei="";
declare variable $bio := doc('/db/resources/commons/WSC/biodb/wsc_persons.xml');

$bio//tei:persName[ft:query(., "王季烈”)]

Am I overlooking something obvious here?  

Exist-open mailing list
Exist-open <at>
NueMeta | 29 Jul 06:15 2015

Box API Multi-part Post in XQuery

I’m trying to send a request that will upload a file to a Box storage account using the httpclient module.  The Box API specifies that it requires a multi-part POST request.  Below is the equivalent request in cURL:

curl \
 -H "Authorization: Bearer ACCESS_TOKEN" -X POST \
 -F attributes='{"name":"tigers.jpeg", "parent":{"id":"11446498"}}' \
 -F file= <at> myfile.jpg

So far I have not been successful in sending Box a POST that does not return a status code of 400. I suspect it is a problem with my use of the httpclient module. 

Can anyone give me some insight on how to properly send a multi-part POST request in XQuery?

Here is what I have:

let $upload-file-url := xs:anyURI('')
let $content2 := 
<httpclient:fields xmlns:httpclient="">
<httpclient:field name="attributes" value=“{“name”:"tigers.jpeg”,”parent”:{“id”:"11446498"}}" type="json"/>
<httpclient:field name="file" value="myfile.jpg" type="binary"/>

let $pr-header := 
<header name="Authorization" value="Bearer ACCESS_TOKEN"/>

let $upload-file-request := oauth2-box:post-form-request($upload-file-url, $content2, (), $pr-header)

Is $content2 equivalent to the JSON listed in the Box API? Is there something I am coding incorrectly?


Exist-open mailing list
Exist-open <at>
Alberto Simões | 28 Jul 20:31 2015

RPC (continuation on the previous e-mail)


For me there are some inconsistencies from REST and RPC APIs, that could be better (I think).

you get a set of strings concatenated (can make sense):

<exist:result exist:hits="2" exist:start="1" exist:count="2">CavaloarCavalo</exist:result>

Something like:[.//orth[contains%28.,%22avalo%22%29]]%20!%20fn:base-uri%28.%29
returns a XML document with some extra info:

<exist:result exist:hits="2" exist:start="1" exist:count="2"><exist:value exist:type="xs:anyURI">/db/dicaberto/026841.xml</exist:value><exist:value exist:type="xs:anyURI">/db/dicaberto/026840.xml</exist:value></exist:result>

But when using the RPC retrieveResults method, the second query returns:

<exist:result xmlns:exist="" hitCount="2">/db/dicaberto/026841.xml/db/dicaberto/026840.xml</exist:result>

Is this supposed to be like this, or am I doing something wrong?

Thank you

Alberto Simões
Exist-open mailing list
Exist-open <at>
p_j_anderson | 28 Jul 15:54 2015

Query access via http (session login)

In eXist 2.1, if I use j_security_check and the JAAS login module to log in to my application, eXist
correctly allows access via the user and groups to xquery and other resources during an http session. This
works whether I make the request via a /rest/ URL or a URL rewriting path (and of course also works when I use
basic auth instead).

But if (with 2.1 and 2.2) I log the user in with xmldb:login(), queries can only be executed via http if they
have -public- execute permission - even if the user in the http session has privileges higher than guest.
Otherwise the basic auth prompt pops up.
However, the user's identity and groups are available -inside- queries during an http session. So
visibility of resources accessed by these queries, and visibility of subqueries called with util:eval,
correctly depend on the user's privileges - it is only execution of the containing query via http that
seems odd. 

To check it's not just my code, I tested putting an xquery file inside the dashboard application with no
'other' execute permission and logging into the dashboard as a user that should have group or owner
execute permission on the resource, with the same result as above (xquery file executable via http only if public).

Is this by design? A user is always 'guest' over http even with xmldb:login and session opening, and login is
done on each request by xquery with credentials stored in the session? If so, why does a session using
container security and JAAS behave differently - is it because the JAAS step is the intended, but
optional, mechanism to extend eXist login into the http session? Is there a convention (when not using
JAAS) that I need so store certain attributes in the session for the user's login to be recognized for
accessing resources (the JAAS login module source code is my next stop)? Or will resources always have to
be visible to 'guest', and I have to log the user in within each resource? 


Alberto Simões | 28 Jul 12:49 2015

Understanding RPC methods


I've been looking to the RPC API and a little confused on some aspects.

Two questions:

1) line 389 of RpcAPI [1] says, about byte[] query(...):
    * <at> deprecated use List query() or int executeQuery() instead
but there isn't any List query() signature.
Is it missing or never implemented?

2) when using executeQuery, with a query like this:

    collection("/db/foo")//bar[ <at> x="y"] ! fn:base-uri(.)

what is supposed to be the result of  'retrieveAll'  on that query?
A well formed XML snippet or just the list of the return values?
Exist-open mailing list
Exist-open <at>
Alberto Simões | 27 Jul 22:38 2015

XML RPC docs


When using XMLRPC, I am getting a string of XML elements, without a root node.

When using REST, there is a _wrap option, to ask the elements to be wrapped by a <exist:result> element.

Is there such a parameter for XMLRPC?


Alberto Simões
Exist-open mailing list
Exist-open <at>
Maryam Pashmi | 27 Jul 22:02 2015

How can I go out from this list?


I would like to unscribe from the list.


Exist-open mailing list
Exist-open <at>
Poulter, Dale | 26 Jul 20:41 2015

Exist 2.2



We have been running an application on Exist 2.1 for a year which has been fairly stable.  However,  when we upgraded to 2.2 the system seems to crash regularly – often resulting in database corruption.  Has anyone else experienced similar issues?  Thanks.






Dale Poulter

Coordinator, Search and Core Services

Library Digital Services
Vanderbilt University

419 21st Avenue South, Room 812 
Nashville, TN  37203-2427
(615)207-9705 (cell)
dale.poulter <at>



Exist-open mailing list
Exist-open <at>