Kay Drangmeister | 10 Jul 10:32 2011
Picon

OSM rendering dead on toolserver?

Hi

For a couple of days, OSM tile rendering is dead now on toolserver. See
https://jira.toolserver.org/browse/TS-1101 and
https://jira.toolserver.org/browse/TS-1100
The queue is at over 20k tiles right now :-)

Can anybody of the OSM MMT please try to restart tirex?

Kind regards,
Kay

Tim Alder | 10 Jul 12:56 2011
Picon

Re: OSM rendering dead on toolserver?

Hello, if I want to do something like:
	osm <at> willow:~/tirex/bin$ ./tirex-tiledir-stat
I get the following answer:
	cannot open configuration file '/etc/tirex/tirex.conf' at
	/home/project/o/s/m/osm/tirex/lib/vendor_perl/5.12/Tirex
	/Config.pm line 55.
the same answer is coming with tirex-master, tirex-rendering-control, ... .
I'dont know what the reason is and why it doesn't work anymore.

Greetings Kolossos

P.S: Next week is the "State of the Map" in Vienna, I hope to meet 
somebody of the list there and off-course would it be nice to have a 
running system until than.

Am 10.07.2011 10:32, schrieb Kay Drangmeister:
> Hi
>
> For a couple of days, OSM tile rendering is dead now on toolserver. See
> https://jira.toolserver.org/browse/TS-1101 and
> https://jira.toolserver.org/browse/TS-1100
> The queue is at over 20k tiles right now :-)
>
> Can anybody of the OSM MMT please try to restart tirex?
>
> Kind regards,
> Kay
>
> _______________________________________________
> Maps-l mailing list
(Continue reading)

Kay Drangmeister | 10 Jul 16:59 2011
Picon

Re: OSM rendering dead on toolserver?

Hi Tim,

Am 10.07.2011 12:56, schrieb Tim Alder:
> 	osm <at> willow:~/tirex/bin$ ./tirex-tiledir-stat
> 	cannot open configuration file '/etc/tirex/tirex.conf' at

Not sure if willow is the right server for this, I guess that it's
ptolemy that hosts tirex.

Greetings, I planned to write a news article about the opening of
our new university campus ("... and it's already mapped in OSM"),
but since e.g. the parking map is down ATM, it's no use. Pity.
Keeping fingers crossed for the SOTM.

Greetings,
Kay

Peter Körner | 11 Jul 13:03 2011
Picon

Re: OSM rendering dead on toolserver?

Am 10.07.2011 12:56, schrieb Tim Alder:
> P.S: Next week is the "State of the Map" in Vienna, I hope to meet
> somebody of the list there and off-course would it be nice to have a
> running system until than.
I'll be there.

> Am 10.07.2011 10:32, schrieb Kay Drangmeister:
>> For a couple of days, OSM tile rendering is dead now on toolserver. See
>> https://jira.toolserver.org/browse/TS-1101 and
>> https://jira.toolserver.org/browse/TS-1100
>> The queue is at over 20k tiles right now :-)
>>
>> Can anybody of the OSM MMT please try to restart tirex?
I restarted the tirex backend manager and it seems to be rendering 
again, now:

http://munin.toolserver.org/OSM/ptolemy/tirex_status_requests_rendered.html

2011-07-11T11:02:56 id=1310058824_426609200 map=default x=17960 y=29640 
z=16 prio=1 request_time=1310058824 expire= sources=MMM render_time=470 
success=1
2011-07-11T11:02:57 id=1310058839_426549736 map=default x=67456 y=45304 
z=17 prio=1 request_time=1310058839 expire= sources=M render_time=994 
success=1
2011-07-11T11:02:58 id=1310058838_426624588 map=default x=16856 y=11320 
z=15 prio=1 request_time=1310058838 expire= sources=MMMM 
render_time=2995 success=1
2011-07-11T11:02:59 id=1310058839_426641436 map=default x=33728 y=22648 
z=16 prio=1 request_time=1310058839 expire= sources=MMMMM 
render_time=2027 success=1
(Continue reading)

Kay Drangmeister | 19 Jul 00:57 2011
Picon

Updated styles ready for deployment

Hi Peter,

I updated the following styles:

* bw-mapnik
* bw-noicons
* parking
* parktrans

(assuming a cd /home/kayd for the following text)

Please find them under deploy.

Rendered samples are here: map-*.png -- rendered with render-samples.sh.
You may also try render-samples4000.sh for higher resolution test
images.

I don't have a MMP account yet, so I cannot do this myself. I would like
to revise the rendering soon, ticket vending machines are now rendered
in higher zoom levels...

Kind regards,
Kay

Tim Alder | 23 Jul 20:48 2011
Picon

ptolemy-performance

Hello,
during the clustering of the database index I made a mistake and we have 
now some problems (a blocked query and no index on hstore).
Sorry for that.

We work on that:
https://jira.toolserver.org/browse/TS-1122
But it needs time and perhaps we are stopping rendering process or 
blocking the DB during this process.

Greetings Kolossos

Tim Alder | 24 Jul 17:47 2011
Picon

Re: ptolemy-performance

I try now to create the missing indexes. (The blocking is over.)

I believe it would be faster if we would stop the rendering for this 
time, but as I try it to use tirex-rendering-control, I got following 
error-message.

Greetings Tim

osm <at> ptolemy:~/tirex/bin$ ./tirex-rendering-control --stop
cannot open configuration file '/etc/tirex/tirex.conf' at 
/home/project/o/s/m/osm/tirex/lib/vendor_perl/5.12/Tirex/Config.pm line 55.

Kay Drangmeister | 24 Jul 20:08 2011
Picon

Tile expiry is working again?

Hi,

Looking at the current ptolemy queue size

http://toolserver.org/~mazder/tirex-status/?short=1&extended=0&refresh=0

and

http://munin.toolserver.org/OSM/ptolemy/tirex_status_queued_requests.html

It seems like tile expiry has been turned on again, as on the one hand,
tiles _are_ rendered correctly but on the other hand, the queue is being
filled continuously, currently at a rate slightly higher than the
rendering capacity.

Kind regards,
Kay

Kay Drangmeister | 24 Jul 22:24 2011
Picon

Re: Tile expiry is working again?

Hi

Seems I can partly answer my own question:

Am 24.07.2011 20:08, schrieb Kay Drangmeister:
> http://munin.toolserver.org/OSM/ptolemy/tirex_status_queued_requests.html
> It seems like tile expiry has been turned on again

See https://jira.toolserver.org/browse/TS-1112
Is my assumption right that tile expiry is _not_ active after the
re-render of everything?

Ciao,
Kay

River Tarnell | 25 Jul 16:54 2011
Picon

Re: Tile expiry is working again?


Kay Drangmeister:
> Is my assumption right that tile expiry is _not_ active after the
> re-render of everything?

AFAIK, tile expiry was disabled before, and I haven't enabled it, so 
once a few more tiles have been rendered, the render load will drop back 
to nothing again.

Is there a particular reason why expiry was disabled?  The load seems 
fine at the moment, even though quite a few tiles are being rendered.

	- river.

Gmane