Yolanda Craven Marsh | 18 Jul 20:16 2016

sendmail 8.15.1

I have downloaded sendmail 8.15.1, but I am unable to authenticate.  I’m wondering if anyone else has had the issue.  It looked like this version was compiled with SASL support.





Dagobert Michelsen | 11 Jul 14:20 2016

Re: pixman / tls link time issue

Hi Riccardo,

Am 06.07.2016 um 10:17 schrieb Riccardo Mottola <rmottola@...>:
> Dagobert Michelsen wrote:
>> Hi Riccardo,
>> Am 04.07.2016 um 10:04 schrieb Riccardo Mottola<rmottola@...>:
>>> >the pixman package would be "yours".. I'd like to fix it, cane we collaborate? I don't want to hurt
anyone feet.
>> Sure, in general I don’t mind at all unless you break it;-)
> Let's fix it in case :) I try to be careful.. aftger all we are few people and the receipes seems to "age" and
break with time.
> In this case however, a reebuild shows the issue, but also the old package was already broken on soloaris9,
so I just discovered an issue, didn't break anything yet.
> I did a minor commit to bring up-todate. I removed the and added architectures.
> How do I fix this, on the x86 version?
> gmake[1]: Leaving directory `/home/rmottola/opencsw/pixman/trunk'
> gmake[1]: Entering directory `/home/rmottola/opencsw/pixman/trunk'
> /home/rmottola/opencsw/.buildsys/v2/gar//gar.conf.mk:559: *** The ISA 'amd64' can not be build on
this kernel with the arch 'i386'.  Stop.
> gmake[1]: Leaving directory `/home/rmottola/opencsw/pixman/trunk'
> I thought it was implied that solaris9x can't build AMD64!
> Is correct, IIRC!

Yes. The building is a bit complex: in the early days when we had packages for
Solaris 8 and 9 there was a trick to allow using the packages on Solaris 10 by
adding the amd64 binaries built on Solaris 10 on Solaris 8 and 9 packages. As
they were not used on 8 and 9 this won’t do any harm but the package could be
used anyway on Solaris 10 with full functionality. Now that we have enough disk
space and Solaris 8 and 9 are old and we always have additional Solaris 10
packages this behaviour is considered „legacy“ and no amd64 should be included
on Solaris 8 and 9 x86 any more. If solaris10-i386 is in PACkAGING_PLATFORMS
then this is a bug in GAR.

>> What happens?
> On solaris9 sparc, after the succesful build,  to an ldd:
> ldd -r work/solaris9-sparc/build-isa-sparcv9/pixman-0.22.2/pixman/.libs/libpixman-1.so
>        /usr/lib/secure/64/s9_preload.so.1
>        libm.so.1 =>     /usr/lib/64/libm.so.1
>        libc.so.1 =>     /usr/lib/64/libc.so.1
>        libdl.so.1 =>    /usr/lib/64/libdl.so.1
>        /usr/platform/SUNW,SPARC-Enterprise-T5220/lib/sparcv9/libc_psr.so.1
>        symbol not found: __tls_get_addr (work/solaris9-sparc/build-isa-sparcv9/pixman-0.22.2/pixman/.libs/libpixman-1.so)
> ldd -r work/solaris9-sparc/build-isa-sparcv8/pixman-0.22.2/pixman/.libs/libpixman-1.so
>        /usr/lib/secure/s9_preload.so.1
>        libm.so.1 =>     /usr/lib/libm.so.1
>        libc.so.1 =>     /usr/lib/libc.so.1
>        libdl.so.1 =>    /usr/lib/libdl.so.1
>        /usr/platform/SUNW,SPARC-Enterprise-T5220/lib/libc_psr.so.1
>        symbol not found: __tls_get_addr (work/solaris9-sparc/build-isa-sparcv8/pixman-0.22.2/pixman/.libs/libpixman-1.so)
> On the partial build on solaris9x, where i386 built, it is consistent:
> ldd -r work/solaris9-i386/build-isa-i386/pixman-0.22.2/pixman/.libs/libpixman-1.so
>        libm.so.1 =>     /usr/lib/libm.so.1
>        libc.so.1 =>     /usr/lib/libc.so.1
>        libdl.so.1 =>    /usr/lib/libdl.so.1
>        symbol not found: ___tls_get_addr (work/solaris9-i386/build-isa-i386/pixman-0.22.2/pixman/.libs/libpixman-1.so)
> As a test, I compiled everything with GCC - but I get the same error.
> Perhaps we are missing some linker flag? I tried to look on the internet, other had this problem also on
non-solaris, but found no solutions.
> I'm weary to update pixman: I don't want to enter a dependency hell updating stuff on solaris9. First
rebuilding this package "fixed" would be preferrable!
> A "fresh" rebuild on solaris10s is perfectly fine...
> ldd -r work/solaris10-sparc/build-isa-sparcv9/pixman-0.22.2/pixman/.libs/libpixman-1.so
>        libm.so.2 =>     /lib/64/libm.so.2
>        libc.so.1 =>     /lib/64/libc.so.1
>        /platform/SUNW,SPARC-Enterprise-T5220/lib/sparcv9/libc_psr.so.1

You need to get deeper in multithreading on Solaris 9, I haven’t looked into it
in more detail, feel free to do more investigation.

Best regards

  — Dago

"You don't become great by trying to be great, you become great by wanting to do something,
and then doing it so hard that you become great in the process." - xkcd #896

Habichtsberg, Reinhard | 6 Jul 11:21 2016

wget Vulnerability

Hi all,


Sorry, I’m new here. May I ask a question in this list: There is a vulnerability issue with wget (see below pls.). Newest wget in opencsw is GNU Wget 1.16.3. Is it intended to release a fixed version of wget here soon?


Generally asked: Is there any process that ensures the fix of security issues in the opencsw project?




From SB16-186: Vulnerability Summary for the Week of June 27, 2016

The US-CERT Cyber Security Bulletin provides a summary of new vulnerabilities that have been recorded by the National Institute of Standards and Technology (NIST) National Vulnerability Database (NVD) in the past week. The NVD is sponsored by the Department of Homeland Security (DHS) National Cybersecurity and Communications Integration Center (NCCIC) / United States Computer Emergency Readiness Team (US-CERT). For modified or updated entries, please visit the NVD, which contains historical vulnerability information

Vulnerability Summary for CVE-2016-4971

Original release date: 06/30/2016

Last revised: 07/01/2016



GNU wget before 1.18 allows remote servers to write to arbitrary files by redirecting a request from HTTP to a crafted FTP resource.



TIA, Reinhard


Jan Holzhueter | 27 Jun 09:31 2016

Re: OpenCSW question about package CSWlibssl1-0-0


Am 26.06.16 um 17:48 schrieb yvoinov@...:
> Man,
> please, make 1.0.2 release. It already rancid, but we are require chacha-poly support ASAP, but 1.0.1t
don\'t contain it. Hurry up!

Just a small reminder this is a community project driven by people on
their free time. So hurry up might not be the right why to request an
update. Feel free to rethink your words in a request to a community project.

For everbody else waiting for an 1.0.2 openssl. I have a experimental
package soon but it needs lot's of testing so if there are people out
their with some spare time to test let me know.


Ken Arnold | 23 Jun 17:36 2016

cadaver questions

I was trying to contact the maintainer for cadaver, Yann Rouillard, but I kept getting the “The value entered in the captcha field is not valid” error message.


This is what I’m trying to find out:

Is there a way to get this version of cadaver to compile or install with a cert?  I'm trying to bypass the "WARNING: Untrusted server certificate presented for `www.cloudvault.usda.gov'" message so we and automate a script.



Ken Arnold



Stephen Hjerpe | 17 Jun 20:21 2016

install cryptography==1.3.0 + ffi.h error



I am using opencsw on a Sun Solaris machine. I am attempting to run asroot pip install cryptography==1.3.0


Running setup.py install for cryptography

    c/_cffi_backend.c:15:17: fatal error: ffi.h: No such file or directory


I have already installed libffi_dev. I have attached the full output of asroot pip install cryptography==1.3.0




Stephen Hjerpe

Development Manager




(661) 821-8917

(858) 354-8146 (mobile)



Attachment (my.out): application/octet-stream, 9 KiB
Horst Koenigshofer | 14 Jun 10:24 2016

Becoming a maintainer

Hi !

After talking with a collegue (tosmi <at> opencsw.org), I would like to become a csw (co)maintainer for puppet and various
other packages required for puppet (ruby, facter).
Could you please create a user on the build farm for me?
  username: hoko
  mail address: hoko <at> opencsw.org

Horst Koenigshofer
Lara Blatchford | 9 Jun 22:18 2016

mgar up error

Good evening – I’m new to OpenCSW and am trying to set up a repository to build a new package, but I’m getting an error running mgar up.


Running mgar init is successful


-bash-3.2$ mgar init

Initializing the package build tree at /export/home/lara2/opencsw

A    opencsw/.buildsys/v2-ips

A    opencsw/.buildsys/v2-ips/gar.mk

A    opencsw/.buildsys/v2-ips/category.mk

A    opencsw/.buildsys/v2-ips/gar.lib.mk

A    opencsw/.buildsys/v2-ips/gar.svn.mk


A    opencsw/.buildsys/bts/etc/commondirs-i386

A    opencsw/.buildsys/bts/Makefile

A    opencsw/.buildsys/bts/garrc.sample

Checked out revision 25770.

Checked out revision 25770.


Initialized the package build tree at /export/home/lara2/opencsw.

Registering the package build tree location in ~/.garrc


Now you can fetch the package build descriptions via: "mgar up --all"

Please be advised that this will take some time. So grab yourself a cup

of tea/coffee :)



Running mgar up generates an error, and I couldn’t find an explanation when I searched.


-bash-3.2$ mgar up --all

This command is supposed to be run from within a package build

directory (i.e. one with a build recipe). Please change to one

and re-run this command.

-bash-3.2$ ls

local.cshrc    local.login    local.profile  opencsw


Can someone explain what could be wrong?  Thanks very much,



David Hollenberg | 3 May 19:36 2016

Unable to authenticate users after Samba update

I updated CSWSamba from the testing catalog today, on a Solaris 10, Update 10 x86 server.
This caused authentication to the host specified in a "wins server" parameter to
stop working with "permission denied" errors, whereas prior to the update it was working.

I restored the following 2 files from a backup made before the update and
file access via Samba started working again:


Before the update pkgutil showed

    CSWsamba                  3.6.25,REV=2016.02.08     3.6.25,REV=2016.04.17

(version number is 3.6.25 for both old and new versions).

I'm not a Samba expert.  Can anyone tell me what the problem might be?

I don't know what protocol Samba uses to talk to the domain controller
specified in the "wins server" parameter.  Could removal of SSL2 be the problem?


David Hollenberg | 29 Apr 21:28 2016

Will OpenSSL 1.0.1s be released?

Will the OpenSSL 1.0.1s package be released?

I noticed that OpenSSL 1.0.1s has blocking bugs.  Looks like there is some
concern that removal of SSL2 will break some things.

We don't need 1.0.1s, but the OpenSSL project has announced version 1.0.1t
to be released on May 3.  It has fixes for some high impact security bugs
so we hope to get that version soon after it is released.


Fishwick Keith | 15 Apr 16:09 2016

CUPS: foomatic-rip file missing



I’m still very new to CUPS !

But I have now installed all the CUPS software (I think !) onto my Solaris 10 branded zone.

I have created a printer thru the web interface.


But after I’ve issued a simple lp command, lpstat is telling me

File "/opt/csw/lib/cups/filter/foomatic-rip" not available


Sure enough, it ain’t there in    /opt/csw/lib/cups/filter

Has anyone any idea what it is that I’m still missing ?




Keith Fishwick
Finance, Infrastructure and Transformation Directorate


Integrated Business Centre


Hull City Council

Maritime Buildings

Alfred Gelder Street, HULL, HU1 2AA


Tel: +44 1482 614519

Email: mailto:keith.fishwick <at> hullcc.gov.uk


This transmission is intended for the named addressee(s) only. Unless you are the named addressee (or authorised to receive it for the addressee) you may not copy or use it, or disclose it to anyone else. If you have received this transmission in error please notify the sender immediately. All transmissions may be subjected to recording and/or monitoring in accordance with relevant legislation.

This footnote also confirms that this email message has been swept for the presence of computer viruses.

Website: www.hullcc.gov.uk Tel: 01482 300 300 Text Phone: 01482 300 349