Sam Lin | 1 Jan 13:05 2011
Picon

Very strange network issues on PCBSD 8.1 (i386)

Hi all -

I recently came across with a couple of issues regarding the network.

1. I have been using a “Captive Portal” to connect to the Internet on
PCBSD in my office; although need to launch a browser to enter my user
name and password to get connect to the Internet every time I boot
PCBSD, at least I have not had big problem with it. On the other hand,
I have also been trying to use the Internet from my house but through
normal ADSL but for unknown reasons I have never been able to connect
to the Internet at home despite out adsl modem and the network are in
fact working (tested with Windows machine). The network device on my
laptop is working for sure (tested by installing Windows on it and try
the network out). Both wired and wireless on PCBSD appeared not being
able to get connect to the Internet at home. For your information, my
network devices on my laptop are:

- Wired: sis0 (NatSemi DP8381[56] 10/100BaseTX); detected at bootup
- Wireless: wlan0 (Ralink 54M USB from TP-Link TL-WN321G); detected at bootup

- ADSL modem: DSL-G604T

As I am not going to the office during the Xmas break and the captive
portal is not covering my house, I have had to try all the ways I
could try to get the network work at home on PCBSD. Ultimately I came
to a very strange solution but never failed to "activate" the network
on my laptop on PCBSD. Below is the step:

(1) Before start up the PCBSD machine make sure that network cable (or
usb network adapter) is plugged onto the laptop
(Continue reading)

Sam Lin | 7 Jan 07:03 2011
Picon

Re: Very strange network issues on PCBSD 8.1 (i386)

On 6 January 2011 05:56, Kris Moore <kris@...> wrote:
> On Sun, Jan 02, 2011 at 01:05:43AM +1300, Sam Lin wrote:
>> Ultimately I came to a very strange solution but never failed to "activate" the network
>> on my laptop on PCBSD. Below is the step:
>>
>> (1) Before start up the PCBSD machine make sure that network cable (or
>> usb network adapter) is plugged onto the laptop
>> (2) Start up the PCBSD machine
>> (3) Wait until PCBSD and KDE are fully launched. At this stage the
>> network device status shows "associated" but the Internet is not
>> working on this laptop.
>> (4) Unplug the network cable/usb network adapter
>> (5) Right click on the network icon in systray, pick "Restart the
>> Network" and enter root's password.
>> (6) Plug the network cable or usb network adapter back to the laptop
>> (7) Wait for 5-10 seconds (?)
>> (8) Now finally the Internet is working on this laptop with PCBSD.

>
> I've never run across this problem here. Have you tried disabling the "lagg" interface, maybe thats
> causing issues since it attempts to "clone" the wired -> wifi mac addresses for failover.
>
> If you edit /etc/rc.conf, remove any "lagg" stuff, so your network setup looks something like this:
>
> wlans_ath0="wlan0"
> ifconfig_jme0="DHCP"
> ifconfig_wlan0="WPA DHCP"
>
> (Replace ath0/jme0 with your device names)
>
(Continue reading)

Sam Lin | 7 Jan 07:25 2011
Picon

Re: Very strange network issues on PCBSD 8.1 (i386)

Forgot to mention that once I commented out lagg and then restarted
the machine, ip was no longer not assigned to this machine even though
the status showed associated.

On 7 January 2011 19:03, Sam Lin <semin2006@...> wrote:

> Unfortunately no. Commenting out all lagg adversely resulted that even
> the "unplug/restart/replug" steps could not activate my network
> anymore... so probably lagg is not the cause?
>
> Regards,
> Sam
Sam Lin | 7 Jan 22:13 2011
Picon

Re: Very strange network issues on PCBSD 8.1 (i386)

On 8 January 2011 04:26, Kris Moore <kris@...> wrote:
>
> Maybe this really is a networking bug :(
>
> Can you post your rc.conf lines relating to networking?
>
> --
> Kris Moore

This is my rc.conf. To ensure I am not missing out anything I just
leave everything as is instead of picking up networking-related
entries.

==============================

background_dhclient="YES"
compat5x_enable="YES"
sshd_enable="YES"
devd_enable="YES"
devfs_system_ruleset="devfsrules_common"
ldconfig_paths="/usr/lib/compat /usr/local/lib /usr/local/kde4/lib
/usr/local/lib/compat/pkg"

# Disable Sendmail by default
sendmail_enable="NONE"

# Enable console mouse
moused_type="auto"
moused_enable="YES"

(Continue reading)

Sam Lin | 11 Jan 05:24 2011
Picon

Re: Very strange network issues on PCBSD 8.1 (i386)

On 11 January 2011 09:17, Kris Moore <kris@...> wrote:

> Try changing this section:
>
> # Auto-Enabled NICs from pc-sysinstall
> ifconfig_sis0="DHCP"
> hostname="pcbsd-4583"
> wlans_rum0="wlan0"
> ifconfig_rum0="`ifconfig sis0 ether`"
> ifconfig_rum0="ether ${ifconfig_rum0##*ether }"
> ifconfig_wlan0="WPA"
> cloned_interfaces="lagg0"
> ifconfig_lagg0="laggproto failover laggport sis0 laggport wlan0 DHCP"
> ipv6_defaultrouter=""vboxnet_enable="YES"
> vboxnet_enable="YES"
>
> to
>
> # Auto-Enabled NICs from pc-sysinstall
> hostname="pcbsd-4583"
> ifconfig_sis0="DHCP"
> wlans_rum0="wlan0"
> ifconfig_wlan0="WPA DHCP"
> vboxnet_enable="YES"
>
>
> Does that make any difference?
>
>
> --
(Continue reading)

Sam Lin | 11 Jan 07:19 2011
Picon

Update Manager - not really updated

Did not realise that my Pidgin was actually outdated until I noticed
that the version of Pidgin mentioned in another thread is (much) newer
than mine, although my Update Manager thought that my Pidgin is
updated.

From the attached snapshot you shall see that the current Pidgin is
2.7.9 released a few days ago, whereas my Pidgin is still 2.7.1, from
Jun last year!

Any reason why my Update Manager does not pick up the outdated software?
_______________________________________________
Pbi-dev mailing list
Pbi-dev@...
http://lists.pcbsd.org/mailman/listinfo/pbi-dev
Sam Lin | 13 Jan 23:10 2011
Picon

Re: Very strange network issues on PCBSD 8.1 (i386)

On 12 January 2011 03:58, Kris Moore <kris@...> wrote:
>> Unfortunately, no difference at all - the network is still dead, the
>> "unplug/restart network/replug" workaround does not work, and no ip is
>> assigned either. We have hit a tough bug, Kris.
>
> Well, this is just straight FreeBSD at this point, so I'm thinking we may have found
> a network driver bug of some type. Have you tried this on any of the 8.2 stuff? If you can
> confirm the bug there, we may want to bring this up on the FreeBSD mailing lists, see if
> we can get some developer attention.
>
>
> --
> Kris Moore
> PC-BSD Software

Unfortunately I cannot bother testing this on 8.2-RC1 at this stage as
that means I will have to wipe my current 8.1 system out of my laptop
before which I will need to do a thorough backup. And testing this
network issue on 8.2 in my virtualbox is just not possible as my
laptop is just too slow to do any decent test in a virtual machine;
it's not really that old thought - only 7 years old  :-)

Regards,
Sam
eculp | 14 Jan 02:11 2011

PCBSD running on an AtomD410

Is anyone running PCBSD on and ATOM D410 or similar processor.  I  
bought two Compaq Presario All-in-One CQ1-1001LA Desktop PC 's with  
Red-Flag linux.  From the documentation it would appear to be a  
Chinese version of linux.

some specs:

Intel Atom D410 processor (P)
Chipset: Intel NM10 Express
Motherboard: Manufacturer: Pegatron
Motherboard Name: IPPPV-CP
HP/Compaq motherboard name: Sanxia
Audio codec: Realtek ALC663

Does anyone have any experience with PCBSD as a desktop system to  
replace RedFlag?
For operators who have only used windows?

I have used FreeBSD for years for all of my machines from laptops to  
servers but for folks a bit more technical than the ones who are using  
the Compaq's.  Any suggestions appreciated.  They are using them but  
they are ridiculously slow.  Seems to be more the OS and probably a  
memory upgrade would help but first I want to change the OS.

Thanks,

ed
James D. Parra | 20 Jan 01:48 2011

upgrade of virtual box will only run as root

Hello,

Upgraded VirtualBox from 3.2.10 to 3.2.12 and now only root can run it. Previously, my user could run and
admin VirtualBox. After uninstalling, reinstalling and changing the ownership of the .Virtualbox
files to my username, I still need to supply the root password.

Any suggetions on how I can fix this?

Many thanks in advance,

James 

Gmane