Timothy Hatcher | 3 Oct 20:58 2006

Bugzilla moved (tip on how to redirect to the new address)

Most of you have already noticed that we have moved WebKit's Bugzilla to bugs.webkit.org. We have updated the WebKit site and ChangeLogs to use the new Bugzilla URL; however, any old URLs will not automatically redirect like we would like. Many of you will still have bugzilla.opendarwin.org links somewhere, so here is a tip how to make bugzilla.opendarwin.org locally redirect.

1) Open /etc/hosts:

sudo $EDITOR /etc/hosts

2) Append the following:

17.254.17.105 bugzilla.opendarwin.org

3) Save /etc/hosts.

Now old Bugzilla URLs will redirect to the new address.

— Timothy Hatcher


_______________________________________________
webkit-dev mailing list
webkit-dev <at> opendarwin.org
http://www.opendarwin.org/mailman/listinfo/webkit-dev
Ashish Gokhale | 4 Oct 09:27 2006

RE: S60 - Get the contents of current active page

Hi Zalan,
Either way, source or via DOM API are both equally interesting. It may
not be possible to get page source as stream. It would be worth
investigating a possible DOM or SAX events plug-in framework. 

Thanks,

Ashish

-----Original Message-----
From: Zalan.Bujtas <at> nokia.com [mailto:Zalan.Bujtas <at> nokia.com] 
Sent: Friday, September 29, 2006 5:17 PM
To: ashishg <at> helloware.com; webkit-dev <at> opendarwin.org
Subject: RE: [webkit-dev] S60 - Get the contents of current active page

Hi,
Unfortunately, it is not possible to scan the contents of the page in
s60 browser. (are you interested in the page source or the page content
through DOM api?)
Thanks,
Zalan.

________________________________

From: webkit-dev-bounces <at> opendarwin.org
[mailto:webkit-dev-bounces <at> opendarwin.org] On Behalf Of ext Ashish
Gokhale
Sent: Tuesday, September 26, 2006 7:46 AM
To: webkit-dev <at> opendarwin.org
Subject: [webkit-dev] Get the contents of current active page

Hello,

This query is specific to Web-Kit port for S60. 

Is it possible to scan contents of page user has currently opened in
browser? May be by using some sort of a browser plug-in? 

Thanks

- AG
玲 吴 | 5 Oct 17:48 2006
Picon

How to build webkit on s60

I have set java, perl and epocroot path. I have got s60 sdk installed. When I run build.bat, there is error as follows. where is the platform_paths.hrh located? I can't find it. Could you tell me how to build the webkit on s60?

WARNING: Cannot determine the version of the RVCT Compiler.
In file included from .\BLD.INF:51:
.\.\WEBKIT\group\bld.inf:42: domain\osextensions\platform_paths.hrh: No such file or directory
BLDMAKE ERROR: ERROR: cpp.exe returned non-zero exit status (8448)
    cpp.EXE -undef -nostdinc -+  -I ..\Symbian\9.1\S60_3rd\epoc32\include -I . -I .\  -I "..\Symbian\9.1\S60_3rd\epoc32\include\variant" -include ..\Symbian\9.1\S60_3rd\epoc32\include\variant\Symbian_OS_v9.1.hrh ".\BLD.INF"

  make -r  -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\s60\EXPORT.make" EXPORT VERBOSE=-s
copy "\s60\WEBKIT\BrowserControl\inc\BrCtlDefs.h" "\Symbian\9.1\S60_3rd\EPOC32\INCLUDE\MW_LAYER_DOMAIN_EXPORT_PATH"
copy 1 file
....

Mp3疯狂搜-新歌热歌高速下
_______________________________________________
webkit-dev mailing list
webkit-dev <at> opendarwin.org
http://www.opendarwin.org/mailman/listinfo/webkit-dev
bradley.morrison | 5 Oct 19:38 2006
Picon

RE: How to build webkit on s60

Hello, 

> I have set java, perl and epocroot path. I have got s60 sdk installed. 

Ok, but note that's not necessary. build.bat will set your compilation environment for you. 

> where is the platform_paths.hrh located? I can't find it.

You shouldn't need that header - it's being conditionally included. There's something not quite right
with your environment.

> Could you tell me how to build the webkit on s60? 

The webkit wiki is down just at the moment (sorry about that), but really it's just:

	- Install ActivePerl v5.6.1, Carbide C++ Express and the S60 3.0 SDK
	- Open a command prompt and do:
         - cd <SDK Installation Path>
         - svn checkout svn://anonsvn.opensource.apple.com/svn/webkit/S60/trunk S60
	   - cd S60
         - build

Please let s60webkit <at> nokia.com know if after following those steps, you're still having any problems
(probably off list is better).

>  cpp.EXE -undef -nostdinc -+  -include
..\Symbian\9.1\S60_3rd\epoc32\include\variant\Symbian_OS_v9.1.hrh -I
   ^^^^^^^                                                                             ^^^^^^^^^^^^^^^^^^^

Yep, this is the wrong compiler and the default global header, you should be seeing mwccsym2.exe and
-include "S60.hrh" here.

Hope that helps!

Bradley
   
________________________________

From: webkit-dev-bounces <at> opendarwin.org [mailto:webkit-dev-bounces <at> opendarwin.org] On Behalf Of wulingemail <at> yahoo.com.cn
Sent: Thursday, October 05, 2006 11:48 AM
To: webkit-dev <at> opendarwin.org
Subject: [webkit-dev] How to build webkit on s60


I have set java, perl and epocroot path. I have got s60 sdk installed. When I run build.bat, there is error as
follows. where is the platform_paths.hrh located? I can't find it. Could you tell me how to build the
webkit on s60? 

WARNING: Cannot determine the version of the RVCT Compiler.
In file included from .\BLD.INF:51:
.\.\WEBKIT\group\bld.inf:42: domain\osextensions\platform_paths.hrh: No such file or directory
BLDMAKE ERROR: ERROR: cpp.exe returned non-zero exit status (8448)
    cpp.EXE -undef -nostdinc -+  -I ..\Symbian\9.1\S60_3rd\epoc32\include -I . -I .\  -I
"..\Symbian\9.1\S60_3rd\epoc32\include\variant" -include
..\Symbian\9.1\S60_3rd\epoc32\include\variant\Symbian_OS_v9.1.hrh ".\BLD.INF"

  make -r  -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\s60\EXPORT.make" EXPORT VERBOSE=-s
copy "\s60\WEBKIT\BrowserControl\inc\BrCtlDefs.h" "\Symbian\9.1\S60_3rd\EPOC32\INCLUDE\MW_LAYER_DOMAIN_EXPORT_PATH"
copy 1 file
....



________________________________

Mp3?迱ˑ-Ђ?興?踟˙ς <http://music.yahoo.com.cn/?source=mail_mailbox_footer> 
_______________________________________________
webkit-dev mailing list
webkit-dev <at> opendarwin.org
http://www.opendarwin.org/mailman/listinfo/webkit-dev
Ashish Gokhale | 6 Oct 08:59 2006

Error building S60 browser

Hello,

I am building S60 source tree. I am getting following errors. The trace is rather lengthy. In the beginning there is

--

make -s  -r -f "\EPOC32\BUILD\S60\MEMMAN\WINSCW\MEMMAN.WINSCW" CLEANUDEB

make[1]: \EPOC32\BUILD\S60\MEMMAN\WINSCW\MEMMAN.WINSCW: No such file or directory

make[1]: *** No rule to make target `\EPOC32\BUILD\S60\MEMMAN\WINSCW\MEMMAN.WINSCW'.  Stop.

make: *** [CLEANMEMMAN] Error 2

--

 

---Start---

Errors caused tool to abort.

make[1]: *** [\EPOC32\RELEASE\WINSCW\UDEB\MemMan.dll] Error 1

make: *** [TARGETMEMMAN] Error 2

make -s  -r -f "\EPOC32\BUILD\S60\MEMMAN\WINSCW\MEMMAN.WINSCW" UDEB

MemoryManager.cpp

Allocator.cpp

SlabAllocator.cpp

RescueZone.cpp

StopScheduler.cpp

fast_malloc.cpp

MemoryManager\Src\fast_malloc.cpp:3730: warning: variable / argument 'm' is not

used in function

MemMan.UID.CPP

mwldsym2.exe: Undefined symbol: '___CxxFrameHandler'

mwldsym2.exe: referenced from 'void CAllocator::AddStopper(class MOOMStopper *)(?AddStopper <at> CAllocator <at> <at> QAEXPAVMOOMStopper <at> <at> <at> Z)' in Allocator.cpp:92

mwldsym2.exe: referenced from 'CSimpleNotifier::CSimpleNotifier(void) (??0CSimpleNotifier <at> <at> QAE <at> XZ)' in Allocator.cpp:379

mwldsym2.exe: referenced from 'void * CBase::operator new(unsigned int) (??2CBase <at> <at> SAPAXI <at> Z)' in e32base.inl:36

mwldsym2.exe: referenced from 'class CAllocator * Allocator(void) (?Allocator <at> <at> YAPAVCAllocator <at> <at> XZ)' in MemoryManager.cpp:92

mwldsym2.exe: referenced from 'void invokeTable(void (* *)(void), void (* *)(void)) (?invokeTable <at> <at> YAXPAP6AXXZ0 <at> Z)' in win32crt.h:121 (EDLL.LIB)

mwldsym2.exe: referenced from 'void * operator new(unsigned int) (??2 <at> YAPAXI <at> Z)' in win32crt.h:154 (EDLL.LIB)

mwldsym2.exe: referenced from 'void operator delete(void *) (??3 <at> YAXPAX <at> Z)' in win32crt.h:176 (EDLL.LIB)

mwldsym2.exe: referenced from '__E32Dll' in uc_dll.cpp:41 (EDLL.LIB)

mwldsym2.exe: ...

mwldsym2.exe: Undefined symbol: '___destroy_new_array'

mwldsym2.exe: referenced from 'CPlainAllocator::~CPlainAllocator(unsigned int) (??_ECPlainAllocator <at> <at> UAE <at> I <at> Z)' in MemoryManager.o

mwldsym2.exe: referenced from 'CStopScheduler::~CStopScheduler(unsigned int) (??_ECStopScheduler <at> <at> UAE <at> I <at> Z)' in Allocator.o

mwldsym2.exe: referenced from 'CBase::~CBase(unsigned int) (??_ECBase <at> <at> UAE <at> I <at> Z)' in Allocator.o

mwldsym2.exe: referenced from 'CSimpleNotifier::~CSimpleNotifier(unsigned int) (??_ECSimpleNotifier <at> <at> UAE <at> I <at> Z)' in Allocator.o

mwldsym2.exe: referenced from 'CAllocator::~CAllocator(unsigned int) (??_ECAllocator <at> <at> UAE <at> I <at> Z)' in MemoryManager.o

mwldsym2.exe: Undefined symbol: '___unexpected'mwldsym2.exe: referenced from 'void operator delete(void *) (??3 <at> YAXPAX <at> Z)' in w

in32crt.h:176 (EDLL.LIB)

mwldsym2.exe: referenced from 'void * CBase::operator new(unsigned int) (??2CBase <at> <at> SAPAXI <at> Z)' in e32base.inl:36

  make -r  -f "\EPOC32\BUILD\S60\WINSCW.make" FINAL CFG=UDEB VERBOSE=-s

make -s  -C \S60\WEBKIT\group -f "ICONS.MK" TO_ROOT=..\..\.. EPOCBLD=..\..\..\EP

OC32\BUILD\S60\ICONS\WINSCW TO_BLDINF=..\..\..\S60 PLATFORM=WINSCW CFG=UDEB FINA

L

make -s  -C \S60\S60WebUi\WebUi\group -f "WEBUIAIFSVGICONSDC.MK" TO_ROOT=..\..\.

.\.. EPOCBLD=..\..\..\..\EPOC32\BUILD\S60\WEBUIAIFSVGICONSDC\WINSCW TO_BLDINF=..\..\..\..\S60 PLATFORM=WINSCW CFG=UDEB FINAL

make -s  -C \S60\S60WebUi\WebUi\group -f "WEBUIICONSDC.MK" TO_ROOT=..\..\..\.. EPOCBLD=..\..\..\..\EPOC32\BUILD\S60\WEBUIICONSDC\WINSCW TO_BLDINF=..\..\..\..\S60 PLATFORM=WINSCW CFG=UDEB FINAL

 

        Completed in: 00:15:50

 

        Scanning build output for errors: 4 found

Restoring variant.cfg

 

C:\Symbian\9.1\S60_3rd\S60>

---End---

 

How to sort these errors?

Thank you

 

- AG

 

_______________________________________________
webkit-dev mailing list
webkit-dev <at> opendarwin.org
http://www.opendarwin.org/mailman/listinfo/webkit-dev
Bradley Morrison | 6 Oct 17:43 2006
Picon

RE: Error building S60 browser

Hello,

> In the beginning there is ...

That output is Ok, it's letting you know there's nothing  to clean up
for the memory manager  during the clean phase of the compilation. The
build script ignores this when parsing for compilation errors.

> mwldsym2.exe: Undefined symbol: '___CxxFrameHandler'

That symbol is defined by the libraries that ship with the compiler.
Your build environment, set by build.bat, is not finding it. Which
version of carbide do you have installed? Do you have multiple
versions of Carbide or the SDK in your environment?

Anyway, please do a debug build via:

	C:\Symbian\9.1\S60_3rd\S60>build -d >out.txt 2>&1

And send me out.txt - off list please as this may be quite a large file.

Thanks,
Bradley
________________________________

From: webkit-dev-bounces <at> opendarwin.org
[mailto:webkit-dev-bounces <at> opendarwin.org] On Behalf Of ext Ashish
Gokhale
Sent: Friday, October 06, 2006 3:00 AM
To: webkit-dev <at> opendarwin.org
Subject: [webkit-dev] Error building S60 browser

Hello,

I am building S60 source tree. I am getting following errors. The
trace is rather lengthy. In the beginning there is

--

make -s  -r -f "\EPOC32\BUILD\S60\MEMMAN\WINSCW\MEMMAN.WINSCW" CLEANUDEB

make[1]: \EPOC32\BUILD\S60\MEMMAN\WINSCW\MEMMAN.WINSCW: No such file
or directory

make[1]: *** No rule to make target
`\EPOC32\BUILD\S60\MEMMAN\WINSCW\MEMMAN.WINSCW'.  Stop.

make: *** [CLEANMEMMAN] Error 2

--

---Start---

Errors caused tool to abort.

make[1]: *** [\EPOC32\RELEASE\WINSCW\UDEB\MemMan.dll] Error 1

make: *** [TARGETMEMMAN] Error 2

make -s  -r -f "\EPOC32\BUILD\S60\MEMMAN\WINSCW\MEMMAN.WINSCW" UDEB

MemoryManager.cpp

Allocator.cpp

SlabAllocator.cpp

RescueZone.cpp

StopScheduler.cpp

fast_malloc.cpp

MemoryManager\Src\fast_malloc.cpp:3730: warning: variable / argument 'm' is not

used in function

MemMan.UID.CPP

mwldsym2.exe: Undefined symbol: '___CxxFrameHandler'

mwldsym2.exe: referenced from 'void CAllocator::AddStopper(class
MOOMStopper *)(?AddStopper <at> CAllocator <at>  <at> QAEXPAVMOOMStopper <at>  <at>  <at> Z)' in
Allocator.cpp:92

mwldsym2.exe: referenced from 'CSimpleNotifier::CSimpleNotifier(void)
(??0CSimpleNotifier <at>  <at> QAE <at> XZ)' in Allocator.cpp:379

mwldsym2.exe: referenced from 'void * CBase::operator new(unsigned
int) (??2CBase <at>  <at> SAPAXI <at> Z)' in e32base.inl:36

mwldsym2.exe: referenced from 'class CAllocator * Allocator(void)
(?Allocator <at>  <at> YAPAVCAllocator <at>  <at> XZ)' in MemoryManager.cpp:92

mwldsym2.exe: referenced from 'void invokeTable(void (* *)(void), void
(* *)(void)) (?invokeTable <at>  <at> YAXPAP6AXXZ0 <at> Z)' in win32crt.h:121
(EDLL.LIB)

mwldsym2.exe: referenced from 'void * operator new(unsigned int)
(??2 <at> YAPAXI <at> Z)' in win32crt.h:154 (EDLL.LIB)

mwldsym2.exe: referenced from 'void operator delete(void *)
(??3 <at> YAXPAX <at> Z)' in win32crt.h:176 (EDLL.LIB)

mwldsym2.exe: referenced from '__E32Dll' in uc_dll.cpp:41 (EDLL.LIB)

mwldsym2.exe: ...

mwldsym2.exe: Undefined symbol: '___destroy_new_array'

mwldsym2.exe: referenced from
'CPlainAllocator::~CPlainAllocator(unsigned int)
(??_ECPlainAllocator <at>  <at> UAE <at> I <at> Z)' in MemoryManager.o

mwldsym2.exe: referenced from
'CStopScheduler::~CStopScheduler(unsigned int)
(??_ECStopScheduler <at>  <at> UAE <at> I <at> Z)' in Allocator.o

mwldsym2.exe: referenced from 'CBase::~CBase(unsigned int)
(??_ECBase <at>  <at> UAE <at> I <at> Z)' in Allocator.o

mwldsym2.exe: referenced from
'CSimpleNotifier::~CSimpleNotifier(unsigned int)
(??_ECSimpleNotifier <at>  <at> UAE <at> I <at> Z)' in Allocator.o

mwldsym2.exe: referenced from 'CAllocator::~CAllocator(unsigned int)
(??_ECAllocator <at>  <at> UAE <at> I <at> Z)' in MemoryManager.o

mwldsym2.exe: Undefined symbol: '___unexpected'mwldsym2.exe:
referenced from 'void operator delete(void *) (??3 <at> YAXPAX <at> Z)' in w

in32crt.h:176 (EDLL.LIB)

mwldsym2.exe: referenced from 'void * CBase::operator new(unsigned
int) (??2CBase <at>  <at> SAPAXI <at> Z)' in e32base.inl:36

  make -r  -f "\EPOC32\BUILD\S60\WINSCW.make" FINAL CFG=UDEB VERBOSE=-s

make -s  -C \S60\WEBKIT\group -f "ICONS.MK" TO_ROOT=..\..\.. EPOCBLD=..\..\..\EP

OC32\BUILD\S60\ICONS\WINSCW TO_BLDINF=..\..\..\S60 PLATFORM=WINSCW CFG=UDEB FINA

L

make -s  -C \S60\S60WebUi\WebUi\group -f "WEBUIAIFSVGICONSDC.MK" TO_ROOT=..\..\.

.\.. EPOCBLD=..\..\..\..\EPOC32\BUILD\S60\WEBUIAIFSVGICONSDC\WINSCW
TO_BLDINF=..\..\..\..\S60 PLATFORM=WINSCW CFG=UDEB FINAL

make -s  -C \S60\S60WebUi\WebUi\group -f "WEBUIICONSDC.MK"
TO_ROOT=..\..\..\..
EPOCBLD=..\..\..\..\EPOC32\BUILD\S60\WEBUIICONSDC\WINSCW
TO_BLDINF=..\..\..\..\S60 PLATFORM=WINSCW CFG=UDEB FINAL

        Completed in: 00:15:50

        Scanning build output for errors: 4 found

Restoring variant.cfg

C:\Symbian\9.1\S60_3rd\S60>

---End---

How to sort these errors?

Thank you

- AG
peliom | 3 Oct 11:49 2006
Picon

a question on printing: whither WSIWYG?

	

Here is the original website  page:
http://www.michaelang.com/a/92/fall-classes-at-the-lemurplex.html

When printed using Safari 2.0.4, this is the resulting PDF.  It it  
looks like the stylesheet is missing or something.
http://tikirobot.net/t/1DFE8229/SafariSaveAsPDF.pdf

Here are the webarchive and pdf files created by my application.  As  
with Safari, the web page looks great but the PDF page looks terrible.

http://tikirobot.net/t/1DFE8229/1DFE8229.webarchive
http://tikirobot.net/t/1DFE8229/1DFE8229.pdf

Anybody know what is going on?

Thanks! :-)

------------
TikiRobot!
http://www.tikirobot.net
David D. Kilzer | 7 Oct 03:50 2006
Picon

Re: a question on printing: whither WSIWYG?

That's definitely a bug.  I was able to reproduce it with a locally  
built debug build of r16799.

Please file a bug on http://bugs.webkit.org/ with information on how  
to reproduce it.

Dave

On Oct 3, 2006, at 4:49 AM, peliom <at> tikirobot.net wrote:

> Here is the original website  page:
> http://www.michaelang.com/a/92/fall-classes-at-the-lemurplex.html
>
> When printed using Safari 2.0.4, this is the resulting PDF.  It it  
> looks like the stylesheet is missing or something.
> http://tikirobot.net/t/1DFE8229/SafariSaveAsPDF.pdf
>
>
> Here are the webarchive and pdf files created by my application.   
> As with Safari, the web page looks great but the PDF page looks  
> terrible.
>
> http://tikirobot.net/t/1DFE8229/1DFE8229.webarchive
> http://tikirobot.net/t/1DFE8229/1DFE8229.pdf
>
> Anybody know what is going on?
>
> Thanks! :-)
>
> ------------
> TikiRobot!
> http://www.tikirobot.net
Mike Fischer | 7 Oct 04:11 2006
Picon

Re: a question on printing: whither WSIWYG?

Am 03.10.2006 um 11:49 schrieb peliom <at> tikirobot.net:

> Here is the original website  page:
> http://www.michaelang.com/a/92/fall-classes-at-the-lemurplex.html
>
> When printed using Safari 2.0.4, this is the resulting PDF.  It it  
> looks like the stylesheet is missing or something.
> http://tikirobot.net/t/1DFE8229/SafariSaveAsPDF.pdf
>
>
> Here are the webarchive and pdf files created by my application.   
> As with Safari, the web page looks great but the PDF page looks  
> terrible.

Well basically you are right. The stylesheet is missing when  
printing. But this seems to be a design choice. If you look at line 7  
of the page source you will see the line:

	<style type="text/css" media="screen">

The media attribute is set so that the stylesheet is only applied  
when the page is viewed on a screen. When printing it is not used.

> http://tikirobot.net/t/1DFE8229/1DFE8229.webarchive
> http://tikirobot.net/t/1DFE8229/1DFE8229.pdf
>
> Anybody know what is going on?

Well either the page is missing a stylesheet for media="print" or the  
given stylesheet should not be limited to media="screen". Unless of  
course the author wanted it this way on purpose. Using custom  
stylesheets for printing can very effectively enhance readability and  
printability of printed web pages.

BTW. This question has nothing to do with the development of webkit.  
It would be better placed on web-dev-request <at> lists.apple.com or some  
other HTML/CSS forum.

HTH
Mike
--

-- 
Mike Fischer         Softwareentwicklung, EDV-Beratung
                                     Schulung, Vertrieb
Web: <http://homepage.mac.com/mike_fischer/index.html>
David D. Kilzer | 7 Oct 04:43 2006
Picon

Re: a question on printing: whither WSIWYG?

Ignore what I said.  See Mike's reply.

Dave

On Oct 6, 2006, at 8:50 PM, David D. Kilzer wrote:

> That's definitely a bug.  I was able to reproduce it with a locally  
> built debug build of r16799.
>
> Please file a bug on http://bugs.webkit.org/ with information on  
> how to reproduce it.
>
> Dave
>
>
> On Oct 3, 2006, at 4:49 AM, peliom <at> tikirobot.net wrote:
>
>> Here is the original website  page:
>> http://www.michaelang.com/a/92/fall-classes-at-the-lemurplex.html
>>
>> When printed using Safari 2.0.4, this is the resulting PDF.  It it  
>> looks like the stylesheet is missing or something.
>> http://tikirobot.net/t/1DFE8229/SafariSaveAsPDF.pdf
>>
>>
>> Here are the webarchive and pdf files created by my application.   
>> As with Safari, the web page looks great but the PDF page looks  
>> terrible.
>>
>> http://tikirobot.net/t/1DFE8229/1DFE8229.webarchive
>> http://tikirobot.net/t/1DFE8229/1DFE8229.pdf
>>
>> Anybody know what is going on?
>>
>> Thanks! :-)
>>
>> ------------
>> TikiRobot!
>> http://www.tikirobot.net
>
> _______________________________________________
> webkit-dev mailing list
> webkit-dev <at> opendarwin.org
> http://www.opendarwin.org/mailman/listinfo/webkit-dev

Gmane