Juan Manuel Palacios | 6 Sep 22:31 2006

New mailing lists ready


	Evening everybody! I'm happy to announce that our new mailing lists 
are ready for usage, so we plan to complete our transition to them in a 
week's time. This one will be closed to new posts ASAP (meaning, when I 
get to it later on today ;-) and an auto-reply will be sent instructing 
you to join the new ones on MacOSForge if you do happen to post to it 
by mistake. Therefore all current and new threads will be 
continued/held there. For more information on our new mailing lists, 
check my post explaining them:

http://opendarwin.org/pipermail/darwinports/2006-September/035470.html

	Next week I'll consider this list completely closed and ready for 
removal from the map, so be quick to join us on MacOSForge if you're 
interested in keeping up with discussion.

	Regards,...

-jmpp
Kevin Walzer | 6 Sep 16:25 2006

ANN: Port Authority 1.1


Port Authority 1.1, the GUI for MacPorts, is now available.  This
version updates the application to reflect the transition to the
MacPorts name,  interface enhancements, an improved user help system
that is now searchable and easily browsed, and bug fixes.

With this release, I am moving away from the hybrid freeware/payware
approach that I used with version 1.0. The free X11 version will no
longer be developed. I have changed the license from  GPL to a standard
shareware license. A free updater is available for paid users of the
1.0-Aqua version, and a 30-day demo is available for others who wish to
try the Aqua version.

For more information, and to download, see
http://www.kevin-walzer.com/software/portauthority_aqua/.

Support questions should be directed to me off-list. Thank you.

--
Kevin Walzer
Poetic Code
http://www.kevin-walzer.com
Tomasz Mieszkowski | 5 Sep 18:58 2006
Picon

XeTeX-0.994 package won't compile

Hello everyone,

I was trying to install XeTeX-0.994a package - without success :(
Since full log is quite long, here are the most relevant (IMO) lines:

--- CUT FROM BUILD LOG ---

ld: /usr/lib/gcc/darwin/3.3/libstdc++.a(functexcept.o) illegal reference
to symbol: std::logic_error::logic_error(std::basic_string<char,
std::char_traits<char>, std::allocator<char> > const&) defined in
indirectly referenced dynamic library /usr/lib/libstdc++.6.dylib
ld: ../../libs/icu-xetex/lib/libsicuuc.a(cstring.ao) illegal reference
to symbol: ___udivdi3 defined in indirectly referenced dynamic library
/usr/lib/libgcc_s.1.dylib
ld: warning suggest use of -bind_at_load, as lazy binding may result in
errors or different symbols being used
symbol _acosl used from dynamic library /usr/lib/libstdc++.6.dylib
(single module) not from earlier dynamic library
/usr/lib/libSystem.B.dylib(ld64.o)

[...SNIP...]

make: *** [xetex] Error 1

gcc -DHAVE_CONFIG_H -I. -I../../../texk/xdv2pdf -I.. -I../../../texk/
xdv2pdf/..  -g -O2 -c ../../../texk/xdv2pdf/xdv2pdf_main.c
-o xdv2pdf_main.o c++ -g -O2 -DHAVE_CONFIG_H -I. -I../../../texk/xdv2pdf
-c ../../../texk/xdv2pdf/xdv2pdf.cpp ../../../texk/xdv2pdf/xdv2pdf.cpp:
In function `void doNativeFontDef(FILE*)': ../../../texk/xdv2pdf/
xdv2pdf.cpp:1625: error: `CGFontCreateCopyWithVariations' undeclared
(Continue reading)

Tim Visher | 6 Sep 08:14 2006
Picon

Problems activating pdflib

Hey Everyone,

I'm having a lot of trouble installing pdflib.  The Version of  
DarwinPorts is 1.320.

Here's the output I'm getting:
sudo port activate pdflib
Password:
--->  Activating pdflib
Error: port activate failed: Image error: /opt/local/lib/perl5/ 
site_perl/5.8.8/darwin-2level already exists and does not belong to a  
registered port.  Unable to activate port pdflib.

Any help?

Thanks a bunch!

Tim Visher
System Specs: PowerPC, 10.4.7, XCode 2.4
Jim Mock | 5 Sep 23:36 2006

Fwd: gtk28 port

This came back when I sent it earlier from my macports.org address...

- jim

Begin forwarded message:

> From: Jim Mock <mij <at> macports.org>
> Date: September 5, 2006 1:22:17 PM PDT
> To: darwinports <at> opendarwin.org
> Subject: gtk28 port
>
> Howdy folks,
>
> Here's a gtk28 port for those of you running into trouble with 2.10  
> (or those of you that need 2.8 for some reason).  Please give it a  
> try and let me know how it goes.  It worked fine for me, but 2.10.2  
> does as well, so I wanted to get some people to try it before I  
> check it into the tree.
>
> - jim


_______________________________________________
Darwinports mailing list
Darwinports <at> opendarwin.org
http://www.opendarwin.org/mailman/listinfo/darwinports
(Continue reading)

Wolfgang Keller | 5 Sep 18:58 2006
Picon
Picon

MacOS X fonts with Darwinports applications?

Hello,

is there a way to make the MacOS X fonts available for Darwinports 
applications, like with the applesystemfonts and xfontpath packages in *duck* 
Fink?

TIA,

Sincerely,

Wolfgang Keller

--

-- 
My email-address is correct.
Do NOT remove ".nospam" to reply.
Marc André Selig | 5 Sep 20:55 2006

committer needed for patches: yelp; ktoblzcheck

Hello all,

could some friendly committer please have a look at the following  
tickets in trac and commit them to svn?

10458	BUG: yelp requires additional dependencies
10652	UPDATE: ktoblzcheck 1.11

I have provided a patch for the first bug, and a complete updated  
Portfile for the second one.  Thanks in advance!

Regards,
Marc
Tabitha McNerney | 5 Sep 06:58 2006
Picon

tomcat5 and related dependent ports on Intel

Has anyone had any luck installing the tomcat5 port (and its dependencies
such as kaffe, junit, et al) on a Mac running Intel and 10.4.x ?

I have had an awful time trying to install the tomcat5 "family" of ports
starting with kaffe on Intel. Previously I had no problem installing these
port on the PPC Macs but now starting with Darwin Ports 1.3.2 and
XCode 2.4(as recommended by several people on the mailing list who
scolded me for
using anything less than 2.4), I can not even get the kaffe port to install
successfully on PPC.

If there's not much interest and if maintenance is too much of a hassle,
perhaps MacPorts should consider dropping the tomcat5 / java related ports
from the entire repertoire of ports?

Best regards,

T.
Adam Price | 5 Sep 17:21 2006
Picon

Re: Customizing an install


On Sep 4, 2006, at 5:53 PM, darwinports-request <at> opendarwin.org wrote:

> From: Frank McPherson <frank.mcpherson <at> janusresearch.com>
> Date: September 4, 2006 6:21:39 AM PDT
> To: Adam Price <ami <at> spamcop.net>
> Cc: darwinports <at> opendarwin.org
> Subject: Re: Customizing an install
>
>
> Adam,
>
> You can use 'port extract amphetamine' to extract the distribution  
> files for the port. Then, 'port dir amphetamine' to find out where  
> it's located on your file system. Go in there and change the files  
> you want. Then you can either 'port install amphetamine' and I  
> think it'll use the working copy of the source you just changed.  
> Or, you can use the other developer targets for port for finer- 
> grained control over the process: port configure, port build, port  
> archive, port activate, whatever. 'man port' lists all the targets  
> for port, but doesn't have very good examples in that section, so I  
> had to apply a bit of trial and error to do this type of thing.
>
> Frank
>
>

Thanks - that got me going.

-Adam
(Continue reading)

Wolfgang Keller | 5 Sep 06:38 2006
Picon
Picon

GNUstep broken

Hello,

it seems the GNUstep portfile is broken. Darwinports looks for an outdated 
version of gworkspace, which is no longer available on the servers.

TIA for fixing,

Sincerely,

Wolfgang Keller

--

-- 
My email-address is correct.
Do NOT remove ".nospam" to reply.
Frank McPherson | 5 Sep 03:10 2006

Trouble with libgnomeui

I'm having trouble with libgnomeui on a new macports install on  
10.4.7 with xcode 2.4. Any ideas what I can do to fix this? I've  
tried removing, rebuilding, and reinstalling libgnomeui and related  
ports like gconf, gtk2, gnome-vfs, etc.

Here's my error:

-- Cut from build log
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I.. -DXTHREADS -DORBIT2=1 - 
D_REENTRANT -I/opt/local/include/gtk-2.0 -I/opt/local/lib/gtk-2.0/ 
include -I/opt/local/include/atk-1.0 -I/opt/local/include/cairo -I/ 
opt/local/include/pango-1.0 -I/opt/local/include/glib-2.0 -I/opt/ 
local/lib/glib-2.0/include -I/opt/local/include/freetype2 -I/opt/ 
local/include -I/opt/local/include/libpng12 -I/usr/X11R6/include -I/ 
opt/local/include/libgnome-2.0 -I/opt/local/include/orbit-2.0 -I/opt/ 
local/include/libbonobo-2.0 -I/opt/local/include/gconf/2 -I/opt/local/ 
include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/ 
local/include/bonobo-activation-2.0 -D_FILE_OFFSET_BITS=64 - 
D_BSD_SOURCE -D_GNU_SOURCE -D_LARGEFILE64_SOURCE - 
D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -DG_DISABLE_DEPRECATED -L/opt/ 
local/lib -I/opt/local/include -g -O2 -MT gtkfilesystemgnomevfs.lo - 
MD -MP -MF .deps/gtkfilesystemgnomevfs.Tpo -c  
gtkfilesystemgnomevfs.c  -fno-common -DPIC -o .libs/ 
gtkfilesystemgnomevfs.o
gtkfilesystemgnomevfs.c: In function  
'gtk_file_system_gnome_vfs_iface_init':
gtkfilesystemgnomevfs.c:387: warning: assignment from incompatible  
pointer type
gtkfilesystemgnomevfs.c:388: warning: assignment from incompatible  
(Continue reading)


Gmane