Peter Eisch | 2 Mar 16:53 2004
Picon

1.6.2 won't install on Netra T1/105


Early on, I get this:

  kernfs_get_rrootdev: no raw root device

Then everything is fine until it's time to install the packages, then we
bomb out:

pciide0:1:0: lost interrupt
        type: atapi tc_bcount: 0 tc_skip: 0
pciide0:1:0: lost interrupt
        type: atapi tc_bcount: 0 tc_skip: 0
...

-----------------------

Netra t1 (UltraSPARC-IIi 440MHz), No Keyboard
OpenBoot 3.10.24 ME, 256 MB memory installed, Serial #12694124.
Ethernet address 8:0:20:c1:b2:6c, Host ID: 80c1b26c.

ok boot cdrom
Boot device: /pci <at> 1f,0/pci <at> 1/pci <at> 1/ide <at> e/cdrom <at> 2:f  File and args:
NetBSD IEEE 1275 Bootblock
..>> NetBSD/sparc64 OpenFirmware Boot, Revision 1.5
>> (he <at> kveite.urc.uninett.no, Sun Feb  1 14:34:43 CET 2004)
devopen: getdisklabel sez no disk label
devopen: search_label sez no disk label
loadfile: reading header
elf64_exec: Booting /pci <at> 1f,0/pci <at> 1/pci <at> 1/ide <at> e/cdrom <at> 2,0:f/netbsd
4566488 <at> 0x1000000+5401288 <at> 0x1800000+2987320 <at> 0x1d26ac8
(Continue reading)

Andrey Petrov | 2 Mar 21:21 2004
Picon

Re: 1.6.2 won't install on Netra T1/105

On Tue, Mar 02, 2004 at 09:53:52AM -0600, Peter Eisch wrote:
> 
> Early on, I get this:
> 
>   kernfs_get_rrootdev: no raw root device
> 
> Then everything is fine until it's time to install the packages, then we
> bomb out:
> 
> pciide0:1:0: lost interrupt
>         type: atapi tc_bcount: 0 tc_skip: 0
> pciide0:1:0: lost interrupt
>         type: atapi tc_bcount: 0 tc_skip: 0
> ...
> 
> 

It's probably caused by kernel failure to find interrupt number for
ide controller. That should be fixed in -current. Can you try?

	Andrey

Andrey Petrov | 2 Mar 21:27 2004
Picon

Re: 1.6.2_RC4 and cron

On Tue, Feb 24, 2004 at 09:11:33PM -0700, Rick Kelly wrote:
> 
> I see the situation where cron dumps core at startup, but starts up fine
> by hand after booting to multi-user. Is this related to port-sparc64/20675?
> 

Looks so, as PR is already closed can you try -current kernel?

	Andrey

Martin Husemann | 2 Mar 21:50 2004
Picon

Re: 1.6.2_RC4 and cron

On Tue, Feb 24, 2004 at 09:11:33PM -0700, Rick Kelly wrote:
> I see the situation where cron dumps core at startup, but starts up fine
> by hand after booting to multi-user. Is this related to port-sparc64/20675?

Yes. I didn't request pullup for that fixes since there is a whole bunch
of related problems on the 1.6 branch prior to the SA branch merge, so the
fix from -current won't be enough to solve the problem on the branch.

Martin

Peter Eisch | 2 Mar 22:47 2004
Picon

Re: 1.6.2 won't install on Netra T1/105


Chicken/egg thing.  I can't get the OS loaded over the net because I need to
build the mii patched kernel which I figured I'd load by shuttling source
tarballs via cdrom.  Netbooting is out of the question at this point for me
yet as well as I don't have a -current playground to mess in on.

I'll come back to it when I can -- I have a pressing need for the box to hit
service and Solaris will cover me for the couple weeks I need it.  Then I'll
re-visit the issue with a bit more leisure.

Thanks,

peter

> From: Andrey Petrov <petrov <at> netbsd.org>
> Date: Tue, 2 Mar 2004 12:21:06 -0800
> To: Peter Eisch <peter <at> boku.net>
> Cc: port-sparc64 <at> netbsd.org
> Subject: Re: 1.6.2 won't install on Netra T1/105
> 
> On Tue, Mar 02, 2004 at 09:53:52AM -0600, Peter Eisch wrote:
>> 
>> Early on, I get this:
>> 
>>   kernfs_get_rrootdev: no raw root device
>> 
>> Then everything is fine until it's time to install the packages, then we
>> bomb out:
>> 
>> pciide0:1:0: lost interrupt
(Continue reading)

James Chacon | 3 Mar 02:29 2004
Picon

Re: 1.6.2 won't install on Netra T1/105

On Tue, Mar 02, 2004 at 03:47:17PM -0600, Peter Eisch wrote:
> 
> Chicken/egg thing.  I can't get the OS loaded over the net because I need to
> build the mii patched kernel which I figured I'd load by shuttling source
> tarballs via cdrom.  Netbooting is out of the question at this point for me
> yet as well as I don't have a -current playground to mess in on.
> 
> I'll come back to it when I can -- I have a pressing need for the box to hit
> service and Solaris will cover me for the couple weeks I need it.  Then I'll
> re-visit the issue with a bit more leisure.

If it would help I could create a -current sparc64 iso image fairly easily
and throw it onto ftp.

James

Erik E. Fair | 3 Mar 05:33 2004

What's left to do to make UltraSPARC SMP work?

What are the outstanding issues that prevent NetBSD from running
SMP (or as close as we currently get to that) on UltraSPARC?

	Erik <fair <at> netbsd.org>

matthew green | 3 Mar 06:20 2004
Picon

re: 1.6.2 won't install on Netra T1/105


   On Tue, Mar 02, 2004 at 03:47:17PM -0600, Peter Eisch wrote:
   > 
   > Chicken/egg thing.  I can't get the OS loaded over the net because I need to
   > build the mii patched kernel which I figured I'd load by shuttling source
   > tarballs via cdrom.  Netbooting is out of the question at this point for me
   > yet as well as I don't have a -current playground to mess in on.
   > 
   > I'll come back to it when I can -- I have a pressing need for the box to hit
   > service and Solaris will cover me for the couple weeks I need it.  Then I'll
   > re-visit the issue with a bit more leisure.

   If it would help I could create a -current sparc64 iso image fairly easily
   and throw it onto ftp.

FYI, i created:

	ftp.netbsd.org:/pub/NetBSD/misc/mrg/netbsd-1.6ZJ-sparc64.iso

just over a couple of weeks ago.

.mrg.

Peter Eisch | 3 Mar 06:52 2004
Picon

Re: 1.6.2 won't install on Netra T1/105


Cool, I've pulled it down and I'll spin it on tomorrow AM.

Thanks Matthew & James,

As long as I'm running with scissors on the outsides of current "supported"
implementations:  Where would an e450 fit on the map?

Thanks again,

peter

> From: matthew green <mrg <at> eterna.com.au>
> Date: Wed, 03 Mar 2004 16:20:45 +1100
> To: James Chacon <jmc <at> NetBSD.org>
> Cc: port-sparc64 <at> NetBSD.org, Peter Eisch <peter <at> boku.net>
> Subject: re: 1.6.2 won't install on Netra T1/105
> 
> 
>  On Tue, Mar 02, 2004 at 03:47:17PM -0600, Peter Eisch wrote:
>> 
>> Chicken/egg thing.  I can't get the OS loaded over the net because I need to
>> build the mii patched kernel which I figured I'd load by shuttling source
>> tarballs via cdrom.  Netbooting is out of the question at this point for me
>> yet as well as I don't have a -current playground to mess in on.
>> 
>> I'll come back to it when I can -- I have a pressing need for the box to hit
>> service and Solaris will cover me for the couple weeks I need it.  Then I'll
>> re-visit the issue with a bit more leisure.
>  
(Continue reading)

Volker A. Brandt | 3 Mar 10:04 2004
Picon

Re: What's left to do to make UltraSPARC SMP work?

> What are the outstanding issues that prevent NetBSD from running
> SMP (or as close as we currently get to that) on UltraSPARC?

I am also very interested in the answer to that question.

FWIW, I have an several systems (Ultra2 with 2 CPUs, E3000 with 4 
CPUs) sitting here that I could do some testing on.  I have an 
install server all set up. 

[Actually, the install server for our Solaris boxes runs NetBSD. :-)]

Regards -- Volker
--

-- 
------------------------------------------------------------------------
Volker A. Brandt                  Consulting and Support for Sun Solaris
Brandt & Brandt Computer GmbH              WWW: http://www.bb-c.de/~vab/
Meckenheim, Germany                                   Email: vab <at> bb-c.de


Gmane