Tyler Retzlaff | 5 Apr 08:10 2003
Picon

xsrc build set creation bombing

During tarup of sets after a successful build one of the sets is failing
to be created correctly.  pax is reporting it's inability to access items
in ./usr/X11R6/include/X11/* because they're missing.  

Is this a packing list issue?  Or have I neglected to do something I
should have.  Btw building for i386 with xsrc updated yesterday.

--

-- 

Tyler Retzlaff <rtr <at> netbsd.org> http://www.netbsd.org

Matthias Scheler | 7 Apr 19:48 2003
Picon

Re: xsrc build set creation bombing

In article <20030405061002.GA19034 <at> splode.eterna.com.au>,
	Tyler Retzlaff <rtr <at> netbsd.org> writes:
> During tarup of sets after a successful build one of the sets is failing
> to be created correctly.  pax is reporting it's inability to access items
> in ./usr/X11R6/include/X11/* because they're missing.  

What XFree86 version are you building on which version of which
NetBSD platform?

	Kind regards

--

-- 
Matthias Scheler                                  http://scheler.de/~matthias/

vasant kanchan | 7 Apr 21:08 2003
Picon

Xlib based mozilla 1.3 on NetBSD 1.6


Hi,

I have successfully installed the mozilla pkg on
a NetBSD 1.6 system. The default build creates a
GTK+ based mozilla. I would like to build Xlib based
mozilla. How can I do that ?. Thanks for your help.

Regards
Kanchan

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more
http://tax.yahoo.com

vasant kanchan | 7 Apr 21:10 2003
Picon

Thread safe Xlib

Hi,

Is the Netbsd 1.6 release libX11.* thread safe ?

Regards
Kanchan

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more
http://tax.yahoo.com

Jason Thorpe | 7 Apr 21:48 2003

Re: Thread safe Xlib


On Monday, April 7, 2003, at 12:10  PM, vasant kanchan wrote:

> Is the Netbsd 1.6 release libX11.* thread safe ?

No, because 1.6 does not include a native threads library.  The Xlib in 
NetBSD 2.0 will be thread-safe (as it is in -current).

         -- Jason R. Thorpe <thorpej <at> wasabisystems.com>

Shin'ichiro TAYA | 8 Apr 16:52 2003
Picon

Re: Xlib based mozilla 1.3 on NetBSD 1.6

From: vasant kanchan <v_kanchan <at> yahoo.com>
Subject: Xlib based mozilla 1.3 on NetBSD 1.6
Date: Mon, 7 Apr 2003 12:08:10 -0700 (PDT)

> I have successfully installed the mozilla pkg on
> a NetBSD 1.6 system. The default build creates a
> GTK+ based mozilla. I would like to build Xlib based
> mozilla. How can I do that ?. Thanks for your help.

IIRC add --enable-default-toolkit=xlib to configure arg.
But AFAIK mozilla with X11 is experimental.
I recommend normal build(with gtk).

Tyler Retzlaff | 9 Apr 14:51 2003
Picon

Re: xsrc build set creation bombing


>> During tarup of sets after a successful build one of the sets is failing
>> to be created correctly.  pax is reporting it's inability to access items
>> in ./usr/X11R6/include/X11/* because they're missing.

> What XFree86 version are you building on which version of which
> NetBSD platform?

XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6

NetBSD silence 1.6Q NetBSD 1.6Q (silence) #0: Sat Apr  5 11:18:02 EST 2003

--

-- 

Tyler Retzlaff <rtr <at> netbsd.org> http://www.netbsd.org

vasant kanchan | 9 Apr 15:03 2003
Picon

Re: Xlib based mozilla 1.3 on NetBSD 1.6


--- Shin'ichiro TAYA <taya <at> ba2.so-net.ne.jp> wrote:
> From: vasant kanchan <v_kanchan <at> yahoo.com>
> Subject: Xlib based mozilla 1.3 on NetBSD 1.6
> Date: Mon, 7 Apr 2003 12:08:10 -0700 (PDT)
> 
> > I have successfully installed the mozilla pkg on
> > a NetBSD 1.6 system. The default build creates a
> > GTK+ based mozilla. I would like to build Xlib
> based
> > mozilla. How can I do that ?. Thanks for your
> help.
> 
> IIRC add --enable-default-toolkit=xlib to configure
> arg.
> But AFAIK mozilla with X11 is experimental.
> I recommend normal build(with gtk).

I did a manual ./configure and gmake to the patched
mozilla tree. Mozilla builds correctly but doesn't
run.
I have had no problem on the linux version.

Regards
Kanchan

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more
http://tax.yahoo.com
(Continue reading)

Martin Husemann | 29 Apr 10:56 2003
Picon

xconsole broken for xdm/gdm setups

I filed a PR because the removal of the UCONSOLE option broke my setup
by making xconsole fail. It is PR kern/21304 (ignore the "kern" part for now).
It contains a bit of discussion boiling down to the point that, IMHO, xdm
and friends (I'm actually using gdm) are broken. They seem to not use
ttyaction(5) and we don't install the Give/TakeConsole hacks.

Any suggestion how to proceed from here?
I don't think re-adding UCONSOLE would be a good idea.

Martin


Gmane