Martti Kuparinen | 3 Sep 08:05 2007
Picon
Picon

PHP failure

Hi,

Anyone else having this kind of problem?

Martti

CHROOT www:/usr/pkgsrc/mail/squirrelmail-locales> make deinstall package clean 
clean-depends
...
=> Required installed package php5-gettext>=4.3.3: NOT found
=> Verifying package for ../../devel/php-gettext
=> Required installed package digest>=20010302: digest-20070803 found
===> Skipping vulnerability checks.
WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
WARNING: To fix run: `download-vulnerability-list'.
===> Configuring for php5-gettext-5.2.4
/usr/pkg/bin/phpize: /usr/pkgsrc/lang/php5/work/.tools/bin/sed: not found
/usr/pkg/bin/phpize: /usr/pkgsrc/lang/php5/work/.tools/bin/sed: not found
/usr/pkg/bin/phpize: /usr/pkgsrc/lang/php5/work/.tools/bin/sed: not found
...

CHROOT www:/usr/pkgsrc/mail/squirrelmail-locales> grep SED= /usr/pkg/bin/phpize
SED="/usr/pkgsrc/lang/php5/work/.tools/bin/sed"

Julian Coleman | 3 Sep 11:38 2007
Picon

Re: Binary packages for 2007Q2 NetBSD-3.0/sparc64 available

The results of a pkgsrc bulk build update of pkgsrc-2007Q2 on
NetBSD-3.0.2/sparc64 have been uploaded and the packages are now
available at:

  ftp://ftp.NetBSD.org/pub/pkgsrc/packages/NetBSD/sparc64/3.0_2007Q2

and its mirrors.

The packages were built from sources updated on August 20, 2007.

The packages were built on a machine running NetBSD 3.0.2 and should be
useable on any sparc64 machine running NetBSD 3.0.x or NetBSD 3.x.

J

--

-- 

Matthias Scheler | 3 Sep 13:59 2007
Picon

Re: PHP failure

On Mon, Sep 03, 2007 at 09:05:16AM +0300, Martti Kuparinen wrote:
> Anyone else having this kind of problem?
> 
> Martti
> 
> 
> CHROOT www:/usr/pkgsrc/mail/squirrelmail-locales> make deinstall package 
> clean clean-depends
> ...
> => Required installed package php5-gettext>=4.3.3: NOT found
> => Verifying package for ../../devel/php-gettext
> => Required installed package digest>=20010302: digest-20070803 found
> ===> Skipping vulnerability checks.
> WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
> WARNING: To fix run: `download-vulnerability-list'.
> ===> Configuring for php5-gettext-5.2.4
> /usr/pkg/bin/phpize: /usr/pkgsrc/lang/php5/work/.tools/bin/sed: not found
> /usr/pkg/bin/phpize: /usr/pkgsrc/lang/php5/work/.tools/bin/sed: not found
> /usr/pkg/bin/phpize: /usr/pkgsrc/lang/php5/work/.tools/bin/sed: not found
> ...

I've fixed that a few minutes ago. Please update your "php" package to
version 5.2.4nb1.

	Kind regards

--

-- 
Matthias Scheler                                  http://zhadum.org.uk/

(Continue reading)

Matt Fleming | 3 Sep 15:12 2007
Picon

textproc/xmlto does not build on Mac OS X


Hi,

I've run into the following problem when trying to build xmlto on my Mac OS X 
machine. Do I need to add something to pkg/etc/xml/catalog? I'm not at all 
familiar with XML catalogs. Any help at all would be appreciated.

--mjf

===> Building for xmlto-0.0.18nb4
/Volumes/NetBSD/pkg/bin/bmake  all-am
if gcc -DHAVE_CONFIG_H -I. -I. -I.   -no-cpp-precomp -I/Volumes/NetBSD/pkg/include -I/usr/include 
-pipe -O2 -I/Volumes/NetBSD/pkg/include -I/usr/include -MT xmlif/xmlif.o -MD -MP -MF
"xmlif/.deps/xmlif.Tpo" -c -o xmlif/xmlif.o `test -f 'xmlif/xmlif.c' || echo './'`xmlif/xmlif.c; 
then mv -f "xmlif/.deps/xmlif.Tpo" "xmlif/.deps/xmlif.Po"; else rm -f "xmlif/.deps/xmlif.Tpo";
exit 1; fi
gcc  -pipe -O2 -I/Volumes/NetBSD/pkg/include -I/usr/include  -L/Volumes/NetBSD/pkg/lib -L/usr/lib
-o xmlif/xmlif  xmlif/xmlif.o  
for xml in xmlif.xml xmlto.xml; do  FORMAT_DIR=./format XSL_DIR=./xsl  bash ./xmlto -o man/man1 man
./doc/$xml ;  done || ( RC=$?; cat ./FAQ; exit $RC )
xmlto: input does not validate (status 3)
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd
/Volumes/NetBSD/pkgsrc/textproc/xmlto/work/xmlto-0.0.18/./doc/xmlif.xml:4: warning: failed to
load external entity "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd"
   "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
                                                            ^
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd
warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd"
validity error : Could not load the external subset "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd"
Document /Volumes/NetBSD/pkgsrc/textproc/xmlto/work/xmlto-0.0.18/./doc/xmlif.xml does not validate
(Continue reading)

Gergo Szakal | 4 Sep 04:02 2007
Picon

Re: djbdns/dnscache extgernal IP

Thank you, the dnscache_ip variable did the trick. But can I specify
multiple listening IP's somehow? Like dnscache_ip="127.0.0.1,
192.168.0.1"? Or just set it to 0.0.0.0?

Havard Eidnes | 4 Sep 08:52 2007
Picon

Package binaries for NetBSD/alpha 2.1 / pkgsrc-2007Q2

Hi,

I've uploaded the results of a bulk rebuild for NetBSD/alpha
2.1 to

   ftp://ftp.NetBSD.org/pub/pkgsrc/packages/NetBSD/alpha/2.1_2007Q2/

A total of 4.4GB of packages were uploaded.

Following our relatively recent policy, the 2006Q3 packages for
this platform will soon be removed; we keep only at most two sets
of binaries for each os-version / architecture.

The source tree this was built from was updated Jul 14 2007.

I have a new update to this lined up already, but it'll be a
couple of days until I can upload the result.

Regards,

- Håvard

Peter Eisch | 4 Sep 17:55 2007
Picon

Bacula user seeks maintainer


I recall seeing the notice that the former maintainer of the package is no
longer in a place to keep the release found in pkgsrc fresh.  It seems to be
a wee bit complicated of a package for a n00b maintainer to raise a hand.
If there were tender guidance I might be of use though.

Ideas?

peter

Picon

Installing MaraDNS on Solaris 10/SPARC using pkgsrc-2007Q2

While installing MaraDNS I got the following error. Any ideas?

$ sudo bmake package
=> Required installed package digest>=20010302: digest-20060826 found
===> Checking for vulnerabilities in maradns-1.0.39
===> Installing for maradns-1.0.39
=> Creating installation directories
=> Running PRE-INSTALL script actions
cd build ; TOPLEVEL=`pwd`/.. VERSION=1.0.39 PREFIX=/usr ./install.sh ;
gcc -lxnet -DSOLARIS -DNO_FLOCK copy.devs.c ; ./a.out ; rm ./a.out ;
cd ..
Installing MaraDNS, placing programs in /usr/bin/ and /usr/sbin/,
man pages in /usr/man/man1/, /usr/man/man5/,
and /usr/man/man8/, and documents in /usr/lib/maradns-1.0.39
Can not mknod device /etc/maradns/dev//dev
mv: cannot access /usr/pkg/share/doc/maradns/examples
*** Error code 2

Stop.
bmake: stopped in /usr/pkgsrc/net/maradns
*** Error code 1

Stop.
bmake: stopped in /usr/pkgsrc/net/maradns
*** Error code 1

Stop.
bmake: stopped in /usr/pkgsrc/net/maradns

--

-- 
(Continue reading)

Amitai Schlair | 5 Sep 05:12 2007

Re: djbdns/dnscache extgernal IP

Gergo Szakal wrote:

> Thank you, the dnscache_ip variable did the trick. But can I specify
> multiple listening IP's somehow? Like dnscache_ip="127.0.0.1,
> 192.168.0.1"? Or just set it to 0.0.0.0?

Do you really need to listen on multiple IPs? If you want the machine 
that's running a cache for your internal network to use that same cache, 
just point /etc/resolv.conf at 192.168.0.1. What are you trying to do?

If you really need to listen on any and all IPs, 0.0.0.0 should work. If 
you really need to listen on multiple specific IPs, you need multiple 
dnscache services. This is a limitation of dnscache itself; you'd run 
into it using DJB's install instructions, too.

(See also PR 30957.)

Gergo Szakal | 6 Sep 00:48 2007
Picon

Re: djbdns/dnscache extgernal IP

Thank you for all the information you provided.


Gmane