oster | 1 Mar 04:35 2012
Picon

Re: pkg/46107 (meta-pkgs/boost fails to build on NetBSD-5.1/amd64)

Synopsis: meta-pkgs/boost fails to build on NetBSD-5.1/amd64

State-Changed-From-To: open->closed
State-Changed-By: oster <at> NetBSD.org
State-Changed-When: Thu, 01 Mar 2012 03:35:05 +0000
State-Changed-Why:
hans <at>  fixed this with the update to boost 1.49.0.  Thanks!

yamt | 1 Mar 09:30 2012
Picon

pkg/46117: graphics/opencv doesn't build on OS X

>Number:         46117
>Category:       pkg
>Synopsis:       graphics/opencv doesn't build on OS X
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 01 08:30:00 +0000 2012
>Originator:     YAMAMOTO Takashi
>Release:        pkgsrc current
>Organization:
	
>Environment:
	
	
>Description:

	i got the following on Mac OS X 10.6. (snow leopard)

Scanning dependencies of target libtiff
[  0%] Building C object 3rdparty/libtiff/CMakeFiles/libtiff.dir/tif_aux.o
In file included from /Users/takashi/wrkobjdir/graphics/opencv/work/.buildlink/include/tiff.h:30,
                 from /Users/takashi/wrkobjdir/graphics/opencv/work/.buildlink/include/tiffio.h:33,
                 from /Users/takashi/wrkobjdir/graphics/opencv/work/OpenCV-2.2.0/3rdparty/libtiff/tiffiop.h:67,
                 from /Users/takashi/wrkobjdir/graphics/opencv/work/OpenCV-2.2.0/3rdparty/libtiff/tif_aux.c:32:
/Users/takashi/wrkobjdir/graphics/opencv/work/.buildlink/include/tiffconf.h:18:1: warning:
"TIFF_INT64_T" redefined
(Continue reading)

jonathan+pkgsrc | 1 Mar 11:40 2012

pkg/46119: libX11 doesn't finish build on Debian GNU/Linux 6.0 (squeeze)

>Number:         46119
>Category:       pkg
>Synopsis:       libX11 doesn't finish build on Debian GNU/Linux 6.0 (squeeze)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 01 10:40:00 +0000 2012
>Originator:     Jonathan
>Release:        Debian GNU/Linux 6.0 (squeeze)
>Organization:
>Environment:
Linux asa 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011 x86_64 GNU/Linux

LSB Version:	core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:qt4-3.1-amd64:qt4-3.1-noarch
Distributor ID:	Debian
Description:	Debian GNU/Linux 6.0 (squeeze)
Release:	6.0
Codename:	squeeze

>Description:
cd util && /usr/bin/make
make[5]: Entering directory `/data/pkgsrc/x11/libX11/work/libX11-1.3.5/src/util'
make[5]: Nothing to be done for `all'.
make[5]: Leaving directory `/data/pkgsrc/x11/libX11/work/libX11-1.3.5/src/util'
test -z "/data/linux/lib" || /data/pkgsrc/x11/libX11/work/.tools/bin/mkdir -p "/data/pkgsrc/x11/libX11/work/.destdir/data/linux/lib"
 ../doltlibtool   --mode=install /usr/bin/install -c -o jonathan -g users   libX11.la libX11-xcb.la '/data/pkgsrc/x11/libX11/work/.destdir/data/linux/lib'
(Continue reading)

oster | 1 Mar 17:50 2012
Picon

pkg/46123: devel/qtscriptgenerator fails to build on NetBSD-5.1/amd64

>Number:         46123
>Category:       pkg
>Synopsis:       devel/qtscriptgenerator fails to build on NetBSD-5.1/amd64
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 01 16:50:00 +0000 2012
>Originator:     Greg Oster
>Release:        NetBSD 5.1
>Organization:
>Environment:
	
	
System: NetBSD mickey 5.1 NetBSD 5.1 (MICKEY) #0: Sun Nov 7 08:21:58 CST 2010
oster <at> quad:/u1/builds/build184/src/obj/amd64/u1/builds/build184/src/sys/arch/amd64/compile/MICKEY amd64
Architecture: x86_64
Machine: amd64
>Description:

	In my so-far-failing quest to get kde4 to build, I've now discovered
that devel/qtscriptgenerator fails thusly:

...

libtool --silent --mode=compile c++ -c -O2 -I/usr/pkg/include -I/usr/include
-I/usr/pkg/qt4/include -I/usr/pkg/include/freetype2 -DQ_TRAILING_DIR_SEP -D_REENTRANT -fPIC
(Continue reading)

yamt | 1 Mar 19:35 2012
Picon

pkg/46124: textproc/dsssl-docbook-modular collateindex.pl is not executable

>Number:         46124
>Category:       pkg
>Synopsis:       textproc/dsssl-docbook-modular collateindex.pl is not executable
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 01 18:35:14 +0000 2012
>Originator:     YAMAMOTO Takashi
>Release:        pkgsrc current
>Organization:
	
>Environment:
	Mac OS X 10.6
	
	
>Description:
	textproc/dsssl-docbook-modular installs collateindex.pl without
	executable mode bit.  postgresql's configure script seems to expect
	it executable.

>How-To-Repeat:
	
>Fix:
	

>Unformatted:
(Continue reading)

yamt | 1 Mar 20:10 2012
Picon

pkg/46125: lang/erlang doesn't build on OS X 10.6.8

>Number:         46125
>Category:       pkg
>Synopsis:       lang/erlang doesn't build on OS X 10.6.8
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 01 19:10:00 +0000 2012
>Originator:     YAMAMOTO Takashi
>Release:        pkgsrc current
>Organization:
	
>Environment:
	
	
System: Mac OS X 10.6.8
>Description:
	i got the following error.

=== Entering application runtime_tools
make 
RELEASE_PATH=/Users/takashi/wrkobjdir/lang/erlang/work/.destdir/Users/takashi/pkg/lib/erlang
  release_spec
/usr/bin/install -c -o takashi -g staff -d /Users/takashi/wrkobjdir/lang/erlang/work/.destdir/Users/takashi/pkg/lib/erlang/lib/runtime_tools-1.8.6/src
/usr/bin/install -c -o takashi -g staff -m 644 -p erts_alloc_config.erl inviso_rt.erl
inviso_rt_meta.erl inviso_rt_lib.erl inviso_as_lib.erl inviso_autostart.erl
inviso_autostart_server.erl runtime_tools.erl runtime_tools_sup.erl dbg.erl
(Continue reading)

dholland | 1 Mar 20:52 2012
Picon

Re: pkg/46119 (libX11 doesn't finish build on Debian GNU/Linux 6.0 (squeeze))

Synopsis: libX11 doesn't finish build on Debian GNU/Linux 6.0 (squeeze)

State-Changed-From-To: open->closed
State-Changed-By: dholland <at> NetBSD.org
State-Changed-When: Thu, 01 Mar 2012 19:52:11 +0000
State-Changed-Why:
Submitter reported in chat that it turned out to be a local problem.

David Holland | 1 Mar 20:55 2012
Picon

Re: pkg/46104: kdegames4 ALIGN defined in sys/param.h NetBSD 6.99.3 patch

The following reply was made to PR pkg/46104; it has been noted by GNATS.

From: David Holland <dholland-pbugs <at> netbsd.org>
To: gnats-bugs <at> NetBSD.org
Cc: 
Subject: Re: pkg/46104: kdegames4 ALIGN defined in sys/param.h NetBSD 6.99.3
 patch
Date: Thu, 1 Mar 2012 19:50:43 +0000

 On Wed, Feb 29, 2012 at 07:00:07AM +0000, Mark Davies wrote:
  >  >  This doesn't make sense. ALIGN and __CMSG_ALIGN are not necessarily 
  >  >  the
  >  >  same. So why can't this just use CMSG_SPACE as defined in 
  >  >  sys/socket.h?
  >  
  >  This is historic.  In a previous version of the code, using the standard 
  >  CMSG_SPACE resulted in 
  >  
  >  misc_private.h:78: error: array bound is not an integer constant
  >  
  >  so CMSG_SPACE was redefined the same way that they were doing it for 
  >  MacOS.
  >  
  >  Looks like this is no longer required and the whole patch can go away.

 Unfortunately, it'll still be needed for netbsd-5.

 -- 
 David A. Holland
 dholland <at> netbsd.org
(Continue reading)

jonathan+pkgsrc | 1 Mar 21:25 2012

pkg/46126: Add 256 colors support to rxvt-unicode

>Number:         46126
>Category:       pkg
>Synopsis:       Add 256 colors support to rxvt-unicode
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 01 20:25:00 +0000 2012
>Originator:     jonathan buschmann
>Release:        None
>Organization:
>Environment:
Linux
>Description:
rxvt-unicode support 256 colors via a configure args but it's currently not activated so it's still
limited, use the patch below to correct this.
>How-To-Repeat:

>Fix:
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 15112fc..5d82c0e 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
 <at>  <at>  -18,6 +18,8  <at>  <at>  USE_FEATURES+=                snprintf

 CONFIGURE_ENV+=                ac_cv_path_TIC=no

(Continue reading)

wiz | 1 Mar 23:12 2012
Picon

Re: pkg/46126 (Add 256 colors support to rxvt-unicode)

Synopsis: Add 256 colors support to rxvt-unicode

Responsible-Changed-From-To: pkg-manager-≥morr
Responsible-Changed-By: wiz <at> NetBSD.org
Responsible-Changed-When: Thu, 01 Mar 2012 22:12:52 +0000
Responsible-Changed-Why:
morr agreed to handle this.


Gmane