Hisashi T Fujinaka | 1 Nov 01:08 2004

Re: MySQL4 client & pthread

On Mon, 1 Nov 2004, Jaromir Dolecek wrote:

> Hisashi T Fujinaka wrote:
>> I'm not sure it works at all right now. A PR was filed by Martin
>> Husemann and it won't build for me, either. I wonder if someone can poke
>> grant.
>
> It appears there is some problem some libtoolization of the package.
> Is there _anyone_ who successfully built it on NetBSD?

I got it to work, but I'm not sure libmysqlclient ever built (I didn't
check).

--

-- 
Hisashi T Fujinaka - htodd <at> twofifty.com
BSEE(6/86) + BSChem(3/95) + BAEnglish(8/95) + MSCS(8/03) + $2.50 = latte

Louis Guillaume | 1 Nov 04:44 2004

Netatalk 2.0.1

Hello,

Is anyone working on upgrading net/netatalk to version 2.0.1?

I wouldn't mind trying my hand at it but don't want to duplicate anyone 
else's efforts. Also - I'm having a hard time building the package 
myself. Not sure how to go about creating a new PLIST, patches, 
buildlink3.mk and Makefile. Especially since I haven't gotten the 
package to even configure outside of pkgsrc. It gets stuck when checking 
out the Berkeley DB stuff...

checking whether default CNID scheme has been activated... yes
checking for Berkeley DB headers in /usr/pkg/include/db4.2... no
checking for Berkeley DB headers in /usr/pkg/include/db42... no
checking for Berkeley DB headers in /usr/pkg/include/db4.1... no
checking for Berkeley DB headers in /usr/pkg/include/db41... no
checking for Berkeley DB headers in /usr/pkg/include/db4... yes
checking /usr/pkg/include/db4/db.h version >= 4.1.0... 4.2.52, yes
checking for Berkeley DB link (-ldb-4.2)... no
checking for Berkeley DB link (-ldb42)... no
checking for Berkeley DB link (-ldb-42)... no
checking for Berkeley DB link (-ldb-4-2)... no
checking for Berkeley DB link (-ldb-4.1)... no
checking for Berkeley DB link (-ldb41)... no
checking for Berkeley DB link (-ldb-41)... no
checking for Berkeley DB link (-ldb-4-1)... no
checking for Berkeley DB link (-ldb-4)... no
checking for Berkeley DB link (-ldb4)... yes
checking Berkeley DB library version >= 4.1.0... no
checking for Berkeley DB headers in /usr/pkg/include/... no
(Continue reading)

Hisashi T Fujinaka | 1 Nov 05:27 2004

Re: MySQL4 client & pthread

On Sun, 31 Oct 2004, Hisashi T Fujinaka wrote:

> On Mon, 1 Nov 2004, Jaromir Dolecek wrote:
>
>> Hisashi T Fujinaka wrote:
>>> I'm not sure it works at all right now. A PR was filed by Martin
>>> Husemann and it won't build for me, either. I wonder if someone can poke
>>> grant.
>> 
>> It appears there is some problem some libtoolization of the package.
>> Is there _anyone_ who successfully built it on NetBSD?
>
> I got it to work, but I'm not sure libmysqlclient ever built (I didn't
> check).

I just reverted everything to pre-10/31 versions in
pkgsrc/databases/mysql-client and it builds successfully in current,
even installing libmysqlclient.

--

-- 
Hisashi T Fujinaka - htodd <at> twofifty.com
BSEE(6/86) + BSChem(3/95) + BAEnglish(8/95) + MSCS(8/03) + $2.50 = latte

Mark Davies | 1 Nov 05:28 2004
Picon
Picon

Re: Netatalk 2.0.1

On Monday 01 November 2004 16:44, Louis Guillaume wrote:
> Is anyone working on upgrading net/netatalk to version 2.0.1?

Well I have a package of version 2.0.0 that I've been testing over the last 
few days and which hopefully tonight I'll update to 2.0.1 and commit.

cheers
mark

John Klos | 1 Nov 12:45 2004

pkg_install problem

pkg_install is special; how is this supposed to be handled properly?

lain: {16} make update
===> do-su-deinstall [pkg_install-20041031] ===> Deinstalling for pkg_install
===> do-su-deinstall [pkg_install-20041031] ===> Becoming root <at> lain.ziaspace.com to deinstall pkg_install.
/usr/bin/su Terminal type is xterm-color.
Running /usr/sbin/pkg_delete -K /var/db/pkg -r pkg_install-20040813
Package `pkg_install-20040813' is marked as not for deletion
===> do-fetch [pkg_install-20041031] ===> Checking for vulnerabilities in pkg_install-20041031
===> do-su-install [pkg_install-20041031] ===> Installing for pkg_install-20041031
===> do-su-install [pkg_install-20041031] ===> Becoming root <at> lain.ziaspace.com to install pkg_install.
/usr/bin/su Terminal type is xterm-color.
===> real-su-install [pkg_install-20041031] ===> pkg_install-20040813 is already installed -
perhaps an older version?
*** If so, you may use either of:
***  - "pkg_delete pkg_install-20040813" and "/usr/bin/make reinstall" to upgrade properly
***  - "/usr/bin/make update" to rebuild the package and all of its dependencies
***  - "/usr/bin/make replace" to replace only the package without re-linking
***    dependencies, risking various problems.
*** Error code 1

John Klos
--

-- 
"An idealist is one who, on noticing that a rose smells better than a 
cabbage, concludes that it will also make better soup." - H.L. Mencken

Thomas Klausner | 1 Nov 12:49 2004
Picon

Re: pkg_install problem

On Mon, Nov 01, 2004 at 03:45:05AM -0800, John Klos wrote:
> pkg_install is special; how is this supposed to be handled properly?
> 
> lain: {16} make update
> ===> do-su-deinstall [pkg_install-20041031] ===> Deinstalling for 
> pkg_install
> ===> do-su-deinstall [pkg_install-20041031] ===> Becoming 
> root <at> lain.ziaspace.com to deinstall pkg_install.
> /usr/bin/su Terminal type is xterm-color.
> Running /usr/sbin/pkg_delete -K /var/db/pkg -r pkg_install-20040813
> Package `pkg_install-20040813' is marked as not for deletion
> ===> do-fetch [pkg_install-20041031] ===> Checking for vulnerabilities in 
> pkg_install-20041031
> ===> do-su-install [pkg_install-20041031] ===> Installing for 
> pkg_install-20041031
> ===> do-su-install [pkg_install-20041031] ===> Becoming 
> root <at> lain.ziaspace.com to install pkg_install.
> /usr/bin/su Terminal type is xterm-color.
> ===> real-su-install [pkg_install-20041031] ===> pkg_install-20040813 is 
> already installed - perhaps an older version?
> *** If so, you may use either of:
> ***  - "pkg_delete pkg_install-20040813" and "/usr/bin/make reinstall" to 
> upgrade properly
> ***  - "/usr/bin/make update" to rebuild the package and all of its 
> dependencies
> ***  - "/usr/bin/make replace" to replace only the package without 
> re-linking
> ***    dependencies, risking various problems.
> *** Error code 1

(Continue reading)

John Klos | 1 Nov 13:11 2004

Re: pkg_install problem


> Try re-adding the following two lines to the Makefile:
> NO_PKG_REGISTER=       # defined
> NO_PACKAGE=            Deinstallation is not permitted

Yep, that did it. I'm surprised that with this committed so long ago there 
weren't other complaints.

> If that's not sufficient, try 'make replace' and hope it works...

Nope. None of make replace, make deinstall reinstall, make update worked.

Who cares to commit?

Thanks,
John
--

-- 
"An idealist is one who, on noticing that a rose smells better than a 
cabbage, concludes that it will also make better soup." - H.L. Mencken

John Klos | 1 Nov 13:44 2004

pkglint?

Anyone know why lintpkgsrc is giving me 36 lines of:

Use of uninitialized value in pattern match (m//) at /usr/local/bin/lintpkgsrc line 747.

John

John Klos | 1 Nov 13:49 2004

Re: pkg_install problem

>> Try re-adding the following two lines to the Makefile:
>> NO_PKG_REGISTER=       # defined
>> NO_PACKAGE=            Deinstallation is not permitted

Might be worth mentioning that this left the old pkg_install stuff around:

Version mismatch: 'pkg_install' 20040813 vs 20041031

drwxr-xr-x    2 root  wheel      512 Oct 19 00:57 pkg_install-20040813

John

Thomas Klausner | 1 Nov 14:20 2004
Picon

Re: pkglint?

On Mon, Nov 01, 2004 at 04:44:18AM -0800, John Klos wrote:
> Anyone know why lintpkgsrc is giving me 36 lines of:
> 
> Use of uninitialized value in pattern match (m//) at 
> /usr/local/bin/lintpkgsrc line 747.

From looking at that line:
Perhaps because there are about 36 packages where it can't
find PKGNAME nor DISTNAME?
 Thomas


Gmane