hotlips Internet admin | 20 Jul 18:56 2015

swapcontext missing in - 10.2.-BETA2 amd64

please see bug # 201674  <at> for details

Bruce Becker			+1 416 410 0879
GTS Network Administration	Toronto, Ont.
Email:	hostmaster <at> GTS.Net
freebsd-stable <at> mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscribe <at>"

Beat Siegenthaler | 19 Jul 20:24 2015

cannot compile net/mosquitto port 10.1-STABLE

there seems to be some problem with the port, which i cannot resolve
with my poor compiler knowledge. Maintainers did not answer.
Any hint?

regards, Beat

[root <at> myserver:~] # uname -a
FreeBSD 10.1-STABLE FreeBSD 10.1-STABLE #0 r282210:
Wed Apr 29 17:38:56 CEST 2015

[root <at> myserver:/usr/ports/net/mosquitto] # make
===>  License BSD3CLAUSE accepted by the user
===>  Found saved configuration for mosquitto-1.3.2
===>   mosquitto-1.4.2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by mosquitto-1.4.2 for building
===>  Extracting for mosquitto-1.4.2
=> SHA256 Checksum OK for mosquitto-1.4.2.tar.gz.
===>  Patching for mosquitto-1.4.2
===>  Applying FreeBSD patches for mosquitto-1.4.2
/usr/bin/sed -i.bak -e '/ldconfig/d'
===>   mosquitto-1.4.2 depends on executable: xsltproc - found
===>   mosquitto-1.4.2 depends on file: /usr/local/bin/cmake - found
===>   mosquitto-1.4.2 depends on file: /usr/local/bin/python2.7 - found
===>   mosquitto-1.4.2 depends on executable: python2 - found
===>   mosquitto-1.4.2 depends on shared library: - found
(Continue reading)

Marc UBM via freebsd-stable | 19 Jul 17:34 2015

problem with geli and LSI controller

Hi all,

a few weeks ago our Highpoint Rocket Raid controller (hptrr) started
biting the dust (spurious channel resets). We bought a LSI 9201-16i
(mps) to replace it. Connected to the hptrr were 4 external e-sata
enclosures, configured in JBOD mode. Together with two disks connected
to the onboard SATA controller, this formed a geli encrypted raidz-2
Just now, I connected the disks to the mps controller. They show
up fine in dmesg. The problem is, when trying to attach the disks
formerly connected to the hptrr controller, geli is unable to find the
metadata on the disks and errors out with:

"geli: Cannot read metadata from /dev/da4: Invalid argument"

gpart show says "gpart: No such geom: da4"

Trying to restore the geli metadata gives:
"geli: Provider size mismatch: wrong backup file?"

Is it possible that the hptrr controller handled the disks in some
special way and it's only possible to read them there?

freebsd-stable <at> mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscribe <at>"
(Continue reading)

Joseph Mingrone | 19 Jul 02:04 2015

Re: suspend/resume regression

Head worked for me.

Joseph Mingrone <jrm <at>> writes:
> On head, resume worked, but the fn-f4 keybinding didn't suspend.  I
> had to use zzz.

Joseph Mingrone <jrm <at>> writes:
> No problem with -head on the X220 as well.

Shawn Webb | 18 Jul 17:54 2015

unionfs or tmpfs Kernel Panic on 10.2-BETA1

Looks like there's some locking issues in 10.2-BETA1/amd64. I'm at revision
bf2d0b176566519b95f21d01cc101f4b60247ab8 in this repo:

=== Begin Log ===
Trying to mount root from ufs:/dev/ufs/HardenedBSD_Install [ro,noatime]...
Mounting filesystems...
tunefs: soft updates set
tunefs: file system reloaded
camcontrol: subcommand "identify" requires a valid device identifier
panic: __lockmgr_args: recursing on non recursive lockmgr tmpfs  <at>  /usr/src/sys/kern/vfs_subr.c:2174
cpuid = 1
KDB: enter: panic
[ thread pid 20959 tid 100107 ]
Stopped at      kdb_enter+0x3e: movq    $0,kdb_why
db> bt
Tracing pid 20959 tid 100107 td 0xfffff80006680000
kdb_enter() at kdb_enter+0x3e/frame 0xfffffe00fd9c3200
vpanic() at vpanic+0x146/frame 0xfffffe00fd9c3240
panic() at panic+0x43/frame 0xfffffe00fd9c32a0
__lockmgr_args() at __lockmgr_args+0x1151/frame 0xfffffe00fd9c33b0
vop_stdlock() at vop_stdlock+0x3c/frame 0xfffffe00fd9c33d0
VOP_LOCK1_APV() at VOP_LOCK1_APV+0xfc/frame 0xfffffe00fd9c3400
_vn_lock() at _vn_lock+0xaa/frame 0xfffffe00fd9c3470
vget() at vget+0x67/frame 0xfffffe00fd9c34b0
tmpfs_alloc_vp() at tmpfs_alloc_vp+0x207/frame 0xfffffe00fd9c3530
tmpfs_lookup() at tmpfs_lookup+0x3d5/frame 0xfffffe00fd9c3590
VOP_CACHEDLOOKUP_APV() at VOP_CACHEDLOOKUP_APV+0xf1/frame 0xfffffe00fd9c35c0
vfs_cache_lookup() at vfs_cache_lookup+0xd6/frame 0xfffffe00fd9c3620
(Continue reading) | 18 Jul 06:35 2015

Problems adding Intel 750 to zfs pool


I've installed an Intel 750 400GB NVMe PCIe SSD in a Dell R320 running 
FreeBSD 10.2-beta-1... not STABLE, but not far behind, I think. 
Apologies if this is the wrong mailing list, or if this has been fixed 
in STABLE since the beta.

Anyway, I've gparted it into 2 partitions - 16GB for slog/zil and 357GB 
for l2arc. Adding the slog partition to the pool takes about 2 minutes - 
machine seems hung during that time. Ping works, but I can't open 
another ssh session.

Adding the l2arc doesn't seem to complete - it's been going 10 minutes 
now and nothing. Ping works, but I can't log in to the local console or 
another ssh session.

I'm adding the partitions using their gpt names. i.e.
zpool add zroot log gpt/slog
zpool add zroot cache gpt/l2arc

The system BIOS is up-to-date. The OS was a fresh 10.1 install, then 
freebsd-update to 10.2-beta2. 10.1 exhibited the same symptoms.

Root is on zfs.

Device was tested to be working on Windows 8.1 on a Dell T1700 workstation.

Any ideas?

(Continue reading)

henannk30 | 18 Jul 02:56 2015


Dear :

We come from ZHOUZHENG,HENAN PROVINCE of CHINA. According to the need of company developing, we are
interested in your wine. China is a huge market and has many consumers. I bet your wine will be popular
through our cooperation. We need order 20000 bottles

of white wine , 40000 bottles of red wine and every bottle is 750ml.Please let us know your price.


Thank you

Contact: su zhi jun

Address: zhengzhou wenhua road 18 # in china

Telephone: 0086-15538325676

freebsd-stable <at> mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscribe <at>"

Glen Barber | 18 Jul 00:57 2015

FreeBSD 10.2-BETA2 Now Available

The second BETA build of the 10.2-RELEASE release cycle is now

Installation images are available for:

o amd64 GENERIC
o i386 GENERIC
o ia64 GENERIC
o powerpc GENERIC
o powerpc64 GENERIC64
o sparc64 GENERIC

The image checksums follow at the end of this email.

FreeBSD/arm SD card images are available for:


Note:  For convenience for those without console access to supported arm
devices, a default 'freebsd' user exists for ssh(1) login.  The password
is 'freebsd', which it is strongly recommended to change after gaining
access to the system.  Additionally, the 'root' user password is 'root',
which is also recommended to change.

(Continue reading)

Michael L. Squires | 17 Jul 00:14 2015

Regression in FreeBSD-STABLE 10.2-BETA1 r28551

I've not worked with 10.x a lot, so please excuse novice mistakes.

I upgraded the OS on a quad Opteron Tyan S4881 (known to have SMP 
bugs, but I haven't seen any and I've been running this system for 
years).  I upgraded from an earlier version of FreeBSD-10.x to
FreeBSD 10.2-BETA1 r285551.

Problem:  during boot, when accessing the DVD drive attached to the 
EIDE bus there is an interrupt storm on interrupt 16.  After a few 
minutes of errors the boot continues successfully and the system 
appears to behave normally after that.  I do not use the DVD drive 
except for installs, which are infrequent.

The earlier kernel does not exhibit this behavior.

This is part of a verbose dmesg during a boot.  The complete dmesg is 

This does not appear to be a serious issue, and this is a home server 

Mike Squires
mikes <at> or michael.leslie.squires <at>
UN*X at home since 1986

FreeBSD 10.2-BETA1 #5 r285551: Tue Jul 14 23:13:18 EDT 2015
     root <at> amd64
FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512
CPU: AMD Opteron(tm) Processor 850 (2405.51-MHz K8-class CPU)
   Origin="AuthenticAMD"  Id=0x20f51  Family=0xf  Model=0x25  Stepping=1
(Continue reading)

jenkins-admin | 16 Jul 12:05 2015

Jenkins build is back to normal : Build-UFS-image #1973

See <>

freebsd-stable <at> mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscribe <at>"

Per olof Ljungmark | 15 Jul 21:52 2015

jail: /etc/rc: cannot create /dev/null: Operation not supported

FreeBSD 10.2-PRERELEASE #0 r284949

The jail can be started, but when /etc/rc is executed:

root <at> mar:/ # sh -x /etc/rc
+ stty status ^T
/etc/rc: cannot create /dev/null: Operation not supported
+ trap : 2
+ trap 'echo '\''Boot interrupted'\''; exit 1' 3
+ HOME=/
+ PATH=/sbin:/bin:/usr/sbin:/usr/bin
+ export HOME PATH
+ [ '' = autoboot ]
+ autoboot=no
+ _boot=quietstart
+ /sbin/sysctl -n vfs.nfs.diskless_valid
/etc/rc: cannot create /dev/null: Operation not supported

I have done the procedure several times before but never saw this one  
before and don't know how to get around it.

Ideas anyone? Any recent changes that can show up like the above?



freebsd-stable <at> mailing list
(Continue reading)