perikillo | 1 Jan 02:32 2006
Picon

Re: ipnat -CF -f /etc/ipnat.rules

On 12/30/05, Ruben Bloemgarten <rubenl <at> bloemgarten.demon.nl> wrote:
> Hi Caleb,
>
> Add ipfs_enable="YES".
>
> Regards,
> Ruben
>
> -----Original Message-----
> From: owner-freebsd-questions <at> freebsd.org
> [mailto:owner-freebsd-questions <at> freebsd.org] On Behalf Of caleb
> Sent: December 31, 2005 3:16 AM
> To: freebsd-questions <at> freebsd.org
> Subject: ipnat -CF -f /etc/ipnat.rules
>
> Hi everyone,
>             I have just put together a router/firewall using 5.4 RELEASE
> and IPFILTER. Everything is working fine except I have to manually flush
> the NAT table every time the router boots. below is my rc.conf and
> ipnat.rules, I have used rc.conf to start everything at boot;
>
> /* rc.conf */
>
> gateway_enable="YES"
> sshd_enable="YES"
> ifconfig_rl1="inet 10.0.0.1 netmask 255.255.255.0"
> ifconfig_rl0="inet 192.168.0.1 netmask 255.255.255.0"
> hostname="tweak"
> ipfilter_enable="YES"
> ipfilter_rules="/etc/ipf.rules"
(Continue reading)

Jeff Molofee | 1 Jan 02:56 2006

gdm, dbus or xscreensaver...?

I've had a serious problem this past week. I did an update last week, 
and after rebooting, I noticed an odd bar of scrambled graphics at the 
top of the screen in gdm/gnome. When I moved the mouse the bar would 
change, my keyboard would lock, etc. I ended up removing everything, and 
reinstalling clean.

For the past 3 nights everything has been fine. Until I updated my ports 
today.

 From console I watched the system upgrade GDM, DBUS and XSCREENSAVER. I 
shutdown, restarted my machine, and as soon as the gdm login screen 
appears I see this scrambled bar of color at the top of the screen. It 
looks like the mouse is somehow causing data to write directly to the 
display. I can still see my mouse pointer, and everything seems to be 
fine (keyboard works), but this bar of about 20-50 pixels full of random 
colors wont go away. The minute I move the mouse those lines are filled 
with colors.

I tried disabling dbus. This didn't help. I removed, and reinstalled 
gdm, nothing. I removed and reinstalled xscreensaver, still nothing. I 
know those were the only threee ports upgraded. Does anyone know what's 
going on?

releng_6
intel cpu
sata drives
usb mouse/keyboard
gnome2
all ports up to date
kernel/world up to date
(Continue reading)

Loren M. Lang | 1 Jan 03:31 2006

Re: FreeBSD router two DSL connections

On Wed, Dec 21, 2005 at 09:55:37AM -0800, Danial Thom wrote:
> 
> 
> --- "Loren M. Lang" <lorenl <at> alzatex.com> wrote:
> 
> > On Sun, Dec 11, 2005 at 11:28:17PM -0800, Ted
> > Mittelstaedt wrote:
> > > 
> > > If both DSL lines go to the same ISP it is
> > easy, run
> > > PPP on them and setup multilink PPP.  The ISP
> > has to
> > > do so also.
> > > 
> > > If they are going to different ISP's then you
> > cannot
> > > do it with any operating system or device
> > save BGP - the idea is
> > > completely -stupid- to put it simply.  If you
> > think different,
> > > then explain why and I'll shoot every
> > networking scenario
> > > you present so full of holes you will think
> > it's swiss cheese.
> > > And if you think your going to run BGP I'll
> > shoot that full
> > > of holes also.
> > 
> > I strongly disagree.  There are many reasons
> > for this.  Two of which are
(Continue reading)

Loren M. Lang | 1 Jan 03:38 2006

Re: FreeBSD router two DSL connections

On Fri, Dec 23, 2005 at 03:46:50PM -0800, Danial Thom wrote:
> Ted the incompetent, wrong on all counts once
> again:
> 
> 
> --- Ted Mittelstaedt <tedm <at> toybox.placo.com>
> wrote:
> 
> > 
> > 
> > >-----Original Message-----
> > >From: Danial Thom
> > [mailto:danial_thom <at> yahoo.com]
> > >Sent: Wednesday, December 21, 2005 9:56 AM
> > >To: Loren M. Lang; Ted Mittelstaedt
> > >Cc: Yance Kowara;
> > freebsd-questions <at> freebsd.org
> > >Subject: Re: FreeBSD router two DSL
> > connections
> > >
> > >
> > >All upstream ISPs are
> > >connected to everyone on the internet, so it
> > >doesn't matter which you send your packets to
> > >(the entire point of a "connectionless"
> > network.
> > >They both can forward your traffic to wherever
> > >its going.
> > 
> > They aren't going to forward your traffic
(Continue reading)

Loren M. Lang | 1 Jan 03:51 2006

Re: 6.0 STABLE install locks up within a few minutes

On Fri, Dec 09, 2005 at 08:49:14AM -0500, Brown, Steve wrote:
> By the way, the issue was gone when I installed to one of the IDE drives.
> 
> FreeBSD 6 must not like my SATA controller.  At least it tries though.  Red
> Hat 9 and Solaris 10 would not recongnize it at all during installation.

What SATA controller is it?  I know in particular the SiL3112 Silcon
Image chipset is buggy hardware.  If it's only an add-in card, you could
try another one.  I have a cheap Highpoint RocketRAID 1520.  It works
fine as a SATA controller, but the raid on it is fake-raid.  There is
little to no hardware support on it and it would be better to use
FreeBSD's built-in software raid if you need it.

By the way, the SiL3112 had problems on both linux and bsd, but it
worked most of the time.  I think the windows drivers they provide have
a work-around in them for the buggy hardware, but would you really want
buggy hardware?

> 
> -----Original Message-----
> From: owner-freebsd-questions <at> freebsd.org
> [mailto:owner-freebsd-questions <at> freebsd.org]On Behalf Of Brown, Steve
> Sent: Wednesday, December 07, 2005 3:25 PM
> To: FreeBSD Questions (E-mail)
> Subject: 6.0 STABLE install locks up within a few minutes
> 
> 
> Hello everyone,
>  
> I'm trying to get v6.0-STABLE installed on a PC that is running Windows (XP
(Continue reading)

Greg 'groggy' Lehey | 1 Jan 03:56 2006
Picon

Re: Nvidia fx 5500 Dual Monitor support

On Friday, 23 December 2005 at 20:30:26 -0600, Brandon Reeves wrote:
> I just got a dual head nvidia 5500 and am trying to get dual monitors setup
> where the monitors are basically independant of each other.  I seem to be
> doing something majorly wrong here but cant quite figure it out. Any insight
> on this type of config would be greatly appreciated.

It would help if you could say what you tried and what happened.

Greg
--
When replying to this message, please copy the original recipients.
If you don't, I may ignore the reply or reply to the original recipients.
For more information, see http://www.lemis.com/questions.html
See complete headers for address and phone numbers.
Ahnjoan Amous | 1 Jan 04:04 2006
Picon

setfacl file modification time

In 5.2.1-RELEASE, setfacl updates the modification time of the file
when acls are changed.  I haven't been able to find any complaints
about this behavior, is this something folks on the list would expect
when using setfacl?  If so, does anyone know a work around?

Thanks
Ahnjoan
_______________________________________________
freebsd-questions <at> freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe <at> freebsd.org"

Teo De Las Heras | 1 Jan 04:19 2006
Picon

Unable to boot to internal or serial console

I read through serial communication section in the FreeBSD handbook this
morning. I was able to configure the serial on one of my machines through
the following steps:
1. Edit /etc/ttys
a. ttyd0 "ttyd0 "/usr/libexec/getty std.9600" vt100 on insecure
2. Edit /boot/loader.rc
b. In the very first line add set console="comconsole"

After doing this on the second machine and rebooting, I am not able to get
to the serial console, video console, or SSH.  There are not errors on the
screen, just a blinking curser after "FreeBSD/i386 bootstrap loader,
Revision 1.1"

How can I get back into the system?
_______________________________________________
freebsd-questions <at> freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe <at> freebsd.org"

Ted Mittelstaedt | 1 Jan 05:18 2006

RE: RE: How to convert BIND to TinyDNS?


>-----Original Message-----
>From: Kristian Vaaf [mailto:vaaf <at> broadpark.no]
>Sent: Saturday, December 31, 2005 6:43 AM
>To: Ted Mittelstaedt
>Cc: questions <at> freebsd.org
>Subject: Re: RE: How to convert BIND to TinyDNS?
>
>
>
>You got some messed up spaces, or maybe it's me?
>
>Anyway. I totally agree to what you're saying. I am running BIND
>myself and I am not changing. But this person who manages my
>upcoming NS2, he is the one running TinyDNS, and he is among
>the smartest software developers I know of, so his reason to use
>TinyDNS is not to be questioned.
>

I'm not questioning his personal reasons to use tinyDNS, if he
wants to use it for himself, then fine.  But, it seems to me that the
responsibility of converting the data files to TinyDNS format belongs
to the person who wants to use TinyDNS.

If positions were reversed and the nameserver was already running
TinyDNS, and you came along and wanted to run BIND, then I
would say it would be your responsibility to convert it to BIND.

As a general rule in system administration, when someone
wants to change an existing system that is working to a new
(Continue reading)

JK | 1 Jan 05:32 2006

pkg or version conflict problems

I'm afraid that through my moronic attempts over the last few months I 
have gotten my 5.1 system into bad shape.  While trying to clean it up 
and make some sense out of it I've been trying to build mysql.  I'm 
getting this error message and no matter what I try I cannot get past 
it.

root <at> mysys:/usr/ports/databases/mysql50-server# make WITH_OPENSSL=yes
===>  mysql-server-5.0.17 is marked as broken: MySQL versions 
mismatch: mysql41-client is installed and wanted version is 
mysql50-client.

pkg_info doesn't show any mysql's installed.  I've tried pkg_delete 
and pkg_deinstall's. I've gone into all the 
/usr/ports/databases/mysql* directories and done make deinstall

Can someone please tell me what's wrong and how to fix it ( and maybe 
how I got into this state so I can understand what's going on)?

There must be another database or more involved that I'm not 
understanding.

Thank you

_______________________________________________
freebsd-questions <at> freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe <at> freebsd.org"


Gmane