Peter Ross | 19 Dec 07:22 2014
Picon

Apache 22 modules

Hallo allerseits,

ich habe tatsächlich noch Apache 2.2-Kisten.. Nun ja.

Seit kurzem konnte ich mod_php5 und mod_dav_svn nicht mehr bauen.

Dann haben ich in den Makefils USE_APACHE geändert. Von "22+" zu "22-24".

Jetzt geht es (und das mod_php5-Modul scheint auch zu funktionieren, ich 
habe ein MediaWiki erfolgreich darauf laufen).

Ich glaube, /usr/ports/Mk/bsd.apache.mk funktioniert nicht wie erwartet:

#  USE_APACHE= 22+      # specify [min] version, no [max] version
#  USE_APACHE= 22-24    # specify [min]-[max] range

Oder?

Es grüßt
Peter
Christoph Sold | 12 Dec 21:18 2014
Picon

Upgrade 9.3-Stable => 10-Stable ?

Hallo Allerseits,

$SUBJECT sagt schon alles: ich möchte meine 9.3-Stable-Kiste auf 10-Stable heben. Irgendwelche Besonderheiten?

Plan:
0) 9.3-Stable auf aktuelle 9-Stable heben (ist das nötig)?

1) /usr/src löschen, 10-Stable-Sourcen ziehen
2) make toolchain (ist das nötig? gleich kommt doch...)
3) make buildworld -Orgie (wie in /usr/src/UPDATING beschrieben)
4) make kernel
*) Single user entfällt: Remote Kiste ohne Konsole
5) mergemaster -p
6) make installworld
7) mergemaster -i
8 ZFS upgrade laut Notizen aus Updating
9) make delete-old
10) reboot

Tips, Hinweise, oder einfach machen?

-Cheasy

To Unsubscribe: send mail to majordomo <at> de.FreeBSD.org
with "unsubscribe de-bsd-questions" in the body of the message

Marc Santhoff | 30 Nov 23:59 2014
Picon

Bildschirm aus nach Xorg

Tag allerseits,

ich habe hier ein komisches Problem:

Ein Rechner ist ganz frisch auf leerer Platte mit R 9.3 aufgesetzt. Dazu
sind aktuelle packages mit pkg installiert, namentlich der Xorg Server
1.12.4.

Erstmal funktioniert auch alles wunschgemäß, aber wenn man ein mit
startx losgelassenes X wieder beendet, bleibt der Bildschirm schwarz.

Alles andere arbeitet, ich kann mit ALT-Fn die Konsole umschalten und
auch Befehle eingeben, mit einem anderen Rechner per ssh einloggen und
mit watch(8) zugucken. Daher weiß ich, daß der X-Server ordentlich
terminiert und kann das auch im Xorg.log sehen.

Aber die Anzeige läßt sich nicht wieder einschalten. Ich habe versucht
mit

# vidcontrol 80x25 < /dev/ttyv0

einen Reset zu erzwingen, der Befehl wird akzeptiert und ohne Fehler
ausgeführt, hilft aber nicht. Ich nehme an, die Hintergrundbeleuchtung
ist einfach aus, sowas hatte ich auch auf der stable-Liste neulich kurz
gesehen, da ging es auch um iirc 1.12.4 aber auf FBSD 10.

Kennt jemand das Problem? Eine Lösung vielleicht auch?
Wenn nicht, werde ich mal auf der stanle-Liste posten.

Netten Rest-Advent,
(Continue reading)

W4W - Nicola Tiling | 22 Nov 11:54 2014
Picon

Erfahrungen mit CBSD Jail Management ?

Hi

Hat jmd. hier schon mal CBSD (sysutils/cbsd) ausprobiert oder gar im produktiven Einsatz und könnte dazu
etwas berichten?

http://www.bsdstore.ru/en/about.html

Viele Grüße
Nicola

To Unsubscribe: send mail to majordomo <at> de.FreeBSD.org
with "unsubscribe de-bsd-questions" in the body of the message

W4W - Nicola Tiling | 22 Nov 11:51 2014
Picon

Der Weihnachtsmann ...

war schon da:

https://twitter.com/michaeldexter/status/534473413511741440/photo/1

:-)

To Unsubscribe: send mail to majordomo <at> de.FreeBSD.org
with "unsubscribe de-bsd-questions" in the body of the message

Peter Ross | 20 Nov 00:11 2014
Picon

ZFS kopieren mit Kompression am Empfänger

Hallo,

ich möchte gern ZFS send/receive für ein "mittelfristiges" Backup nutzen. 
Dazu wäre es gut, wenn ich das ZFS am Empfänger mit Kompression versehe.

Wenn ich das richtig sehe, kann ich nur neue Daten verdichten. Wenn ich 
ein ZFS mit Kompression anlege und auf beiden Seiten Snapshots habe, dann 
geht das für alle inkrementell übertragenen Daten, nehme ich an.

Wenn ich aber schon 100 GB Daten (ohne Snapshots) habe und die übertrage, 
legt das "zfs receive" das ZFS an - und  der Sender hat keine
Kompression angeschaltet.

Gibt es einen intelligenten Ausweg?

Es grüßt
Peter
Marc Santhoff | 11 Nov 10:53 2014
Picon

sshd im jail mag nicht binden

Tag allerseits,

ich habe hier ein seltsames Problem:

In einem Jail soll sshd laufen. Der kann aber (plötzlich?) nicht an
einen Port binden.

avrnut# /usr/sbin/sshd -Dde
debug1: sshd version OpenSSH_5.1p1 FreeBSD-20080901
debug1: private host key: #0 type 0 RSA1
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-Dde'
debug1: Bind to port 2222 on 10.0.0.31.
Bind to port 2222 on 10.0.0.31 failed: Can't assign requested address.
Cannot bind any address.

Komisch, das ganze ging zuletzt, obwohl es eine ganze Weile her ist. Ich
konnte von anderen Rechnern im LAN per ssh einloggen bzw. mit scp
Dateien umherschaufeln, das geht natürlich nicht mehr. Am Host- und auch
Jail-System wurde bis auf Kleinigkeiten nichts geändert, eigentlich
hatte ich keine Schwierigkeiten erwartet.

Jail-relevante Konfiguration sieht so aus:

ifconfig_re0_alias0="inet 10.0.0.31 netmask 0xffffffff"
ifconfig_re0_alias0="inet 10.0.0.32 netmask 0xffffffff"

jail_enable="YES"
(Continue reading)

Peter Ross | 10 Nov 06:39 2014
Picon

Virtualbox - remote X11

Hallo,

im Moment stehe ich vor einem kleinem Rätsel.

Ich habe derzeit lokal Oracle Linux, remote ein FreeBSD 10, auf dem 
VirtualBox läuft.

"Im Alltag laufen VMs ohne Grafik, headless.

Zur Installation benutze ich aber die GUI.

Einloggen: "ssh -X <remote>" funktioniert (xauth ist installiert)

"su -m" funktioniert auch.

"VirtualBox" - bringt mir die GUI auf meinen Desktop.

"Start" der VM bringt leider nicht die Konsole für die Installation, 
sondern:

"X11 connection rejected because of wrong authentication."

Ich bin etwas ratlos, da das vor zwei Wochen funktioniert hat und mich an 
keine Änderung erinnere.

Hat jemand eine Idee?

Danke
Peter
(Continue reading)

Matthias Fechner | 7 Nov 17:48 2014
Picon

Kann lokale IP von em0 nicht pingen

Hi,

ich habe ein komisches Problem.
Ich habe FreeBSD 10.0-RELEASE-p12 im Einsatz.

Es existieren 2 Netzwerkkarten:
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

options=4219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC,VLAN_HWTSO>
        ether 00:1b:21:7b:34:68
        inet 192.168.0.251 netmask 0xffffff00 broadcast 192.168.0.255
        inet6 fe80::21b:21ff:fe7b:3468%em0 prefixlen 64 scopeid 0x1
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
        ether bc:5f:f4:0c:46:09
        inet6 fe80::be5f:f4ff:fe0c:4609%re0 prefixlen 64 scopeid 0x2
        inet 192.168.1.2 netmask 0xffffff00 broadcast 192.168.1.255
        inet6 fd00::be5f:f4ff:fe0c:4609 prefixlen 64 autoconf
        inet6 2001:a60:1239:3d01:be5f:f4ff:fe0c:4609 prefixlen 64 autoconf
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active

Es ist keine Firewall aktiv.
# pfctl -s all
No ALTQ support in kernel
(Continue reading)

Heino Tiedemann | 3 Nov 19:45 2014
X-Face
Picon
Picon

lokale systemmails "bouncen" - Mail Delivery Subsystem <MAILER-DAEMON>

Hallo,

ich habe hier ein Standard FreeBSD 10 RELEASE installiert.
und meine Systemmails gahen jetzt auf _meinen_ user.

und ...d es ist echt merkwürdig: Dieses F*** Mailsystem braucht
anscheinend eine Verbindung ins Internet, für diese lokale zustellung.
Eigentlich ist es nicht mein wille, mich mit Dendmail zu befassen.

ich bekomme aber - wenn keine Verbindung zum Netztz besteht täglich
sowas:

Wie krank ist das denn? Was macht Sendmail da?

Heino

From: Mail Delivery Subsystem <MAILER-DAEMON>
Subject: Warning: could not send message for past 4 hours
To: <root <at> moby.tihnet>
Date: Mon, 3 Nov 2014 07:29:58 +0100 (CET) (12 hours, 11 minutes ago)

    **********************************************
    **      THIS IS A WARNING MESSAGE ONLY      **
    **  YOU DO NOT NEED TO RESEND YOUR MESSAGE  **
    **********************************************

The original message was received at Mon, 3 Nov 2014 03:01:19 +0100 (CET)
from localhost [127.0.0.1]

   ----- Transcript of session follows -----
(Continue reading)

Peter Ross | 17 Oct 08:37 2014
Picon

iSCSI target

Hi all,

Ich konfiguriere gerade ein iSCSI-Target.

Ich mag es nicht, in ctld.conf Passwörter in Klartext reinzustreuen. Kann 
man das umgehen? Gibt es andere Autentifizierungsmechanismen?

Ich habe das ähnlich bei ppp gesehen, aber immerhin ist es dort in einer 
"Extradatei", ppp.secret, so daß ich die Konfigs "paßwortfrei" in ein 
Repository einchecken konnte.

Es grüßt
Peter

Gmane