Alexander Klein | 20 May 17:42 2015
Picon

Berechtigungen bei symbolischen Links

Hallo,

ich hatte dieser Tage die Idee, man könnte vielleicht eine große Anzahl 
von Dateien, die alle zusammen verarbeitet werden sollen, vor 
Veränderungen schützen, indem man sie zusammen in ein Arbeitsverzeichnis 
symbolisch verlinkt, und dann die Rechte der Links entsprechend setzt.

Leider scheinen sich die Rechte der Links aber nicht wie gewünscht 
auszuwirken:

$ touch x; ls -l
total 0
-rw-r--r--  1 alex  alex  0 20 Mai 17:30 x

$ ln -s x y; ls -l
total 0
-rw-r--r--  1 alex  alex  0 20 Mai 17:30 x
lrwxr-xr-x  1 alex  alex  1 20 Mai 17:30 y -> x

$ chmod -h a-w y; ls -l
total 0
-rw-r--r--  1 alex  alex  0 20 Mai 17:30 x
lr-xr-xr-x  1 alex  alex  1 20 Mai 17:30 y -> x

$ echo test >> y; ls -l
total 4
-rw-r--r--  1 alex  alex  10 20 Mai 17:33 x
lr-xr-xr-x  1 alex  alex   1 20 Mai 17:30 y -> x

$ mv y z; ls -l
(Continue reading)

Nicolas Rachinsky | 17 May 22:34 2015

ipfw und pf

Hallo,

wie interagieren denn pf und ipfw, wenn beide aktiv sind?

Ich finde dazu in der Doku nichts und mein Googlen ist auch nicht
erfolgreich.

Danke!

Nicolas

To Unsubscribe: send mail to majordomo <at> de.FreeBSD.org
with "unsubscribe de-bsd-questions" in the body of the message

Marc Santhoff | 13 May 22:20 2015
Picon

dynamische Bibliothek umbennenen unter x64

Tag allerseits,

ich versuchte neulich, eine .so-Library umzubennenen und mittels Eintrag
in /etc/libmap.conf unter dem Originalnamen wieder zur Verfügung zu
stellen.

Dabei geht es konkret um den Port science/hdf5, der einmal in der
mittlerweile veralteten version 1.6.x und zusätzlich als neue Version
1.8.x sein Zeug, also die Bibliotheken und eine ganze handvoll tools
unter den gleichen Namen installiert. Zum Umstieg auf die neuere Version
würde ich gern in libmap.conf umschalten, welche grade benutzt wird,
damit ältere Progrmme bei Bedarf trotzdem sofort laufen können. Dazu
müssen natürlich beide gleichzeitig installiert sein, was ohne
umbennenen nicht möglich ist.

Problem dabei:
Selbst eine umbenannte .so wird vom Linker wieder mit ihrem
Originalnamen angesprochen.

Ich erinnere mich dunkel, daß bei 64-Bit-Systemen diese Information in
die Bibliothek mit eincompiliert wird, finde aber darüber nichts, habe
auch keine griffigen Suchwörter.

Kann mit jemand dies Phänomen erklären oder zumindest eine
Informationsquelle nennen?

Oder noch besser, kennt jemand eine Lösung?

Grüße,
Marc
(Continue reading)

Matthias Fechner | 29 Apr 21:22 2015
Picon

Probleme mit IPv6 und PF bei einem Hetzner Rechner

Hi,

ich habe komische Probleme auf einem Hetzner Rechner.
IPv4 geht mit Firewall problemlos.
IPv6 kann ich pingen, aber nicht anderes.
Wenn ich mit pfctl -d die Firewall deaktiviere klappt alles, wenn ich
sie mit pfctl -e wieder aktiviere geht nur noch ping6 aber alles andere
ist nicht erreichbar.

Vllt. kann mal jemand einen Blick auf die Config werfen, ich habe
aktuell keine Idee mehr woran es liegen könnte.
/etc/pf.conf:
######
EXT_IF = "xn0"

set block-policy return

# define table
table <fail2ban> persist
table <spamd> persist
table <spamd-white> persist

TcpState="flags S/SA modulate state"
UdpState="keep state"

tcp_pass="{ssh http https smtp smtps submission pop3 pop3s imap imaps
sieve ftp 30000:50000 5666 14534 8080 git}"
udp_pass="{8767}"

# don't filter on the loopback interface
(Continue reading)

Alexander Klein | 28 Apr 13:53 2015
Picon

Versionskonflikte nach pkg update

Hallo,

ich hatte heute - und habe teilweise auch noch - ein paar kuriose 
Probleme nach einem pkg update:

Zunächst lief eigentlich alles nach Plan, allerdings war es schon 
seltsam, dass pkg upgrade dann unbedingt Thunderbird entfernen wollte. 
Wie auch immer, ich habe ihm erlaubt, alle Änderungen durchzuführen und 
mir die Sache dann einmal näher betrachtet, wobei ein paar lustige 
Pannen aufgetaucht sind:

1. Thunderbird ist tatsächlich aus /latest verschwunden. Meine Versuche, 
die Pakete aus dem Cache manuell nachzuinstallieren waren alle 
erfolglos, insofern sich das Programm dann hinterher trotzdem nicht 
starten ließ, wegen einer falschen Bibliotheksversion.

2. Also schnell nach /quarterly umgeschaltet und von da Thunderbird 
installiert, das ging dann aber auch nicht, und zwar mit dem gleichen 
Problem, wohl weil für Pakete kein automatisches Downgrading vorgesehen ist.

3. Im Netz gesucht und gefunden: Das Versionsproblem hängt mit dem Paket 
icu zusammen, das ich dann auch noch einmal manuell als Downgrade von 
Version 55 auf 53 installiert habe. Danach ging Thunderbird, aber dafür 
LyX nicht mehr.

4. Also wieder pkg upgrade, dann manuell noch zusätzlich das 
icu-53-Paket aus der lokalen Paketdatei installiert und siehe da, beide 
Programme laufen.

Jetzt funktioniert alles, aber natürlich hat ein versuchsweises pkg 
(Continue reading)

Peter Ross | 22 Apr 04:28 2015
Picon

Samba 4.1 Member Server und Winbind-Nutzer

Hallo allerseits,

seit einiger Zeit habe ich einen Samba 4.1-AD-Server laufen.

Nun wollte ich einen Fileserver in die Domain bringen, als Member Server.

Also, smb4.conf gemäß

https://wiki.samba.org/index.php/Setup_a_Samba_AD_Member_Server

aufgesetzt.

wbinfo -u zeigt die Nutzer,

getent passwd - nur lokale Nutzer.

In /etc/nsswitch folgendes eingetragen:

passwd: files winbind
group: files winbind

Die Bibliothek.. nichts in ldconfig -r.. unter /usr/local/lib

nss_winbind.so.1

Umbenennen in libnss_winbind.so.1 ? (Hat das was mit dem Bug hier zu tun?:
https://bugzilla.samba.org/show_bug.cgi?id=9704 ) - dann sehe ich es unter 
ldconfig -r .. Bug? Oder mache ich hier was falsch?

Immer noch nichts.. RFC2307? Schema erweitert nach:
(Continue reading)

Alexander Klein | 20 Apr 15:38 2015
Picon

Nvi hängt auf smbfs-mounts

Hallo zusammen,

ich habe hier ein kleines Problem mit nvi und Dateien, die auf einer 
Windows-Freigabe liegen, und zwar verhält es sich so, dass in den 
allermeisten Fällen nvi direkt nach dem Start 100% der freien CPU-Zeit 
verbraucht, aber nichts am Bildschirm anzeigt. Besonders ärgerlich ist 
das bei Mercurial-Commits, denn hier kann man zwar mit ^C immerhin noch 
alles abbrechen, aber der verklemmte vi-Prozess bleibt trotzdem noch im 
Hintergrund hängen.

Nun hatte ich gehofft, dass das alles einfach mit "set nolock" zu lösen 
sei, aber das hat leider keinen Erfolg gebracht.

Da LibreOffice kurioserweise dasselbe Problem zu haben scheint, vermute 
ich irgendein Problem mit den Freigabeparametern, habe aber keine 
Ahnung, was es sein könnte, zumal die nsmb.conf ja recht einfach 
gestrickt ist.

Die Prozesse selbst scheinen die Rechenzeit übrigens nicht zu 
verbrauchen, aber in top steigt der CPU-Verbrauch der Kategorie "System" 
auf fast 100%.

Hat vielleicht jemand eine Erklärung für diesen kuriosen Effekt?

Danke und viele Grüße,

	Alexander

--

-- 
Alexander Klein
(Continue reading)

Johannes Kastl | 19 Apr 21:33 2015
Picon

FreeBSD und der Raspi


N Abend zusammen,

ich bastle gerade mit FreeBSD 10.1 auf einem Raspberry Pi B+ herum,
was eigentlich recht gut geht. Allerdings nervt das
Nicht-Vorhandensein der Pakete. Alles per Ports zu installieren
daaaaaaaaauert.

Weiß jemand, ob es Überlegungen gibt, Pakete für Raspi & Co
anzubieten? Oder übersteigt das die Kapazitäten des Projekts, da es ja
doch einige solche Rechner gibt, die dann alle gerne Pakete hätten...

Hat jemand schon mal Pakete für den Pi per cross-compile gebaut?
Klappt das einigermaßen einfach, oder ist das nur für Leute mit guten
Nerven? (Ich müsste dann eh noch schauen, wie ich die Pakete auf den
Pi kriege, anderes Netzwerk und so...)

Vielen Dank im Voraus!

Grüße,
Johannes
Peter Ross | 8 Apr 09:10 2015
Picon

FreeBSD IPSec "road warrior" - "Client"

Hallo,

ich habe derzeit bei einem Büro-Umzug in Sydney Probleme, meine "gewohnte" 
VPN-Verbindung mit fester IP hinzubekommen.

Ich muß erst einmal mit einem 4G-Modem vorlieb nehmen, welches lediglich 
eine dynamische 10.0.0.0/8-Adresse hat. Irgendwo beim Internetprovider 
findet NAT statt.. ab er immerhin wurde mir versprochen, daß es kein 
filtern gibt, so daß IPSec wohl klappen müßte.

Hier in Melbourne habe ich eine feste IP, und ein FreeBSD-Server, welcher 
als "Eingang" hinterm Modem steht ("DMZ-Server")

Das Gleiche in Sydney, aber halt nun hinter dem Modem mit dynamischer IP.

Ich kenne aus dem Handbuch den Aufbau von IPSec mit fester IP-Adresse (das 
habe ich auch benutzt), und ich habe auch Beispiele für die "Einwahl" von 
"road warriors" auf einen FreeBSD-Server mit IPSec (das habe ich auch 
schon benutzt)

Ich habe kein Beispiel, wo ein FreeBSD-Rechner der "Wanderer", der "road 
warrior", ist.

Ich hoffe, das schnell hinzubekommen, würde mich aber über jede Hilfe dazu 
freuen.. ich habe praktisch nur morgen, um das zu testen, bevor ich dahin 
gehe..

Danke für Hinweise
Peter
(Continue reading)

Johannes Kastl | 25 Mar 22:14 2015
Picon

Verwaltung von ports und packages gleichzeitig

Guten Abend,

vorab: Das soll kein Troll-Posting werden, da mir FreeBSD ziemlich gut
gefällt. Da gibt es nur eine Sache, zu der ich verwirrend viel
unterschiedliche Informationen finde. Aber von Anfang an...

Ich brauche postfix mit SASL2-Support, für das es kein Paket gibt. Daher
ist auf meiner FreeBSD-Maschine eine Mischung aus Paketen und Ports
installiert. Die ich jetzt irgendwie verwalten muss.

Variante 1:
Ich mache alles per Ports, und warte 8 Milliarden Stunden, bis alles
fertig installiert ist, obwohl ich eigentlich nur einen Port und viele
Pakete installiert habe.

Variante 2:
portmaster soll Pakets und Ports gleichzeitig verwalten können. Geht
aber nicht mit dem neuen PKGNG. Schade.

Variante 3:
Ich lasse alles per pkg aktualisieren, muss dann aber damit leben, dass
postfix neu installiert wird, ohne SASL2.

Variante 3b:
Ich setze ein lock (pkg lock) auf postfix, und aktualisiere alles per
pkg. Dann verpasse ich halt Updates für postfix.

Da man leider viel zu viel nicht mehr Aktuelles zur Verwaltung von
Paketen und Ports findet (Stichwort: PKGNG), habe ich mir folgende
Bastellösung überlegt:
(Continue reading)

Heino Tiedemann | 21 Mar 09:43 2015
X-Face
Picon
Picon

Warum gehen youtube videos aber keine Vimeo Videos auf freebsd

Hallo,

hat einer eine idee, warum alle Welt mit ihremn Firefox vimeo Videos
abspielen kann (ohne installiertes Flash) und das auf Linux, Windows,
und Mac, nur ich auf freeBSD kann keine Vimeo Videos abspielen.

Youtube klappt dagegegn hervorragend bei mir.

Ideen?

in

about:config

media.mediasource.enabled habe ich auf true gesetzt
media.mediasource.mp4.enabled habe ich auf true gesetzt

Huss das OS noch etwas bereitstellen jetzt?

Heino

To Unsubscribe: send mail to majordomo <at> de.FreeBSD.org
with "unsubscribe de-bsd-questions" in the body of the message


Gmane