Francesco Steno | 15 Sep 09:57 2014
Picon

pkg problems

Salve …
   .. non so se a causa di un ripristino di un disco in RAID 1 che ho ripristinato, oppure a causa di 
una mia distrazione,  fatto sta che dopo aver lanciato un portsnap fetch update, 
,  do un occhiata per trovare qualche corrispondenza tra l’output di  pkg_version -l “<“ ed il file
UPDATING …

così lancio

overdrive <at>  FaipRyLp /usr/ports]$ sudo portmaster -a
Password:
===>>> Gathering distinfo list for installed ports

===>>> Starting check of installed ports for available updates

	===>>> The databases/db42 port moved to databases/db48
	===>>> Reason: Superseded by databases/db48

===>>> Launching child to reinstall db42-4.2.52_5

===>>> All >> db42-4.2.52_5 (1/1)

	===>>> The databases/db42 port moved to databases/db48
	===>>> Reason: Superseded by databases/db48

===>>> Currently installed version: db48-4.8.30.0_2
===>>> Port directory: /usr/ports/databases/db48

===>>> Launching 'make checksum' for databases/db48 in background
===>>> Gathering dependency list for databases/db48 from ports
===>>> Launching child to install ports-mgmt/pkg
(Continue reading)

Kruznak | 6 Sep 10:38 2014
Picon

Ripristino RAID mirroring

Salve a tutti,

mi scuso in anticipo per la banalità della domanda ma, non avendo mai
avuto a che fare con la configurazione di un RAID software prima d'ora,
non vorrei commettere qualche stupidaggine e compromettere i dati
presenti su disco. La situazione è la seguente:

su una macchina FreeBSD 8.2 con 2 dischi in RAID, ad6 è improvvisamente
morto, lasciando il device gm0 in stato degraded; dopo aver richiesto ai
tecnici in server farm la sostituzione del disco danneggiato, mi ritrovo
l'esigenza di ripristinare la situazione antecedente al guasto.

*Credo che dovrebbe* bastare dare un:

# gmirror insert gm0 /dev/ad6

perché si avvii l'autosync e tutto ritorni alla normalità, ma non ne
sono affatto sicuro. Qualcuno di buon cuore potrebbe darmene conferma? :-)

Grazie mille, ciao!

Kruznak

_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto

Franco Marchesini | 25 Aug 21:23 2014
Picon

jail, pf e ossec

Nella infrastruttura virtuale che sto' provando a realizzare non mi funziona il collegamento tra ossec-server ed un agente installato in una jail.

Nello specifico queste sono le regole  utilizzate dal pf.

ext_if = "re0"
int_if = "em0"
local_net = "10.10.10/24"
web_server = "10.10.10.10"
web_ports = "{ http, https }"
udp_ports ="{ domain, ntp }"

ssh_server = "10.10.10.9"
ssh_port = " ssh "

table <ossec_fwtable> persist #ossec_fwtable

scrub in all

nat on $ext_if from $local_net to any -> $ext_if
rdr on $ext_if proto tcp from any to any port $web_ports -> $web_server
rdr on $ext_if proto tcp from any to any port $ssh_port -> $ssh_server

antispoof log quick for { $ext_if } inet

#block all
block in all
pass on $int_if all
pass out on $ext_if all

set skip on lo0

block in log quick from <ossec_fwtable>

pass quick proto tcp from any to $web_server port $web_ports
pass quick proto tcp from any to $ssh_server port $ssh_port 

pass in on $int_if proto udp from $local_net to any port 1514


La jail ha indirizzo 10.10.10.9 e dovrebbe dialogare con l'host che ha indirizzo 10.10.10.1.
Le macchine si vedono, entro ed esco con ssh da una all'altra.

Il netstat sull'host e sulla jail dicono che c'e' il collegamento solo dalla jail verso l'host (la porta 1514 viene interpretata come fujitsu-dtc)

udp4       0      0 10.10.10.9.53362       10.10.10.1.fujitsu-dtc 

per cui penso che sia un problema di udp che pensavo di aver risolto con l'ultima regola del firewall, evidentemente sto' sbagliando qualcosa.

Ogni idea e' la bene accetta.

Saluti
Franco


_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto
Franco Marchesini | 21 Aug 11:42 2014
Picon

jail.conf

Ciao,

in lista c'e' qualcuno che sia riuscito a far funzionare una jail su freebsd10 usando il sistema del jail.conf?

Saluti
Franco
_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto
Franco Marchesini | 20 Aug 16:56 2014
Picon

qjail e pkg

Ciao a tutti,
il problema: ho una mail che non esce da nessuna parte.
Cerchero' di essere preciso.

Ho installato una macchina ex novo, l'ho aggiornata, l'ho messa in internet ed ho installato solo qjail

franco <at> jails:~ % uname -a
FreeBSD jails.xxxxxx.net 10.0-RELEASE-p7 FreeBSD 10.0-RELEASE-p7 #0: Tue Jul  8 06:37:44 UTC 2014     root <at> amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

franco <at> jails:~ % pkg info
pkg-1.3.6                      Package manager
qjail-3.4                      Utility to quickly deploy and manage jails

Come da manuale ho installato qjail ed ho allineato i binari in sharedfs

root <at> jails:~ # qjail install
root <at> jails:~ # qjail update -b

Ho creato una jail di test

root <at> jails:~ # qjail create -i 1GB -4 10.10.10.10 -n em0 jweb

Attivo ed entro nella mail appena creata
root <at> jails:~ # qjail start jweb
root <at> jails:~ # qjail console jweb

Last login: Wed Aug 20 16:10:40 on ttyv0
FreeBSD 10.0-RELEASE-p7 (GENERIC) #0: Tue Jul  8 06:37:44 UTC 2014

Welcome to your FreeBSD jail.
jweb /root >

Se provo ad installare il package di apache

jweb /root >pkg install apache24
The package management tool is not yet installed on your system.
Do you want to fetch and install it now? [y/N]: y
Bootstrapping pkg from pkg+http://pkg.FreeBSD.org/freebsd:10:x86:64/latest, please wait...
A pre-built version of pkg could not be found for your system.
Consider changing PACKAGESITE or installing it from ports: 'ports-mgmt/pkg'.

Il problema penso che risieda nel fatto chela mail non riesca ad uscire, infatti dopo aver installato i ports e provato con quelli ottengo:

jweb /root >cd /usr/ports/www/apache24/
jweb /usr/ports/www/apache24 >make install -DBATCH clean
===>   apache24-2.4.10_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>  License BSD2CLAUSE accepted by the user
=> pkg-1.3.6.tar.xz doesn't seem to exist in /var/ports/distfiles/.

Per completare questo e' l'rc.conf della jail

jweb /usr/ports/www/apache24 >less /etc/rc.conf 
# No network interfaces in jails
network_interfaces=""
 
# Prevent rpc
rpcbind_enable="NO"
 
# Prevent jails from doing their cron jobs at the same time
cron_flags=" -J 60"
 
# Prevent syslog from opening sockets
syslogd_enable="NO"
syslogd_flags="-ss"
 
# Prevent sendmail from trying to connect to localhost
sendmail_enable="NO"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"

jweb /usr/ports/www/apache24 >less /etc/resolv.conf 
domain  xxxxxx.net
nameserver 88.149.128.22
nameserver 88.149.128.12

Questa la configurazione dell'host

root <at> jails:~ # less /etc/rc.conf 
hostname="jails.xxxxxx.net"
keymap="it.iso.kbd"
ifconfig_re0="inet 78.134.xx.20 netmask 255.255.255.248"
ifconfig_em0="inet 10.10.10.1 netmask 255.0.0.0"

#pf_enable="YES"
#pflog_enable="YES"

sshd_enable="YES"
ntpd_enable="YES"
dumpdev="NO"
zfs_enable="YES"
sendmail_enable="NONE"
defaultrouter="78.134.xx.22"
syslogd_flags="-ss"
gateway_enable="YES"
ipv6_gateway_enable="YES"
qjail_enable="YES"

root <at> jails:~ # less /etc/resolv.conf 
domain  xxxxxx.net
nameserver 88.149.128.22
nameserver 88.149.128.12

Qualcuno riesce a dirmi cosa ho sbagliato?

Grazie infinite
Franco



_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto
Franco Marchesini | 20 Aug 13:09 2014
Picon

cio' e' strano

Ciao a tutti,

tempo fa' avevo registrato un dominio mai utilizzato.
Adesso ho attivato una macchina di prova con ip pubblico statico e sul pannellino del provider ho associato il dominio all'IP.

Funziona tutto ma ho fatto una scoperta che mi ha lasciato basito.

Mettiamo che il dominio sia pippo.net

Macchina accesa
Pingo da un'altra rete il nome del dominio e mi risponde la macchina
Macchina spenta
Pingo da un'altra rete il nome del dominio e nessuno mi risponde  

Pero', sia a macchina spenta che accesa pingo qualsiasicosa.pippo.net mi risponde sempre l'IP 208.91.197.27, con cui non ho niente a che fare.

Cosa devo pensare?

Grazie per le risposte
Franco

_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto
Nico Lime | 26 Jun 09:05 2014
Picon

Re: Digest di Aiuto, Volume 73, Numero 5

> Piuttosto, che configurazione dischi pensi di adottare?

>la mia idea era quella di adottare un raid5 hardware con 4 dischi WD RED.
>non ho mai capito perchè ZFS e raid hardware non vanno d'accordo, ne sapete di più voi ?
>grazie nico


Il giorno 10 giugno 2014 12:00, <aiuto-request <at> gufi.org> ha scritto:
Invia le richieste di iscrizione alla lista Aiuto all'indirizzo
        aiuto <at> gufi.org

Per iscriverti o cancellarti attraverso il web, visita
        http://mailman.gufi.org/mailman/listinfo/aiuto
oppure, via email, manda un messaggio con oggetto `help' all'indirizzo
        aiuto-request <at> gufi.org

Puoi contattare la persona che gestisce la lista all'indirizzo
        aiuto-owner <at> gufi.org

Se rispondi a questo messaggio, per favore edita la linea dell'oggetto
in modo che sia più utile di un semplice "Re: Contenuti del digest
della lista Aiuto..."


Argomenti del Giorno:

   1. Re: file system per uso multimedia (Pino Cinelli)
   2. Re: file system per uso multimedia (Paolo Faustini)
   3. Re: file system per uso multimedia (Davide D'Amico)
   4. Re: file system per uso multimedia (Paolo Faustini)
   5. Re: file system per uso multimedia (Paolo Faustini)
   6. Re: E normale ?? (Cristiano Deana)


----------------------------------------------------------------------

Message: 1
Date: Mon, 9 Jun 2014 12:59:15 +0200
From: Pino Cinelli <pinocino <at> gmail.com>
To: Aiuto su FreeBSD <aiuto <at> gufi.org>
Subject: Re: file system per uso multimedia
Message-ID:
        <CAE4ML4j4tcd2krHwx=Za38GnEY9yf3TmiquyHxc_6s8ouvqnsA <at> mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Ciao

forse ci hai gia pensato ma potresti utilizzare FreeNAS , sa hai bisgono di
qualche funzione particolare puoi compilarti il plugin .

Pino


Il giorno 09 giugno 2014 11:41, Nico Lime <nicosuperwav <at> gmail.com> ha
scritto:

> ciao a tutti
> sono alle prese con la costruzione di un NAS da 12TB per uso multimediale,
> utilizzando il file system UFS quali sono i parametri che più si adattano a
> questo suo (file grandi minimo sono 30/40 MB per file) ? mi aiutate a
> costruire il file system ?
> grazie mille a tutta la comunity
> nico
>
> _______________________________________________
> Aiuto mailing list
> Aiuto <at> gufi.org
> http://mailman.gufi.org/mailman/listinfo/aiuto
>
>
-------------- parte successiva --------------
Un allegato HTML è stato rimosso...
URL: <http://mailman.gufi.org/pipermail/aiuto/attachments/20140609/0b9bc7a6/attachment-0001.html>

------------------------------

Message: 2
Date: Mon, 09 Jun 2014 13:29:19 +0200
From: Paolo Faustini <paolo.faustini <at> 1807snc.it>
To: aiuto <at> gufi.org
Subject: Re: file system per uso multimedia
Message-ID: <53959A8F.9080903 <at> 1807snc.it>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

On 09/06/2014 11:41, Nico Lime wrote:
>
> sono alle prese con la costruzione di un NAS da 12TB per uso
> multimediale, utilizzando il file system UFS quali sono i parametri
> che più si adattano a questo suo (file grandi minimo sono 30/40 MB per
> file) ? mi aiutate a costruire il file system ?
>

Usa ZFS, se puoi. Senza volere denigrare UFS3, che e' la mia scelta per
i FS di sistema (nel caso possa disporre di uno spindle separato), ZFS
ha molti vantaggi nell' uso pratico, per volumi cosi' grandi.

Piuttosto, che configurazione dischi pensi di adottare?

Per la mia esperienza (NAS da 6Tb in su, prima con UFS poi con ZFS), i
dischi da 2-3Tb hanno la brutta abitudine di guastarsi troppo spesso,
magari in modo intermittente: con ZFS e una giusta configurazione, e' un
attimo togliere il disco guasto, rimettere quello nuovo, ricreare la
partizione, e via, senza perdere dati...

Salve, Paolo



------------------------------

Message: 3
Date: Mon, 9 Jun 2014 12:32:33 +0100
From: "Davide D'Amico" <davide.damico <at> gmail.com>
To: Aiuto su FreeBSD <aiuto <at> gufi.org>
Subject: Re: file system per uso multimedia
Message-ID:
        <CAHykR+KyabWe8byczmNTX_HwPNK5SBAbmdMAVmJpRZtApfoxtw <at> mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Hai valutato progetti come MogileFS?


Il giorno 09 giugno 2014 12:29, Paolo Faustini <paolo.faustini <at> 1807snc.it>
ha scritto:

> On 09/06/2014 11:41, Nico Lime wrote:
>
>>
>> sono alle prese con la costruzione di un NAS da 12TB per uso
>> multimediale, utilizzando il file system UFS quali sono i parametri che più
>> si adattano a questo suo (file grandi minimo sono 30/40 MB per file) ? mi
>> aiutate a costruire il file system ?
>>
>>
> Usa ZFS, se puoi. Senza volere denigrare UFS3, che e' la mia scelta per i
> FS di sistema (nel caso possa disporre di uno spindle separato), ZFS ha
> molti vantaggi nell' uso pratico, per volumi cosi' grandi.
>
> Piuttosto, che configurazione dischi pensi di adottare?
>
> Per la mia esperienza (NAS da 6Tb in su, prima con UFS poi con ZFS), i
> dischi da 2-3Tb hanno la brutta abitudine di guastarsi troppo spesso,
> magari in modo intermittente: con ZFS e una giusta configurazione, e' un
> attimo togliere il disco guasto, rimettere quello nuovo, ricreare la
> partizione, e via, senza perdere dati...
>
> Salve, Paolo
>
>
> _______________________________________________
> Aiuto mailing list
> Aiuto <at> gufi.org
> http://mailman.gufi.org/mailman/listinfo/aiuto
>



--
d.
-------------- parte successiva --------------
Un allegato HTML è stato rimosso...
URL: <http://mailman.gufi.org/pipermail/aiuto/attachments/20140609/ede186a6/attachment-0001.html>

------------------------------

Message: 4
Date: Mon, 09 Jun 2014 16:16:16 +0200
From: Paolo Faustini <paolo.faustini <at> 1807snc.it>
To: aiuto <at> gufi.org
Subject: Re: file system per uso multimedia
Message-ID: <5395C1B0.9020207 <at> 1807snc.it>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

On 09/06/2014 13:32, Davide D'Amico wrote:
> Hai valutato progetti come MogileFS?
>

No, non conoscevo, grazie ( https://code.google.com/p/mogilefs/ ).

Innanzitutto, scusate i post parziali doppi...

Avevo considerato anche nelle mie scelte questo tipo di FS distribuiti,
se la domanda era rivolta a me, ma li avevo esclusi, per diversi motivi.

Sintetizzando, trovo che ZFS sia (per adesso e spero per molto altro
tempo) una scelta interessante per prestazioni velocistiche,
scalabilita' e flessibilita' di configurazione, ed effettivamente pecca
negli strumenti di backup/replica/resilienza, ma temo di dire cose che
gia' sappiate tutti.

Effettivamente e' assolutamente banale impiantare una macchina a basso
costo con 6 dischi da 2/3 TB, ZFS e qualche script di controllo (il
backup efficace puo' essere, invece, un problema reale).

Salve, Paolo.







------------------------------

Message: 5
Date: Mon, 09 Jun 2014 16:20:06 +0200
From: Paolo Faustini <paolo.faustini <at> 1807snc.it>
To: aiuto <at> gufi.org
Subject: Re: file system per uso multimedia
Message-ID: <5395C296.5040607 <at> 1807snc.it>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

On 09/06/2014 13:32, Davide D'Amico wrote:
> Hai valutato progetti come MogileFS?
>
Scusate mi sanno partendo messaggi *parziali* doppi e tripli, tra l'
altro ancora da editare.

Scusate ancora, certo che la qualita' di Thunderbird e' scesa parecchio
da qualche tempo a questa parte.

Salve, Paolo



------------------------------

Message: 6
Date: Tue, 10 Jun 2014 10:03:46 +0200
From: Cristiano Deana <cris <at> gufi.org>
To: Aiuto su FreeBSD <aiuto <at> gufi.org>
Subject: Re: E normale ??
Message-ID:
        <CAOQnpdfahG7Rcvvs2n5j6xOL8wP4J7dyLjvtgWE5zsdN=nuLWQ <at> mail.gmail.com>
Content-Type: text/plain; charset=UTF-8

2014-06-06 20:40 GMT+02:00 Pino Cinelli <pinocino <at> gmail.com>:

Ciao,

> Non convinto ho disinstallato il pp53 con pkg delete xxx , ed ho installato
> php53 con pkg install xxx e meraviglia NON mi ha creato il modulo libphp5.so
> .

a memoria:

pkg install mod_php5


--
Cris, member of G.U.F.I
Italian FreeBSD User Group
http://www.gufi.org/



------------------------------

Subject: Chiusura del digest

_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto


------------------------------

Fine di Digest di Aiuto, Volume 73, Numero 5
********************************************

_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto
Gianmarco Giovannelli | 25 Jun 21:39 2014

Re: vmtools

At 20:04 25/06/2014, Cristiano Deana wrote:

>Esperienze.
>vmtools si o no?
>
>Oggi mi si è inchiodata una macchina che gira 
>su un VMware 5.1 mentre compilava il world.
>Pochi servizi, poche risorse, ma... Bang.
>
>Voi i tools li usate? Quali?

open-vmtools, bovinamente installato dai packages su 10-STABLE e 9-STABLE.

in rc.conf:
vmware_guest_vmblock_enable="YES"
vmware_guest_vmhgfs_enable="YES"
vmware_guest_vmmemctl_enable="YES"
vmware_guest_vmxnet_enable="YES"
vmware_guestd_enable="YES"

vmware 5.1 e 5.5 ( ma anche in qualche 5.0 forse ) .

La macchina 10-STABLE e 9-STABLE template 
ricompilano world e ports almeno una volta ogni 10-15 gg.  (su 5.5).
Per ora mai avuto problemi simili al tuo.

Best Regards,
Gianmarco Giovannelli ,  "Unix expert since yesterday"
http://utenti.gufi.org/~gmarco/

_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto

Cristiano Deana | 25 Jun 20:04 2014

vmtools

Esperienze.
vmtools si o no?

Oggi mi si è inchiodata una macchina che gira su un VMware 5.1 mentre compilava il world.
Pochi servizi, poche risorse, ma... Bang.

Voi i tools li usate? Quali?

_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto
Alberto Rizzi | 15 Jun 16:46 2014

Atom D2500 - x86 o amd64

Buongiorno a tutti
ho una scheda madre Intel Atom D2500 su cui ho montato un modulo da 2GB 
di ram e un disco da 60 GB di recupero.
Uso questo come server casalingo (cvs, bacula, nas via samba) a basso 
traffico.

Mi collego al server solo via rete e raramente via console seriale.

Devo (re)installare FreeBSD 10 e sono in dubbio tra la versione x86 e 
quella amd64.
C'è un qualche buon motivo per cui dovrei preferire amd64?
Ovvero, c'è qualche funzionalità che mi serve e che esiste solo su amd64?

Cercando in giro ho visto solo più problemi che funzionalità.

Grazie

_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto

Franco Marchesini | 11 Jun 17:27 2014
Picon

trasferimento con scp

Ciao a tutti,

il problema non e' urgente in quanto presente da anni.

Capita che devo interfacciarmi con una macchina remota freebsd di cui non ho la gestione/amministrazione e quando trasferisco dei file arrivo sempre al 99/100% e poi il trasferimento non si conclude.

Al contrario il trasferimento fatto tramite cyberduck o winscp funziona sempre, per cui l'altro "amministratore" dice, evidentemente con ragione, che sono fatti miei.

Qualcuno ha gia' avuto e risolto il problema?

Grazie
Franco



_______________________________________________
Aiuto mailing list
Aiuto <at> gufi.org
http://mailman.gufi.org/mailman/listinfo/aiuto

Gmane