sam wun | 1 Feb 04:43 2005

Re: missing libraries in building ISO

Davide D'Amico wrote:

>> I inserted the following lines in 7.customer.sh and hopefully it will 
>> solve the problem automaticaly.
>> cpdup -o -vvv /usr/local/lib/ $FREESBIEBASEDIR/usr/local/lib/
>> mkdir -p $FREESBIEBASEDIR/usr/X11R6/lib/
>> cpdup -o -vvv /usr/X11R6/lib/ $FREESBIEBASEDIR/usr/X11R6/lib/
>>
> The ugliest, less optimized, disk space crunching method a human brain 
> could find.
>
Just found that in my original FreeBSD machine, there is only a 
/usr/lib/compat/ directory exist. Copy all files from this dir to 
livefs/usr/lib/compat does not solve the problem. So the "dirty way" is 
a temporary solution.

Sam.

> dave
>

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)

Matteo Riondato | 1 Feb 19:13 2005

[CVS Update of freesbie - M:1 A:0 R:0]

Log Message:
-----------
Correct $id$ with correct $Id$

Modified Files:
--------------
    freesbie/files/scripts/sound:
        snd_card_ids.txt

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)

Matteo Riondato | 1 Feb 19:19 2005

[CVS Update of freesbie - M:1 A:0 R:0]

Log Message:
-----------
Update copyright year
Correct spelling of G.U.F.I. (it's not G.U.F.I )

Modified Files:
--------------
    freesbie:
        COPYING

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)

Matteo Riondato | 1 Feb 19:20 2005

[CVS Update of freesbie - M:1 A:0 R:0]

Log Message:
-----------
Add $Id$

Modified Files:
--------------
    freesbie:
        README

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)

Matteo Riondato | 1 Feb 19:22 2005

[CVS Update of freesbie - M:1 A:0 R:0]

Log Message:
-----------
Remove done items

Modified Files:
--------------
    freesbie:
        TODO

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)

sam wun | 1 Feb 19:26 2005

About selecting packages

Hi,

I found another bug in the installation script (not the dfui* C program).
The problem is after selected packages from the installation menu and 
when the program get back to the menu (in 1.1), I double-check the 
packages again, I found some of the packages are unchecked from the 
check box. I need to re-check these packages from the menu before it 
built the desire packages into the iso file.

Sam.

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)

Scott Ullrich | 1 Feb 19:34 2005
Picon

Re: About selecting packages

Sam,

Okay, I misread your prior message about "checking all packages".  At
any rate, I know how time consuming checking all of those checkboxes
can be so I decided to send you the script that I use.   It
automatically installs ALL packages into FreeSBIE.   I use it inside
jails where I know that the package count will not change (a jail per
livecd that I build.)

In the future it would be nice to add a "Select All" and "Select None"
options to ./6_packages.sh

Hope that this comes in handy to someone!

Scott

#!/bin/sh

set -u

. ./config.sh

echo Installing all packages into LiveBSD ...
BACK=$PWD
cd $FREESBIEBASEDIR/
for i in `ls /var/db/pkg/`; do
        pkg_create -zvb $i
done
for i in `ls /var/db/pkg/`; do
        chroot $FREESBIEBASEDIR pkg_add -v $i.tgz
(Continue reading)

Matteo Riondato | 1 Feb 19:47 2005

[CVS Update of freesbie - M:2 A:0 R:0]

Log Message:
-----------
Correct spelling of G.U.F.I. (it's not G.U.F.I )

Modified Files:
--------------
    freesbie:
        README.dk
        README.it

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)

mm | 1 Feb 22:37 2005
Picon

md5

Hi,I make excuses myself for my English bad one...  I have downloaded 
freesbie 1,1 from ftp.nl.freesbie but md5 is not equal:
[abj <at> btnm ~ ] $ md5sum FreeSBIE-1.1-i386.iso
5c09cd95êaab152d31áe956942daeb FreeSBIE-1.1-i386.iso
[abj <at> btnm ~ ] $

Thi is the original md5 (ftp.nl.freesbie):

MD5 (FreeSBIE-1.1-i386.iso) = 61e6433b8ace7c83cee281b731e73f1c

Hi thanks
(?!) :)

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)

Ben Pratt | 1 Feb 22:17 2005

Re: About selecting packages

I have experienced the same problem. I select a large amount of packages 
from one group, /net for instance, and when I go back to the main menu I 
then re-enter the packages option, the net group and some of the 
packages have been automatically de-selected. I'm not certain but it 
appears to be the bottom few packages that I select. I'll have to do 
some testing to see if it's only remembering a certain number of 
packages or what's going on. I've been busy with moving so if nobody 
gets to it by this weekend I'll have more time then.

Ben

sam wun wrote:
> Hi,
> 
> I found another bug in the installation script (not the dfui* C program).
> The problem is after selected packages from the installation menu and 
> when the program get back to the menu (in 1.1), I double-check the 
> packages again, I found some of the packages are unchecked from the 
> check box. I need to re-check these packages from the menu before it 
> built the desire packages into the iso file.
> 
> Sam.
> 

--

-- 
FreeSBIE mailing list (http://www.freesbie.org)


Gmane