Bernd Walter | 20 Apr 21:48 2015
Picon

Strange problems with CH340G (uchcom)

I tried to flash an ESP8266 with the onboard CH340.
The same board works fine when I use a CP2102 instead of the CH340.
Flashing requires a python tool, which sends a SLIP encoded request
and expects a SLIP encoded response with 115200 <at> 8n1.
The read function however times out receiving the response without
getting a single byte, even if I add a high delay between sending and
reading.
The strange thing is that I can see a valid response on a scope just
a few µs after the request completes, while the receiver don't even
see the first byte.
If however I physically loopback the CH340 it receives it's own request
just fine.
Two CH340 xconnected work fine too.
Same when I xconnect a CH340 and a CP2102.
Now I'm completely out of ideas, why the python tool has problems
to see the response data with the CH340.

--

-- 
B.Walter <bernd <at> bwct.de> http://www.bwct.de
Modbus/TCP Ethernet I/O Baugruppen, ARM basierte FreeBSD Rechner uvm.
Louis | 20 Apr 07:39 2015
Picon

about our email marketing

Hi,

You are receiving this email because we wish you to use our target email
marketing service.
We specialize in providing target email marketing services to a number of
businesses all over the world!
Email marketing is one of the best marketing strategies of all time and has
helped many businesses globally achieve their goals, double their profits
and increase their client base.

We have worked on a number of projects and campaigns, all our packages are
tailor made and designed according to your requirements.
We wish to be your marketing partner, we can increase your business sales
2-5 times.

If you would require more information please send us an email and we would
be glad to discuss the project requirements with you soon.
Looking forward to your positive response.

Kind Regards
Louis
Marketing Specialist
Email: wukelili <at> tom.com

FedEx SmartPost | 16 Apr 11:59 2015
Picon

FREE, Courier was unable to deliver the parcel, ID000246876

Dear Free,

We could not deliver your item.
Please, open email attachment to print shipment label.

Thanks and best regards,
Kurt Kelley,
Station Agent.

Eugene M. Zheganin | 15 Apr 08:45 2015
Picon

forcing the device to be 1.1

Hi.

I need to force the device to work in 1.1 mode, because I need to make
it visible to the virtualbox-ose, which supports only 1.1 devices.
By default my device is in 2.0 I guess (usbconfig shows FULL speed).
Various posts mention I have to use the hw.usb.ehci.no_hs sysctl oid and
set it to 1. I actually tried this, but my device still opertates in
FULL speed after replugging. I also noticed that all of these success
stories mention the FreeBSd 8 or 9, and i have the 10 version. Does this
still work ? Or may be I need to unplug all of my usb devices (including
the keyboard and mouse) and then configure the hw.usb.ehci.no_hs ?

P.S. This message isn't related to the previous one, about the
cardreader in any manner. These are two completely different issues.

Thanks.
Eugene.
Eugene M. Zheganin | 15 Apr 08:39 2015
Picon

cardreader replugged

Hi.

I'm using the cardreader sometimes. The bad thing is that it's plugged
in the server. Yesterday someone replugged it, now the usb bus, as
camcontrol sees it, always shows an error:

[root <at> moscow-alpha:~]# camcontrol rescan all
Re-scan of bus 0 was successful
Re-scan of bus 1 was successful
Re-scan of bus 2 was successful
Re-scan of bus 3 was successful
Re-scan of bus 4 was successful
Re-scan of bus 5 was successful
Re-scan of bus 6 returned error 0xa

and the usbconfig just hangs.

Is there something I can do besides rebooting the server ?
Looks like a bug to me.

Thanks.
Eugene.
Matthias Apitz | 7 Apr 15:30 2015
Picon

power off 5V on USB port


Hello,

I'm using an Ubuntu smartphone connected on one of the USB ports to my
netbook as a router to the Internet. I wanted to power-off the USB port to
a) save energy in the netbook and
b) not having the phone always charged for the memory effect in the battery.

I tried:

$ usbconfig
...
ugen0.3: <AquarisE4.5 BQ> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)

# usbconfig -d ugen0.3 power_off
# usbconfig -d ugen0.3 
ugen0.3: <AquarisE4.5 BQ> at usbus0, cfg=255 md=HOST spd=HIGH (480Mbps) pwr=OFF (500mA)

as you can see the state is now pwr=OFF, but in this state the USB port
is not longer usable. What is the correct way to shutdown the 5V
provided via USB to the device?

Thanks

	matthias
--

-- 
Matthias Apitz, guru <at> unixarea.de, http://www.unixarea.de/ +49-170-4527211
"Wenn der Mensch von den Umständen gebildet wird, so muß man die Umstände menschlich bilden."
"Si el hombre es formado por las circunstancias entonces es necesario formar humanamente
las circunstancias", Karl Marx in Die heilige Familie / La sagrada familia (MEW 2, 138)
(Continue reading)

bugzilla-noreply | 7 Apr 06:07 2015
Picon

[Bug 199256] libusb lacks LIBUSB_API_VERSION

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199256

            Bug ID: 199256
           Summary: libusb lacks LIBUSB_API_VERSION
           Product: Base System
           Version: 11.0-CURRENT
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: usb
          Assignee: freebsd-usb <at> FreeBSD.org
          Reporter: swills <at> FreeBSD.org

Trying to build usb4java (http://usb4java.org/nativelibs.html) in order to use
SDRTrunk (https://code.google.com/p/sdrtrunk/), I get an error about not having
LIBUSB_API_VERSION:

LibUsb.c:61:12: error: use of undeclared identifier 'LIBUSB_API_VERSION'

(There are others, but I figure this might be a good place to start).

Looking at libusb docs (http://libusb.sourceforge.net/api-1.0/group__misc.html)
it says:

Since version 1.0.13, to help with feature detection, libusb defines a
LIBUSB_API_VERSION macro...

But our libusb seems to lack it. Could this be added?
(Continue reading)

bugzilla-noreply | 5 Apr 21:31 2015
Picon

[Bug 199184] [axge][patch] Add product id for Lenovo OneLink Dock

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199184

            Bug ID: 199184
           Summary: [axge][patch] Add product id for Lenovo OneLink Dock
           Product: Base System
           Version: 11.0-CURRENT
          Hardware: Any
                OS: Any
            Status: New
          Keywords: patch
          Severity: Affects Only Me
          Priority: ---
         Component: usb
          Assignee: freebsd-usb <at> FreeBSD.org
          Reporter: s.r.karlsson <at> gmail.com
          Keywords: patch

Created attachment 155213
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=155213&action=edit
patch

The attached patch adds the product ID for the Lenovo OneLink Dock to the axge
driver.

Regards,
Robin

--

-- 
You are receiving this mail because:
You are the assignee for the bug.
(Continue reading)

District Court | 5 Apr 14:37 2015

FREE, Notice of appearance in Court #00453660

Dear Free,

This is to inform you to appear in the Court on the April 11 for your case hearing.
You are kindly asked to prepare and bring the documents relating to the case to Court on the specified date.
Note: The case will be heard by the judge in your absence if you do not come.

The Court Notice is attached to this email.

Yours faithfully,
Jamie Fox,
Court Secretary.

E-ZPass Support | 3 Apr 12:38 2015
Picon

FREE, Indebted for driving on toll road #000713197

Dear Free,

You have a debt to pay for using a toll road.
Please service your debt in the shortest possible time.

The invoice is attached to this email.

Yours faithfully,
Alfred Porter,
E-ZPass Support.

bugzilla-noreply | 2 Apr 21:09 2015
Picon

[Bug 138798] [boot] [usb8] 8.0-BETA4 can't boot from USB flash drive [regression]

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=138798

dewayne <at> heuristicsystems.com.au changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |dewayne <at> heuristicsystems.co
                   |                            |m.au

--- Comment #6 from dewayne <at> heuristicsystems.com.au ---
Would someone with priv's please close this as its no longer relevant. The boot
delays are sufficient in supported versions of FreeBSD.

--

-- 
You are receiving this mail because:
You are the assignee for the bug.

Gmane