Chris Carlson | 2 Oct 05:53 2014

Problem with Cygwin/X from remote Linux

I've been using Cygwin on a Windows 7 laptop for a few years as an X
server from my Fedora Linux system.  I "ssh -X" to my Linux system and
run various X programs (thunderbird, chrome, nautilus, etc.) with very
few issues.

Every now and then, I will upgrade Cygwin_64 just to get the latest
changes.  I hope that the few issues I have will be cleared up.  I
believe the one issue I have with Thunderbird may be Thunderbird, not

Anyway, over the past weekend, I upgraded again.  The upgrade seemed to
go well.  No surprises until...

One of the things I've been doing is learning OpenGL.  I'm converting a
sample program that I acquired while working at SGI to OpenGL (it was
written in gl, the original SGI graphics language). For the past few
months, all of my OpenGL programs have worked fine over the network.
Suddenly, with the latest version of Cygwin/X, it doesn't.

     Welcome to the XWin X Server
     Vendor: The Cygwin/X Project
     OS: CYGWIN_NT-6.1 grover 1.7.32(0.274/5/3) 2014-08-13 23:06 x86_64
     OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (Win64)
     Package: version 1.16.1-1 built 2014-09-29

     XWin was started with the following command line:

     X :0 -multiwindow

(Continue reading)

Jon TURNEY | 29 Sep 18:28 2014

[ANNOUNCEMENT] Updated: xorg-server-1.16.1-1

The following packages have been updated in the Cygwin distribution:

*** xorg-server-*1.16.1-1

These packages contain XWin and the other X.Org X11 servers.

In addition to upstream fixes [1][2], this contains the following 
cygwin-specific changes since 1.16.0-2:

* Also automatically activate the -nolock option if /tmp is on an exFAT 
filesystem (Reported by 't s')
* Log owning HWND when OpenClipboard fails
* Log name of format atom when conversion of X clipboard to a format is 
* Also use _NET_WM_NAME for window titles in multiwindow mode
* Downgrade some uninformative, always-emitted log output to debug
* Check TEMP and TMP directories for accessibility before using for 
xkbcomp temporary file
* Log filename when xkbcomp temporary file cannot be opened
* Don't add an extra null character at the end of the text on the 
Windows clipboard (Thanks to Colin Harrison for patch)

6b72d0bdaba1e89e90430a751eef61a9 *xorg-server-1.16.1-1-src.tar.xz
7b63f2b0e424292b62ceead452802f80 *xorg-server-1.16.1-1.tar.xz
9ca33a0326e50c5583730c495940903d *xorg-server-common-1.16.1-1.tar.xz
90c76a195c62251322883b31709817da *xorg-server-debuginfo-1.16.1-1.tar.xz
ab4dfe97c97d333bb1cfb30f9ebee8b7 *xorg-server-devel-1.16.1-1.tar.xz
da75032daeaf0e4664ed85c1d333657e *xorg-server-dmx-1.16.1-1.tar.xz
(Continue reading)

Joel Ledain | 26 Sep 04:52 2014

Problem starting the X server

Hello good guys,

I just installed the Cygwin packages on top of a "Windows 7". The 
machine is Gateway NV55S28u. Install went fine. Rebooted the machine and 
tried the bash window, this works fine. Then tried to start the X 
server, and here I have a problem. I thing my problem is related to the 
keyboard binding/support/missing packages...

I tried to use the command setxkbmap, but without the X server running I 
am not getting anything beside "cannot open display".

For the Windows control panel -> devices -> keyboard, I see a "standard 
PS2 keyboard".  I have the xkeyboard-config package installed.

I am attaching the log of my troubles.

Thanks in advance for your great help.
Script started on Thu, Sep 25, 2014  5:59:11 PM

$ cygcheck -c xkeyboard-config
Cygwin Package Information
Package              Version        Status
xkeyboard-config     2.12-1         OK
$ which xkbcomp 
$ ls -l /usr/bin/xkbcomp
(Continue reading)

t s | 21 Sep 18:56 2014

problems running Cygwin/x

I successfully installed Cygwin/x on an NTFS drive

unfortunately the menu items are limited to;

one item for Cygwin (cygwin64 terminal)

five items for cygwinx (GNOME openbox, KDE openbox, openbox, xlaunch, xwin server)

please see graphic at;

if I try GNOME Openbox, or KDE Openbox, or Openbox; it appears to start, but I cannot run xclock and there is no
X server icon in the lower right icon panel

if I try xlaunch, it shows a dialog "select display settings", then "select how to start clients", then
"extra settings"; then it shows an 'X' icon in the lower RH panel; and when I right-mouse-click the X icon,
choose applications/xterm, it brings up a terminal window where I can run xclock etc

if I try "xwin server" it doesn't bring up the xlaunch dialogs, instead it immediately opens a terminal
window where I can start xclock etc

essentially I want to be sure Cygwin/x has installed correctly; particularly the three Openbox options do
not seem to do anything; should they be bringing up some sort of GNOME or KDE desktop? 		 	   		  
Unsubscribe info:
Problem reports:

Yaakov Selkowitz | 19 Sep 22:14 2014

[ANNOUNCEMENT] Updated: shared-mime-info-1.3-3

The following package has been updated for the Cygwin distribution:

* shared-mime-info-1.3-3

This package provides the MIME type database.

This release adds several upstream patches:

* Adds an -n flag to only update the database when there is newer MIME

* fix detection of OTF fonts;

* speed up detection of PNG files.


Unsubscribe info:
Problem reports:

Yaakov Selkowitz | 19 Sep 09:08 2014

[ANNOUNCEMENT] Updated: glib2.0-2.38.2-4

The following packages have been updated for the Cygwin distribution:

* libglib2.0_0-2.38.2-4
* libglib2.0-devel-2.38.2-4
* libglib2.0-doc-2.38.2-4

GLib is the low-level core library that forms the basis for projects
such as GTK+ and GNOME. It provides data structure handling for C,
portability wrappers, and interfaces for such runtime functionality as
an event loop, threads, dynamic loading, and an object system.

This release includes the latest upstream changes to the gdb scripts,
which are now shipped in the debuginfo package.


Unsubscribe info:
Problem reports:

Jon TURNEY | 17 Sep 20:08 2014

[ANNOUNCEMENT] Updated: xorg-server-1.16.0-2

The following packages have been updated in the Cygwin distribution:

*** xorg-server-*1.16.0-2

These packages contain XWin and the other X.Org X11 servers.

The following cygwin-specific changes have been made since 1.16.0-1:

* Fix -displayfd to respect -pn/-nopn
* Fix -displayfd to check port 65535
* Fix problems with pixelformat selection for GLX pixmaps with certain 
display drivers
* Add experimental Windows-DRI extension

cff75107d42345622f063cd2e02ff4bc *xorg-server-1.16.0-2-src.tar.xz
1a61054927751d233c5ed5c0d2e0cefd *xorg-server-1.16.0-2.tar.xz
dc41d9b3536df9261f6851884eeb5e6f *xorg-server-common-1.16.0-2.tar.xz
be9984f25a1cdc987040d30a4ceab946 *xorg-server-debuginfo-1.16.0-2.tar.xz
f0a4074a0647321ce9475e9940321155 *xorg-server-devel-1.16.0-2.tar.xz
d918a31db9db190fd60b8d99762436d0 *xorg-server-dmx-1.16.0-2.tar.xz
910359981408a60b952efbed9d47781a *xorg-server-extra-1.16.0-2.tar.xz
b494cc65bcc0be350a8307ee0c047dcd *xwinclip-1.16.0-2.tar.xz

aac6ba4d7e6f82abf7aad058004d7d4d *xorg-server-1.16.0-2-src.tar.xz
d02369e2ccc09f0525fe17d15741d11f *xorg-server-1.16.0-2.tar.xz
5f00d12d2096d559540df716bf684b24 *xorg-server-common-1.16.0-2.tar.xz
26928680a222a3aac74b2931f21144a1 *xorg-server-debuginfo-1.16.0-2.tar.xz
(Continue reading)

t s | 16 Sep 19:06 2014

FW: cygwin-xfree Digest 5 Sep 2014 16:55:49 -0000 Issue 3554

sorry to "bug" you ; do you know of any utility which can convert a volume from EXFAT to NTFS?

if not then no worries, but please email me and say so

thank you

> From: furriner67 <at>
> To: marco.atzeri <at>
> Subject: FW: cygwin-xfree Digest 5 Sep 2014 16:55:49 -0000 Issue 3554
> Date: Thu, 11 Sep 2014 16:18:05 -0400
> I tried CONVERT from the NT command line
> it says
> C:\Users\Tadeusz Szocik>convert /?
> Converts a FAT volume to NTFS.
> CONVERT volume /FS:NTFS [/V] [/CvtArea:filename] [/NoSecurity] [/X]
> volume Specifies the drive letter (followed by a colon),
> mount point, or volume name.
> /FS:NTFS Specifies that the volume will be converted to NTFS.
> /V Specifies that Convert will be run in verbose mode.
> /CvtArea:filename
(Continue reading)

t s | 11 Sep 11:51 2014

FW: cygwin-xfree Digest 5 Sep 2014 16:55:49 -0000 Issue 3554

From: furriner67 <at>
To: cygwin-xfree <at>; marco.atzeri <at>
Subject: FW: cygwin-xfree Digest 5 Sep 2014 16:55:49 -0000 Issue 3554
Date: Thu, 11 Sep 2014 05:49:53 -0400


please see file;

why are my posts to cygwin-xfree <at> not going through?

thank you

From: furriner67 <at>
To: cygwin-xfree <at>
Subject: RE: cygwin-xfree Digest 5 Sep 2014 16:55:49 -0000 Issue 3554
Date: Fri, 5 Sep 2014 19:04:34 -0400

(Continue reading)

Nem W Schlecht | 10 Sep 18:33 2014

Clipboard interaction issues - breaks after awhile

After the latest update to xorg-server (1.16.0-1), I've been having
issues with clipboard interaction between my xterm windows and Windows
apps.  Bi-directional copy/paste works initially, but at some unknown
point stops working.  Anybody else seeing this as well?  What can I do
to help debug this issue?


Nem W Schlecht

Unsubscribe info:
Problem reports:

mathog | 5 Sep 18:55 2014

Possible X11 server bug

I have run into an issue which _may_ indicate a bug in the cygwin X11 
server.  The issue is documented here:

In brief, for certain test files viewed in Inkscape (current trunk at 
least) over a putty ssh tunnel from an Ubuntu 12.04lts system to the 
cygwin X11 server there are glitches in the image when it is 
zoomed in and out.  This does not occur if the same program is run 
locally on the console of the test machine.  It also does not happen if 
I run a native Windows version (not cygwin, not X11) of Inkscape on the 
same PC which hosts that X11 server on the same test files.  The glitch 
does not occur with a huge number of other test files I have looked at 
over the years.  It seems there is something specific to the clipping 
code in Inkscape and this particular X11 transport path/server 
combination.  Moreover, it looks like the problem is only manifested (or 
only manifested frequently) when the clipping path consists of two (or 
more?) disjoint sections.

When the glitches occur nothing is added to XWin.0.log.

Also this X11 server is not running in the full cygwin environment, but 
rather in one edited down to just the minimum needed to run the X11 
server.  I distribute this version here:

I don't think this is a factor though, since all of the action is going 
on inside the X11 server process(es).

(Continue reading)