Larry Hall (Cygwin X | 1 Dec 01:34 2005

Re: "No absolute path for shell:" error

On 11/30/2005, Douglas Spearot wrote:
> Thank you for the response Thomas. I downloaded the source from the website 
> that you listed below. When I try to run the 'configure' file that you 
> created to build XTERM, I get a number of error messages (all of which say 
> the same thing): "The procedure entry point getline could not be located in 
> the dynamic link library cygwin1.dll"

Make sure you have one and only one cygwin1.dll on your system.  If you do,
make sure you've rebooted after the last install you did (from setup.exe).
This is a classic message that occurs when you're running apps that expect
a more current cygwin1.dll than can be found/loaded into memory.

--

-- 
Larry Hall                              http://www.rfk.com
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
838 Washington Street                   (508) 893-9889 - FAX
Holliston, MA 01746

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

km4hr | 1 Dec 15:25 2005
Picon

Is Cygwin/X compatible with HP's mwm?

Is Cygwin/X compatible with the mwm (Motif Window Manager) that comes 
with HPUX 10.20?  Or is Cygwin/X only supposed to work  with Linux? I 
have an application that works fine with Redhat's X server, Exceed, and 
Reflections, but not Cygwin/X.  I was hoping to use Cygwin/X instead of 
the commercial X servers. But Cygwin/X doesn't communicate with mwm. 
I've been trying for days but it's just not working. Application 
windows all appear normal in Cygwin/X but there is no interaction with 
the window manager. For example,  I can't move windows on the screen. 
The last window created is the only one that gets "focus". Clicking on 
the others does nothing. Window manager pull down menus don't display. 
In short, there is no interaction at all between Cygwin/X and the mwm 
window manager. Is anyone out there using Cygwin/X successfully in this 
environment? Does anyone know if Cygwin/X has been tested with HP's 
mwm? I also tried the twm window manager that comes with HPUX 10.20.  
Is doesn't work right either. The problems are similar but not exactly 
the same. In the case of twm an outline of the last window created is 
attached to the mouse pointer. Clicking on the desktop causes the 
window to be completed and appear normal.  I am able to interact with 
the window manager after that. But what's going on with this weird 
behavior?

___________________________________________________
Try the New Netscape Mail Today!
Virtually Spam-Free | More Storage | Import Your Contact List
http://mail.netscape.com

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
(Continue reading)

sherwit | 1 Dec 19:57 2005
Picon

Strange keyboard behavior w/XDMCP and AIX

I start the XDMCP session and the keyboard works fine at the
login screen.  However, once the Motif window manager
starts, the keyboard gets messed up.  Typing "s" results in
"a" on the screen.  "d" gives "s"... and so on.  Almost as if
every key on the keyboard shifted by one.  All mouse functions
work as expected.  The keyboard returns to normal after exiting
MWM and returning to the login screen.  Starting X with
different keyboard maps does not affect problem.  Suggestions/solutions
on the Cygwin/X side (I have limited permissions on AIX system)?
TIA.

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Soong, SylokeJ | 1 Dec 20:28 2005

RE: Is Cygwin/X compatible with HP's mwm?


Did you start cygwin/x xdm and then attempted to run remote host's
mwm on it?

What about going thro xdmcp?

I have always run cygwin/x using both its xdm and xwm on the
same machine.
I have never tried running cygwin/x xdm and then running remote
Solaris or HPUX mwm on it. Is that possible?
Could I also deploy cygwin/x multiwindow and then attempt to throw
remote mwm on it?

Is going thro the remote xdmcp the only way to use remote xwm?

Presuming my terminology is correct:...
xdm - x display mgr to set up the x display
xwm - x win mgr runs on top of xdm,
  to manage the willy nilly remote windows,
  without which those windows will pile up
  on one corner of the local xdm.
mwm - motif based xwm.

-----Original Message-----
From: cygwin-xfree-owner <at> cygwin.com
[mailto:cygwin-xfree-owner <at> cygwin.com]On Behalf Of km4hr <at> netscape.net
Sent: Thu, December 01, 2005 9:25 AM
To: cygwin-xfree <at> cygwin.com
Subject: Is Cygwin/X compatible with HP's mwm?

(Continue reading)

Igor Pechtchanski | 2 Dec 02:40 2005
Picon

Re: Is Cygwin/X compatible with HP's mwm?

On Thu, 1 Dec 2005, km4hr wrote:

> Is Cygwin/X compatible with the mwm (Motif Window Manager) that comes
> with HPUX 10.20?  Or is Cygwin/X only supposed to work with Linux? I
> have an application that works fine with Redhat's X server, Exceed, and
> Reflections, but not Cygwin/X.  I was hoping to use Cygwin/X instead of
> the commercial X servers. But Cygwin/X doesn't communicate with mwm.
> I've been trying for days but it's just not working. Application windows
> all appear normal in Cygwin/X but there is no interaction with the
> window manager. For example, I can't move windows on the screen. The
> last window created is the only one that gets "focus". Clicking on the
> others does nothing. Window manager pull down menus don't display. In
> short, there is no interaction at all between Cygwin/X and the mwm
> window manager. Is anyone out there using Cygwin/X successfully in this
> environment? Does anyone know if Cygwin/X has been tested with HP's mwm?
> I also tried the twm window manager that comes with HPUX 10.20.  Is
> doesn't work right either. The problems are similar but not exactly the
> same. In the case of twm an outline of the last window created is
> attached to the mouse pointer. Clicking on the desktop causes the window
> to be completed and appear normal.  I am able to interact with the
> window manager after that. But what's going on with this weird behavior?

Hard to say without any information on how you start the X server[*].  A
couple of WAGs: don't run the X server in multiwindow mode (or you'll get
two window managers trying to outdo each other), and check that your
NumLock is not on.  Also, are you connecting to the HPUX machine via ssh?
If so, read
<http://x.cygwin.com/docs/faq/cygwin-x-faq.html#q-ssh-no-x11forwarding>.
HTH,
	Igor
(Continue reading)

Picon

QUARANTINED: Message could not be delivered

The message "Message could not be delivered" from , sent on 12/2/2005 11:10 was quarantined because it
contained either an executable file, a batch file or a screen saver file. All of these types of attachments
are considered security risks. Please consult your mail administrator who can release the message.

This message was checked by MailScan for WorkgroupMail.
www.workgroupmail.com 

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Robert Folland | 2 Dec 22:56 2005
Picon

Switch auto-focus (focus follows cursor) off?

Hi,

I have installed Cygwin with X on a new machine and I am getting an
auto-focus behaviour, i.e. the input focus follows the cursor instead
of switching windows with Alt-Tab, even if the other window is
highlighted. From the documentation it only says I can switch this ON
for all Windows XP apps with TweakUI, but I want the opposite, the
default Windows XP beahviour. I am starting XWin with -multiwindows.

What am I overlooking? On my machine at work I am getting the default
Win XP behaviour...?

-Robert

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Afro_PL | 3 Dec 00:03 2005
Picon

XTerm problem- xinit

Hello there.
I have little problem when in XTerm i write "xinit":
"A fatal error has ocurred and Cygwin/X will now exit.
Please open /tmp/Xwin.log for more information.

Vendor: The Cygwin/X Project
Release: 6.8.2.0-4
Contact: cygwin-xfree <at> cygwin.com
XWin was started with the following command-line

X :0"

What I should do?

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

B. Brickhouse | 3 Dec 21:44 2005
Picon

cygwin locks up after starting gnome session via xdmcp and gdm

Hello.

I have the following problem that I have not been able to work around and am 
hoping someone has a fix, or hoping that at least someone has seen it 
before.

I am running cygwin/x on a Dell XPS400 running WinXP w/ SP2.  I am using 
XDMCP to connect to a gentoo linux server running gdm.  Everything was 
working perfectly for ~week and then yesterday, out of the blue, the Cygwin 
screen would lock up whenever I try and resize windows or access the desktop 
toolbar menus.  I noticed that the network utilization goes way up on both 
the client and the server when this happens.  Eventually the Linux 
workstation times out and 'whacks' the connection.  Has anyone seen any of 
these symptoms?

I have read through the mailing list archives and have tried the following 
based on what I read.  Nothing has helped:

1) disabled the Windows and McAfee firewall software
2) tried starting XWin.exe with the -kb option
3) rebooted both Windows and Linux machines (I've done this numerous times)

Using tethereal I was able to capture the packets that seem to be causing 
the high network utilization (see snippet below).  It appears that the 
Cygwin application is sending a ton of X11 Error packets, but the error code 
is 0 (success).

101233  25.503239  192.168.1.7 -> 192.168.1.8  X11 Error: 
Success[Unreassembled Packet]
101234  25.503274  192.168.1.7 -> 192.168.1.8  X11 Error: 
(Continue reading)

PoWah Wong | 5 Dec 15:45 2005
Picon

How to add a title to xterm

How to add a title to xterm?

I start cygwinx by "startx".
The following commands does not work:
xterm -T columbia &
xterm -title columbia &
xterm -title "columbia" &

	

	
		
__________________________________________________________ 
Find your next car at http://autos.yahoo.ca

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/


Gmane