Jean-Marc Colagrossi | 18 Dec 11:51 2014
Picon

X server doesn't start with a empty .startxwinrc

Hi all, 

I need you help to understand what's wrong with X server or my .startxwinrc
file.

I work with X server -> Xterm and vim since month now. Every thing was
always working perfectly.

Yesterday I upgraded all cygwin packages and just after that I was unable to
start X server again.

I made a new fresh installation and X server works correctly. Then I made a
copy of my olds files like .startwinrc, .bashrc .vimrc and all my shortcuts.
When I tried to start the X server I had the same problems. X server crashed.

I removed one by one all the files I copied up to I deleted .startxwinrc.
Then the X server start correctly. my .startxwinrc had only 3 lines with :

xterm -bg Black -fg White&

I deleted all the lines just to have a blank .startxwinrc. But X server
still crashes.

Here is the log when I run startxwin from terminal with an empty
.startxwinrc file

I don't understand what I did wrong as it was working fine before.

Thank you

(Continue reading)

Kenneth Wolcott | 14 Dec 02:41 2014
Picon

FYI: Unknown package error during post-installation of 32-bit cywgin

Hi;

FYI: Unknown package error during post-installation of 32-bit cywgin:

Package: Unknown package
    mate-session-manager.sh exit code 127
    openbox.sh exit code 127
    WindowMaker.sh exit code 127
    xfce4-session.sh exit code 127
    xinit.sh exit code 127

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Will Parsons | 12 Dec 19:07 2014

startxwin.exe no longer exists?

For several years now I have been starting X windows by clicking on an
icon on my desktop that is a link to C:\cygwin\bin\startxwin.exe.  It
has recently ceased to work because apparently startxwin.exe no longer
exists.  Somehow I missed where this was removed, so what is the
recommended way of starting X from a desktop icon now?

I seem to recall that startxwin.exe was introduced some time ago
because using a script to start X was inadequate somehow, but I don't
remember the details, so what changed?

--

-- 
Will

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Don Webster | 11 Dec 19:31 2014
Picon

remote xterm's can't open display after upgrade

I needed to upgrade gs to gs 9.15, so I ran setup yesterday. It wanted to update a whole bunch of stuff,
including X. OK, fine, I hadn't updated cygwin in quite a while, and I had other stuff to do. 

After the upgrade, I can't display remote xterms. OK, my old X shortcut didn't work, but I found "XWin
Server" and pinned it to my task bar. I launch that and I have the X server running, and a local xterm pops up. I
ssh into my linux server, and run my xterm, and get "can't open display". I did these steps. 

- turned off my Windows Firewall (I am on a safe, local network). 
- launched XWin Server. 

In the xterm that popped up: 
dcw <at> dcwdt02 ~ 
$ xhost + 
access control disabled, clients can connect from any host 

dcw <at> dcwdt02 ~ 
$ ssh centos6 
Last login: Wed Dec 10 16:31:16 2014 from dcwdt02 
centos6% setenv DISPLAY 10.11.22.33:0.0    # I use tcsh 
centos6% xterm 
xterm Xt error: Can't open display: 10.11.22.33:0.0 
centos6% 

Is there something obvious? 

Note: when run xterm with the firewall off, the error is immediate. when I do it when the firewall is on, there
is a delay before I get the error. 

This was all working on Monday with my older version of cygwin-x, which I think was a 2011 vintage. (I don't
upgrade stuff very often for this very reason.) 
(Continue reading)

Peter Ziobrzynski | 10 Dec 22:56 2014
Picon

event delivery changes after XWin minimize/restore or resize

Recently (last week) my window manager key bindings stopped working 
after I minimize XWin window and restore it or resize it.  My 
combination of Alt key and mouse clicks do not work anymore.
I use kind of exotic window manager (ctwm) so to make it easy to 
replicate I used xev to repeat the same Alt + mouse click sequence and 
captured the xev list of events before and after XWin minimize and 
restore.  It looks like the list of events listed changes drastically 
explaining why ctwm stopped behaving properly.  I see the same behavior 
in Win8-64 and Win7-32.  I see that Alt key stopped working as a 
modifier. I tried twm instead of ctwm with the same result.

Here is the output of xev before XWin minimize/restore or resize while 
pressing Alt and clicking left mouse button in xev window:

LeaveNotify event, serial 32, synthetic NO, window 0xc00001,
     root 0x16d, subw 0xc00002, time 118362968, (41,42), root:(1747,393),
     mode NotifyGrab, detail NotifyVirtual, same_screen YES,
     focus NO, state 264

EnterNotify event, serial 32, synthetic NO, window 0xc00001,
     root 0x16d, subw 0xc00002, time 118363968, (41,42), root:(1747,393),
     mode NotifyUngrab, detail NotifyVirtual, same_screen YES,
     focus NO, state 8

KeymapNotify event, serial 32, synthetic NO, window 0x0,
     keys:  109 0   0   0   0   0   0   0   1   0   0   0   0 0   0   0
            0   0   0   0   0   0   0   0   0   0   0   0   0 0   0   0

Here is the output of the same actions after XWin minimize/restore:

(Continue reading)

Bob Cunningham | 5 Dec 17:34 2014

xf86-video-nested HOWTO or FAQ?

Hi,

I've seen the announcements that xf86-video-nested is included in 
CygwinX, and is intended to replace Xnest/Xephyr.  But nowhere have I 
(well, google) been able to find instructions on how to actually 
accomplish this within the Cygwin environment.

Has anyone actually successfully done this?  Or is it a work-in-progress 
that isn't yet ready for end-users?

TIA,

-BobC

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Postmaster | 3 Dec 05:17 2014

MDaemon Notification -- Attachment Removed

-------------------------------------------------------------------
MDaemon has detected restricted attachments within an email message
-------------------------------------------------------------------

From      : cygwin-xfree <at> cygwin.com
To        : hungpv <at> tanhoangminh.com.vn
Subject   : [***SPAM*** Score/Req: 11.90/5.0] Returned mail: see transcript for details
Message-ID: <MDAEMON-F201412031117.AA1701803md50000001818 <at> mail90159.dotvndns.vn>

---------------------
Attachment(s) removed
---------------------
hungpv <at> tanhoangminh.com.vn

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Gulliver Smith | 2 Dec 16:53 2014
Picon

Sunday's update broke startx - crash on clipboard (winCpliboardProc trapped WM_QUIT

This has happened on two different computers in different locations,
one with 32 bit and one with 64 bit cygwin. Latter cygcheck attached.

xwin log attached.

I can still run /usr/bin/X -multiwindow but I really like to have the clipboard.

Thanks
Gulliver
Attachment (XWin.1.log): application/octet-stream, 3567 bytes
Attachment (cygcheck.out): application/octet-stream, 127 KiB
--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/
l.wood | 2 Dec 05:34 2014
Picon

Re: 64-bit xfree86 failing?

> (Resending because qmail can't handle mime)

I don't have a ~/.startxwinrc file, because the account home directory was created without one.

Creating one, making it executable, adding commands to it makes no difference - the X server launches
(--muiltiwindow or not) and then decides to shut down.

Do not update your cygwin installations, would be my advice.

Lloyd Wood
http://about.me/lloydwood
________________________________
From: Tim Kingman <tim.kingman <at> gmail.com>
Sent: Tuesday, 2 December 2014 3:22 AM
To: cygwin-xfree <at> cygwin.com; Wood L Dr (Electronic Eng)
Subject: Re: 64-bit xfree86 failing?

I see the same issue, and it looks like this is because I have an empty (co=
mmented-out) ~/.startxwinrc

Removing this file causes X to open and start an xterm, probably because it=
broke several of the new rules in https://cygwin.com/ml/cygwin-xfree/2014-=
11/msg00029.html:

* User-defined ~/.startxwinrc files must now be executable, the final comma=
nd therein must be run in the foreground, and that command's exiting will e=
nd the X session, just like with startx and ~/.xinitrc or ~/.Xclients.

This is then another problem for me because my .bashrc calls startxwin to m=
ake sure I always have an X server running ( per http://stackoverflow.com/a=
(Continue reading)

J. Offerman | 1 Dec 20:09 2014
Picon

build error on 1.16.2-1

Can somebody help me overcome this error? What am I missing this time?
Last time I tried to build X was 2 months ago and it was 1.16.1-1,
which was built just fine. Thanks for your help.

====================================================
make[5]: Entering directory
'/usr/src/xorg-server-1.16.2-1.src/xorg-server-1.16.2-1.x86_64/src/xserver-cygwin-1.16.2-1/hw/xwin/glx'
  CC       libnativeGLthunk_la-glthunk.lo
In file included from glthunk.c:87:0:
generated_gl_thunks.c: In function 'glVertex2bOESWrapper':
generated_gl_thunks.c:7098:3: error: too few arguments to function 'proc'
   RESOLVED_PROC(PFNGLVERTEX2BOESPROC)( x_ );
   ^
generated_gl_thunks.c: In function 'glVertex3bOESWrapper':
generated_gl_thunks.c:7110:3: error: too few arguments to function 'proc'
   RESOLVED_PROC(PFNGLVERTEX3BOESPROC)( x_, y_ );
   ^
generated_gl_thunks.c: In function 'glVertex4bOESWrapper':
generated_gl_thunks.c:7122:3: error: too few arguments to function 'proc'
   RESOLVED_PROC(PFNGLVERTEX4BOESPROC)( x_, y_, z_ );
   ^
Makefile:712: recipe for target 'libnativeGLthunk_la-glthunk.lo' failed

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

(Continue reading)

l.wood | 1 Dec 10:49 2014
Picon

64-bit xfree86 failing?

Just updated a fairly recent was-working two-months-old 64-bit cygwin install. (Asus X102BA, Win 8.1 -
just a little AMD netbook.)

XFree86 now failing with the below. Ideas? thanks.

(--) Windows reports only 2 mouse buttons, defaulting to -emulate3buttons
(II) xorg.conf is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
LoadPreferences: /home/Lloyd/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 00000015
winSetEngine - Using Shadow DirectDraw NonLocking
winScreenInit - Using Windows display depth of 32 bits per pixel
winWindowProc - WM_SIZE - new client area w: 1350 h: 689
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of shared memory support in
the kernel
(EE) AIGLX: No native OpenGL in modes with a root window
(II) AIGLX: enabled GLX_EXT_texture_from_pixmap
(II) AIGLX: Loaded and initialized swrast
(II) GLX: Initialized DRISWRAST GL provider for screen 0
winPointerWarpCursor - Discarding first warp: 675 344
(--) 2 mouse buttons found
(--) Setting autorepeat to delay=500, rate=31
(--) Windows keyboard layout: "00000409" (00000409) "US", type 7
(--) Found matching XKB configuration "English (USA)"
(--) Model = "pc105" Layout = "us" Variant = "none" Options = "none"
(Continue reading)


Gmane