cygwin | 2 Jan 17:51 2009

[1.5] Updated: {gettext/gettext-devel/libgettextpo0/libintl8/libasprintf0}-0.17-3

gettext is the GNU package which provides 'national language support'
for other programs. It includes a number of utility programs.

This is a packaging and bugfix update of the gettext package(s).  This
will most likely be the final gettext update for the cygwin-1.5
distribution; future development will continue with gettext-0.17-10 for
cygwin-1.7.

    gettext-0.17-3
    gettext-devel-0.17-3
    libintl8-0.17-3
    libgettextpo0-0.17-3
    libasprintf0-0.17-3

CHANGES (gettext-0.17-1 ---> gettext-0.17-10):
(includes changes in the released but un-announced gettext-0.17-2)

* Fixed packaging bug in setup.hint for libasprintf0
* Fixed a bug in lib-link.m4 exposed when dependent libraries
  are installed in different directories. Also fixed upstream
  (in future gettext-0.18).
* Fixed an issue in the rpath (e.g. lib-link.m4) test suite
  where only the installed .m4 files were tested, rather than
  the in-package ones. This explains (and corrects) the
  odd rpath test results in gettext-0.17-1. See
  http://cygwin.com/ml/cygwin-announce/2008-11/msg00015.html
* Modified the rpath (e.g. lib-link.m4) test suite so that the
  tests continue to pass. As it happens, in gettext-0.15.1-X
  and previous, these tests never should have passed; they
  were erroneously linking statically. Now they link shared,
(Continue reading)

cygwin | 2 Jan 17:51 2009

[1.7] Updated: {gettext/gettext-devel/libgettextpo0/libintl8/libasprintf0}-0.17-10

gettext is the GNU package which provides 'national language support'
for other programs. It includes a number of utility programs.

This is the first release specific for cygwin-1.7.  The only differences
between this package and the simultaneously-released gettext-0.17-3
for cygwin-1.5 are (1) compiled against the cygwin-1.7 DLL and its
import library, and (2) documentation changes.

COMPILER USED: gcc-3.4.4-3 and g++-3.4.4-3
This is important to note, because libasprintf0 is a C++ library. Later
updates MAY use gcc-4.3, but will be accompanied by DLL version number
bumps for all C and C++ dlls.

These packages should be updated together with libiconv 1.12-10:

    libiconv-1.12-10
    libiconv2-1.12-10
    libcharset1-1.12-10

    gettext-0.17-10
    gettext-devel-0.17-10
    libintl8-0.17-10
    libgettextpo0-0.17-10
    libasprintf0-0.17-10

CHANGES (gettext-0.17-1 ---> gettext-0.17-10):
(includes changes in the released but un-announced gettext-0.17-2)

* Fixed packaging bug in setup.hint for libasprintf0
* Fixed a bug in lib-link.m4 exposed when dependent libraries
(Continue reading)

cygwin | 2 Jan 17:51 2009

[1.7] Updated: {libiconv/libiconv2/libcharset1}-0.12-10

The GNU libiconv package provides an iconv() implementation, for use on
systems which don't have one, or whose implementation cannot convert
from/to Unicode.

This is the first release specific for cygwin-1.7.  The only differences
between this package and the earlier libiconv-0.12-1 (released for both
cygwin-1.5 and cygwin-1.7) are (1) compiled against the cygwin-1.7 DLL
and its import library, and (2) documentation changes. There is no
corresponding "simultaneously released" version of libiconv solely for
cygwin-1.5; libiconv-0.12-1 will most likely be the final libiconv
update for the cygwin-1.5 distribution, and future libiconv development
will continue with this libiconv-0.12-10 package for cygwin-1.7 only.

COMPILER USED: gcc-3.4.4-3 and g++-3.4.4-3
Later updates MAY use gcc-4.3, but will be accompanied by DLL version
number bumps for all C dlls.

Changes (libiconv-0.12-1 ---> libiconv-0.12-10)

* Fork from cygwin-1.5 package development stream
* Updated packaging to use (cygwin-1.7-specific) cygport 0.9.2
  rather than legacy cygport 0.4.x.

TESTSUITE RESULTS:
All tests pass.

--
Charles Wilson
libiconv volunteer maintainer for cygwin

(Continue reading)

David Rothenberger | 5 Jan 04:25 2009
Picon

[1.7] Updated: {subversion,subversion-apache2,subversion-devel,subversion-perl,subversion-python,subversion-ruby}-1.5.5-2

The subversion packages have been rebuilt for Cygwin 1.7.

NEWS:
=====
See CHANGES (URL below) for more information details about the
changes from earlier releases to 1.5.5.

IMPORTANT: This release will silently upgrade your Subversion
working copies to the 1.5 format, rendering them unusable with
previous major versions of Subversion.

Please see the release notes

   http://subversion.tigris.org/svn_1.5_releasenotes.html

for more details about the changes in Subversion.

See

   http://svn.collab.net/viewvc/svn/tags/1.5.5/CHANGES

for more details about the changes in 1.5.5.

DESCRIPTION:
============
Subversion is a version control system designed to be a compelling
successor to CVS.

Please see

(Continue reading)

cygwin | 7 Jan 06:32 2009

New: gcc-tools-autoconf-2.59-2

This is an unmodified version of autoconf-2.59, installed into
/opt/gcc-tools/ for the use of gcc developers. Gcc requires
an unpatched, pristine version of autoconf when preparing patches
for official submission. For various reasons [1] it cannot coexist with
the existing autoconf packages in /usr.

Autoconf is an extensible package of m4 macros that produce shell
scripts to automatically configure software source code packages.

The gcc-tools-autoconf-2.59-2 package was prepared on and for cygwin-1.5
using cygport-0.4.0. It differs from the simultaneously released
gcc-tools-autoconf-2.59-10 for cygwin-1.7 only in the location of some
documentation files.

[1] http://cygwin.com/ml/cygwin-apps/2009-01/msg00007.html

--
Chuck
autoconf volunteer maintainer for cygwin

====================================================================

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

*** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
(Continue reading)

cygwin | 7 Jan 06:32 2009

New: gcc-tools-automake-1.9.6-2

This is an unmodified version of automake-1.9.6, installed into
/opt/gcc-tools/ for the use of gcc developers. Gcc requires an
unpatched, pristine version of the most recent official release from the
automake-1.9 series, when preparing patches for official submission. For
various reasons [1] it cannot coexist with the existing automake
packages in /usr.

Automake is a tool for automatically generating `Makefile.in' files
compliant with the GNU Coding Standards.

The gcc-tools-automake-1.9.6-2 package was prepared on and for
cygwin-1.5 using cygport-0.4.0. It differs from the simultaneously
released gcc-tools-automake-1.9.6-10 for cygwin-1.7 only in the location
of some documentation files.

[1] http://cygwin.com/ml/cygwin-apps/2009-01/msg00007.html

--
Chuck
automake volunteer maintainer for cygwin

====================================================================

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

*** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
(Continue reading)

cygwin | 7 Jan 06:32 2009

New for cygwin-1.7: gcc-tools-autoconf-2.59-10

This is an unmodified version of autoconf-2.59, installed into
/opt/gcc-tools/ for the use of gcc developers. Gcc requires
an unpatched, pristine version of autoconf when preparing patches
for official submission. For various reasons [1] it cannot coexist with
the existing autoconf packages in /usr.

Autoconf is an extensible package of m4 macros that produce shell
scripts to automatically configure software source code packages.

The gcc-tools-autoconf-2.59-10 package was prepared on and for
cygwin-1.7 using cygport-0.9.2. It differs from the simultaneously
released gcc-tools-automake-1.9.6-2 for cygwin-1.5 only in the location
of some documentation files.

[1] http://cygwin.com/ml/cygwin-apps/2009-01/msg00007.html

--
Chuck
autoconf volunteer maintainer for cygwin

====================================================================

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

*** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
(Continue reading)

cygwin | 7 Jan 06:33 2009

New for cygwin-1.7: gcc-tools-automake-1.9.6-10

This is an unmodified version of automake-1.9.6, installed into
/opt/gcc-tools/ for the use of gcc developers. Gcc requires an
unpatched, pristine version of the most recent official release from the
automake-1.9 series, when preparing patches for official submission. For
various reasons [1] it cannot coexist with the existing automake
packages in /usr.

Automake is a tool for automatically generating `Makefile.in' files
compliant with the GNU Coding Standards.

The gcc-tools-automake-1.9.6-10 package was prepared on and for
cygwin-1.7 using cygport-0.9.2. It differs from the simultaneously
released gcc-tools-automake-1.9.6-2 for cygwin-1.5 only in the location
of some documentation files.

[1] http://cygwin.com/ml/cygwin-apps/2009-01/msg00007.html

--
Chuck
automake volunteer maintainer for cygwin

====================================================================

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

*** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
(Continue reading)

Corinna Vinschen | 8 Jan 12:27 2009

Updated: openssl-0.9.8j-1, openssl-devel-0.9.8j-1

I've updated the version of OpenSSL to 0.9.8j-1.  This also includes the
openssl-devel package.

This is an upstream security and bugfix release.  The Cygwin release is
the vanilla version, no additional patches.

OpenSSL Security Advisory:
=======================================================================
OpenSSL Security Advisory [07-Jan-2009]

Incorrect checks for malformed signatures
- -------------------------------------------

Several functions inside OpenSSL incorrectly checked the result after
calling the EVP_VerifyFinal function, allowing a malformed signature
to be treated as a good signature rather than as an error.  This issue
affected the signature checks on DSA and ECDSA keys used with
SSL/TLS.

One way to exploit this flaw would be for a remote attacker who is in
control of a malicious server or who can use a 'man in the middle'
attack to present a malformed SSL/TLS signature from a certificate chain
to a vulnerable client, bypassing validation.

This vulnerability is tracked as CVE-2008-5077.

The OpenSSL security team would like to thank the Google Security Team
for reporting this issue.

Who is affected?
(Continue reading)

Chris Sutcliffe | 11 Jan 23:10 2009
Picon

Updated: mingw-runtime-3.15.2-1

I've made a new version of the mingw-runtime available for download.
For a list of changes see:

http://cygwin.com/cgi-bin/cvsweb.cgi/src/winsup/mingw/ChangeLog?rev=1.427&cvsroot=src

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

If you have questions or comments, please send them to the Cygwin
mailing list at: cygwin <at> cygwin.com .

    *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is
available starting at this URL.

Chris

--

-- 
(Continue reading)


Gmane