Eric Blake | 1 Jul 16:11 2007
Picon

Updated: tar-1.18-1


A new release of tar, 1.18-1, is available, replacing 1.17-1.  Version
1.16.1-1 remains the previous version.

NEWS:
=====
This is a new stable upstream release.  It is one of the first packages to
switch from GPLv2 to GPLv3 (http://gplv3.fsf.org/).  This release requires
cygwin-1.5.24 or later.  A list of changes from 1.17 extracted from the
NEWS file is below; see also /usr/share/doc/tar-1.18/.

version 1.18 - Sergey Poznyakoff, 2007-06-29

* Licensed under the GPLv3

* Fixed several bugs in the testsuite

DESCRIPTION:
============
GNU Tar is an archiver program. It is used to create and manipulate files
that are actually collections of many other files; the program provides
users with an organized and systematic method of controlling a large
amount of data.  Despite its name, that is an acronym of "tape archiver",
GNU Tar is able to direct its output to any available devices, files or
other programs, it may as well access remote devices or files.  The main
areas of usage for GNU Tar are: storage, backup and transportation.

UPDATE:
=======
To update your installation, click on the "Install Cygwin now" link on the
(Continue reading)

Corinna Vinschen | 2 Jul 21:55 2007

Updated: cpio-2.9-1

I've just updated the version of cpio to 2.9-1.

This is an official upstream release.  The Cygwin version has been
built from the vanilla sources.  cpio passes all (four) tests in the
testsuite.

What's new in 2.9 and the skipped 2.8 release?

Version 2.9 - Sergey Poznyakoff, 2007-06-28

* Licensed under the GPLv3.

* Bugfixes:
** Honor umask when creating intermediate directories, not specified
in the archive (debian bug #430053)

^L
Version 2.8 - Sergey Poznyakoff, 2007-06-08

* Option --owner can be used in copy-out mode, allowing to uniformly override
ownership of the files being added to the archive.

* Bugfixes:

** Symlinks were handled incorrectly in copy-out mode.
** Fix handling of large files.
** Fix setting the file permissions in copy-out mode.
** Fix CAN-2005-1111

To update your installation, click on the "Install Cygwin now" link on
(Continue reading)

Brian Dessent | 2 Jul 09:34 2007
Picon

Setup.exe updated to version 2.573.2.2


I've updated the version of setup.exe at <http://cygwin.com/setup.exe>
to version 2.573.2.2.  This version incorporates a number of bug fixes and new
features, as listed below.

 - Fix crash when trying to MD5 a non-existant package file that failed to
   download.

 - Don't append a trailing slash to local package directory location if it
   already has one, or it ends in a backslash.

 - Be more robust in falling back to setup.ini if setup.bz2 doesn't exist
   or appears to be corrupt.

 - Fix crashes and improve specificity of error messages when encountering
   an .ini file parse error.  Make progress meter active during parsing of a
   bz2-compressed .ini file.

 - At the last install step, inform the user of success/failure at the bottom
   of the main panel instead of with an annoying message box popup.

 - Fix bug that caused a wrong version of a source package to be selected
   in some cases due to erroniously comparing versions as text instead of
   numerically.

 - Gracefully handle the case where two packages contain a postinstall script
   of the same name.

 - Allow interactively retrying to replace open files.

(Continue reading)

Samuel Thibault | 4 Jul 17:46 2007

Updated: brltty 3.8-2

Version 3.8-2 of "brltty" has been uploaded.

It is a background process (daemon) providing access to the Windows
Console for a blind person using a refreshable braille display.

----------  brltty-3.8-2 -- 2007-07-03 -----------
Update to subversion 3090 for braille font support.

Heavy #ifdef WINDOWS -> #ifdef __MINGW32__ to use cygwin emulation layer for
everything.

Split into libbrlapi, libbrlapi-devel, python-brlapi, tcl-brlapi, and xbrlapi

If you have questions or comments, please send them to the Cygwin
mailing list at: cygwin <at> cygwin.com .

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list,
look at the "List-Unsubscribe: " tag in the email header of this
message. Send email to the address specified there. It will be in the
format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is available
(Continue reading)

Schulman.Andrew | 4 Jul 21:37 2007
Picon

Updated:lftp-3.5.11-1


A new version of the lftp package is available in the Cygwin
distribution.  lftp is a sophisticated file transfer program and
ftp/http client.  It
supports multiple network protocols, offers tab completion, command
history, job control, and bookmarks, can mirror sites and transfer
multiple files in parallel, and keeps trying interrupted operations
until it can complete them.

Changes in version 3.5.11-1:
* New upstream bugfix release.  The previous Cygwin release was
  version 3.5.9-1; see http://lftp.yar.ru/news.html for a list of
  changes since then.

Andrew E. Schulman

*******************************************************************

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

(Continue reading)

Corinna Vinschen | 5 Jul 12:43 2007

Updated: SWI-Prolog-5.6.36-1

I've just updated the version of SWI-Prolog to 5.6.36-1.

This is the long overdue update to the latest stable upstream release.
The Cygwin version has a few minor patches which I will send upstream.

The differences between the former 5.2.6 version are too numerous to be
listed here.  From the Cygwin perspective the two major differences are
that SWI-Prolog has now been build with shared libs, and that a couple
of the dynamically loadable packages have been build and packed as well:

  clib, http, jasmine, nlp, semweb, ssl, table and zlib.

Unfortunately xpce and sgml don't build on Cygwin right now, but I'm
working on it for a later release.

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple
(Continue reading)

Corinna Vinschen | 6 Jul 17:49 2007

Updated: inetutils-1.3.2-36

I've updated the version of inetutils to 1.3.2-36.

Changes in 1.3.2-36:

- Fix a race problem in rlogin when running in a notty session.

=========================================================================
			  IMPORTANT NOTE:

- When updating inetutils, take care that syslogd.exe, inetd.exe and
  subsequent processes don't run anymore.  Otherwise the update will
  fail.

=========================================================================

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

If you have questions or comments, please send them to the Cygwin
mailing list at: cygwin <at> cygwin.com .

*** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

(Continue reading)

Eric Blake | 7 Jul 06:22 2007
Picon

Updated: sharutils-4.7-1


A new release of sharutils, 4.6.3-1, is available, replacing 4.6.3-1 as
current.

NEWS:
=====
This is a new stable upstream release.  It switches over to GPLv3; little
else has changed.  Using shar on text mounts continues to have the
possibility that line endings on text files might not be handled the way
you want, but if it was truly a text file, that should not matter to you;
the heuristic that shar uses to decide between text and binary files is
whether it contains non-printing characters.  It is safer to use
shar/unshar on binary mounts (remembering that unshar is inherently
unsafe).  uuencode and uudecode, on the other hand, work reliably
regardless of the underlying mount point.  Upstream changes since 4.6.3
are listed below; see also the package documentation found in
/usr/share/doc/sharutils-4.7/.

Version 4.7 - July 2007, by Bruce Korb

* fix a grammatical typo in doc/uuencode.1
* relicense the product under GPL version 3.

DESCRIPTION:
============
The sharutils package contains the GNU shar utilities, a set of tools
for encoding and decoding packages of files (in binary or text format)
in a special plain text format called shell archives (shar).  This
format can be sent through e-mail (which can be problematic for
regular binary files).  The shar utility supports a wide range of
(Continue reading)

Andrew Schulman | 9 Jul 17:05 2007
Picon

Unison: new, updated, and obsoleted packages

Unison is a file synchronizer for Unix and Windows. It allows two replicas
of a collection of files and directories to be stored on different hosts (or
different disks on the same host), modified separately, and then brought up
to date by propagating the changes in each replica to the other.

Several changes have been made to the Unison packages in the Cygwin
distribution:

* unison2.27:  New package.

* unison2.13, unison2.17:  Minor documentation updates.

* unison2.9.1, unison2.9.20, unison2.10.2, unison2.12.0:  Moved to the
"obsolete" category.  I decided to stop maintaining these packages because:
- No Linux or BSD distros that I can find are still using these versions;
  all have moved to 2.13 or later.
- Upstream source is no longer available for all of them except 2.9.1, and
  that version was pretty buggy.
- No further upstream updates will be issued for these versions; bug fixes
  and new features are going into the newer versions.
These packages are still available in the Cygwin archives for now, but
you'll have to uncheck "Hide obsolete or administrative packages" in the
Cygwin installer to see them.  The packages are now unmaintained, and at
some time in the future they'll probably go away altogether.  If you already
have them installed they'll stay installed.

Unison comes in multiple packages for Cygwin, each package representing a
version that's incompatible with the others.  You can safely install as many
of them as you like; their executables are named e.g. unison-2.13.exe, so
they don't conflict.  For more information about version compatibility in
(Continue reading)

Andrew Schulman | 9 Jul 20:56 2007
Picon

Updated: lablgtk2-20060908-1

A new version of the lablgtk2 package is available in the Cygwin
distribution.

Changes in version 20060908-1:
* New upstream bug fix release.
* Changed to cygport build method.

Andrew E. Schulman

*******************************************************************

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

If you have questions or comments, please send them to the Cygwin
mailing list at: cygwin@... .

*** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com@...

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

(Continue reading)


Gmane