Elfyn McBratney | 3 Mar 15:22 2003
Picon

New package: pdksh-5.2.14-1

This new package contains pdksh, the Public Domain Korn Shell. Homepage of
the project is <http://web.cs.mun.ca/~michael/pdksh/>.

This is the latest stable release of pdksh 5.2.14 with a fix for a clean
compile under Cygwin and a change to Makefile.in to delete some .exe files
when doing a `make clean'.

To update your installation, click on the "Install Cygwin now" link on the
http://cygwin.com/ web page.  This downloads setup.exe to your system.  Once
you've downloaded setup.exe, run it and select "Net" or "Mail" and then
click on the appropriate field until the above announced version number
appears if it is not displayed already.

If you have questions or comments, please send them to the Cygwin mailing
list at: cygwin <at> cygwin.com .  I would appreciate it if you would use this
mailing list rather than emailing me directly.  This includes ideas and
comments about the setup utility or Cygwin in general.

If you want to make a point or ask a question, the Cygwin mailing list is
the appropriate place.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look at
the "List-Unsubscribe: " tag in the email header of this message. Send email
to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

If you need more information on unsubscribing, start reading here:
(Continue reading)

Elfyn McBratney | 4 Mar 21:58 2003
Picon

Updated: pdksh-5.2.14-2

This package contains pdksh, the Public Domain Korn Shell. Homepage of the
project is <http://web.cs.mun.ca/~michael/pdksh/> .

This is an update to fix the lack of the postinstall script run. There was
an error at the top of the file, a double '#' bang on the shebang line which
meant that the script would be ignored when executed. This is now fixed and
files such as /etc/profile.ksh will now be installed.

To update your installation, click on the "Install Cygwin now" link on the
http://cygwin.com/ web page.  This downloads setup.exe to your system.  Once
you've downloaded setup.exe, run it and select "Net" or "Mail" and then
click on the appropriate field until the above announced version number
appears if it is not displayed already.

If you have questions or comments, please send them to the Cygwin mailing
list at: cygwin <at> cygwin.com .  I would appreciate it if you would use this
mailing list rather than emailing me directly.  This includes ideas and
comments about the setup utility or Cygwin in general.

If you want to make a point or ask a question, the Cygwin mailing list is
the appropriate place.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look at
the "List-Unsubscribe: " tag in the email header of this message. Send email
to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

(Continue reading)

Corinna Vinschen | 6 Mar 18:05 2003

Updated: tcsh-6.12.00-5

I've updated the version of tcsh to 6.12.00-5.

This version adds a csh symlink pointing to tcsh.exe.

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

If you have general questions or comments, please send them to the
Cygwin mailing list at: "cygwin at cygwin dot com".  I would appreciate
it if you would use this mailing list rather than emailing me directly.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is available
starting at this URL.

--

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                                mailto:cygwin <at> cygwin.com
(Continue reading)

Jason Tishler | 6 Mar 19:53 2003
Picon

[fetchmail] Updated Cygwin Package: fetchmail-6.2.2-1

New News:
=== ====
I have updated the version of fetchmail to 6.2.2-1.  The tarballs should
be available on a Cygwin mirror near you shortly.

Additionally, this version has been built against the latest Cygwin
OpenSSL package, 0.9.7a-1.

Old News:
=== ====
Fetchmail is a remote mail retrieval and forwarding utility intended
for use over on-demand TCP/IP links, like SLIP or PPP connections.
Fetchmail supports every remote-mail protocol currently in use on the
Internet (POP2, POP3, RPOP, APOP, KPOP, all IMAPs, ESMTP ETRN, IPv6,
and IPSEC) for retrieval. Then Fetchmail forwards the mail through SMTP
so you can read it through your favorite mail client.

See the fetchmail home page for more details:

    http://catb.org/~esr/fetchmail/

Please read the README file:

    /usr/doc/Cygwin/fetchmail-6.2.2.README

since it covers requirements, installation, known issues, etc.

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.
(Continue reading)

Jason Tishler | 6 Mar 23:18 2003
Picon

Updated Cygwin Package: python-2.2.2-6

New News:
=== ====
I have updated the version of Python to 2.2.2-6.  The tarballs should be
available on a Cygwin mirror near you shortly.

The only purpose of this release is to rebuild against the latest Cygwin
OpenSSL package, 0.9.7a-1.  Otherwise, this package should be identical
to the previous one.

Old News:
=== ====
Python is an interpreted, interactive, object-oriented programming
language.  If interested, see the Python web site for more details:

    http://www.python.org/                                         

Please read the README file:

    /usr/doc/Cygwin/python-2.2.2.README

since it covers requirements, installation, known issues, etc.

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

Note that we have recently stopped downloads from sources.redhat.com
(aka cygwin.com) due to bandwidth limitations.  This means that you will
need to find a mirror which has this update.

(Continue reading)

Jan Nieuwenhuizen | 6 Mar 23:46 2003
Picon

Updated: tetex 2.0.2-1


TeTeX has been updated to version 2.0.2-1.  This is a bugfix release.
It includes upstream bugfixes, packaging fixes and textmode mount
fixes for xdvi and t1lib.

TeTex is split up and packaged in seven parts.  Three packages for
executables and runtime libraries: tetex-bin, libkpathsea3, tetex-x11.
Three packages for the texmf tree: tetex-base, tetex-doc, and
tetex-extra.  And a development package: tetex-devel.

As tetex-base is very big (>10MB), there's an additional package:
tetex-tiny, that provides a very small (~2MB) functional texmf tree.
If you select tetex-base or tetex-tiny, that should take care of
dependencies and provide a working teTeX setup.

The executables and runtime libraries: tetex-bin and libkpathsea3, are
always required.  To get a functional TeX/LaTeX setup, you also need a
texmf tree.  You can choose from tetex-base or tetex-tiny.

NOTE: The tetex-tiny and tetex-base packages overlap.  If you choose
      for a full teTeX installation, or just install everything of
      Cygwin, both will be installed, which should be fine.  Please
      don't uninstall one of them, there should be no need to do so.
      If you do, you must reinstall the remaining other package.

After a successful installation of tetex (tetex-bin + libkpathsea3,
and one of tetex-tiny or tetex-base), you should be able to run, eg,

    latex sample2e
    dvips -o sample2e.ps sample2e
(Continue reading)

Christopher Faylor | 8 Mar 05:34 2003
Picon

Updated: gdb-20030303-1

I've made a new version of GDB (aka insight) available for downloading.
This version is a refresh from CVS on sources.redhat.com.  It fixes
a reported problem where typing a '-' as input caused gdb to crash.

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

IF YOU HAVE PROBLEMS WITH INSIGHT PLEASE SEND THEM TO THE INSIGHT
MAILING LIST at "insight at sources dot redhat dot com".  Then the
insight maintainers can help rectify them.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is available
starting at this URL.

Christopher Faylor

(Continue reading)

Charles Wilson | 8 Mar 05:07 2003
Picon

Updated: tiff-3.6.0-1

The tiff package has been updated to version 3.6.0-1.  It is based
on the official tiff-v3.6.0beta.tar.gz distribution, and provides a
library and utility routines for manipulating tiff files and images.

Changes (relative to 3.5.7)
  o Updated to 3.6.0beta source
    - New utility raw2tiff for converting raw rasters into TIFF files.
    - Lots of new tiff2ps options.
    - Lots of bug fixes for LZW, JPEG and OJPEG compression.

Charles Wilson
tiff volunteer maintainer for cygwin

INSTALLATION:

To update your installation, click on the "Install Cygwin now" link on
the http://sources.redhat.com/cygwin web page.  This downloads setup.exe
to your system.

Run setup and answer all of the questions.  You must choose a
mirror, since direct downloads from 'cygwin.com' are no longer
allowed.

ftp://mirrors.rcn.net/pub/sourceware/cygwin/ (US)
ftp://linux.sarang.net/mirror/development/compiler/cygwin/ (Korea)
ftp://ftp.mirror.ac.uk/sites/sourceware.cygnus.com/pub/cygwin (UK)

The setup.exe program will figure out what needs to be updated on your
system and should install the tiff package automatically.

(Continue reading)

Christopher Faylor | 8 Mar 05:42 2003

Updated: binutils-20030307-1

I've made a new version of binutils available for installation.
This version is a refresh from CVS on sources.redhat.com.

This release has one minor change from Chuck Wilson to make
--enable-runtime-pseudo-reloc the default for `ld'.

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com <at> cygwin.com

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is available
starting at the above URL.

Christopher Faylor

Pavel Tsekov | 8 Mar 18:12 2003
Picon
Picon

Updated: mc-4.6.0-1

The Midnight Commander visual shell has been updated to version 
4.6.0-1. This is major upgrade and the result of more then
one and a half year of bugfixing and code cleanup.

You can find the official announcement here:
http://mail.gnome.org/archives/mc-devel/2003-February/msg00043.html

Full list of changes since version 4.5.55 can be found here:
http://cvs.gnome.org/lxr/source/mc/NEWS

Please, consider reading the file /usr/doc/Cygwin/mc-4.6.0.README
after the installation/upgrade is finished.

IMPORTANT NOTE:

The Cygwin package includes two patches, which are not present in the
official 4.6.0 release.

  * A patch to open the source and destination files in binary mode
    when copying/moving files.

    This patch, in its current form, is unlikely to be accepted by
    the MC developers, but it is good enough for the Cygwin package.

  * A patch to dynamically load libX11 if it is present and the DISPLAY
    variable is set.

    This patch was accepted by the MC developers after the release of 
    MC 4.6.0.

(Continue reading)


Gmane