bugzilla-daemon | 1 Jul 01:38 2011
Picon

[Bug 29662] New: Fatal error: Call to a member function getText() on a non-object in /var/www/mediawiki/includes/Article.php on line 311

https://bugzilla.wikimedia.org/show_bug.cgi?id=29662

       Web browser: ---
             Bug #: 29662
           Summary: Fatal error: Call to a member function getText() on a
                    non-object in /var/www/mediawiki/includes/Article.php
                    on line 311
           Product: MediaWiki
           Version: 1.19-svn
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: critical
          Priority: Unprioritized
         Component: History/Diffs
        AssignedTo: wikibugs-l <at> lists.wikimedia.org
        ReportedBy: mybugs.mail <at> gmail.com
    Classification: Unclassified

I'm running MW trunk (r91235) and every time I open a nonexistent page, add
some content and click on "Show changes" I get:
--------------------------------------------------------------------------------
Fatal error: Call to a member function getText() on a non-object in
/var/www/mediawiki/includes/Article.php on line 311
--------------------------------------------------------------------------------

The line mentioned is this:
http://svn.wikimedia.org/viewvc/mediawiki/trunk/phase3/includes/Article.php?annotate=91162&pathrev=91235#l309
--------------------------------------------------------------------------------
//  <at> todo FIXME: Horrible, horrible! This content-loading interface just plain
(Continue reading)

bugzilla-daemon | 1 Jul 01:41 2011
Picon

[Bug 29662] Fatal error: Call to a member function getText() on a non-object in /var/www/mediawiki/includes/Article.php on line 311

https://bugzilla.wikimedia.org/show_bug.cgi?id=29662

Reedy <sam <at> reedyboy.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |JSchulz_4587 <at> msn.com

--- Comment #1 from Reedy <sam <at> reedyboy.net> 2011-06-30 23:41:41 UTC ---
Possibly r91159

--

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.
bugzilla-daemon | 1 Jul 02:01 2011
Picon

[Bug 29245] Babel: strange page title on preview or after saving (behaving as if it were a category)

https://bugzilla.wikimedia.org/show_bug.cgi?id=29245

--- Comment #4 from Robin Pepermans (SPQRobin) <robinp.1273 <at> gmail.com> 2011-07-01 00:01:20 UTC ---
Created attachment 8727
  --> https://bugzilla.wikimedia.org/attachment.cgi?id=8727
Screenshot before and after doing a null edit

See screenshot. I went to http://www.omegawiki.org/Help:Babel and it displayed
as above (as a category). Then I did a null edit (didn't change anything
actually) and saved the page so it parsed the page again, and it displayed
properly.

So apparently it's not only on page preview or page edit, but also when just
visiting a page.

Does no-one else encounter this strange bug?

--

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
bugzilla-daemon | 1 Jul 02:03 2011
Picon

[Bug 29245] Babel: strange page title on preview or after saving (behaving as if it were a category)

https://bugzilla.wikimedia.org/show_bug.cgi?id=29245

--- Comment #5 from Robin Pepermans (SPQRobin) <robinp.1273 <at> gmail.com> 2011-07-01 00:03:13 UTC ---
And there was also a strange text UNIQb002b8242bbcc42-pre-00000000-QINU
instead of the <pre> stuff.

--

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
bugzilla-daemon | 1 Jul 02:07 2011
Picon

[Bug 29659] Indexed PNG thumbnails are blurrier than true-color

https://bugzilla.wikimedia.org/show_bug.cgi?id=29659

PRO <perhelion1 <at> googlemail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                URL|                            |http://commons.wikimedia.or
                   |                            |g/wiki/File:Jürgen_Alberts_
                   |                            |-_pv_portrait_02-3.png

--- Comment #3 from PRO <perhelion1 <at> googlemail.com> 2011-07-01 00:07:17 UTC ---
Ok I would remove my first sentence. I mean the issue of quality (not size of
thumbs, but these are different too). Maybe this Bug is not sufficiently
defined, or too general. Currently I've only tested grayscale images.

The logic can not tell the difference - thumbs from the same image (same colors
but only different Bitdepth) to the same truecolor thumbs must be equal (or the
indexed should be sharper?)

Another very simple 1b example (minimally, only to detect under magnification):
Sharp Trucolor:
http://upload.wikimedia.org/wikipedia/commons/thumb/archive/b/b5/20100430150734%21Ping_deny.png/300px-Ping_deny.png
Unsharp Indexed 4b:
http://upload.wikimedia.org/wikipedia/commons/thumb/archive/b/b5/20110630223939%21Ping_deny.png/300px-Ping_deny.png

--

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.
(Continue reading)

bugzilla-daemon | 1 Jul 02:13 2011
Picon

[Bug 29245] Babel: strange page title on preview or after saving (behaving as if it were a category)

https://bugzilla.wikimedia.org/show_bug.cgi?id=29245

Bawolff <bawolff+wn <at> gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bawolff+wn <at> gmail.com
             Blocks|                            |26213

--

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
bugzilla-daemon | 1 Jul 02:13 2011
Picon

[Bug 26213] UNIQ tracking bug

https://bugzilla.wikimedia.org/show_bug.cgi?id=26213

Bawolff <bawolff+wn <at> gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Depends on|                            |29245

--

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.
bugzilla-daemon | 1 Jul 02:14 2011
Picon

[Bug 29662] Fatal error: Call to a member function getText() on a non-object in /var/www/mediawiki/includes/Article.php on line 311

https://bugzilla.wikimedia.org/show_bug.cgi?id=29662

Aaron Schulz <JSchulz_4587 <at> msn.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED

--- Comment #2 from Aaron Schulz <JSchulz_4587 <at> msn.com> 2011-07-01 00:14:43 UTC ---
Fixed in r91238.

--

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.
bugzilla-daemon | 1 Jul 02:21 2011
Picon

[Bug 28904] Update jQuery version to 1.6.2 in trunk (MediaWiki 1.19)

https://bugzilla.wikimedia.org/show_bug.cgi?id=28904

--- Comment #13 from Reedy <sam <at> reedyboy.net> 2011-07-01 00:21:18 UTC ---
(In reply to comment #12)
> JQuery 1.6.2 has been released:
> http://blog.jquery.com/2011/06/30/jquery-162-released/

You could've just opened a new bug

--

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
bugzilla-daemon | 1 Jul 02:26 2011
Picon

[Bug 29659] Indexed PNG thumbnails are blurrier than true-color

https://bugzilla.wikimedia.org/show_bug.cgi?id=29659

--- Comment #4 from Brion Vibber <brion <at> wikimedia.org> 2011-07-01 00:26:01 UTC ---
Ok I did a quick check resizing these versions of the Ping_deny.png image:

a.png -- the truecolor version
b.png -- the grayscale version (it is in fact grayscale, not indexed!)
truecolor.png -- a version explicitly re-saved from Gimp from a.png
gray.png -- a version explicitly converted to grayscale in Gimp from a.png
indexed.png -- a version explicitly converted to indexed color in Gimp from
a.png

for x in a.png b.png gray.png indexed.png truecolor.png
do
    convert \
        -quality 95 \
        -background white \
        $x \
        -thumbnail 300x142\! \
        -depth 8 -auto-orient \
        300px-$x
done

The resulting images match what I see from the above-linked thumbs:

* truecolor image, scaled, is still truecolor.
* grayscale image, scaled, is still grayscale. Looks slightly darker and
possibly blurrier than scaled version of truecolor image.
* indexed-color image, scaled, becomes truecolor. Looks identical to grayscale
version.
(Continue reading)


Gmane