gypsy | 10 Feb 00:43 2012

Bypass XHDR

First, it needs to be stated emphatically that I am not a C programmer! 
All I can do is copy code and then hack it until it does what I want, or
I admit defeat and give up.

The reason for this patch is that I wanted to suck a newsgroup with over
5 million articles; it was taking about 7 hours to run XHDR.  In my
opinion, XHDR is a complete waste of time for a news server because it
downloads the entire article and never just the headers.  In addition to
the wasted 7 hours, my upstream NNTP server - newsguy - places a
limitation on either the number of articles or the number of bytes
downloaded in a single setting, and sends "503 transfer limit, closing
connection." when that limit is reached.  I didn't time it, but my guess
is that the actual article download ran for 10 or 11 hours before the
503 error.  Thus, each attempt consumed 17 or 18 hours, of which
something like 40% was totally wasted.  Worse, if I allowed snfetch to
automatically restart, it would begin with the original .serial number
value and download the same articles again, providing a screenfull of
"oops"s and not progressing at all.

My connection is very fast, via a cable modem.

So I hacked snfetch to skip sending XHDR and go straight to downloading
articles, beginning with the article number in .serial.  In order to
assure that .serial is reasonably correct, the following shell script
runs on a different terminal:

#! /bin/bash
# This is Serial.sh.  It updates .serial and terminates sn when a 503
error occurs.
# The last article requested is received even though there is no 220
(Continue reading)

Chris Niekel | 17 Aug 14:30 2006
Picon

Xref just shows reference for current group

When crossposting a mesasge to two local groups, upon reading the message,
sn shows the xref just for the current group. It should tell the number in
every group.

A debian user posted a bug about it, so I thought I'd report it here.
Looking forward to a fix! :-)

Regards,
Chris Niekel

--

-- 
    I've been down so long, if I'd cheer up, I'd still be depressed.
            - Lisa Simpson, Moanin' Lisa Blues.

jegoer | 9 Jul 06:37 2006
Picon

Local Groups Message Body/Headers Blank

Good Evening,

I compiled and installed sn 0.3.8 on a fresh install of OpenBSD 3.9/i386 
  this evening.  After the initial install I found that messages sent to 
locally created groups were showing up in my newsreader as blank.  Upon 
further investigation I found that the only information contained within 
the message was the header "Xref: [host] test.group:10".  This was 
confirmed by opening a telnet session to the nntp port.

Telnet Dump:
   200 Hi, you can post (sn version 0.3.8)
   GROUP test.group
   211 1 10 10 test.group
   ARTICLE 10
   220 10 <0> Article follows
   Xref: [host] test.group:10

   .

Associated log entry:
   snntpd:SNPOST:test.group 10 <1bf8.44b07cff.ad101 <at> [host]>
   snntpd:SNPOST:Posted to test.group

I found that some files (SNHELLO, SNPOST and dot-outgoing.ex) appeared 
to be missing links to bash, as it was not installed.  I redirected the 
she-bang to /bin/sh but found an issue when using snget regarding a < on 
line 80 of SNHELLO.  I then installed bash to resolve any other 
conflicts.  I changed the she-bangs to point to bash and had the same 
issue with blank messages.  I then ran a gmake clean/install and tried 
again - same result.
(Continue reading)

Jeff Wilson | 23 Dec 08:11 2005
Picon

calling snstore from .forward under sendmail

snstore wants to be news.news, but if I call it from user bob's .forward 
file, sendmail forces it to run as bob.bob. How do people use sn's 
mail-to-news with sendmail then?

Jeff
--

-- 
Jeff Wilson - jwilson <at> io.com
< http://www.io.com/~jwilson >

Jeff Wilson | 22 Dec 05:28 2005
Picon

mailing list threading preservation?

Do the mail-to-news and news-to-mail interfaces that come with sn 
preserve message threading? That is, will mailing list replies (that 
originate as follow-ups to articles in the sitewide newsgroup of that 
mailing list) show up as likewise replies to that original mailing list 
post when other people on the mailing list view them in a threaded mail 
client?

Jeff
--

-- 
Jeff Wilson - jwilson <at> io.com
< http://www.io.com/~jwilson >

Nero Zero | 17 Oct 09:18 2005
Picon

Newsgroup 2 Mail Service?

Can I somehow convert article into mailbox formats?

Nero Zero | 17 Oct 01:39 2005
Picon

crontab 4 snget: by root or news as user?

How do I tell crontab to get news every 15 min? do i use as user news or
root here?

Nero Zero | 17 Oct 01:35 2005
Picon

Why does allow.hosts nntp: localhost not work? & message-id snget

I still have trouble with getting to post an my local system :; (Suse
does not need this Red Hat workaround?!)

BTW how do you get an old article from the news server by snget? (via
message-id?!=

Nero Zero | 15 Oct 14:14 2005
Picon

Fixing right for /var/spool/sn

sngetd:Can't write in /var/spool/sn (I am news.news, must be root.root)
news <at> linux:~>                                                             

news <at> linux:~> telnet localhost 119
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
snntpd:Can't write in /var/spool/sn (I am news.news, must be root.root)
Connection closed by foreign host.

:: Where do I find online an archive of this mailinglist?

Nero Zero | 14 Oct 03:33 2005
Picon

Localhost:119 Hi, you cannot post!!!


:: What can it be that I cannot post locally? telnet localhost 119 "No
Posting allowe" list command works to show me all kinds of newsgroups
snget works as well for internet newsgroups....

# /etc/hosts.allow
# See `man tcpd and `man 5 hosts_access for a detailed description
# of /etc/hosts.allow and /etc/hosts.deny.
#
# short overview about daemons and servers that are built with
# tcp_wrappers support:
# 
# package name  |       daemon path     |       token
#
----------------------------------------------------------------------------
# ssh, openssh  |  /usr/sbin/sshd       |  sshd, sshd-fwd-x11,
sshd-fwd-≤port>
# quota         | /usr/sbin/rpc.rquotad |  rquotad
# tftpd         | /usr/sbin/in.tftpd    |  in.tftpd
# portmap       |  /sbin/portmap        |  portmap
#                       The portmapper does not verify against hostnames
#                       to prevent hangs. It only checks non-local
addresses.
# 
# (kernel nfs server)
# nfs-utils     |  /usr/sbin/rpc.mountd |  mountd
# nfs-utils     |  /sbin/rpc.statd      |  statd
#
# (unfsd, userspace nfs server)
# nfs-server    |  /usr/sbin/rpc.mountd |  rpc.mountd
(Continue reading)

Nero Zero | 13 Oct 12:34 2005
Picon

Converting from Leafnode to SN

Hi there;
I was unhappy with leafnode while setting up a local newsgroup server 
for merely local newsgroups of my own creation since when I created them 
i never was abler to also receive again my postings via localhost...

So, what must I do to run SN on Suse 9.2 I have installed the rpm on 
rpmseek.com and now have no clue how to make it nntp daemon and how to 
swiftly set up local newsgroups with it

Many thanx


Gmane