Chris Gotstein | 1 Apr 03:49 2009

Re: Slave graphs not showing up


G.W. Haywood wrote:
> Hi there,
> 
> Please don't top post.
> 
>>> On Sat, 28 Mar 2009, Chris Gotstein wrote:
>>>
>>>> G.W. Haywood wrote:
>>> The debugging output should tell you whether (a) the slave is sending
>>> the NaNs and the master is faithfully reproducing them or (b) the
>>> slave is sending real numbers and the master is ignoring them.
>> Data from log on slave:
>>
>> Sat Mar 28 19:13:35 2009 - FPing: Executing /usr/local/sbin/fping -C 21
>> -q -B1 -r1 -i10 10.96.110.2 10.96.109.10 10.255.8.1 66.96.110.4
>> 216.234.103.194 216.234.97.2 sea.speakeasy.net ns3.uplogon.com
>> 10.96.109.12 10.99.1.71 10.96.109.11 dfw.speakeasy.net 10.96.109.135
>> lax.speakeasy.net atl.speakeasy.net 66.96.110.3 nyc.speakeasy.net
>> 10.96.109.140 10.96.109.136 66.96.110.1 shawcable.com
>> Sat Mar 28 19:13:56 2009 - FPing: Got fping output: '10.96.110.2       :
>> 1.72 1.90 1.75 1.87 1.81 1.95 1.82 1.87 1.89 1.94 1.78 2.19 2.08 1.77 ...
>> [snip]
>> Sat Mar 28 19:14:15 2009 - Sent data to Server. Server said OK
> 
> So what's the next step in the diagnosis?
> 
> --
> 
> 73,
(Continue reading)

G.W. Haywood | 1 Apr 10:09 2009
Picon

Re: Slave graphs not showing up

Hi there,

On Tue, 31 Mar 2009, Chris Gotstein wrote:

> >>> On Sat, 28 Mar 2009, Chris Gotstein wrote:
> >>>
> >>>> G.W. Haywood wrote:
> >>> The debugging output should tell you whether (a) the slave is sending
> >>> the NaNs and the master is faithfully reproducing them or (b) the
> >>> slave is sending real numbers and the master is ignoring them.
> >> Data from log on slave:
> >>
> >> Sat Mar 28 19:13:35 2009 - FPing: Executing /usr/local/sbin/fping -C 21
> >> -q -B1 -r1 -i10 10.96.110.2 10.96.109.10 10.255.8.1 66.96.110.4
> >> 216.234.103.194 216.234.97.2 sea.speakeasy.net ns3.uplogon.com
> >> 10.96.109.12 10.99.1.71 10.96.109.11 dfw.speakeasy.net 10.96.109.135
> >> lax.speakeasy.net atl.speakeasy.net 66.96.110.3 nyc.speakeasy.net
> >> 10.96.109.140 10.96.109.136 66.96.110.1 shawcable.com
> >> Sat Mar 28 19:13:56 2009 - FPing: Got fping output: '10.96.110.2       :
> >> 1.72 1.90 1.75 1.87 1.81 1.95 1.82 1.87 1.89 1.94 1.78 2.19 2.08 1.77 ...
> >> [snip]
> >> Sat Mar 28 19:14:15 2009 - Sent data to Server. Server said OK
> >
> > So what's the next step in the diagnosis?
>
> Still needing some help with this.  Anyone got an idea what i should
> look at next?

Well the slave log tells you that the slave is producing the data, and
that the server said 'OK', yes?
(Continue reading)

Chris Gotstein | 1 Apr 13:53 2009

Re: Slave graphs not showing up


G.W. Haywood wrote:
> Hi there,
> 
> On Tue, 31 Mar 2009, Chris Gotstein wrote:
> 
>>>>> On Sat, 28 Mar 2009, Chris Gotstein wrote:
>>>>>
>>>>>> G.W. Haywood wrote:
>>>>> The debugging output should tell you whether (a) the slave is sending
>>>>> the NaNs and the master is faithfully reproducing them or (b) the
>>>>> slave is sending real numbers and the master is ignoring them.
>>>> Data from log on slave:
>>>>
>>>> Sat Mar 28 19:13:35 2009 - FPing: Executing /usr/local/sbin/fping -C 21
>>>> -q -B1 -r1 -i10 10.96.110.2 10.96.109.10 10.255.8.1 66.96.110.4
>>>> 216.234.103.194 216.234.97.2 sea.speakeasy.net ns3.uplogon.com
>>>> 10.96.109.12 10.99.1.71 10.96.109.11 dfw.speakeasy.net 10.96.109.135
>>>> lax.speakeasy.net atl.speakeasy.net 66.96.110.3 nyc.speakeasy.net
>>>> 10.96.109.140 10.96.109.136 66.96.110.1 shawcable.com
>>>> Sat Mar 28 19:13:56 2009 - FPing: Got fping output: '10.96.110.2       :
>>>> 1.72 1.90 1.75 1.87 1.81 1.95 1.82 1.87 1.89 1.94 1.78 2.19 2.08 1.77 ...
>>>> [snip]
>>>> Sat Mar 28 19:14:15 2009 - Sent data to Server. Server said OK
>>> So what's the next step in the diagnosis?
>> Still needing some help with this.  Anyone got an idea what i should
>> look at next?
> 
> Well the slave log tells you that the slave is producing the data, and
> that the server said 'OK', yes?
(Continue reading)

G.W. Haywood | 1 Apr 14:12 2009
Picon

Re: Slave graphs not showing up

Hi there,

On Wed, 1 Apr 2009, Chris Gotstein wrote:

> >>>>> G.W. Haywood wrote:
> >>>>> The debugging output should tell you whether (a) the slave is
> >>>>> sending the NaNs and the master is faithfully reproducing them
> >>>>> or (b) the slave is sending real numbers and the master is
> >>>>> ignoring them.

> >>>> Sat Mar 28 19:14:15 2009 - Sent data to Server. Server said OK

> >>> So what's the next step in the diagnosis?

> >> Still needing some help with this.  Anyone got an idea what i
> >> should look at next?

> > Well the slave log tells you that the slave is producing the data,
> > and that the server said 'OK', yes?

> Correct.

So you need to find out what the master is seeing.  Is it
(a) incorrectly reading the data sent by the slave
(b) doing something stupid with it
(c) none of the above?

So what's the next step in the diagnosis?

(Continue reading)

Alegria, Luis | 1 Apr 17:37 2009
Picon

Re: Smokeping on Wink2008

Hi:

Any more good Samaritans out there that might want to take a stab at
this....

Thank you

-----Original Message-----
From: Alegria, Luis 
Sent: Thursday, March 19, 2009 2:40 PM
To: 'G.W. Haywood'
Cc: smokeping-users <at> lists.oetiker.ch
Subject: RE: [smokeping-users] Smokeping on Wink2008

Hi:

thank you for your response:

I did install it on win2k and win2003 to see if the problem was related
to wink2008, but I got the same problem. Host graphs are fine just the
info under charts. I'm pretty sure that I'm might missing a setting or
module somewhere and I just can Figured it out......

Thank you

LA (frustrated)

-----Original Message-----
From: G.W. Haywood [mailto:ged <at> jubileegroup.co.uk] 
Sent: Thursday, March 19, 2009 2:17 PM
(Continue reading)

Alegria, Luis | 1 Apr 18:23 2009
Picon

Re: Smokeping on Wink2008

Hi everyone:

Thank you all for your help, I finally got this solved.. I'm happy to say that I have Smokeping 2.4.2 running
(Fping only so far) under Rrdtool 1.2.30, Perl10...and Windows 2008

The contents of smokeping.pl under the cgi folder is
As follow

#!C:/Perl/bin/Perl.exe -w
# -*-perl-*-
#use strict;
#use warnings;
#use lib qw(rrdtool);
use lib qw(C:/smokeping-2.4.2/lib); ========>>  Forward Slash  - changing this made the difference 
use lib qw(lib);
Smokeping::cgi("C:/smokeping-2.4.2/etc/config.dist");

But the contents of smokeping.pl under the bin folder is as follow

#!/Perl/bin/Perl.exe -w
# -*-perl-*-
use lib qw(C:\smokeping-2.4.2\lib); =========>>  Backward SLASH
use lib qw(lib);

use strict;
use warnings;
use Smokeping (2.004002);

Smokeping::main("C:/smokeping-2.4.2/etc/config.dist");

(Continue reading)

Sipponen, Sami | 14 Apr 09:50 2009

Problem with LDAP probe

Hi,

 

I’m running Smokeping 2.3.6 on Debian Squeeze (Linux 2.6.26-2-686 on i686) and got this message repeatedly to my syslog:

 

Apr 14 10:30:48 sensping1 smokeping[3719]: "LDAP_SYNC_INFO" is not exported by the Net::LDAP::Constant module at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10

Apr 14 10:30:48 sensping1 smokeping[3719]: Can't continue after import errors at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10

Apr 14 10:30:48 sensping1 smokeping[3719]: Can't continue after import errors at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10#012BEGIN failed--compilation aborted at /usr/share/perl5/Net/LDAP/Intermediate.pm line 12, <DATA> line 378.

Apr 14 10:30:48 sensping1 smokeping[3719]: Can't continue after import errors at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10#012BEGIN failed--compilation aborted at /usr/share/perl5/Net/LDAP/Intermediate.pm line 12, <DATA> line 378.#012Compilation failed in require at /usr/share/perl5/Net/LDAP/Search.pm line 11, <DATA> line 378.

Apr 14 10:30:48 sensping1 smokeping[3719]: Can't continue after import errors at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10#012BEGIN failed--compilation aborted at /usr/share/perl5/Net/LDAP/Intermediate.pm line 12, <DATA> line 378.#012Compilation failed in require at /usr/share/perl5/Net/LDAP/Search.pm line 11, <DATA> line 378.#012BEGIN failed--compilation aborted at /usr/share/perl5/Net/LDAP/Search.pm line 11, <DATA> line 378.

Apr 14 10:30:48 sensping1 smokeping[3719]: Can't continue after import errors at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10#012BEGIN failed--compilation aborted at /usr/share/perl5/Net/LDAP/Intermediate.pm line 12, <DATA> line 378.#012Compilation failed in require at /usr/share/perl5/Net/LDAP/Search.pm line 11, <DATA> line 378.#012BEGIN failed--compilation aborted at /usr/share/perl5/Net/LDAP/Search.pm line 11, <DATA> line 378.#012Compilation failed in require at /usr/share/perl5/Net/LDAP.pm line 433, <DATA> line 378.

Apr 14 10:30:48 sensping1 smokeping[3344]: Use of uninitialized value $response in scalar chomp at /usr/share/perl5/smokeping/Smokeping/probes/basefork.pm line 217.

Apr 14 10:30:48 sensping1 smokeping[3344]: Use of uninitialized value $response in split at /usr/share/perl5/smokeping/Smokeping/probes/basefork.pm line 218.

Apr 14 10:30:48 sensping1 smokeping[3344]: Use of uninitialized value $response in concatenation (.) or string at /usr/share/perl5/smokeping/Smokeping/probes/basefork.pm line 223.

Apr 14 10:31:08 sensping1 smokeping[3752]: "LDAP_SYNC_INFO" is not exported by the Net::LDAP::Constant module at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10

 

All probes start fine but during operation LDAP probe throws these errors. I have tried Googling about this issue, but so far found nothing. However LDAP probe seems to work and I got measurements to my Smokeping. So seems that this is only annoyance, but I’d like to know should I do something to it or not?

 

Best Regards, Sami Sipponen

_______________________________________________
smokeping-users mailing list
smokeping-users <at> lists.oetiker.ch
https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users
Niko Tyni | 14 Apr 13:53 2009
Picon
Picon

Re: Problem with LDAP probe

On Tue, Apr 14, 2009 at 09:50:37AM +0200, Sipponen, Sami wrote:

> I'm running Smokeping 2.3.6 on Debian Squeeze (Linux 2.6.26-2-686 on i686) and got this message
repeatedly to my syslog:
> 
> Apr 14 10:30:48 sensping1 smokeping[3719]: "LDAP_SYNC_INFO" is not exported by the
Net::LDAP::Constant module at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10

That's weird. So this is libnet-ldap-perl 1:0.39-1 ?

Does this work for you?

 % perl -w -E 'use Net::LDAP::Constant q/LDAP_SYNC_INFO/; say LDAP_SYNC_INFO'
 1.3.6.1.4.1.4203.1.9.1.4

Is it possible that you have another Net::LDAP installation on the system?
--

-- 
Niko Tyni

_______________________________________________
smokeping-users mailing list
smokeping-users <at> lists.oetiker.ch
https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users

Sipponen, Sami | 14 Apr 20:14 2009

Re: Problem with LDAP probe

Hi,

When I run:

perl -w -E 'use Net::LDAP::Constant q/LDAP_SYNC_INFO/; say LDAP_SYNC_INFO'

I got answer:

1.3.6.1.4.1.4203.1.9.1.4

Sorry about my N00Bness, but I don't know a good way to check my libnet-ldap-perl version... However I did
"apt-get install libnet-ldap-perl" and got answer "libnet-ldap-perl is already the newest version.",
I also did "apt-cache show libnet-ldap-perl" and it says "Version: 1:0.39-1".

What comes to checking about multiple installations of Net::LDAP I don't know how to do that, any hints? I
have installed my Debian box very carefully and it should only have the packages I need. I have pretty good
documentation of commands how I have done that. Only other LDAP thingy which comes to my mind is PHP5-LDAP
which is installed.

Regards, Sami

-----Original Message-----

On Tue, Apr 14, 2009 at 09:50:37AM +0200, Sipponen, Sami wrote:

> I'm running Smokeping 2.3.6 on Debian Squeeze (Linux 2.6.26-2-686 on i686) and got this message
repeatedly to my syslog:
> 
> Apr 14 10:30:48 sensping1 smokeping[3719]: "LDAP_SYNC_INFO" is not exported by the
Net::LDAP::Constant module at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10

That's weird. So this is libnet-ldap-perl 1:0.39-1 ?

Does this work for you?

 % perl -w -E 'use Net::LDAP::Constant q/LDAP_SYNC_INFO/; say LDAP_SYNC_INFO'
 1.3.6.1.4.1.4203.1.9.1.4

Is it possible that you have another Net::LDAP installation on the system?
--

-- 
Niko Tyni

_______________________________________________
smokeping-users mailing list
smokeping-users <at> lists.oetiker.ch
https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users

Niko Tyni | 15 Apr 15:42 2009
Picon
Picon

Re: Problem with LDAP probe

On Tue, Apr 14, 2009 at 08:14:53PM +0200, Sipponen, Sami wrote:

> perl -w -E 'use Net::LDAP::Constant q/LDAP_SYNC_INFO/; say LDAP_SYNC_INFO'
> 
> I got answer:
> 
> 1.3.6.1.4.1.4203.1.9.1.4

That would indicate that Net::LDAP isn't totally broken.

> Sorry about my N00Bness, but I don't know a good way to check
> my libnet-ldap-perl version... However I did "apt-get install
> libnet-ldap-perl" and got answer "libnet-ldap-perl is already the newest
> version.", I also did "apt-cache show libnet-ldap-perl" and it says
> "Version: 1:0.39-1".

'dpkg -s libnet-ldap-perl' is the command to check what you have installed.

Are you aware that Debian Squeeze is not a released version?
5.0 (Lenny) was released in February. 'Squeeze' is the current testing version.

> What comes to checking about multiple installations of Net::LDAP
> I don't know how to do that, any hints? I have installed my Debian
> box very carefully and it should only have the packages I need. I have
> pretty good documentation of commands how I have done that. Only other
> LDAP thingy which comes to my mind is PHP5-LDAP which is installed.

That's probably not the problem then.

Googling shows one other report of this issue:

 http://www.nntp.perl.org/group/perl.ldap/2009/02/msg3071.html

which is on FreeBSD, Perl 5.8.9, Net::LDAP 0.39.

Assuming you've restarted smokeping after upgrading libnet-ldap-perl,
I'm pretty short on further ideas. Sorry. Maybe downgrading to
libnet-ldap-perl 1:0.36-1 from Lenny would help.

> > Apr 14 10:30:48 sensping1 smokeping[3719]: "LDAP_SYNC_INFO" is not exported by the
Net::LDAP::Constant module at /usr/share/perl5/Net/LDAP/Intermediate.pm line 10

--

-- 
Niko Tyni

_______________________________________________
smokeping-users mailing list
smokeping-users <at> lists.oetiker.ch
https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users


Gmane