Guðmundur Örn Ingvarsson | 4 Mar 10:38 2004
Picon

Smokeping process terminating after awhile

I have a RH9 machine that is running smokeping with a init.d script.
This works fine except for one small problem, smokeping terminates after a 
few hours
leaving my graphs full og huge gaps. It often leaves behind the 
speedy_backend scritps
running but not the actual perl process nor does it work.
Logs tell me nothing so I'm at a loss.
I'm running two machines both on RH9 with the same setup and the other one 
works fine.

Anyone encountered this problem?

Með kveðju/Best Regards
Guðmundur Örn Ingvarsson
Netstjóri/Network Administrator
Skyggnir hf. 

Holtasmára 1, 201 Kópavogur 
Sími/Tel: +354 575 6100  Fax: + 354 575 6110 
E-mail:gudmo <at> skyggnir.is, Vefur/web www.skyggnir.is 
--
Unsubscribe mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/smokeping-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

Simon Westlake | 4 Mar 20:08 2004
Picon

alert for echoping http

Hello,

I'm trying to setup an alert for echoping http - is there a specific syntax to use? I'm not sure what is
returned (e.g. would >10% be a legitimate thing to measure for an echoping http probe?)

I'm running it on a laptop that is too slow to run apache etc - the purpose for is it to page someones cell phone
when a particular website stops responding
however, the alert doesn't seem to be working, and I'm not sure if it's because I've written it incorrectly.

Before I start messing around trying to figure it out, I was just wondering if someone has done this in the past.

Thanks for any help you can provide!

--
Unsubscribe mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/smokeping-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

Roger | 4 Mar 21:49 2004
Picon

EchoPingHttp probs

I've tried to setup smokeping to monitor some web sites, I started out 
w/ google but have not gotten anywhere.  The graphs are generated but 
they have no data in them

Below are the relvant sections, I'm running smokeping 1.26

*** Probes ***

+ EchoPingHttp

binary = /usr/local/bin/echoping

*** Targets ***

+ World

menu = World
title = Worldwide Connectivity

++ PROBE_CONF
url = /
ignore_cache = yes
revalidate_data = no
port = 80
timeoute = 50

++ Google

probe = EchoPingHttp
menu = Google
(Continue reading)

Tobias Oetiker | 9 Mar 21:57 2004
Picon
Picon

ANNOUNCE SmokePing 1.27

Fellows,

I have released SmokePing 1.27 ...

2004/03/09 -- 1.27
* allow . in labels -- Tobi
* fix mkdir with missing permissions -- Xander Jansen <Xander.Jansen <at> surfnet.nl>
* make echoping probes complain when they do not get a 0 return value -- Tobi
* make manu and title = host if not set -- tobi
* forbid . in section names .. bad things will happen when used. -- tobi
* patches for the Radius and LDAP probes --  Niko Tyni <ntyni <at> cc.helsinki.fi>
* prevent requests to non existing pages -- tobi

as usual to be found on

http://people.ee.ethz.ch/~oetiker/webtools/smokeping/pub

cheers
tobi

--

-- 
 ______    __   _
/_  __/_  / /  (_) Oetiker  <at>  ISG.EE, ETZ J97, ETH, CH-8092 Zurich
 / // _ \/ _ \/ /  System Manager, Time Lord, Coder, Designer, Coach
/_/ \.__/_.__/_/   http://people.ee.ethz.ch/~oetiker   +41(0)1-632-5286

--
Unsubscribe mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/smokeping-users
(Continue reading)

Dmitry Melekhov | 10 Mar 08:11 2004

problem with LDAP probe

Hello!

If I add LDAP probe to config as
+ LDAP

then I can't  see results in .cgi:

Can't locate Encode/ConfigLocal.pm in  <at> INC ( <at> INC contains: .. 
/usr/local/smokeping/lib /var/adm/perl-modules 
/usr/lib/perl5/5.8.0/i586-linux-thread-multi /usr/lib/perl5/5.8.0 
/usr/lib/perl5/site_perl/5.8.0/i586-linux-thread-multi 
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at 
/usr/lib/perl5/5.8.0/i586-linux-thread-multi/Encode.pm line 52.

Looks very  strange...

Any ideas?

--
Unsubscribe mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/smokeping-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

Scott Schappell | 10 Mar 19:51 2004

1.26 execution errors

I installed the 1.26 version from the FreeBSD ports collection.  My previous version was working just fine,
however, after installing the port, I receive the following error when trying to run it:

[S: root <at> arthur: /home/archon] # /usr/local/etc/rc.d/smokeping.sh start
Not enough arguments for mkdir at /usr/local/smokeping/lib/Smokeping.pm line 1971, near "$dir unless"
BEGIN failed--compilation aborted at /usr/local/bin/smokeping line 6.
[S: root <at> arthur: /home/archon] #

Unfortunately, I'm way too Perl clueless to even begin to try to fix this.  Any suggestions on what this
error may be?
--

-- 
PGP Key: http://archon.silvertree.org/pgp.txt
Fingerprint: E799 F032 BD9A 66B8 2930 AE2B E742 0B78 BADB 8E11 
"Compassion and retribution are two sides of the same coin. Necessity
dictates on what side the coin will fall."

--
Unsubscribe mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/smokeping-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

Tobias Oetiker | 11 Mar 08:13 2004
Picon
Picon

Re: 1.26 execution errors

Yesterday Scott Schappell wrote:

> I installed the 1.26 version from the FreeBSD ports collection.
> My previous version was working just fine, however, after
> installing the port, I receive the following error when trying to
> run it:
>
> [S: root <at> arthur: /home/archon] # /usr/local/etc/rc.d/smokeping.sh start
> Not enough arguments for mkdir at /usr/local/smokeping/lib/Smokeping.pm line 1971, near "$dir unless"
> BEGIN failed--compilation aborted at /usr/local/bin/smokeping line 6.
> [S: root <at> arthur: /home/archon] #
>
> Unfortunately, I'm way too Perl clueless to even begin to try to
> fix this.  Any suggestions on what this error may be?

yes, perl 5.006 in freebsd wants a second argument for mkdir
along the lines ...

mkdir $file, 0755

or you could just use the latest release ...

tobi

--

-- 
 ______    __   _
/_  __/_  / /  (_) Oetiker  <at>  ISG.EE, ETZ J97, ETH, CH-8092 Zurich
 / // _ \/ _ \/ /  System Manager, Time Lord, Coder, Designer, Coach
/_/ \.__/_.__/_/   http://people.ee.ethz.ch/~oetiker   +41(0)1-632-5286

(Continue reading)

Curtis Doty | 13 Mar 07:10 2004
Picon

Re: Smokeping process terminating after awhile

>-----Original Message-----
>Sent: Thursday, March 04, 2004 1:39 AM
>
>I have a RH9 machine that is running smokeping with a init.d script.
>This works fine except for one small problem, smokeping 
>terminates after a 
>few hours

Take a look at my rudamentary init in this rpm package and let us know
if your have any improvements.

http://www.GreenKey.net/~curtis/rpm/noarch/smokeping-1.27-gk1.noarch.rpm

The rpm was built on Valhalla (rh7.3) but I've had it running on Shrike
(rh9) for many months without issue. It also ensures you have the proper
dependencies.

Requires:	perl >= 5.6.1
Requires:	rrdtool >= 1.0.33-1gk2
Requires:	fping >= 2.4b2
Requires:	echoping >= 4.2.0
Requires:	webserver
Requires:	net-tools
Requires:	perl(Net::SMTP)
Requires:	perl-PersistentPerl

Enjoy!
../C

--
(Continue reading)

Niko Tyni | 14 Mar 11:32 2004
Picon
Picon

Re: EchoPingHttp probs

On Thu, Mar 04, 2004 at 02:49:04PM -0600, Roger wrote:
> I've tried to setup smokeping to monitor some web sites, I started out 
> w/ google but have not gotten anywhere.  The graphs are generated but 
> they have no data in them

Hi,

	are you aware that you need to run the smokeping as a daemon as well as
the CGI? The daemon is responsible for the measurements.

If you are running the daemon but aren't getting any data, look at the 
syslog output and/or try running the daemon in debug mode ('-debug' option.)

HTH,
--

-- 
Niko Tyni		ntyni <at> smokeping-users <at> mappi.helsinki.fi

--
Unsubscribe mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request <at> list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/smokeping-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

LEGROS Gaetan | 15 Mar 09:40 2004

RE : Re: EchoPingHttp probs

Hi,
You cannot measure google.com with echoping probe because the www.google.com
isn't a "real" website; it does only redirect you to an other google web
server.

#/opt/echoping/bin/echoping -A -a -h / www.google.com
HTTP error "HTTP/1.1 302 Found
"
#/opt/echoping/bin/echoping -A -a -h / www.google.fr
Elapsed time: 0.157536 seconds
#

Before monitor a web site, run manually echoping because sometimes you have
this kind of error or this "HTTP error "HTTP/1.1 302 Object Moved" when the
website is directly redirect to an other.

Cheers,
Gaetan

-----Message d'origine-----
De : Niko Tyni [mailto:ntyni+smokeping-users <at> mappi.helsinki.fi] 
Envoyé : dimanche 14 mars 2004 11:33
À : smokeping-users <at> list.ee.ethz.ch
Objet : [smokeping-users] Re: EchoPingHttp probs

On Thu, Mar 04, 2004 at 02:49:04PM -0600, Roger wrote:
> I've tried to setup smokeping to monitor some web sites, I started out 
> w/ google but have not gotten anywhere.  The graphs are generated but 
> they have no data in them

(Continue reading)


Gmane