Corrado Ravinetto | 9 Jun 10:37 2010

centinaia di errori nei log.....

ciao a tutti,
e' da parecchio tempo che noto centinaia di errori di questo tipo nei log:
Jun  9 10:27:04 localhost smbd[3053]: [2010/06/09 10:27:04,  0] 
lib/util_sock.c:1491(get_peer_addr_internal)
Jun  9 10:27:04 localhost smbd[3053]:   getpeername failed. Error was 
Transport endpoint is not connected
Jun  9 10:27:04 localhost smbd[3053]: [2010/06/09 10:27:04,  0] 
lib/util_sock.c:738(write_data)
Jun  9 10:27:04 localhost smbd[3053]: [2010/06/09 10:27:04,  0] 
lib/util_sock.c:1491(get_peer_addr_internal)
Jun  9 10:27:04 localhost smbd[3053]:   getpeername failed. Error was 
Transport endpoint is not connected
Jun  9 10:27:04 localhost smbd[3053]:   write_data: write failure in 
writing to client 0.0.0.0. Error Connessione abbattuta dal corrispondente
Jun  9 10:27:04 localhost smbd[3053]: [2010/06/09 10:27:04,  0] 
smbd/process.c:62(srv_send_smb)
Jun  9 10:27:04 localhost smbd[3053]:   Error writing 4 bytes to client. 
-1. (Transport endpoint is not connected)

apparentemente non creano problemi, come unico effetto 'gonfiano' 
notevolmente i log .....
girando un po su google non ho trovato nessuna spiegazione se non il 
fatto che windows tenta una connessione su entrambe le porte di samba 
(139,445) e poi chiude una delle 2 connessioni: ho lasciato attiva solo 
la porta 139 ma il problema non  si e' risolto......

mi potete spiegare il motivo...

ciao e grazie

(Continue reading)

Dario Lesca | 9 Jun 15:18 2010
Picon

Re: centinaia di errori nei log.....

Il giorno mer, 09/06/2010 alle 10.37 +0200, Corrado Ravinetto ha
scritto:
> ho lasciato attiva solo la porta 139 ma il problema non  si e'
> risolto...... 

Io ho fatto lo stesso, e il problema dei msg si è risolto.

Ho utilizzato la seguente direttiva: "smb ports = 139"

Comunque anche io sono curioso di sapere se ci sono contro indicazioni a
fare una cosa del genere ... a qualcosa dovrà pur servire la porta 445
inventata a suo tempo da MS no?.

Ciao.

--

-- 
Dario Lesca <d.lesca@...>
Corrado Ravinetto | 9 Jun 16:24 2010

Re: centinaia di errori nei log.....

anche io ho usato la stessa direttiva, ma senza risultati: hai anche 
chiuso la porta su linux o solo usato la direttiva su smb.conf ??

ciao  e grazie

Il 09/06/2010 15:18, Dario Lesca ha scritto:
> Il giorno mer, 09/06/2010 alle 10.37 +0200, Corrado Ravinetto ha
> scritto:
>    
>> ho lasciato attiva solo la porta 139 ma il problema non  si e'
>> risolto......
>>      
> Io ho fatto lo stesso, e il problema dei msg si è risolto.
>
> Ho utilizzato la seguente direttiva: "smb ports = 139"
>
> Comunque anche io sono curioso di sapere se ci sono contro indicazioni a
> fare una cosa del genere ... a qualcosa dovrà pur servire la porta 445
> inventata a suo tempo da MS no?.
>
> Ciao.
>
>    

--

-- 

*Corrado Ravinetto *

*Area Servizi Informativi*

(Continue reading)

Andrea Pagano | 9 Jun 17:06 2010
Picon

Re: centinaia di errori nei log.....



Il giorno 09 giugno 2010 15.18, Dario Lesca <d.lesca <at> solinos.it> ha scritto:

Comunque anche io sono curioso di sapere se ci sono contro indicazioni a
fare una cosa del genere ... a qualcosa dovrà pur servire la porta 445
inventata a suo tempo da MS no?.
_______________________________________________


La porta 445 dovrebbe servire solo per il join a dominio.

--
Andrea Pagano
_______________________________________________
Samba-it mailing list
Samba-it@...
https://lists.xsec.it/mailman/listinfo/samba-it
Dario Lesca | 10 Jun 14:38 2010
Picon

Re: centinaia di errori nei log.....

Il giorno mer, 09/06/2010 alle 16.24 +0200, Corrado Ravinetto ha
scritto:
> anche io ho usato la stessa direttiva, ma senza risultati: hai anche 
> chiuso la porta su linux o solo usato la direttiva su smb.conf ?? 

E' presente anche un firewall (iptables) ma entrambe le porte sono
aperte sulla LAN e chiuse sulla WAN.

Ho anche usato un altra direttiva che forse può influenzare
(interfaces). Questo è un estratto dal mio testparm:

> [global]
> 	interfaces = 127.0.0.0/8, 192.168.1.0/24
> 	security = SHARE
> 	smb ports = 139
> 	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
> 	os level = 83
> 	preferred master = No
> 	local master = No
> 	domain master = No
> 	dns proxy = No
> 	wins server = 192.168.1.1

Ciao.

--

-- 
Dario Lesca <d.lesca@...>
simo | 10 Jun 21:08 2010
Picon

Re: centinaia di errori nei log.....

On Wed, 2010-06-09 at 10:37 +0200, Corrado Ravinetto wrote:
> ciao a tutti,
> e' da parecchio tempo che noto centinaia di errori di questo tipo nei log:
> Jun  9 10:27:04 localhost smbd[3053]: [2010/06/09 10:27:04,  0] 
> lib/util_sock.c:1491(get_peer_addr_internal)
> Jun  9 10:27:04 localhost smbd[3053]:   getpeername failed. Error was 
> Transport endpoint is not connected
> Jun  9 10:27:04 localhost smbd[3053]: [2010/06/09 10:27:04,  0] 
> lib/util_sock.c:738(write_data)
> Jun  9 10:27:04 localhost smbd[3053]: [2010/06/09 10:27:04,  0] 
> lib/util_sock.c:1491(get_peer_addr_internal)
> Jun  9 10:27:04 localhost smbd[3053]:   getpeername failed. Error was 
> Transport endpoint is not connected
> Jun  9 10:27:04 localhost smbd[3053]:   write_data: write failure in 
> writing to client 0.0.0.0. Error Connessione abbattuta dal corrispondente
> Jun  9 10:27:04 localhost smbd[3053]: [2010/06/09 10:27:04,  0] 
> smbd/process.c:62(srv_send_smb)
> Jun  9 10:27:04 localhost smbd[3053]:   Error writing 4 bytes to client. 
> -1. (Transport endpoint is not connected)
> 
> apparentemente non creano problemi, come unico effetto 'gonfiano' 
> notevolmente i log .....
> girando un po su google non ho trovato nessuna spiegazione se non il 
> fatto che windows tenta una connessione su entrambe le porte di samba 
> (139,445) e poi chiude una delle 2 connessioni: ho lasciato attiva solo 
> la porta 139 ma il problema non  si e' risolto......
> 
> mi potete spiegare il motivo...

Quell'errore indica che il client si é disconnesso malamente. Potrebbe
essere dovuto a problemi di rete.

Se non ricordo male abbiamo alzato il livello di logging ad un certo
punto, che versione di samba stai usando ?

Simo.
simo | 10 Jun 21:11 2010
Picon

Re: centinaia di errori nei log.....

On Wed, 2010-06-09 at 15:18 +0200, Dario Lesca wrote:
> Il giorno mer, 09/06/2010 alle 10.37 +0200, Corrado Ravinetto ha
> scritto:
> > ho lasciato attiva solo la porta 139 ma il problema non  si e'
> > risolto...... 
> 
> Io ho fatto lo stesso, e il problema dei msg si è risolto.
> 
> Ho utilizzato la seguente direttiva: "smb ports = 139"
> 
> Comunque anche io sono curioso di sapere se ci sono contro indicazioni a
> fare una cosa del genere ... a qualcosa dovrà pur servire la porta 445
> inventata a suo tempo da MS no?.

La porta 139 è utilizzata solo da client piú vecchi o da client nuovi se
la porta 445 non è diposnibile.

La connettivitá via IPv6 e il nuovo protocollo SMB2 sono disponibili
solo sulla 445 (per ora il supporto a SMB2 é considerato sperimentale e
non abilitato per default in 3.5.x).

In generale se hai client moderni (> win 9x) e vuoi chiudere una delle
due porte, probabilmente vuoi chiudere la 139 e lasciare la 445.

Simo.
Corrado Ravinetto | 11 Jun 08:25 2010

Re: centinaia di errori nei log.....


> Quell'errore indica che il client si é disconnesso malamente. Potrebbe
> essere dovuto a problemi di rete.
>
>    
ma sono veramente molti i messaggi che vedo nei log, mentre non mi 
sembra di avere problemi rete (almeno evidenti)...
> Se non ricordo male abbiamo alzato il livello di logging ad un certo
> punto, che versione di samba stai usando ?
>
>    
3.4.8
> Simo.
>
>    
ciao e grazie
Paolo Sala | 30 Jun 17:33 2010
Picon

brace expansion su partizioni cifs

Ciao a tutti. Ho un piccolo problema totalmente incomprensibile a mio
avviso...

Con CIFS monto una share windows; Non so se è sempre stato così ma non
è case sensitive infatti se faccio
> archivio <at> serverone:~$ ls -l
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.* -rwxrwSrwx 1
> archivio nogroup    6462  7 mag 16:12
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.log -rwxrwSrwx
> 1 archivio nogroup  251002 11 mag 09:14
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.quan -rwxrwSrwx
> 1 archivio nogroup 2405316  7 mag 16:12
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.RAW -rwxrwSrwx
> 1 archivio nogroup    2348 11 mag 09:14
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.XLS
> archivio <at> serverone:~$ ls -l
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.xls -rwxrwSrwx
> 1 archivio nogroup 2348 11 mag 09:14
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.xls
Questo può anche essere comodo, ma a me giunge inaspettato.

Il problema è che non trovo coerenza; infatti se uso la brace
expansion della shell trovo qualcosa AFAIK contraddittorio:
> archivio <at> serverone:~$ ls
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.{x,X}{l,L}{s,S}
>  /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.xls
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.Xls
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.xlS
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.XlS
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.xLs
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.XLs
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.xLS
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.XLS
> archivio <at> serverone:~$ ls
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03?{x,X}{l,L}{s,S}
>  ls: impossibile accedere a
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03?xls: No such
> file or directory ls: impossibile accedere a
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03?xlS: No such
> file or directory ls: impossibile accedere a
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03?xLs: No such
> file or directory ls: impossibile accedere a
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03?xLS: No such
> file or directory ls: impossibile accedere a
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03?Xls: No such
> file or directory ls: impossibile accedere a
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03?XlS: No such
> file or directory ls: impossibile accedere a
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03?XLs: No such
> file or directory
> /home/archivio/mnt/192.168.70.17/data/Studi/4369_03.XLS
Credete sia il caso di aprire un bug report? Sono io che non ho capito
niente sulla shell expansion?

Grazie

Piviul
Corrado Ravinetto | 1 Jul 16:55 2010

migrare active directory su samba con tdbsam

  sapete se c'e' un tutorial valido o qualche tool che aiuta a fare la 
cosa in oggetto ??? devo passare un win2k3 con ad su samba e avevo 
bisogno di qualche consiglio per non cambiare sid password e quantaltro 
......

ciao e grazie
--

-- 

Gmane