Pedro Henrique | 31 Jul 16:03 2014
Picon

FlowVisor and OFPBRC_BUFFER_UNKNOWN

Hi.
I'm using FlowVisor 1.4.0 to slice my network, basically I'm giving one slice to the Floodlight Controller and another two slices to the Pox Controller. Maybe I'm doing something wrong during this slices configuration, but I want to do something like this:
1 - All the UDP traffic will be handled by Pox
2 - All the TCP traffic will be handled by Pox
3 - Any other traffic will be handled by Floodlight

To do this, I'm setting the priority of Pox's slices to 2 and Floodlight's slices to 1.
As you can see below:

{"force-enqueue": -1, "name": "floodlight_1", "slice-action": [{"slice-name": "floodlight_slice", "permission": 7}], "queues": [], "priority": 1, "dpid": "all_dpids", "id": 41, "match": {"wildcards": 4194303}}
{"force-enqueue": -1, "name": "pox_1", "slice-action": [{"slice-name": "pox_slice", "permission": 7}], "queues": [], "priority": 2, "dpid": "all_dpids", "id": 40, "match": {"wildcards": 4194271, "nw_proto": 17}}
{"force-enqueue": -1, "name": "pox_2", "slice-action": [{"slice-name": "pox_slice", "permission": 7}], "queues": [], "priority": 2, "dpid": "all_dpids", "id": 42, "match": {"wildcards": 4194271, "nw_proto": 6}}  

Ok, after this, I'm running Floodlight, Pox and I can ping any hosts without problem, I mean, Floodlight is working perfectly. However, when I try to send an UDP or TCP traffic, POX show me this message for all switches and the traffic is not sent.

ERROR:openflow.of_01:[00-00-00-00-00-44 3] OpenFlow Error:
[00-00-00-00-00-44 3] Error: header: 
[00-00-00-00-00-44 3] Error:   version: 1
[00-00-00-00-00-44 3] Error:   type:    1 (OFPT_ERROR)
[00-00-00-00-00-44 3] Error:   length:  36
[00-00-00-00-00-44 3] Error:   xid:     0
[00-00-00-00-00-44 3] Error: type: OFPET_BAD_REQUEST (1)
[00-00-00-00-00-44 3] Error: code: OFPBRC_BUFFER_UNKNOWN (8)
[00-00-00-00-00-44 3] Error: datalen: 24
[00-00-00-00-00-44 3] Error: 0000: 01 0d 00 18 00 00 38 e2  00 00 0b 69 00 01 00 08   ......8....i....
[00-00-00-00-00-44 3] Error: 0010: 00 00 00 08 ff fb 00 00                            ........
 
Some more details, if I turn off flowvisor, Pox works perfectly and no problem happens. Also my network topology doesn't have loops and I'm running this module without modification:  forwarding.l2_learning.

Thank you for the attention.  
<div><div dir="ltr">
<span>Hi.</span><div>I'm using FlowVisor 1.4.0 to slice my network, basically I'm giving one slice to the Floodlight Controller and another two slices to the Pox Controller. Maybe I'm doing something wrong during this slices configuration, but I want to do something like this:</div>
<div>1 - All the UDP traffic will be handled by Pox</div>
<div>2 - All the TCP traffic will be handled by Pox</div>
<div>
3 - Any other traffic will be handled by Floodlight</div>
<div><br></div>
<div>To do this, I'm setting the priority of Pox's slices to 2 and Floodlight's slices to 1.</div>
<div>As you can see below:</div>
<div><br></div>
<div>{"force-enqueue": -1, "name": "floodlight_1", "slice-action": [{"slice-name": "floodlight_slice", "permission": 7}], "queues": [], "priority": 1, "dpid": "all_dpids", "id": 41, "match": {"wildcards": 4194303}}</div>
<div>{"force-enqueue": -1, "name": "pox_1", "slice-action": [{"slice-name": "pox_slice", "permission": 7}], "queues": [], "priority": 2, "dpid": "all_dpids", "id": 40, "match": {"wildcards": 4194271, "nw_proto": 17}}</div>
<div>{"force-enqueue": -1, "name": "pox_2", "slice-action": [{"slice-name": "pox_slice", "permission": 7}], "queues": [], "priority": 2, "dpid": "all_dpids", "id": 42, "match": {"wildcards": 4194271, "nw_proto": 6}} &nbsp;</div>
<div><br></div>
<div>Ok, after this, I'm running Floodlight, Pox and I can ping any hosts without problem, I mean, Floodlight is working perfectly. However, when I try to send an UDP or TCP traffic, POX show me this message for all switches and the traffic is not sent.</div>
<div><br></div>
<div>ERROR:openflow.of_01:[00-00-00-00-00-44 3] OpenFlow Error:</div>
<div>
[00-00-00-00-00-44 3] Error: header:&nbsp;</div>
<div>[00-00-00-00-00-44 3] Error: &nbsp; version: 1</div>
<div>[00-00-00-00-00-44 3] Error: &nbsp; type: &nbsp; &nbsp;1 (OFPT_ERROR)</div>
<div>[00-00-00-00-00-44 3] Error: &nbsp; length: &nbsp;36</div>
<div>[00-00-00-00-00-44 3] Error: &nbsp; xid: &nbsp; &nbsp; 0</div>
<div>
[00-00-00-00-00-44 3] Error: type: OFPET_BAD_REQUEST (1)</div>
<div>[00-00-00-00-00-44 3] Error: code: OFPBRC_BUFFER_UNKNOWN (8)</div>
<div>
[00-00-00-00-00-44 3] Error: datalen: 24</div>
<div>[00-00-00-00-00-44 3] Error: 0000: 01 0d 00 18 00 00 38 e2 &nbsp;00 00 0b 69 00 01 00 08 &nbsp; ......8....i....</div>
<div>
[00-00-00-00-00-44 3] Error: 0010: 00 00 00 08 ff fb 00 00 &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;........</div>
<div>&nbsp;</div>
<div>
Some more details, if I turn off flowvisor, Pox works perfectly and no problem happens. Also my network topology doesn't have loops and I'm running this module without modification: &nbsp;forwarding.l2_learning.</div>
<div>
<br>
</div>
<div>Thank you for the attention. &nbsp;</div>
</div></div>
王栋耀 | 27 Jul 11:23 2014
Picon

question on VLAN push

hi all, 
   I am a new comer for OpenFlow, and now studying VLAN related operation based on OpenFlow spec 1.4.0.  and I got a little confusion about the VLAN PUSH action. according to the spec, it will use the following struct
struct ofp_action_push { uint16_t type; /* OFPAT_PUSH_VLAN/MPLS/PBB. */ uint16_t len; /* Length is 8. */ uint16_t ethertype; /* Ethertype */ uint8_t pad[2]; };and here only the ethertype is indicated. so how to control the PCP and VID value when pushing a new VLAN tag?
can anybody explain it for me? in addition, more words on QinQ-based matching are appreciated. thanks in advance.
Best Regards wang
<div><div dir="ltr">hi all,&nbsp;<div>&nbsp; &nbsp;I am a new comer for OpenFlow, and now studying VLAN related operation based on OpenFlow spec 1.4.0. &nbsp;and I got a little confusion about the VLAN PUSH action. according to the spec, it will use the following struct</div>
<div>
<span>struct</span><span> </span><span>ofp_action_push</span><span> </span><span>{</span>

<span>    </span>uint16_t<span> </span><span>type</span><span>;</span><span>                  </span><span>/*</span><span> </span><span>OFPAT_PUSH_VLAN/MPLS/PBB.</span><span> </span><span>*/</span>

<span>    </span>uint16_t<span> </span><span>len</span><span>;</span><span>                   </span><span>/*</span><span> </span><span>Length</span><span> </span><span>is</span><span> </span><span>8.</span><span> </span><span>*/</span>

<span>    </span>uint16_t<span> </span><span>ethertype</span><span>;</span><span>             </span><span>/*</span><span> </span><span>Ethertype</span><span> </span><span>*/</span>

<span>    </span>uint8_t<span> </span><span>pad</span><span>[</span><span>2</span><span>];</span>

<span>};</span><span>and here only the ethertype is indicated. so how to control the PCP and VID value when pushing a new VLAN tag?</span>
<span><br></span>can anybody explain it for me? in addition, more words on QinQ-based matching are appreciated. thanks in advance.
<br>Best Regards
wang</div>
</div></div>
Pedro Bastida Abellán | 23 Jul 17:20 2014
Picon

1G-NetFPGA packet loss test

Hello everybody,

I´ve installed 1G-NetFPGA cards working as OpenFlow switches. They are 
connected one to the other. To each of them I have connected two hosts 
as in the figure.

HOST1--------OFS1------------OFS2----------HOST3
                         /                        \
                       /                             \
                HOST2                        HOST4

The controller is Beacon, working with the default bundles. We are 
trying to  test the platform obtaining the packet loss rate depending on 
the the load of the link (1 Gbps) between OF switches. The tool we are 
using to meassure packet loss is Iperf. We have realized that UDP 
datagram size used with Iperf has a very high impact on the results. 
Here you are the results reported by Iperf when we generate a 10Mbps UDP 
flow between HOST1 and HOST2 with a background traffic of 1Gbps (500Gbps 
from HOST1 to HOST2 and 500Gbps from HOST3 to HOST4) and datagram size 
of 1470 bytes, depending on the datagram size of packets from the 10Mbps 
flow:

Datagram size (bytes)        Packet loss rate (%)
100                                            0.00043
200                                            0.11
250                                            0.37
500                                            1.8
750                                             4
1000                                           5
1250                                          9.3
1500                                         13

These results are not the expected by me since the differences are very  
big and losses  for small datagram sizes are very small.Could it have 
something to do with the design of the OpenFlow switch? Maybe the packet 
preprocessor or any other module gives this advantage to small datagram. 
I´ve been looking for documentation, modules designs and functions, etc  
for the openflow switch implementation for the NetFPGA but I´ve only 
found it for the 10G NetFPGA card and as far as I know there are many 
differences. Does anyone have any explanation  to these results?.
Thanks in advance.

Pedro Bastida.

Divya Chitimalla | 18 Jul 21:33 2014
Picon

OpenFlow version that supports bandwidth assignment to a flow

Hi all,

Which version of openflow controller supports dedicated bandwidth assignment to a flow? I have come across a material that states that the controller checks the bandwidth required by each flow via switches' flow table counters.

Thank you.
<div><div dir="ltr">Hi all,<div><br></div>
<div>Which version of openflow controller supports dedicated bandwidth assignment to a flow? I have come across a material that states that the controller checks the bandwidth required by each flow via switches' flow table counters.</div>
<div><br></div>
<div>Thank you.</div>
</div></div>
Ping Chun Huang | 15 Jul 11:26 2014
Picon

Support OpenvSwitch v2.1.2 for OpenWrt

Hi,

We recently complete porting OpenvSwitch 2.1.2 to OpenWrt

If someone doing research about OpenFlow or SDN,

you can refer to this OpenvWrt project.

https://github.com/pichuang/openvwrt

Thank you.

pichuang, Ping-Chun Huang 黃秉鈞


Wireless Internet Laboratory
D-Link NCTU Joint Research Center
Computer Center, Department of Computer Science
National Chiao Tung University
<div><div dir="ltr">Hi,<br><br>We recently complete porting OpenvSwitch 2.1.2 to OpenWrt<br><br>If someone doing research about OpenFlow or SDN,<br><br>you can refer to this OpenvWrt project.<br><br><a href="https://github.com/pichuang/openvwrt">https://github.com/pichuang/openvwrt</a><br><br>Thank you.<br><div>
<span><br clear="all"></span><div><div dir="ltr">
<div>pichuang, Ping-Chun Huang &#40643;&#31177;&#37406;<br>
</div>
<div><br></div>
<div><br></div>

<div>
<div>Wireless Internet Laboratory</div>
<div>
<span>D-Link NCTU Joint Research Center</span><br>
</div>
<div>
<span>Computer Center,&nbsp;</span><span>Department of Computer Science</span><br>
</div>
<div>National Chiao Tung University</div>
</div>
</div></div>
</div>
</div></div>
Rod N. Melton | 14 Jul 03:30 2014
Picon

problem with openflow dissector in wireshark 1.12.0 rc2

I am working with mininet 2.1.0 and OVS 2.0.1 on Ubuntu 14.04.

I downloaded the latest wireshark 1.12.0rc2 and built from source.  I can see the openflow

filters in wireshark and can capture OF packets going to and from the builtin controller on 127.0.0.1.

 

The problem is that the OF dissector is not formatting the OFPT_FLOW_MOD messages correctly.

Look at packet 146 in the attached capture file.  This is a flow mod message sent by the controller

but the output port is wrong.  I think it is wrong because the dissector is not allowing the correct

amount of bytes for the ofp_match part of the flow_mod message.  If you look at the ofp_match

struct in http://archive.openflow.org/documents/openflow-spec-v1.0.0.pdf and compare it with

the OpenFlow 1.0 dissector output for ofp_match, you will see that some match fields are missing.  This makes

the rest of the dissection be wrong (and hence output port is wrong).

 

I believe that the message is correct and is understood correct when received by OpenVSwitch.

 

Can you verify that the dissector built into wireshark 1.12.0rc2 is working correctly for  OpenFlow 1.0 for OFPT_FLOW_MOD message.


Thanks,

Rod M.

PS. Here is wireshark screen dump:

 
Attachment (of_capture_filter_problem.pcapng): application/octet-stream, 24 KiB
<div>
<p>I am working with mininet 2.1.0 and OVS 2.0.1 on Ubuntu 14.04.<br><br>I downloaded the latest wireshark 1.12.0rc2 and built from source.&nbsp; I can see the openflow<br><br>filters in wireshark and can capture OF packets going to and from the builtin controller on 127.0.0.1.</p>
<p>&nbsp;</p>
<p>The problem is that the OF dissector is not formatting the OFPT_FLOW_MOD messages correctly.</p>
<p>Look at packet 146 in the attached capture file.&nbsp; This is a flow mod message sent by the controller</p>
<p>but the output port is wrong.&nbsp; I think it is wrong because the dissector is not allowing the correct </p>
<p>amount of bytes for the ofp_match part of the flow_mod message.&nbsp; If you look at the ofp_match</p>
<p>struct in http://archive.openflow.org/documents/openflow-spec-v1.0.0.pdf and compare it with</p>
<p>the OpenFlow 1.0 dissector output for ofp_match, you will see that some match fields are missing.&nbsp; This makes</p>
<p>the rest of the dissection be wrong (and hence output port is wrong).</p>
<p>&nbsp;</p>
<p>I believe that the message is correct and is understood correct when received by OpenVSwitch.</p>
<p>&nbsp;</p>
<p>Can you verify that the dissector built into wireshark 1.12.0rc2 is working correctly for&nbsp; OpenFlow 1.0 for OFPT_FLOW_MOD message.</p>
<p><br>Thanks,</p>
<p>Rod M.</p>
<p>PS. Here is wireshark screen dump:</p>
<p></p>
<div>&nbsp;</div>
</div>
Inácio Alves | 14 Jul 02:07 2014
Picon

Openflow 1.0 + OpenWRT in a TL-WR741ndV4

Hi all,

I compile openwrt with openflow enabled for TL-WR741nd V4.

I tried to adapt the configurations of WR1043 from Pantou but the switch continue send trafic normally even consulting the controller.
I see messages arriving in the controller, but if I stop the controller I yet be able to send packages  through the switch (router).

Can anyone help-me?
There is my configurations

openflow
config 'ofswitch'
        option 'dp' 'dp0'
        option 'dpid' '000000000001'
        option 'ofports' 'eth0 eth1 wlan0'
        option 'ofctl' 'tcp:10.13.37.1:6633'
        option 'mode'  'outofband'

network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '10.13.37.2'

config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0t 1'
option vid '1'

config switch_vlan
option device 'eth0'
option vlan '2'
option vid '2'
option ports '0t 2'

config switch_vlan
option device 'eth0'
option vlan '3'
option vid '3'
option ports '0t 3'

config switch_vlan
option device 'eth0'
option vlan '4'
option vid '4'
option ports '0t 4'


wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '64:66:b3:e5:83:9c'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option txpower '30'
option country 'US'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'ifce-wrt'


prof. Inácio Alves
IFCE/Campus Maracanaú
Bacharel em Matemática (UFC)/ Técnico em Conectividade(IFCE)
Lattes: http://lattes.cnpq.br/1022303386341552

<div><div dir="ltr">Hi all,<div><br></div>
<div>
<div>
<div dir="ltr">I compile openwrt with openflow enabled for TL-WR741nd V4.</div>
<div dir="ltr"><br></div>
<div dir="ltr">I tried to adapt the configurations of WR1043 from Pantou but the switch continue send trafic normally even consulting the controller.</div>
<div dir="ltr">I see messages arriving in the controller, but if I stop the controller I yet be able to send packages &nbsp;through the switch (router).</div>
<div dir="ltr"><br></div>
<div>Can anyone help-me?</div>
<div>There is my configurations</div>
<div><br></div>
<div>openflow</div>
<div>
<div>config 'ofswitch'</div>
<div>&nbsp; &nbsp; &nbsp; &nbsp; option 'dp' 'dp0'</div>
<div>&nbsp; &nbsp; &nbsp; &nbsp; option 'dpid' '000000000001'</div>
<div>&nbsp; &nbsp; &nbsp; &nbsp; option 'ofports' 'eth0 eth1 wlan0'</div>
<div>&nbsp; &nbsp; &nbsp; &nbsp; option 'ofctl' 'tcp:<a href="http://10.13.37.1:6633">10.13.37.1:6633</a>'</div>
<div>&nbsp; &nbsp; &nbsp; &nbsp; option 'mode' &nbsp;'outofband'</div>
</div>
<div><br></div>
<div>network</div>
<div>
<div>config interface 'loopback'</div>
<div>
<span class="">	</span>option ifname 'lo'</div>
<div>
<span class="">	</span>option proto 'static'</div>
<div>
<span class="">	</span>option ipaddr '127.0.0.1'</div>
<div>
<span class="">	</span>option netmask '255.0.0.0'</div>
<div><br></div>
<div>config interface 'lan'</div>
<div>
<span class="">	</span>option ifname 'eth0'</div>
<div>
<span class="">	</span>option type 'bridge'</div>
<div>
<span class="">	</span>option proto 'static'</div>
<div>
<span class="">	</span>option netmask '255.255.255.0'</div>
<div>
<span class="">	</span>option ipaddr '10.13.37.2'</div>
<div><br></div>
<div>config interface 'wan'</div>
<div>
<span class="">	</span>option ifname 'eth1'</div>
<div>
<span class="">	</span>option proto 'dhcp'</div>
<div><br></div>
<div>config switch</div>
<div>
<span class="">	</span>option name 'eth0'</div>
<div>
<span class="">	</span>option reset '1'</div>
<div>
<span class="">	</span>option enable_vlan '1'</div>
<div><br></div>
<div>config switch_vlan</div>
<div>
<span class="">	</span>option device 'eth0'</div>
<div>
<span class="">	</span>option vlan '1'</div>
<div>
<span class="">	</span>option ports '0t 1'</div>
<div>
<span class="">	</span>option vid '1'</div>
<div><br></div>
<div>config switch_vlan</div>
<div>
<span class="">	</span>option device 'eth0'</div>
<div>
<span class="">	</span>option vlan '2'</div>
<div>
<span class="">	</span>option vid '2'</div>
<div>
<span class="">	</span>option ports '0t 2'</div>
<div><br></div>
<div>config switch_vlan</div>
<div>
<span class="">	</span>option device 'eth0'</div>
<div>
<span class="">	</span>option vlan '3'</div>
<div>
<span class="">	</span>option vid '3'</div>
<div>
<span class="">	</span>option ports '0t 3'</div>
<div><br></div>
<div>config switch_vlan</div>
<div>
<span class="">	</span>option device 'eth0'</div>
<div>
<span class="">	</span>option vlan '4'</div>
<div>
<span class="">	</span>option vid '4'</div>
<div>
<span class="">	</span>option ports '0t 4'</div>
</div>
<div dir="ltr"><br></div>
<div dir="ltr"><br></div>
<div>wireless</div>
<div>
<div>config wifi-device 'radio0'</div>
<div>
<span class="">	</span>option type 'mac80211'</div>
<div>
<span class="">	</span>option channel '11'</div>
<div>
<span class="">	</span>option hwmode '11ng'</div>
<div>
<span class="">	</span>option macaddr '64:66:b3:e5:83:9c'</div>
<div>
<span class="">	</span>option htmode 'HT20'</div>
<div>
<span class="">	</span>list ht_capab 'SHORT-GI-20'</div>
<div>
<span class="">	</span>list ht_capab 'SHORT-GI-40'</div>
<div>
<span class="">	</span>list ht_capab 'RX-STBC1'</div>
<div>
<span class="">	</span>list ht_capab 'DSSS_CCK-40'</div>
<div>
<span class="">	</span>option txpower '30'</div>
<div>
<span class="">	</span>option country 'US'</div>
<div><br></div>
<div>config wifi-iface</div>
<div>
<span class="">	</span>option device 'radio0'</div>
<div>
<span class="">	</span>option network 'lan'</div>
<div>
<span class="">	</span>option mode 'ap'</div>
<div>
<span class="">	</span>option encryption 'none'</div>
<div>
<span class="">	</span>option ssid 'ifce-wrt'</div>
</div>
<div><br></div>
<div dir="ltr">
<br>prof. In&aacute;cio Alves<div>IFCE/Campus Maracana&uacute;</div>
<div><div>Bacharel em Matem&aacute;tica (UFC)/ T&eacute;cnico em Conectividade(IFCE)<br>Lattes: <a title="Endere&ccedil;o para acessar este CV:" href="https://wwws.cnpq.br/cvlattesweb/PKG_MENU.menu?f_cod=23F9E85E2ED5F4708F29B1755BA4F455#" target="_blank">http://lattes.cnpq.br/1022303386341552</a><br>
</div></div>
<div><br></div>
<div><span></span></div>
</div>
</div>
</div>
</div></div>
Bob Lantz | 7 Jul 22:04 2014
Picon

Mininet Tutorial at SIGCOMM 2014

[Apologies if you receive multiple copies of this call]
--------------------------------------------------------------------------
                       Call for Participation

                          Mininet Tutorial

            Teaching Computer Networking with Mininet
   http://conferences.sigcomm.org/sigcomm/2014/tutorial-mininet.php

      August 18th, Chicago, USA (in conjunction with SIGCOMM)
--------------------------------------------------------------------------

*** Important Dates ***
Early Registration Deadline: July 11th, 11:59pm CDT
Late Registration: July 12th - August 18th
Tutorial Date: August 18th 8:30am - 12:00pm

*** Objective ***
Sharing our experiences using the Mininet network emulation platform to
teach computer networking in a variety of contexts ranging from small
on-campus courses (Stanford, Georgia Tech, MIT) to massive online courses.
We believe that the Mininet platform can make teaching and learning
computer networking more fun and effective by facilitating experiential
learning.

*** Program ***
- Introduce Mininet[1] to the broader network community, including its
capabilities and limitations and some example use cases.
- Familiarize attendees with Mininet through hands-on exercises.
- Share our experiences using Mininet since 2011 for on-campus and
massive online courses at Stanford, Georgia Tech and MIT.
- Disseminate assignments that we used at our universities and help to
develop and expand an online repository of Mininet courseware.

*** Speakers and Panelists ***
Bob Lantz - ON.Lab
Te-Yuan (TY) Huang - Stanford
Vimalkumar Jeyakumar - Stanford
Brian O’Connor - ON.Lab
Nick Feamster - Georgia Tech
Keith Winstein - MIT
Anirudh Sivaraman - MIT

[1] http://mininet.org
Picon

Re: Setting VLAN_ID by nox controller, but it's error

Is the problem  ofdatapath: lib/ofpbuf.c:168: ofpbuf_prealloc_headroom: Assertion `size <= ofpbuf_headroom(b)' failed. solved?
 
Best Regards
杨海祥
 
scbzyhx-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org
<div>
<div>Is the problem&nbsp; ofdatapath: lib/ofpbuf.c:168: ofpbuf_prealloc_headroom: Assertion `size 
&lt;= ofpbuf_headroom(b)' failed.
solved?</div>
<div>&nbsp;</div>
<div><span>
<div>
<div>Best Regards</div>
<div>&#26472;&#28023;&#31077;</div>
<div>&nbsp;</div>
<div>scbzyhx@...</div>
</div></span></div>
</div>
Vasu Devan | 3 Jul 23:27 2014
Picon

FlowVisor support for SSL for control channel communicate - between Switches and controllers through FlowVisor

Dear Members,

I configured Flowvisor and i was able perform some slicing exercises using FlowVisor+POX+Mininet.

But, I wanted to know the procedure to configure the ssl on the FlowVisor such that i can secure the control traffic between the switch to controller(which goes through the flowvisor).

Kindly help me in this regard. I am not finding the right forum to post the flowvisor specific queries and posting open...

Thanks & Regards,
Vasu.


<div><div dir="ltr">
<div>
<div>
<div>
<div>Dear Members,<br><br>
</div>I configured Flowvisor and i was able perform some slicing exercises using FlowVisor+POX+Mininet. <br><br>But, I wanted to know the procedure to configure the ssl on the FlowVisor such that i can secure the control traffic between the switch to controller(which goes through the flowvisor).<br><br>
</div>Kindly help me in this regard. I am not finding the right forum to post the flowvisor specific queries and posting open...<br><br>
</div>Thanks &amp; Regards,<br>
</div>Vasu.<br><div><div>
<br><br>
</div></div>
</div></div>
winterwentao | 3 Jul 10:36 2014
Picon

Flowvisor - Open Networking Lab - Confluence

Dear members,
I am beginner of flowvisor, and now I am following the instruction of webpage https://openflow.stanford.edu/display/ONL/FlowVisor . I have already started the vm but cannot use the command for unknown passwd for fvadmin. Could you please send me it.
Best Regards,
Tao Wen
 
<div>
<div>Dear members,</div>
<div>I am beginner of flowvisor, and now I am following 
the instruction of webpage <a href="https://openflow.stanford.edu/display/ONL/FlowVisor">https://openflow.stanford.edu/display/ONL/FlowVisor 
</a>. I have already started the vm but cannot use the command for unknown 
passwd for fvadmin. Could you please send me it.</div>
<div></div>
<div>Best Regards,</div>
<div>Tao Wen</div>
<div>&nbsp;</div>
<div><span>
<div>
<div></div>
</div></span></div>
</div>

Gmane