Michael Caraballo | 4 Aug 18:45 2010

XRDP server and Apple iPad RDP Client

I’m running the XRDP server on a Red Hat Linux EE server v5 64 bit and on another Linux box RHEL v4 32bit.  The XRDP server is correctly handling and accepting RDP connections from my Mac running the latest Microsoft Windows RDP client v2.0.1 and 3rd part RDP client software Cord v5.3.  When using MS Remote Desktop Version 6.0 I can also connect to both linux boxes.  

I have two problem connecting via other RDP clients:
  1. When using MS Remote Desktop Connection version 6.1 under Windows 7 I get error message “there was an RDP protocol error” after authenticating via the sesman login screen.
  2. When using  “Remote Desktop – RDP” under an Apple iPad I get error message “Information  Host has closed the session”.  There are no log or error messages written to the XRDP sesman.log file.

Any idea how this can be addressed?

Thanks for any help
--
Michael Caraballo | Director of I.T. Operations | mcgarrybowen | 601 West 26th Street, 11th Floor | New York, New York 10001 | T: 212.488.4488 | mcgarrybowen.com
P Please consider the environment before printing this e-mail.
---------------------------------------------------------------------------------------------- The contents of this message may be privileged and confidential. Therefore, if this message has been received in error, please delete it without reading it. All contents of the message, including any attachments, are the copyright property of the sender. This message cannot in any way bind Dentsu McGarry Bowen, L.L.C. to any contract or other obligation.
------------------------------------------------------------------------------
The Palm PDK Hot Apps Program offers developers who use the
Plug-In Development Kit to bring their C/C++ apps to Palm for a share
of $1 Million in cash or HP Products. Visit us here for more details:
http://p.sf.net/sfu/dev2dev-palm
_______________________________________________
xrdp-devel mailing list
xrdp-devel@...
https://lists.sourceforge.net/lists/listinfo/xrdp-devel
Vincent Bernat | 6 Aug 19:29 2010

German keyboard working with rdesktop but not with WinXP TS Client.

Hi!

A user of xrdp reported this bug:
 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=584666

In summary, the  ' <at> ' sign does not work on a  german keyboard with WinXP
TS  client but  works  fine with  "rdesktop  -k de".  Keymaps have  been
regenerated.

The bug report contains some interesting information like xev output but
I don't  know how  to solve  this problem. Any  idea? Debian  package is
based on a CVS snapshot of 2010 03 03.

Thanks.
--

-- 
panic("huh?\n");
	2.2.16 /usr/src/linux/arch/i386/kernel/smp.c

------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 
Andreas Jansen | 8 Aug 00:22 2010
Picon

Re: German keyboard working with rdesktop but not with WinXP TS Client.

Am Freitag 06 August 2010, 19:29:54 schrieb Vincent Bernat:
> Hi!
> 
> A user of xrdp reported this bug:
>  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=584666
> 
> In summary, the  ' <at> ' sign does not work on a  german keyboard with WinXP
> TS  client but  works  fine with  "rdesktop  -k de".  Keymaps have  been
> regenerated.
> 
> The bug report contains some interesting information like xev output but
> I don't  know how  to solve  this problem. Any  idea? Debian  package is
> based on a CVS snapshot of 2010 03 03.
> 
> Thanks.

Hi Vincent,

I know this bug and some month ago I've tried to track down what's going on 
there especially with a german mstsc under Windows XP, but unfortunately ran 
out of time.

So, reading your question I've restarted my analysis today and first of all I 
fetched a fresh update via CVS of my working dir (Gentoo X86_64 on an AMD 
Athlon 64 X2). After compiling and fighting some trouble with tightvnc (I've 
forgotten how to tell tightvnc the right font path via xrdp) I've connected 
with mstsc 6.0.6001 from my Windows XP Home Box to my Gentoo Box and what a 
surprize - all Alt-Gr-Characters were working correctly!

Then I've started up my debian sid box (unstable on Intel Pentium 4) and first 
"apt-get install xrdp" (0.5.0~20100303cvs-5) then "sudo /etc/init.d/xrdp 
start" and connected again from my Windows XP Box. As reported, most of Alt-
Gr-Chars were *NOT* working as expected. Next I've downloaded xrdp from source 
(CVS as of today), ./bootstrap, ./configure, fetched some missing pakets, 
./configure again, make, "sudo make install" and started xrdp in debug-mode  
(--nodaemon) from /usr/local/sbin (of course after terminating the debian 
version of xrdp). After connecting from my Win box, all Alt-Gr-Chars worked as 
expected in bash as in gedit. Rechecked in 'normal mode' still all Alt-Gr-Keys 
(literally  <at> €µ{[]}\~|) are working.

Having a deeper look with xev while connected with mstsc from Win XP to latest 
cvs-version on my debian box, I've still seen some strange things when 
pressing Alt-Gr-Key. I've noticed on my first analysis month ago, that there's 
one CONTROL_L too much which seem to lead to some kind of "Control- <at> ' or 
'Control-{' etc., which are not translatable. Now I see a "KeyPress event 
Control_L" followed by a "KeyRelease event Control_L" and then a "KeyPress 
event ISO-Level3_Shift", which seems to be the right switch for Alt-Gr-Chars. 
But the preceding press/release of Control_L is still a bit strange ...

Anyway, now it's working (at least on my boxes) and therefore I would suggest 
to update to the very latest CVS version, which seems to solve the problem 
with german ALT-Gr-Chars.

I'm curious: can someone sum up, what's being changed, so that Alt-Gr-Chars 
(on german keyboards) now working?

regards
Andreas

------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 
_______________________________________________
xrdp-devel mailing list
xrdp-devel <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xrdp-devel
Andreas Jansen | 8 Aug 22:26 2010
Picon

Re: German keyboard working with rdesktop but not with WinXP TS Client.

Am Sonntag 08 August 2010, 00:22:37 schrieb Andreas Jansen:
> I'm curious: can someone sum up, what's being changed, so that Alt-Gr-Chars
> (on german keyboards) now working?

for the records:
AFAIS fix was introduced in vnc/vnc.c revision 1.44 on 17.03.2010 and it's 
working perfectly. Thanks Jay!

------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 
Jay Sorg | 9 Aug 01:46 2010
Picon

Re: German keyboard working with rdesktop but not with WinXP TS Client.

> Anyway, now it's working (at least on my boxes) and therefore I would suggest
> to update to the very latest CVS version, which seems to solve the problem
> with german ALT-Gr-Chars.
>
> I'm curious: can someone sum up, what's being changed, so that Alt-Gr-Chars
> (on german keyboards) now working?

Yes, it is strange.  The MS client 'sometimes' sends a left control
before altgr.  I could not find any flags to tell if it is this
'virtual' control or not.  Below is a link to the change.
I was not sure if this fixed the problem and if it causes any side affect.

http://xrdp.cvs.sourceforge.net/viewvc/xrdp/xrdp/vnc/vnc.c?r1=1.43&r2=1.44

If it fixes the problem for everyone I can put it in the 0.5 branch.

Jay

------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 
Jay Sorg | 9 Aug 01:51 2010
Picon

Re: XRDP server and Apple iPad RDP Client

> I’m running the XRDP server on a Red Hat Linux EE server v5 64 bit and on
> another Linux box RHEL v4 32bit.  The XRDP server is correctly handling and
> accepting RDP connections from my Mac running the latest Microsoft Windows
> RDP client v2.0.1 and 3rd part RDP client software Cord v5.3.  When using MS
> Remote Desktop Version 6.0 I can also connect to both linux boxes.
>
> I have two problem connecting via other RDP clients:
>
> When using MS Remote Desktop Connection version 6.1 under Windows 7 I get
> error message “there was an RDP protocol error” after authenticating via the
> sesman login screen.
> When using  “Remote Desktop – RDP” under an Apple iPad I get error message
> “Information  Host has closed the session”.  There are no log or error
> messages written to the XRDP sesman.log file.
>
> Any idea how this can be addressed?

The windows 7 client should work with 0.5 of xrdp.
What version are you running?

I don't know about the iPad client.
Is that irdesktop?

Jay

------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 
Cumberland, Lonnie | 9 Aug 16:44 2010

xrdp on Debian Lenny

Greetings,
 
I have just installed XRDP on an installation of Debian Lenny that I am putting together from
 
 
and must say that I really like what I have seen so far, but have encountered 1 problem and one question.
 
I saw on the website that we can set up keymaps and thing that this is probably what is happening in my system. The keyboard maps all of the character to the wrong keys and IK do not know how to fix that?
 
The other question is that the Windows RDP application allow you to map a local drive to the remote system but I do not know how to do that with XRDP?
 
Thanks and have a great day,
Lonnie Cumberland, Prof.
Physicist
 
(301) 975-6869  (Office)
(301) 926-7416  (Fax)

National Institute of Standards and Technology
Ionizing Radiation Division (846)
Radiation Physics Group (245), Room C106
ADDRESS:
                 100 Bureau Drive, Stop 8462
                Gaithersburg, MD 20899-8462
 
 
 
 
------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 
_______________________________________________
xrdp-devel mailing list
xrdp-devel@...
https://lists.sourceforge.net/lists/listinfo/xrdp-devel
Duzenbury, Rich | 11 Aug 17:45 2010

winxp sp3 and xrdp not working.

Hi,
 
I’ve installed xrdp on Suse Linux Enterprise Server 10.3.  Up until recently, mstsc could connect and work.  Apparently, there was some sort of update to the windows version of mstsc, and now, after the password is entered, it throws this message:
 
Because of a protocol error, the session will be disconnected.  Please try connecting to the remote computer again.
 
I’ve read in the forums that 0.4.1 fixes this, however installing it does not seem too, neither does 5.0. 
 
Is http://server1.xrdp.org/xrdp/ the correct location for project files?
 
I see xrdp-sp3-fix.tar.gz at http://server1.xrdp.org/temp/  but no mention anywhere I can find.  Does this solve the issue?  What version is this?
 
Anything I can do to get this going?  
 
Thank you.
 
Regards,
Rich
 
 
 
------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 
_______________________________________________
xrdp-devel mailing list
xrdp-devel@...
https://lists.sourceforge.net/lists/listinfo/xrdp-devel
Nicola Ruggero | 12 Aug 09:14 2010

Re: winxp sp3 and xrdp not working.

2010/8/11 Duzenbury, Rich <rduzenbury <at> biltd.com>:
>
> Is http://server1.xrdp.org/xrdp/ the correct location for project files?
>
> I see xrdp-sp3-fix.tar.gz at http://server1.xrdp.org/temp/  but no mention
> anywhere I can find.  Does this solve the issue?  What version is this?
>
> Anything I can do to get this going?

Hi, try to compile lastes cvs sources. See:
http://sourceforge.net/projects/xrdp/develop

bye
Nicola

------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 
_______________________________________________
xrdp-devel mailing list
xrdp-devel <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xrdp-devel
Duzenbury, Rich | 12 Aug 18:03 2010

Re: winxp sp3 and xrdp not working.

> > Anything I can do to get this going?
> 
> Hi, try to compile lastes cvs sources. See:
> http://sourceforge.net/projects/xrdp/develop
> 
> bye
> Nicola

This had no effect.  I checked out the sources, compiled them, installed them, then restarted the machine.  I
receive the same error message ("Because of a protocol error this session will be disconnected") at the
same point.

There don't appear to be any log entries anywhere in /var/log.  I did configure with --enable-debug, but it
seems to be of no use.

How can I troubleshoot this, please?  

Thank you.

Regards,
Rich

Thank you.

Regards,
Rich

------------------------------------------------------------------------------
This SF.net email is sponsored by 

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev 

Gmane