Albert Yang | 9 Feb 07:52 2004

php and mathopd, still problems

I had some extra time today and so I wanted to move off Apache and to
Mathopd..

But I STILL can't get php to work with mathopd!

I know my php works because I tried it in apache as well as cli...

When I run a php script from mathopd, it says:

Mon Feb  9 06:49:24 2004 [6797] convert_cgi_headers: illegal header line
"Status: 0"
Mon Feb  9 06:49:24 2004 [6797] child process 6826 exited with status
255

<--SNIP-->
Control {
        RunScriptsAsOwner On
        ChildLog /var/mathopd/childlog
        Types {
                text/html { html }
                text/plain { txt }
                image/gif { gif }
                image/jpeg { jpg }
                text/css { css }
                application/octet-stream { * }
        }
        Specials {
                Dump { /dump }
                CGI { cgi }
                Imagemap { map }
(Continue reading)

Michiel Boland | 9 Feb 11:51 2004

Re: php and mathopd, still problems

This is a PHP problem, not a mathopd problem.
I don't know enough about php to do anything about it.
The "Status: 0" header does not make sense at all though.

Sorry I can't be more helpful.

Cheers
Michiel

Juergen Daubert | 9 Feb 17:55 2004
Picon

Re: php and mathopd, still problems

On Mon, Feb 09, 2004 at 02:52:09PM +0800, Albert Yang wrote:
> I had some extra time today and so I wanted to move off Apache and to
> Mathopd..
> 
> But I STILL can't get php to work with mathopd!
> 
> I know my php works because I tried it in apache as well as cli...

You are using the php cli built together with mod_php for apache ? 
Try compiling a "real" php cgi with the configure option --enable-cgi
and your problems will go ;)

Greetings
J├╝rgen

--

-- 
juergen.daubert <at> t-online.de

Timo Ewalds | 12 Feb 06:37 2004
Picon

event 24 or too many files open

I run a rather large website ( www.enternexus.com ), and am using 
mathopd as the image server. There are about 150,000 images, organized 
into small folders. Recently I've been having trouble with mathopd not 
responding properly to image requests. Quite often it'll return error 
404 instead of the actual picture. The picture does exist, and the url 
is right, and all that stuff. Refreshing often gets it to load properly, 
but not always. Up until today I was running mathopd 1.4p3, and have 
huge strings of errors in the error log in the forms

Thu Feb 12 05:13:21 2004 [3505] poll: unexpected event 24
Thu Feb 12 05:13:35 2004 [3505] error sending to <ip>[4519]
Thu Feb 12 05:13:35 2004 [3505] send: Connection reset by peer

Seeing as I have no idea what event 24 is, and mathopd 1.5 is out, I 
figured I'd try it out. It unfortunately is no better, giving me these 
errors instead

Thu Feb 12 05:13:13 2004 [3496] open: Too many open files
Thu Feb 12 05:13:14 2004 [3496] accept: Too many open files
Thu Feb 12 05:13:14 2004 [3496] cannot open 
/home/enternexus/public_html/users/thumbs/604/604557.jpg

Now it is possible the errors from 1.4p3 are still showing up, but 
seeing as I get these errors dozens of times per second, I haven't 
noticed them.

I figured it might be running out of file descriptors, so I reduced the 
number of connections and the timeout, but that didn't do anything.

My servers are running redhat 9 and fedora (happens on both), all with 
(Continue reading)

Michiel Boland | 13 Feb 16:46 2004

mathopd-1.5p1 released

Hi. There is a brown-paper-bag bug in mathopd-1.5. So I have zapped that
release and put up mathopd-1.5p1 instead. If you run 1.5 please upgrade
ASAP. If you cannot upgrade you should at least define a global
Error404File (and an Error403File or Error401File if you use Access or
Realm.)

Thanks to Tahd Dell for pointing this out.

Problem description: normally requests for things like
/../../../../etc/passwd should be denied of course. Unfortunately the
introduction of CGI scripts for ErrorFiles ignored this check. :(

Sorry about this. Now I will go and stand in a corner for a month or so.

Andrew Kornilov | 23 Feb 15:43 2004
Picon

problems on redhat 9

I build 1.5b1 successfully
but unable to run it... On start creates empty logs, empty pid file with no errors or warnings

any suggestions?

Michiel Boland | 23 Feb 17:18 2004

1.5p2 released

Hi.

I just put out 1.5p2. This is a tiny update with respect to p1. If you
already run p1 without problems there is no reason to upgrade.

The p2 version will print a warning if NumConnections is set too high.
This should be useful for troubleshooting if you run into 'too many open
files' errors.

Some tiny bits in the documentation have been cleaned up.

Cheers
Michiel


Gmane