Huijing Zhou | 19 Mar 02:12 2003
Picon
Picon

Re: Cygwin binary of lftp 2.6.5?

>>>> Can someone please make a Cygwin binary of the latest lftp version?
>>>> The last one was 2.5.2, which has been quite a while now. I did try
>>>> several times to compile myself, but it never succeeded "out of the
>>>> box".  Thanks in advande.
 >>>
>>> Just built 2.6.5 out of the box on the latest Cygwin.  Feel
>>> free to grab a copy from:
>>>
>>> http://etree.org/software/lftp-2.6.5-cygwin.tar.gz
>>>
>>> Unpack in /usr/local or your repository of choice.  Enjoy.
>> 
>> That's great, thank. I'm just wondering why my compile failed. I had a 
>> complete reinstallation of Cygwin (all packages) two days ago and still 
>> lftp 2.6.5 failed to compile.
> 
> Make sure you're not building with gcc-mingw.  I think I was
> doign that and was hitting lots of weird issues with various
> Windows DLLs.  Removing the gcc-mingw package seems to fix the
> problem.  I just did ./configure && make && make install.  No
> errors.

That's strange. I sure was not adding "--mno-cygwin" anywhere. But AFAIK 
compiling under Cygwin doesn't use the "win32 native" mode anyway. It 
shouldn't be necessary to *remove* the mingw package!?

Huijing

--

-- 
Huijing Zhou <hj <at> cip.wiwi.uni-karlsruhe.de>
(Continue reading)

Christopher Faylor | 19 Mar 02:27 2003
Picon

Re: cygwin binary of lftp 2.6.5?

On Wed, Mar 19, 2003 at 02:12:37AM +0100, Huijing Zhou wrote:
>>>>>Can someone please make a Cygwin binary of the latest lftp version?
>>>>>The last one was 2.5.2, which has been quite a while now. I did try
>>>>>several times to compile myself, but it never succeeded "out of the
>>>>>box".  Thanks in advande.
>>>>
>>>>Just built 2.6.5 out of the box on the latest Cygwin.  Feel
>>>>free to grab a copy from:
>>>>
>>>>http://etree.org/software/lftp-2.6.5-cygwin.tar.gz
>>>>
>>>>Unpack in /usr/local or your repository of choice.  Enjoy.
>>>
>>>That's great, thank. I'm just wondering why my compile failed. I had a 
>>>complete reinstallation of Cygwin (all packages) two days ago and still 
>>>lftp 2.6.5 failed to compile.
>>
>>Make sure you're not building with gcc-mingw.  I think I was
>>doign that and was hitting lots of weird issues with various
>>Windows DLLs.  Removing the gcc-mingw package seems to fix the
>>problem.  I just did ./configure && make && make install.  No
>>errors.
>
>That's strange. I sure was not adding "--mno-cygwin" anywhere. But AFAIK 
>compiling under Cygwin doesn't use the "win32 native" mode anyway. It 
>shouldn't be necessary to *remove* the mingw package!?

Absolutely.  There is no reason why building with -mno-cygwin package
would have any effect on any Windows DLLs unless you attempt the
standard thinko of trying to mix cygwin and non-cygwin DLLs or
(Continue reading)


Gmane