Wagner Pereira | 13 May 21:45 2010
Picon

Graphs are broked

Hi, folks.

After I've installed all the requisites to run Cacti (as I guess), the 
graph images are all broken.

What should I provide to you guys to help me wit that (logs etc)?

Thanks.

--

-- 

Wagner Pereira

PoP-SP/RNP - Ponto de Presença da RNP em São Paulo
CCE/USP - Centro de Computação Eletrônica da Universidade de São Paulo
http://www.pop-sp.rnp.br
Tel. (11) 3091-8901

------------------------------------------------------------------------------
Rafael Carneiro | 14 May 01:54 2010
Picon

Make all graphs public

Hey guys,
I have recently upgraded a cacti install to 0.8.7e (ubuntu 10.04/64 bit)
from 0.8.6i (debian lenny/32 bit) and everything went well as far as
upgrading the db and I manually exported all rrd's and imported them on the
new box.
The problem I have now is that all graphs used to be public (didn't require
authentication) and now they do. Is that something that changed between
those versions? Is there a way to enable public access graphs only on
0.8.7e?

Any help will be appreciated.

Regards,

--

-- 
Rafael Carneiro
http://ca.linkedin.com/in/rcarneiro
------------------------------------------------------------------------------
Reinhard Scheck | 14 May 11:23 2010
Picon

Re: Graphs are broked

Please check installed rrdtool version:

rrdtool --version

Compare the output to "Settings -> RRDTool Utility Version"

For more help, please use the forums. There's a lot more traffic there
Reinhard

On 13.05.2010 21:45, Wagner Pereira wrote:
> Hi, folks.
> 
> After I've installed all the requisites to run Cacti (as I guess), the 
> graph images are all broken.
> 
> What should I provide to you guys to help me wit that (logs etc)?
> 
> Thanks.
> 

------------------------------------------------------------------------------
a.smith | 14 May 17:16 2010
Picon

Weathermap plugin no longer sees configs

Hi,

   On an upgraded install of cacti, now on version Version 0.8.7e and  
PA version 2.6 Im having a prob where no maps are generated by  
weathermap. There are several configs in the configs directory, these  
can be viewed via the editor.php. However if you go to the weathermap  
section under "console" no configs are shown and the cacti poller log  
always reports this:

Last Completed Run: Fri, 14 May 10 15:50:23 +0100: 0 maps were run in  
0 seconds with 0 warnings

check.php reports all is well from both command line and via a  
browser. Permissions are read/write on the whole cacti directory  
structure to the cacti user and www group. What could be the issue or  
where else should I look for clues? Any ideas?

thanks for any advise, Andy.

------------------------------------------------------------------------------
a.smith | 14 May 18:23 2010
Picon

Re: Weathermap plugin no longer sees configs (SOLVED)

Ok, user error I think! Think I was going to edit groups, then  
clicking add instead of clicking add on the main page.

thanks.

Quoting a.smith <at> ukgrid.net:

> Hi,
>
>   On an upgraded install of cacti, now on version Version 0.8.7e and  
> PA version 2.6 Im having a prob where no maps are generated by  
> weathermap. There are several configs in the configs directory,  
> these can be viewed via the editor.php. However if you go to the  
> weathermap section under "console" no configs are shown and the  
> cacti poller log always reports this:
>
> Last Completed Run: Fri, 14 May 10 15:50:23 +0100: 0 maps were run  
> in 0 seconds with 0 warnings
>
> check.php reports all is well from both command line and via a  
> browser. Permissions are read/write on the whole cacti directory  
> structure to the cacti user and www group. What could be the issue  
> or where else should I look for clues? Any ideas?
>
> thanks for any advise, Andy.
>
>
>

------------------------------------------------------------------------------
(Continue reading)

Wagner Pereira | 17 May 14:11 2010
Picon

Re: Graphs are broked

Hi, Reinhard.

That's the rrdtool version, obtained through CLI.
-------------------------
# rrdtool --version
RRDtool 1.3.1  Copyright 1997-2008 by Tobias Oetiker <tobi <at> oetiker.ch>
                Compiled Sep 26 2008 22:25:10

Usage: rrdtool [options] command command_options

Valid commands: create, update, updatev, graph, graphv,  dump, restore,
                 last, lastupdate, first, info, fetch, tune,
                 resize, xport

RRDtool is distributed under the Terms of the GNU General
Public License Version 2. (www.gnu.org/copyleft/gpl.html)

For more information read the RRD manpages
-------------------------

And that's what I see in the RRDTool Utility Version (Settings):

The version of RRDTool that you have installed: RRDTool 1.0.x

But there is other option: 1.2.x

Att,

--

-- 

(Continue reading)

Reinhard Scheck | 17 May 19:52 2010
Picon

Re: Graphs are broked

If tehre's only "rrdtool-1.0.x" and "rrdtool-1.2.x" under "Settings", then
you're running a quite old version of cacti ;-)
In this case either
- upgrade (but wait a mo', cacti 087f is going to be published this week)
- use "rrdtool-1.2.x" setting with rrdtool 1.3.x

Both option will work
Reinhard

On 17.05.2010 14:11, Wagner Pereira wrote:
> Hi, Reinhard.
> 
> That's the rrdtool version, obtained through CLI.
> -------------------------
> # rrdtool --version
> RRDtool 1.3.1  Copyright 1997-2008 by Tobias Oetiker <tobi <at> oetiker.ch>
>                 Compiled Sep 26 2008 22:25:10
> 
> Usage: rrdtool [options] command command_options
> 
> Valid commands: create, update, updatev, graph, graphv,  dump, restore,
>                  last, lastupdate, first, info, fetch, tune,
>                  resize, xport
> 
> RRDtool is distributed under the Terms of the GNU General
> Public License Version 2. (www.gnu.org/copyleft/gpl.html)
> 
> For more information read the RRD manpages
> -------------------------
> 
(Continue reading)

Wagner Pereira | 17 May 20:25 2010
Picon

Re: Graphs are broked [SOLVED]

Good news, Reinhard.

You were right. Now I am able to see ALL the graphs!

That was the solution: I changed the "RRDTool Utility Version" option 
from 1.0.x to 1.2.x

Then after this exact moment I was ready to see the beautiful graphs  : )

Thank you very very much.

Att,

--

-- 

Wagner Pereira

PoP-SP/RNP - Ponto de Presença da RNP em São Paulo
CCE/USP - Centro de Computação Eletrônica da Universidade de São Paulo
http://www.pop-sp.rnp.br
Tel. (11) 3091-8901

Em 17/5/2010 14:52, Reinhard Scheck escreveu:
> If tehre's only "rrdtool-1.0.x" and "rrdtool-1.2.x" under "Settings", then
> you're running a quite old version of cacti ;-)
> In this case either
> - upgrade (but wait a mo', cacti 087f is going to be published this week)
> - use "rrdtool-1.2.x" setting with rrdtool 1.3.x
>
> Both option will work
(Continue reading)

Tony Roman | 20 May 03:59 2010

Cacti 0.8.7f Released

Cacti 0.8.7f has been released!

Release notes: http://www.cacti.net/release_notes_0_8_7f.php
Download at http://www.cacti.net/download_cacti.php

Spine 0.8.7f will be available by early next week.  Cacti 0.8.7f will 
work just fine with Spine 0.8.7e.

If you have any questions head on over to the forums!
http://forums.cacti.net

Thanks!
Tony Roman
Cacti Developer

------------------------------------------------------------------------------
Tony Roman | 27 May 02:22 2010

Status of Cacti 0.8.7f (Do not use)

We are currently advising people to not install Cacti 0.8.7f due to the 
following issues:

  - LDAP authentication for login produces a warning about an undefined 
index
  - Automatic page refresh on graph views does now function
  - Save button on user management graph permissions does not work
  - Deleting a graph tree does not work with Plugin Architecture installed
  - If using snmp binaries some snmp get requests will fail

If you have already upgraded to 0.8.7f, you can simple move back to 0.8.7e.

Cacti 0.8.7g will be release on June 7th to address these issues.

Sincerely,
The Cacti Group

------------------------------------------------------------------------------

Gmane