HERNAN | 1 Jul 04:14 2006
Picon

Cacti Migration problem !!! :(

Dear All ,

I have a problem to make a server migration with the cacti.sql database .
The old server is installed on Linux Gentoo and the new server is running 
under Debian 3.1 r2 .
I get this error message in the database process migration  :

MON-NTW:/usr/share/doc/cacti# mysql -u cacti -p cacti < 
/usr/share/doc/cacti/cacti_old.sql
Enter password:
 ERROR 1064 at line 29: You have an error in your SQL syntax.  Check the 
manual that corresponds to your MySQL server version for the right syntax to 
use near 'DEFAULT CHARSET=utf8' at line 6
MON-NTW:/usr/share/doc/cacti# :

 Can someone help me with this trouble ?  I'll be very thankfull.

A lot of Thanks !!

Best Regards.
Herny 

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
Tony Roman | 2 Jul 00:52 2006

Re: Cacti Migration problem !!! :(

You are using a newer version of mysql on the old Cacti server than you 
are using on the new Cacti server.

http://dev.mysql.com/doc/refman/5.0/en/mysqldump.html

You need to export the database from the older server in a compatible 
format.

Use the following mysqldump command:

	mysqldump -u cacti -p --compatible=mysql323 cacti > cacti.sql

Good luck,

Tony

HERNAN wrote:
> Dear All ,
> 
> I have a problem to make a server migration with the cacti.sql database .
> The old server is installed on Linux Gentoo and the new server is running 
> under Debian 3.1 r2 .
> I get this error message in the database process migration  :
> 
> MON-NTW:/usr/share/doc/cacti# mysql -u cacti -p cacti < 
> /usr/share/doc/cacti/cacti_old.sql
> Enter password:
>  ERROR 1064 at line 29: You have an error in your SQL syntax.  Check the 
> manual that corresponds to your MySQL server version for the right syntax to 
> use near 'DEFAULT CHARSET=utf8' at line 6
(Continue reading)

Erik Ahlstrom | 3 Jul 15:14 2006
Picon

Disk read perfomance with many rrd's

Hi,

I have a problem with disk IO performance running a large installation with about 8000 rrd files. (about 300 switches and routers).

The size of each rrd's is about 8 MBytes, total diskspace for rrd's is around 22 GB.

It seems like rrdtool is reading through the whole file before adding the new data so iowait is about 25% and disk read is about 65 MByte/sec when updating after a poll round.

Does anyone have experience with a lot's of hosts and rrds with cacti?

The setup of the RRA's is default for cacti,


Regards fyllos




Sneak preview the all-new Yahoo.com. It's not radically different. Just radically better.
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
cacti-user mailing list
cacti-user <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/cacti-user
HERNAN HERNAN | 3 Jul 15:37 2006
Picon

Fw: Cacti Migration problem !!! :(

Hello Tony ,

The process of Backup and restore worked well ; but after making it I can 
not visualize the CACTI site ( http://IP/cacti/). That it can be happening?

That it can be happening?

Can someone help me with this trouble ?  I'll be very thankfull

A lot of Thanks !!

Best Regards.
Herny

----- Original Message -----
From: "Tony Roman" <roman <at> disorder.com>
To: "Support requests/questions about cacti"
<cacti-user <at> lists.sourceforge.net>
Sent: Saturday, July 01, 2006 7:52 PM
Subject: Re: [cacti-user] Cacti Migration problem !!! :(

>You are using a newer version of mysql on the old Cacti server than you are 
>using on the new Cacti server.
>
>http://dev.mysql.com/doc/refman/5.0/en/mysqldump.html
>
>You need to export the database from the older server in a compatible 
>format.
>
>Use the following mysqldump command:
>
>mysqldump -u cacti -p --compatible=mysql323 cacti > cacti.sql
>
>Good luck,
>
>Tony
>
>HERNAN wrote:
>>Dear All ,
>>
>>I have a problem to make a server migration with the cacti.sql database . 
>>The old server is installed on Linux Gentoo and the new server is running 
>>under Debian 3.1 r2 . I get this error message in the database process 
>>migration  :
>>
>>MON-NTW:/usr/share/doc/cacti# mysql -u cacti -p cacti < 
>>/usr/share/doc/cacti/cacti_old.sql
>>Enter password:
>>  ERROR 1064 at line 29: You have an error in your SQL syntax.  Check the 
>>manual that corresponds to your MySQL server version for the right syntax 
>>to use near 'DEFAULT CHARSET=utf8' at line 6
>>MON-NTW:/usr/share/doc/cacti# :
>>
>>  Can someone help me with this trouble ?  I'll be very thankfull.
>>
>>
>>A lot of Thanks !!
>>
>>Best Regards.
>>Herny
>>
>>
>>Using Tomcat but need to do more? Need to support web services, security? 
>>Get stuff done quickly with pre-integrated technology to make your job 
>>easier Download IBM WebSphere Application Server v.1.0.1 based on Apache 
>>Geronimo
>>http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
>>_______________________________________________
>>cacti-user mailing list
>>cacti-user <at> lists.sourceforge.net
>>https://lists.sourceforge.net/lists/listinfo/cacti-user
>
>Using Tomcat but need to do more? Need to support web services, security? 
>Get stuff done quickly with pre-integrated technology to make your job 
>easier Download IBM WebSphere Application Server v.1.0.1 based on Apache 
>Geronimo 
>http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=1216
>42
>_______________________________________________
>cacti-user mailing list
>cacti-user <at> lists.sourceforge.net
>https://lists.sourceforge.net/lists/listinfo/cacti-user

_________________________________________________________________
Consigue aquí las mejores y mas recientes ofertas de trabajo en América 
Latina y USA: http://latam.msn.com/empleos/

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
Jose Madrid | 3 Jul 16:57 2006
Picon

Cisco CSS Template

Guys,

I have imported the host template listed
 <at> http://forums.cacti.net/viewtopic.php?t=5114&postdays=0&postorder=asc&highlight=cisco+css&start=15
for my Cisco CSS's.  The problem is that the host template was
supposed to load a few xml as Data_Queries but they are missing.  Does
anyone have the css-status.xml and css-conns.xml files from the
resource/snmp_queries dir?

--

-- 
Common sense is the best distributed commodity in the world, for every
man is convinced that he is well supplied with it.
Rene Descartes "Discourse on Method"

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
HERNAN | 4 Jul 03:32 2006
Picon

Fw: Cacti Migration problem !!! :(

Hi Tony ,
Thank you very much !!! The Database migration was successful.  :)
Best Regards.
Herny
----- Original Message ----- 
From: "Tony Roman" <roman <at> disorder.com>
To: "Support requests/questions about cacti" 
<cacti-user <at> lists.sourceforge.net>
Sent: Saturday, July 01, 2006 7:52 PM
Subject: Re: [cacti-user] Cacti Migration problem !!! :(

> You are using a newer version of mysql on the old Cacti server than you
> are using on the new Cacti server.
>
> http://dev.mysql.com/doc/refman/5.0/en/mysqldump.html
>
> You need to export the database from the older server in a compatible
> format.
>
> Use the following mysqldump command:
>
> mysqldump -u cacti -p --compatible=mysql323 cacti > cacti.sql
>
> Good luck,
>
> Tony
>
> HERNAN wrote:
>> Dear All ,
>>
>> I have a problem to make a server migration with the cacti.sql database .
>> The old server is installed on Linux Gentoo and the new server is running
>> under Debian 3.1 r2 .
>> I get this error message in the database process migration  :
>>
>> MON-NTW:/usr/share/doc/cacti# mysql -u cacti -p cacti <
>> /usr/share/doc/cacti/cacti_old.sql
>> Enter password:
>>  ERROR 1064 at line 29: You have an error in your SQL syntax.  Check the
>> manual that corresponds to your MySQL server version for the right syntax 
>> to
>> use near 'DEFAULT CHARSET=utf8' at line 6
>> MON-NTW:/usr/share/doc/cacti# :
>>
>>  Can someone help me with this trouble ?  I'll be very thankfull.
>>
>>
>> A lot of Thanks !!
>>
>> Best Regards.
>> Herny
>>
>>
>> Using Tomcat but need to do more? Need to support web services, security?
>> Get stuff done quickly with pre-integrated technology to make your job 
>> easier
>> Download IBM WebSphere Application Server v.1.0.1 based on Apache 
>> Geronimo
>> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
>> _______________________________________________
>> cacti-user mailing list
>> cacti-user <at> lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/cacti-user
>
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job 
> easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> cacti-user mailing list
> cacti-user <at> lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/cacti-user
> 

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
HERNAN | 4 Jul 03:45 2006
Picon

Graph problem in Cacti :(

Dear All ,

I have a problem to visualize all graph after making a migration of server. 
The error in the Graph Management debug is the following one:

RRDTool Says:

ERROR: can't handle RRD file version 0003

That it can be happening?

Can someone help me with this trouble ?  I'll be very thankfull

A lot of Thanks !!

Best Regards.
Herny 

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
Tony Roman | 4 Jul 18:53 2006

Re: Disk read perfomance with many rrd's

This is a known issue and with larger installation, I commonly suggest a
fast I/O Subsystem and more system memory so that the OS disk cache is
larger.

I haven't inspected the RRDtool code, but if I had to guess, which I
shouldn't, it is reading the whole file to create consolidation values.

Tony Roman
Cacti Developer

> Hi,
>
> I have a problem with disk IO performance running a large installation
> with about 8000 rrd files. (about 300 switches and routers).
>
> The size of each rrd's is about 8 MBytes, total diskspace for rrd's is
> around 22 GB.
>
> It seems like rrdtool is reading through the whole file before adding the
> new data so iowait is about 25% and disk read is about 65 MByte/sec when
> updating after a poll round.
>
> Does anyone have experience with a lot's of hosts and rrds with cacti?
>
> The setup of the RRA's is default for cacti,
>
>
> Regards fyllos
>
>
>
>
>
>
> ---------------------------------
> Sneak preview the  all-new Yahoo.com. It's not radically different. Just
> radically better. Using Tomcat but need to do more? Need to support web
> services, security?
> Get stuff done quickly with pre-integrated technology to make your job
> easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> cacti-user mailing list
> cacti-user <at> lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/cacti-user
>

--

-- 
Tony

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
Tony Roman | 4 Jul 18:55 2006

Re: Graph problem in Cacti :(

Upgrade RRDTool from version 1.0.x to 1.2.x.  You can't go backwards
unless you dump all your rrdtool file to XML and then restore them in the
other version.  But I have never tried from version 1.2.x to 1.0.x
conversion.

Tony Roman
Cacti Developer

> Dear All ,
>
> I have a problem to visualize all graph after making a migration of
> server.
> The error in the Graph Management debug is the following one:
>
> RRDTool Says:
>
> ERROR: can't handle RRD file version 0003
>
>
> That it can be happening?
>
> Can someone help me with this trouble ?  I'll be very thankfull
>
> A lot of Thanks !!
>
> Best Regards.
> Herny
>
>
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job
> easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> cacti-user mailing list
> cacti-user <at> lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/cacti-user
>

--

-- 
Tony

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
HERNAN | 5 Jul 04:28 2006
Picon

Re: Graph problem in Cacti :(

Dear Tony Roman ,

I migrated the RRDtool from version 1.0.49 to the newer 1.2.11 in my new 
Debian  3,1 R2 server.
The old server (Gentoo 1.4.6) has the archives * rrd created with RRDTool 
version 1.2.6.
The problem I have is that after migrating the RRDtool to version 1.2.11 I 
could not install the CACTI that was removed after the uninstalling of the 
RRDtool version 1.0.49.
Also I verified that I cannot install any applications after installing the 
new version of RRDtool 1.2.11  (Testing).

The system is showing many errors related to other packages

Could you send me a  -How-to mini-guide  to make upgrade of RRDtool from 
1.0.x  to  1.2.x.
I have not found much information of like doing it. I really dont know what 
i am doing wrong..

MON-NTW:/# rrdtool

RRDtool 1.2.11  Copyright 1997-2005 by Tobias Oetiker <tobi <at> oetiker.ch>

               Compiled Mon Jan  9 17:04:13 UTC 2006

Usage: rrdtool [options] command command_options

Valid commands: create, update, updatev, graph, dump, restore,

                last, first, info, fetch, tune, resize, xport

RRDtool is distributed under the Terms of the GNU General

Public License Version 2. (www.gnu.org/copyleft/gpl.html)

For more information read the RRD manpages

MON-NTW:/#

MON-NTW:/#

MON-NTW:/# apt-get install cacti

Reading Package Lists... Done

Building Dependency Tree... Done

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

  cacti: Depends: php4-mysql (>= 4.3.10-9) but it is not going to be
installed

         Depends: php4-cli but it is not going to be installed

         Depends: php4-snmp but it is not going to be installed

         Depends: mysql-client (> 3.23.3) or

                  mysql-client-4.1 but it is not going to be installed

         Depends: snmp but it is not going to be installed

         Depends: libphp-adodb but it is not going to be installed
         Depends: ucf but it is not going to be installed

  libfreetype6: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge3 is to be 
installed

  libpng12-0: Depends: libc6 (>= 2.3.5-1) but 2.3.2.ds1-22sarge3 is to be 
installed

  librrd2: Depends: libc6 (>= 2.3.5-1) but 2.3.2.ds1-22sarge3 is to be 
installed
  rrdtool: Depends: libc6 (>= 2.3.5-1) but 2.3.2.ds1-22sarge3 is to be 
installed
  ttf-dejavu: Depends: defoma but it is not going to be installed
  zlib1g: Depends: libc6 (>= 2.3.5-1) but 2.3.2.ds1-22sarge3 is to be 
installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify
a solution).

MON-NTW:/#

A lot of Thanks !!

Best Regards.
Herny

----- Original Message ----- 
From: "Tony Roman" <roman <at> disorder.com>
To: "Support requests/questions about cacti" 
<cacti-user <at> lists.sourceforge.net>
Sent: Tuesday, July 04, 2006 1:55 PM
Subject: Re: [cacti-user] Graph problem in Cacti :(

> Upgrade RRDTool from version 1.0.x to 1.2.x.  You can't go backwards
> unless you dump all your rrdtool file to XML and then restore them in the
> other version.  But I have never tried from version 1.2.x to 1.0.x
> conversion.
>
> Tony Roman
> Cacti Developer
>
>> Dear All ,
>>
>> I have a problem to visualize all graph after making a migration of
>> server.
>> The error in the Graph Management debug is the following one:
>>
>> RRDTool Says:
>>
>> ERROR: can't handle RRD file version 0003
>>
>>
>> That it can be happening?
>>
>> Can someone help me with this trouble ?  I'll be very thankfull
>>
>> A lot of Thanks !!
>>
>> Best Regards.
>> Herny
>>
>>
>> Using Tomcat but need to do more? Need to support web services, security?
>> Get stuff done quickly with pre-integrated technology to make your job
>> easier
>> Download IBM WebSphere Application Server v.1.0.1 based on Apache 
>> Geronimo
>> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
>> _______________________________________________
>> cacti-user mailing list
>> cacti-user <at> lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/cacti-user
>>
>
>
> -- 
> Tony
>
>
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job 
> easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> cacti-user mailing list
> cacti-user <at> lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/cacti-user
> 

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

Gmane