Rene Kanzler | 8 Jan 18:36 2007

bug in ZOE?


I am in the process of configuring postfix to send a copy of a incomming
message to the ZOE SMTP server. 

The authentication went well until the part of the MAIL FROM:, it has
the AUTH=<> parameter. I tested the ZOE server with telnet to port
10025, put all the data needed (also the base64 login and pass), and
the message was rejected with the reason "501 Invalid sender address". 

The message was accepted when I remove the AUTH=<> from the MAIL FROM
So, to solve the problem I went to the source and find the reason
for the rejectet sender address in The Java InternetAddress
validator rejects the "aString".
I edited the file, remove the AUTH=<> and compiled the
source and all went well. The patched file is attached. 

Postfix use the AUTH=<> parameter as described in the RFC 2554.
So, maybe this is a bug in ZOE? 

Attachment ( text/x-java, 5789 bytes
Take Surveys. Earn Cash. Influence the Future of IT
Join's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
(Continue reading)

dave johnson | 5 Aug 18:45 2006

identity crisis ?

so i've attempted to move my 9+GB zoe store from my old Windblowz server to my new Linux server and for some
reason, Zoe seems to pickup the account configuration information for the existing user, but doesn't
pickup the message store and apparently created a new one.

here's the kicker, if i launch zoe from the windows system (mounting the share on the linux server via CIFS)
it launches into the same message store.  however, when i launch the same exact zoe from within linux, i get
the same user config, but the new "empty" message store.

to launch zoe, i use the following windows command script:
start /min /b /belownormal java -jar zoe.jar daemon

to launch zoe within linux, i use the following init.d script:

# chkconfig: 2345 80 20
# description: Zoe is google for email :)
# processname: zoe

# Source function library.


test -x $zoepath/Zoe.jar || exit 0

(Continue reading)

Rocky Pope | 26 Apr 07:15 2006

Feature or Problem?


I am running Zoe 0.6.3 in conjunction with Thunderbird 
(20060308).  When I reply to a message from within the Zoe browser 
(using "REPLY" or "ALL"), the resulting reply in Thunderbird does not 
quote the parent message -- the reply window is blank.  Is this a 
misconfiguration of Thunderbird (likely), or an issue with Zoe?

Messages replied to when using " <at> " result in a normal message -- all 
text is quoted properly.

Thanks in advance,


Kristian Rink | 10 Mar 20:00 2006

zoe status / IMAP support?

Hi all,

just subscribed to the list after messing around with Zoe for the first
time and getting pretty much amazed by its capabilities. Anyhow, looking
at the list archive and the latest release date, it seems the project
hasn't seen much activity lately. So, two questions:

(a) Is there still any development goin' on about Zoe, or can this
package be considered "finished"?

(b) For what I see, the server provides a POP3 interface as well as FTP
(which is incredible). But what about IMAP? How are chances to see Zoe
working as an IMAP server in near future?

TIA and bye,


Kristian Rink * * jab: kawazu <at>
icq: 48874445 *  fon: ++49 176 2447 2771
"Wenn einer allein träumt, ist es nur ein Traum. Wenn viele gemeinsam
träumen, ist das der Anfang einer neuen Wirklichkeit." (Hundertwasser)

This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!$1720&dat1642
(Continue reading)

David Han | 25 Jan 00:09 2006

gmail pop access problems

I have about a gig of email in my gmail account. I recently set up the
gmail account for pop access in zoe - hoping that zoe would be able to
get all my gmail messages. It was able to get a few messages, maybe 10
or 20 of them, but then stopped. I saw some error messages saying
there was some problem accessing the gmail pop address. Most of my
Gmail email is not in the Inbox, it's archived and "labeled" in gmail.
Should zoe be able to download all these messages via pop as well?

This email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
Alexandre Takacs | 24 Nov 06:41 2005

Naive question: status of ZOE


A pretty basic and naive question: what is the current status of ZOE ? Is it
still an active project?

Thanks for bringing me up to speed :)


This email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
Baeker, Markus | 1 Jun 08:48 2005

AW: Out of memory ??


Have you tried to give the java process more memory with

java -Xms512m -Xmx1024m -jar "%~dp0zoe.jar" (this is my command line on windows)?

Good luck


>-----Ursprüngliche Nachricht-----
>Von: zoe-general-admin <at> 
>[mailto:zoe-general-admin <at>] Im Auftrag 
>von Florian Overkamp
>Gesendet: Mittwoch, 1. Juni 2005 08:31
>An: zoe-general <at>
>Betreff: RE: [Zoe-General] Out of memory ??
>Anyone any idea about this ? Seems like Zoe won't read in any 
>new mail any
>more either, so my archive folders are growing rather rapidly :-P
>> -----Original Message-----
>> From: zoe-general-admin <at> 
>> [mailto:zoe-general-admin <at>] On Behalf Of 
>> Florian Overkamp
>> Sent: zondag 29 mei 2005 15:53
(Continue reading)

Florian Overkamp | 29 May 15:52 2005

Out of memory ??

Hi guys,

Since a short while my Zoe complains of 'Out of memory' errors:

05/29 15:47:14 (Warning) java.lang.OutOfMemoryError

I can see the timeline and message entries, but I cannot look at any message
particularly. The webserver just wont reply (so mauybe the thread died ?)
Message then look like:

05/29 15:47:09 (Warning) SZInspector.descriptionWithNameForObject:
05/29 15:47:14 (Warning) SZKeyValue$ObjectKeyValue.objectValueForKey:
SZKeyValue.ObjectKeyValue.objectValueForKey: exception for key 'value' in
class '': java.lang.OutOfMemoryError
05/29 15:47:14 (Warning) java.lang.OutOfMemoryError

About page reports:

11 threads running
no messages pending
121.679 messages
4.065 documents
9.019 names
6.072 organizations
20.013 urls

Unix reports:

florian <at> speedster:~$ free
(Continue reading)

frank h. | 8 May 20:39 2005

safari 2 cant connect to Web UI

after upgrading to tiger, I cannot connect to Zoë's web UI anymore
using Safari 2.0

I get an "Unauthorized" error message

using another browser like e.g. Camino works fine

I changed the port number and restarted Zoe, and tried to connect to
the new port number, but the problem persists

anybody has seen this problem? what could be the solution?

this is the debug log when trying to connect with safari 2.0

05/08 20:35:17 (Info) ZeroConf.register: aType: '_qotd._tcp.local.'
05/08 20:35:17 (Info) ZeroConf.register: aName: 'root's zoe._qotd._tcp.local.'
05/08 20:35:21 (Info) ZeroConf.register: aType: '_http._tcp.local.'
05/08 20:35:21 (Info) ZeroConf.register: aName: 'root's zoe
05/08 20:35:25 (Debug) SZService.invokeAction: someActions: null
05/08 20:35:25 (Debug) SZService.invokeAction: aComponent:
05/08 20:35:25 (Debug) Session.isLocalRequest: anAddress: /
05/08 20:35:25 (Debug) Session.isLocalRequest: localAddress:
05/08 20:35:25 (Info) ZeroConf.register: aType: '_http._tcp.local.'
05/08 20:35:25 (Info) ZeroConf.register: aName: 'root's zoe._http._tcp.local.'

(Continue reading)

lwiechec2 | 28 Apr 16:39 2005

accessing ZOE via HTTPS

Dear ZOErs,

have any of you access ZOE using secure HTTP? I'm not sure why, but I'm
experiencing the following behaviour: sometimes I need to click twice or
thrice (!) on links to make them work... I was wondering if this is HTTP
server's fault (ZOE is using Simple), but looking at its project page has
me clueless.

Anybody has any ideas?



SF.Net email is sponsored by: Tell us your software development plans!
Take this survey and enter to win a one-year sub to
Plus IDC's 2005 look-ahead and a copy of this survey
Click here to start!
frank h. | 13 Apr 23:37 2005

ox x mails fetches all but latest mail

I really really like Zoë, what a great piece of software
but my mail progam (OS X Mail) only fetches all but the very latest
mail from Zoe
i.e I always have to look into Zoes Web UI in order to see the very latest mail
what could be wrong?
thanks a lot for any insight

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.