Philipp Jacob | 3 Oct 17:02 2003
Picon
Picon

Authentication problem

Hello everyone,

I try to use popa3d-0.5.1 with stunnel.
I set it up refering to this
HowTo:

http://gene.wins.uva.nl/~talerven/software/add-popa3d-user/pop3-ssl-using-popa3d-HOWTO

But when I try to login via pop3s (port 995)
I get an Authentication failure. The syslog says
the following:

<snip>
Oct  3 16:47:22 debian stunnel[7266]: popa3d connected from
xx.xx.xx.xx:20342
Oct  3 16:47:32 debian popa3d[7267]: Authentication failed for UNKNOWN USER
</snip>

I definitely have set up the user I'm logging in with.
To me it seems, popa3d doesn't get the correct USER
command. But I don't know how to check that, because
the log only says "UNKNOWN USER".

Can anyone help me?

Philipp

--

-- 
NEU FÜR ALLE - GMX MediaCenter - für Fotos, Musik, Dateien...
Fotoalbum, File Sharing, MMS, Multimedia-Gruß, GMX FotoService
(Continue reading)

Tim van Erven | 3 Oct 18:25 2003
Picon

Re: Authentication problem

On Fri, 03/10/2003 17:02 +0200, Philipp Jacob wrote:
> I try to use popa3d-0.5.1 with stunnel.
> I set it up refering to this
> HowTo:
> 
> http://gene.wins.uva.nl/~talerven/software/add-popa3d-user/pop3-ssl-using-popa3d-HOWTO
> 
> But when I try to login via pop3s (port 995)
> I get an Authentication failure. The syslog says
> the following:
> 
> <snip>
> Oct  3 16:47:22 debian stunnel[7266]: popa3d connected from
> xx.xx.xx.xx:20342
> Oct  3 16:47:32 debian popa3d[7267]: Authentication failed for UNKNOWN USER
> </snip>
> 
> I definitely have set up the user I'm logging in with.
> To me it seems, popa3d doesn't get the correct USER
> command. But I don't know how to check that, because
> the log only says "UNKNOWN USER".

I just noticed an error in that HOWTO. I forgot to mention the ip of the
interface popa3d is listening on is appended to the VIRTUAL_HOME_PATH.
So you'll have to set the virtual_domain_root_directory variable in the
add-popa3d-user script to VIRTUAL_HOME_PATH/127.0.0.1.

I'll have to fix that sometime soon.

Regards,
(Continue reading)

Philipp Jacob | 4 Oct 13:26 2003
Picon
Picon

Re: Authentication problem

> On Fri, 03/10/2003 17:02 +0200, Philipp Jacob wrote:
> > I try to use popa3d-0.5.1 with stunnel.
> > I set it up refering to this
> > HowTo:
> > 
> >
>
http://gene.wins.uva.nl/~talerven/software/add-popa3d-user/pop3-ssl-using-popa3d-HOWTO
> > 
> > But when I try to login via pop3s (port 995)
> > I get an Authentication failure. The syslog says
> > the following:
> > 
> > <snip>
> > Oct  3 16:47:22 debian stunnel[7266]: popa3d connected from
> > xx.xx.xx.xx:20342
> > Oct  3 16:47:32 debian popa3d[7267]: Authentication failed for UNKNOWN
> USER
> > </snip>
> > 
> > I definitely have set up the user I'm logging in with.
> > To me it seems, popa3d doesn't get the correct USER
> > command. But I don't know how to check that, because
> > the log only says "UNKNOWN USER".
> 
> I just noticed an error in that HOWTO. I forgot to mention the ip of the
> interface popa3d is listening on is appended to the VIRTUAL_HOME_PATH.
> So you'll have to set the virtual_domain_root_directory variable in the
> add-popa3d-user script to VIRTUAL_HOME_PATH/127.0.0.1.
> 
(Continue reading)

Barry Veinotte | 4 Oct 19:21 2003
Picon

POP before SMTP Patches not working on FreeBSD 4.6

This is a question from an amature:

I am trying to get some form of POP before SMTP working with
sendmail and popa3d. The solution that is most attractive (after
trying and failing with several) is here:
	http://www.koblenz-net.de/~horn/smtp_after_pop/README

However, the patch will not work on my machine. I get this after
each section: 

patch -p0 < popa3d-0.5.1-smtp_after_pop-1.diff
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|diff -r -u popa3d-0.5.1/Makefile popa3d-0.5.1-smtp_after_pop-1/Makefile
|--- popa3d-0.5.1/Makefile      Sun Oct 28 02:10:49 2001
|+++ popa3d-0.5.1-smtp_after_pop-1/Makefile     Fri Feb  7 12:24:51 2003
--------------------------
File to patch: 

Any hints on what I am doing wrong here? Again, I know not what I do...
Would also love to hear what the easiest implimentation is that works.

Thanks,
Barry

Solar Designer | 5 Oct 13:53 2003

Re: POP before SMTP Patches not working on FreeBSD 4.6

On Sat, Oct 04, 2003 at 02:21:35PM -0300, Barry Veinotte wrote:
> This is a question from an amature:
> 
> I am trying to get some form of POP before SMTP working with
> sendmail and popa3d. The solution that is most attractive (after
> trying and failing with several) is here:
> 	http://www.koblenz-net.de/~horn/smtp_after_pop/README

Why, there're pointers to some POP before SMTP resources off the
popa3d homepage.  Please also see past discussions on this mailing
list, in the archives available via MARC (there's a link from the
popa3d homepage, too).

> However, the patch will not work on my machine. I get this after
> each section: 
> 
> patch -p0 < popa3d-0.5.1-smtp_after_pop-1.diff
> Hmm...  Looks like a unified diff to me...
> The text leading up to this was:
> --------------------------
> |diff -r -u popa3d-0.5.1/Makefile popa3d-0.5.1-smtp_after_pop-1/Makefile
> |--- popa3d-0.5.1/Makefile      Sun Oct 28 02:10:49 2001
> |+++ popa3d-0.5.1-smtp_after_pop-1/Makefile     Fri Feb  7 12:24:51 2003
> --------------------------
> File to patch: 

This means that you are not using patch(1) with that patch file
properly.  Most likely the number of leading path components to split
is wrong (the "0" in "-p0").  You need to check the patch file and
then use the right -pN setting according to the patch file and the
(Continue reading)

Barry Veinotte | 5 Oct 16:10 2003
Picon

RE: POP before SMTP Patches not working on FreeBSD 4.6

Thanks for the help Alexander:

> -----Original Message-----
> From: Solar Designer [mailto:solar@...]
> Sent: October 5, 2003 8:53 AM
> To: popa3d-users@...; barry@...
> Subject: Re: POP before SMTP Patches not working on FreeBSD 4.6
>
>
> On Sat, Oct 04, 2003 at 02:21:35PM -0300, Barry Veinotte wrote:
> > This is a question from an amature:
> >
> > I am trying to get some form of POP before SMTP working with
> > sendmail and popa3d. The solution that is most attractive (after
> > trying and failing with several) is here:
> > 	http://www.koblenz-net.de/~horn/smtp_after_pop/README
>
> Why, there're pointers to some POP before SMTP resources off the
> popa3d homepage.  Please also see past discussions on this mailing
> list, in the archives available via MARC (there's a link from the
> popa3d homepage, too).
>
> > However, the patch will not work on my machine. I get this after
> > each section:
> >
> > patch -p0 < popa3d-0.5.1-smtp_after_pop-1.diff
> > Hmm...  Looks like a unified diff to me...
> > The text leading up to this was:
> > --------------------------
> > |diff -r -u popa3d-0.5.1/Makefile popa3d-0.5.1-smtp_after_pop-1/Makefile
(Continue reading)

Georg Horn | 6 Oct 12:00 2003
Picon

Re: POP before SMTP Patches not working on FreeBSD 4.6

On Sat, Oct 04, 2003 at 02:21:35PM -0300, Barry Veinotte wrote:

> I am trying to get some form of POP before SMTP working with
> sendmail and popa3d. The solution that is most attractive (after
> trying and failing with several) is here:
> 	http://www.koblenz-net.de/~horn/smtp_after_pop/README
> 
> However, the patch will not work on my machine. I get this after
> each section: 
> 
> patch -p0 < popa3d-0.5.1-smtp_after_pop-1.diff
> Hmm...  Looks like a unified diff to me...
> The text leading up to this was:
> --------------------------
> |diff -r -u popa3d-0.5.1/Makefile popa3d-0.5.1-smtp_after_pop-1/Makefile
> |--- popa3d-0.5.1/Makefile      Sun Oct 28 02:10:49 2001
> |+++ popa3d-0.5.1-smtp_after_pop-1/Makefile     Fri Feb  7 12:24:51 2003
> --------------------------
> File to patch: 

First, i have made a new patch that works with popa3d-0.5.1 and Berkley-DB
3.3.x (3.3.11 here). The old one was made on an old SuSE-6.3 System with
sendmail 8.9.3 and Berkley-DB 1.8...  You can download the new patch from:
http://www.koblenz-net.de/~horn/popa3d-0.5.1-smtp_after_pop-2.diff

Then you may run the patch program while you are in the directory containing
the popa3d-0.5.1 subdir:

# ls -1d pop*
popa3d-0.5.1/
(Continue reading)

Solar Designer | 6 Oct 23:22 2003

Re: POP before SMTP Patches not working on FreeBSD 4.6

On Mon, Oct 06, 2003 at 12:00:51PM +0200, Georg Horn wrote:
> First, i have made a new patch that works with popa3d-0.5.1 and Berkley-DB
> 3.3.x (3.3.11 here). The old one was made on an old SuSE-6.3 System with
> sendmail 8.9.3 and Berkley-DB 1.8...  You can download the new patch from:
> http://www.koblenz-net.de/~horn/popa3d-0.5.1-smtp_after_pop-2.diff

I was going to place this in contrib/ but I am getting a 404 Not Found
on that URL.

Why are you using popa3d 0.5.1 rather than 0.6.3 (the latest)?

--

-- 
Alexander Peslyak <solar@...>
GPG key ID: B35D3598  fp: 6429 0D7E F130 C13E C929  6447 73C3 A290 B35D 3598
http://www.openwall.com - bringing security into open computing environments

Georg Horn | 7 Oct 10:09 2003
Picon

Re: POP before SMTP Patches not working on FreeBSD 4.6

On Tue, Oct 07, 2003 at 01:22:36AM +0400, Solar Designer wrote:
> On Mon, Oct 06, 2003 at 12:00:51PM +0200, Georg Horn wrote:

> > http://www.koblenz-net.de/~horn/popa3d-0.5.1-smtp_after_pop-2.diff
> 
> I was going to place this in contrib/ but I am getting a 404 Not Found
> on that URL.

Argl, this must be
http://www.koblenz-net.de/~horn/smtp_after_pop/popa3d-0.5.1-smtp_after_pop-2.diff
of course...

> Why are you using popa3d 0.5.1 rather than 0.6.3 (the latest)?

0.5.1 was the latest when i wrote the patch, and i had no particular reason
to upgrade. Maybe someone here wants to port the patch to 0.6.3?

Bye,
Georg

Jason Bouchard | 7 Oct 16:33 2003
Picon

unsubsribe


-----Original Message-----
From: Georg Horn [mailto:horn@...] 
Sent: 7 octobre 2003 04:09
To: popa3d-users@...
Subject: Re: POP before SMTP Patches not working on FreeBSD 4.6

On Tue, Oct 07, 2003 at 01:22:36AM +0400, Solar Designer wrote:
> On Mon, Oct 06, 2003 at 12:00:51PM +0200, Georg Horn wrote:

> > http://www.koblenz-net.de/~horn/popa3d-0.5.1-smtp_after_pop-2.diff
> 
> I was going to place this in contrib/ but I am getting a 404 Not Found
> on that URL.

Argl, this must be
http://www.koblenz-net.de/~horn/smtp_after_pop/popa3d-0.5.1-smtp_after_p
op-2.diff
of course...

> Why are you using popa3d 0.5.1 rather than 0.6.3 (the latest)?

0.5.1 was the latest when i wrote the patch, and i had no particular
reason
to upgrade. Maybe someone here wants to port the patch to 0.6.3?

Bye,
Georg

(Continue reading)


Gmane