Gunnar Ritter | 1 Mar 01:00 2005
Picon

Re: Fix to allow GMail SMTP connections

rafege@... (Gary E. RAFE, Ph.D.) wrote:

> Working with v11.21, I found that the ssl_open() function
> in openssl.c doesn't look for any possible trailing port numbers
> on the "server" argument, which causes it to fail certification.

That's true, although the calling function in the SMTP code should
strip the port string as it is done with IMAP and POP3. The updated
code will be available in public CVS within six hours or so.

Thank you

	Gunnar

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
Luiz Angelo Daros de Luca | 8 Mar 01:29 2005
Picon

Bug when there is no terminal

Hello,

	While using nail with torque(openBPS), it seems to exit with no error code (error 0) but 
it sends no message at all. Tcpdump shows that nothing was exanged between the client
and smtp server.

	So, trying to discover the problem, I turned on verboseness in nail using (-v). And incredibly,
everything worked! Any ideas?

	My env is more or less like this:

cmd:

tr '\10' '\40' <<EOF | strace nail -~ -s "$SUBJECT" "$TO_EMAIL"
~:set from=$FROM_EMAIL
~:set smtp=$SMTP

`cat`

EOF

============Info ===============
/proc/*/fd:
lr-x------  1 pcarga pcarga 64 Mar  7 21:14 0 -> /tmp/sh-thd-1110223161 (deleted)
l-wx------  1 pcarga pcarga 64 Mar  7 21:14 1 -> /var/spool/pbs/spool/380.talassa.OU
l-wx------  1 pcarga pcarga 64 Mar  7 21:14 2 -> /var/spool/pbs/spool/380.talassa.ER
lr-x------  1 pcarga pcarga 64 Mar  7 21:14 3 -> /proc/4745/fd

================================
strace output:
(Continue reading)

Luiz Angelo Daros de Luca | 8 Mar 01:32 2005
Picon

Fwd: Bug when there is no terminal

Sorry,

/proc/xx/fd was from tail cmd. Nail is this one:

lr-x------  1 pcarga pcarga 64 Mar  7 21:14 /proc/self/fd/0 -> pipe:[2321463]
l-wx------  1 pcarga pcarga 64 Mar  7 21:14 /proc/self/fd/1 -> /var/spool/pbs/spool/380.talassa.OU
l-wx------  1 pcarga pcarga 64 Mar  7 21:14 /proc/self/fd/2 -> /var/spool/pbs/spool/380.talassa.ER

----------  Mensagem reenviada  ----------

Subject: Bug when there is no terminal
Date: Seg 07 Mar 2005 21:29
From: Luiz Angelo Daros de Luca <luizd@...>
To: nail-devel@...

Hello,

	While using nail with torque(openBPS), it seems to exit with no error code
 (error 0) but it sends no message at all. Tcpdump shows that nothing was
 exanged between the client and smtp server.

	So, trying to discover the problem, I turned on verboseness in nail using
 (-v). And incredibly, everything worked! Any ideas?

	My env is more or less like this:

cmd:

tr '\10' '\40' <<EOF | strace nail -~ -s "$SUBJECT" "$TO_EMAIL"
~:set from=$FROM_EMAIL
(Continue reading)

Gunnar Ritter | 8 Mar 02:22 2005
Picon

Re: Bug when there is no terminal

Luiz Angelo Daros de Luca <luizd@...> wrote:

> 	While using nail with torque(openBPS), it seems to exit with no error code (error 0) but 
> it sends no message at all. Tcpdump shows that nothing was exanged between the client
> and smtp server.
>
> 	So, trying to discover the problem, I turned on verboseness in nail using (-v). And incredibly,
> everything worked! Any ideas?

See the description of the "sendwait" variable; "verbose" has the
side-effect of activating the same behavior.

> strace output:
> (attached)

| clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0x2a95d0c550) = 4477

The interesting behavior is within the forked child so you need to
use strace -f here.

	Gunnar

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
Gunnar Ritter | 9 Mar 15:46 2005
Picon

Re: Bug when there is no terminal

Luiz Angelo Daros de Luca <luizd@...> wrote:

> > See the description of the "sendwait" variable; "verbose" has the
> > side-effect of activating the same behavior.
> Setting "sendwait" on and verbose off worked too.
> [...]
> That's great! :-P Using "strace -f", nail sent the mail. Strace must interfere 
> in the fd/[012] behavior. I think something strange is happening here...

If you want us to help you with this, send a complete and self-contained
script to reproduce the behavior. Something that "is more or less like"
the example from your first mail works without any problems for me (and,
obviously, for the many people who use nail from cron-jobs or various
other scripts too).

Also continue to send to the mailing list. My previous private reply only
told you not to send long texts _twice_ there.

	Gunnar

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
matts | 16 Mar 18:56 2005

Maybe some changes for the nail man page regarding the forward command

This email is referring to the nail.1 man page included in the 11.21
(2/19/05) source.

I find the forward command extremely useful and certainly, as Gunnar has
said in previous posts to this list, more appropriate in some cases than
the resend command.

After reading the man page and refining my setup, I got results that were
different than I expected.  Often that is a personal problem with me, but
I submit some changes for consideration.  What I was trying to do was to
forward an email with all its attachments (so forward-as-attachment was
set), but I was trying to limit which headers were included from the
original message.

Below I list the four pieces from the man page with possible
modifications, but like I said, I might be the only one to who this wasn't
already obvious.

----------------------------------------------
The current man page states:

   forward-as-attachment
          Original messages are normally sent as inline text with
          the  forward command, and only the first part of a mul-
          tipart message is included.  With this option, messages
          are sent as MIME message/rfc822 attachments, and all of
          their parts are included.

Maybe modify with something like:

(Continue reading)

Gunnar Ritter | 17 Mar 16:14 2005
Picon

Re: Maybe some changes for the nail man page regarding the forward command

matts@... wrote:

> Below I list the four pieces from the man page with possible
> modifications, but like I said, I might be the only one to who this wasn't
> already obvious. [...]
> Any opinions?

I am always open for documentation enhancements. When I am writing the
reference documentation for something I have just implemented, I have
of course a different understanding of it than somebody who is reading
the manual page later, so it is well possible that my descriptions are
not comprehensive enough.

I would only request to send such proposals as unified diffs against
the original text in the future since it is easier to see the actual
changes with this format.

Your proposals are now in the manual page. Thank you.

	Gunnar

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
matts | 17 Mar 18:32 2005

Re: Maybe some changes for the nail man page regarding the forward command

 > From Gunnar.Ritter@...  Thu Mar 17 10:15:12 2005
 > From: Gunnar Ritter <Gunnar.Ritter@...>
 > To: nail-devel@..., matts@...
 > Subject: Re: [nail-devel] Maybe some changes for the nail man page regarding
 >  the forward command
 >
 > matts@... wrote:
 >
 > > Below I list the four pieces from the man page with possible
 > > modifications, but like I said, I might be the only one to who this wasn't
 > > already obvious. [...]
 > > Any opinions?
 >
 > I am always open for documentation enhancements. When I am writing the
 > reference documentation for something I have just implemented, I have
 > of course a different understanding of it than somebody who is reading
 > the manual page later, so it is well possible that my descriptions are
 > not comprehensive enough.
 >
 > I would only request to send such proposals as unified diffs against
 > the original text in the future since it is easier to see the actual
 > changes with this format.

Yes, of course.  That is easy enough.  Sorry about that.

Matt S

 >
 > Your proposals are now in the manual page. Thank you.
 >
(Continue reading)

Gunnar Ritter | 20 Mar 16:22 2005
Picon

nail 11.22 released

Hi,

to celebrate the fifth anniversary of the project, nail 11.22 has been
released and is available from <http://nail.sourceforge.net> as usual.
Changes are:

[11.22] released 3/20/05
* In threaded mode, the thread structure is now shown using line-drawing
  characters in the header summary. (This looks best on a UTF-8 terminal.)
* If a message contains both a 'References' and an 'In-Reply-To' header
  field, 'In-Reply-To' is now preferred for threading and the ',' address.
* When a message part of content-type text/anything is written with the
  pipe-type/subtype mechanism, it is now converted to the character encoding
  of the locale (as it was before 11.14 or so).
* When using a hostname with a port number attached with SMTP STARTTLS,
  strip the port number for correct host name verification (Bugreport by
  Gary E. Rafe).

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
Tivon Luker | 21 Mar 23:13 2005
Picon

Unable to insert messages with attachments

I am using nail 11.22 and when composing a message from the & prompt I am 
unable to include a message with an attachment. For example:

& mail bob
Subject: Test
~F54
temporary mail file: Success
Interpolating: 54&

as you can see I am simply dropped back to the & prompt and the message is 
not sent. Any suggestions in this matter?

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click

Gmane