Arnold | 30 Jul 19:50 2006
Picon

broken link - mailing list seems lost


Tim | 6 May 14:52 2006

Running an external executable?

I'm sure this question must come up a lot, but I get a "page not 
found" error when trying to search the mailing list archive, and I've 
just spent over an hour googling and found no solution (only other 
people asking the same question, but no responses).

Is it possible to run an external executable from the shell? If so, 
how? Typing the name of the executable as you would normally do in any 
other shell results in a "not found" error.

This is currently stopping me from being able to use tomsrtbt, which 
is a pity because it would otherwise be exactly what I need :-(

Thanks in advance!

Joseph Jones | 28 Aug 01:03 2005
Picon

Having trouble with a PCMCIA NIC

Okay, I'm trying to use Tom's to do this:
http://www.damnsmalllinux.org/network-install.html Unfortunately, my
card doesn't work off the bat, so I've made the changes to config as
detailed here: http://linuxgazette.net/110/tag/6.html and restarted
the PCMCIA service, but I still get a message saying that the card in
slot 0 is unsupported. Anybody have any ideas? I'm wondering whether I
need to put in an add-on or something.

Any help much appreciated :)

Joe

John Lumby | 14 Feb 04:36 2005
Picon

version of diff / diff3 for libc5?

I'm starting to need diff more and more in my tomsrtbt.     As far as I can 
see there isn't one.   I can't get into the mailing list archives to check - 
not.toms.net tells me
       Not Found
       The requested URL /cgi-bin/wilma/tomsrtbt was not found on this 
server

I tried building my own diff using the libc5 environment but can't get it to 
compile.    I suppose I might get there eventually but at this point - 
hoping someone can direct to me to a diff/diff3 for libc5???

John

Tom Oehser | 1 Dec 05:41 2004
Picon

Wiki is up,,, sort of,,,


The tomsrtbt wiki is back up.

The searchable email list archive is not, not sure when I'll get that back up.

-Tom

Tom Oehser | 29 Nov 03:26 2004
Picon

twiki / apache compromised


Tomsrtbt wiki users:

There was a bug in TWiki, which wasn't announced well, and the toms.net
apache/twiki user was compromised.  Probably they just ran a spam relay
for a while or something, there were a couple of processes running.  It
doesn't look like they were able to escalate privileges beyond just the
apache id.  It _does_ mean that they could download the .htpasswd file,
used for TWiki user ids / passwords, maybe download it and try to crack
the passwords.  If anyone used a common password for the tomsrtbt twiki
and other accounts that are important, it might be wise to change them.

I'll have Apache and TWiki back up sometime in the next couple of days,
I'm going to be conservative and reinstall anything that was under that
id, even though I don't think they replaced Apache or TWiki stuff it is
best to be paranoid when cleaning up something like this.

-Tom

Tom Oehser | 10 Sep 17:05 2004
Picon

Re: your mail


On Fri, 10 Sep 2004, C Craig wrote:

> Date: Fri, 10 Sep 2004 15:46:56 +0300
> From: C Craig <cwcraig <at> blueyonder.co.uk>
> To: Tom <at> Toms.Net
>
> Hi Tom
> could you please explain to me what is afloppy disk
>

See:

http://en.wikipedia.org/wiki/Floppy_disk

-Tom

Wm. G. McGrath | 24 Aug 16:42 2004
Picon

Re: bios woes

On Mon, 23 Aug 2004 08:59:56 -0600
Cary Jamison <cary_jamison <at> symantec.com> wrote:

: This is what I suspect his problem his, also.  More explicitly,
: the 'file not found' error is caused by not being able to find one
: of the shared libraries needed.  You can verify this by typing
: 'ldd cmospwd' and see what libraries and versions it expects.  The
: solution is as Robert said above - I would first try a static
: link, strip it and compress it to get it small enough to fit on a
: floppy. 

Yes. This is exactly what I did. ldd returned the following two
links:	libc.so.6 => /lib/lib.cso.6 (0x40018000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

gcc with -static did the job, followed by gzip. Strictly sneakernet.

	b.

Wm. G. McGrath | 23 Aug 19:35 2004
Picon

Re: bios woes

On Sun, 22 Aug 2004 15:44:53 -0400 (EDT)
"Tom Oehser" <Tom <at> toms.net> wrote:

: > "filename": not found. ???
: 
: What isn't found is the glibc shared c library
: version 6.  Tomsrtbt is based on libc5.
: 
: Try linking with -static.

Bingo! 

The files were huge and I had to compress them to get them on a
floppy, but they both worked like a dream, and I walked into the
CMOS like smoke. :)

	kudos - bigtime

	bill

Wm. G. McGrath | 22 Aug 16:45 2004
Picon

Re: bios woes

On Fri, 20 Aug 2004 08:51:23 -0700
Arnold Wiegert <awiegert <at> telus.net> wrote:

: Quite often there is a jumper to remove power from the CMOS
: memory, where the password is kept - presumably. Removing the
: jumper and keeping it off for some time - like about 10 min IIRC,
: may/should return the machine to no password.

This board is a little different. It does have a jumper J1 marked
RTC reset. But it doesn't seems to have any affect. Normally it's
open and as with any Ami Bios you hit delete to enter the bios at
boot. But you get prompted for the current password before you can
enter the bios, and of course I don't have it. 

So I've tried to boot with J1 set to closed. The bios still wants
the current password.

Adapting your suggestion, I've left J1 closed overnight with the
power off. Rebooting still wants the password.

And I left the power on with the jumper set for half an hour and
then tried to reboot but the box still wants a password.

One item I found suggested that the CMOS may take days to empty and
another said to be sure and leave the box unplugged as well as off
to eliminate any AC power to the CMOS. Another said that the
DS1287/1187 isn't affected by the reset jumper and can't be reset
without the password. :\ Real encouragement there, eh?

Thanks for the advice btw, in a week of googling I'd not come across
(Continue reading)

Wm. G. McGrath | 20 Aug 15:53 2004
Picon

bios woes

Hi all,

I'm locked out of the bios on an old 486 box. It works and I can
boot with Tom's disk, but I need to be able to read the cmos
password on an old Realtek 1287/1187 combo clock/battery/cmos. I've
found a small utiltity that I can compile, cmospwd-4.3, but alas -
no gcc. I've tried lists of 'universal' passwords without success.
Can anyone recommend another utility I can run with Toms's from a
second floppy, something else to try, or a pointer maybe?

	tia,
	b.


Gmane