Lee Essen | 26 Jan 17:29 2015
Picon

multiple pppd instances -- resolv.conf challenges and suggested improvement

Hi,

I’ve hit a bit of a challenge with the way that pppd creates the resolv.conf file.

Basically if you want to get dns servers from the other side you need ‘usepeerdns’ set.

If you set ‘usepeerdns’ then pppd will create resolve.conf (/etc/ppp/resolv.conf as standard,
although changed in many dists)

The challenge is that if you have two pppd’s running, both getting DNS entries, then there is no way to
specify a different file (so that you can be clever later) and the given file will be overwritten by the most
recent connection. Also, with buiildroot builds the path is set to /etc/resolv.conf which causes even
more of a problem since you can’t ‘usepeerdns’ without making your system use the provided resolvers.

It does feel wrong that just about every other aspect of pppd supports isolated multiple connections, but
the resolv.conf file is a single path that will get overwritten by the last connection, and then, of
course, if that connection drops the file is then incorrect!

Could I suggest a ‘noresolv’ config option that simply suppresses the creation of the resolve.conf
file?  It’s a very simple patch, has no compatibility issues with existing configuration and makes it
possible to use ppp-up scripts to do the heavy lifting with no conflicting resolv.conf creations. This
would also allow buildroot users to avoid the “forced use of peer dns”.

(The other option would be to have a configurable path for resolv.conf)

Cheers,

Lee.

diff -Naur pppd-orig/pppd/ipcp.c pppd-2.4.7/pppd/ipcp.c
(Continue reading)

Matt Dooner | 23 Jan 12:56 2015
Picon

pppd hangup only when traffic sent over connection

Hello,

I'm experiencing an issue where pppd hangs up, but only when traffic
is sent over the connection. The connection is stable if it is idle,
but soon after any traffic is sent over the connection pppd hangs up.
For example, 15-30 pings or a few lines into a telnet session kills
the connection. I suspect this is the result of a lack of support for
a Link Quality Report (which is Confreq'd by the target).

As you can see in the debug about below if-down is started after the
"rcvd [LCP ConfReq id=0xf0 <mru 400> <quality lqr 00 00 01 2c> <magic
0xc0a80ea5> <pcomp> <accomp>]". This ConfReq occured after 17
successful pings over the link, and the link went down after the
ConfReq. Is this expected behaviour?

Thanks in advance,
Matt

using channel 14
Using interface ppp0
Connect: ppp0 <--> /dev/ttyO1
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9ad4ff1a> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0xd5 <mru 400> <quality lqr 00 00 01 2c> <magic
0xc0a80ea5> <pcomp> <accomp>]
sent [LCP ConfRej id=0xd5 <quality lqr 00 00 01 2c>]
rcvd [LCP ConfRej id=0x1 <asyncmap 0x0>]
sent [LCP ConfReq id=0x2 <magic 0x9ad4ff1a> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0xd6 <mru 400> <magic 0xc0a80ea5> <pcomp> <accomp>]
sent [LCP ConfAck id=0xd6 <mru 400> <magic 0xc0a80ea5> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x2 <magic 0x9ad4ff1a> <pcomp> <accomp>]
(Continue reading)

"Antonio Viñal" | 16 Jan 21:56 2015
Picon

Please respond!!!

Please respond!!!
Hello friend!

I would like to contact you personally for an important proposal that
could of interest to you.
I send this email only to know if this email address is functional.
I have something very important to discuss with you. Contact me for
details by:  Email: fernrodyup12 <at> aol.jp with your direct contacts.

Kind regards.
Antonio Viñal.

--
To unsubscribe from this list: send the line "unsubscribe linux-ppp" in
the body of a message to majordomo <at> vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Matthias-Christian Ott | 13 Jan 18:33 2015

ppp_async: ioctl to set MTU needed

Some months ago I filed the following bug report (with some sentences
corrected) on the Kernel Bug Tracker but have received no reaction
reaction so far:

Summary: ppp_async: ioctl to set MTU needed

The MTU of a channel of a Multilink PPP link is set from the MRU of a
Configure-Ack LCP packet. However, just because the is able to receive
packets of a certain size it doesn't mean that the link or the sender
are able to transmit packets of that size, so the received MTU of the
channel should not be set to the MRU of the peer.

A practical example is PPP encapsulated in GRE or L2TP over IPv6
(without fragmentation). Peer A sets its MRU to the link MTU minus
maximum IP header length minus GRE/L2TP header length to be able to
receive packets of maximum length over PPP. Peer B connects to peer A
and the maximum payload size, which is derived from the Path MTU, of the
tunnel between peers A and B is lower than the MRU of peer A. If peer B
sends a packet P smaller than the MRU of peer A and larger than the
maximum payload size of the IP packet encapsulating P, it will exceed
the Path MTU and thus will be rejected and never arrive at peer A. Such
scenario is common for VPNs that use PPP or to transport PPP sessions of
broadband/Internet subscribers (e.g. if one ISP manages the physical
network and another ISP provides Internet access and is the endpoint of
the PPP session that runs over the physical network and the PPP session
is transported over IPv6). IPv4 was able to fragment IP packets larger
than the Path MTU, so setting the MTU to the MRU of peer a worked. With
IPv6 (without fragmentation) this no longer works.

As a workaround I patched pppd and sent a Configure-Nak with the correct
(Continue reading)

MR. MORGAN W. THABO | 12 Jan 19:09 2015
Picon

(unknown)


DEAR FRIEND, 

PLEASE OPEN THE ATTACHED FILE, CAREFULLY GO THROUGH MY PROPOSAL AND GET BACK TO ME AS SOON AS POSSIBLE. 

BEST REGARDS, 

MR. MORGAN W. THABO. 
Attachment (Fund Transfer.doc): application/msword, 43 KiB
fernalynbuendia | 28 Dec 12:30 2014

A recommendation from Friend, screw college, I'm dropping out


Hello,

Hey!

I told you I wouldn't let you down!

First, thanks for putting up that cash so we could keep production on track. I really appreciate it.

Just give me another week and I'll have that $20k back in your pocket.

I've found something that can fund this whole project here:

==> (   http://tinyurl.com/buendia915   )

I'll pay you back and put in for the rest of the film myself.

We'll be showing “Mass Plan” at Cannes next year - guaranteed!

Best,

Fernalyn Buendia

Click below to view the webpage that your friend has recommended:

Friend, screw college, I'm dropping out has used the Tell-a-Friend form to send you this link.

We look forward to your visit!

--
(Continue reading)

oht@openbsd.se | 23 Dec 09:06 2014
Picon

pppd 2.4.7 for bsd

Hi
I'm using pppd to connect to my ip provider via umts.
In the present OpenBSD there is a very old version of pppd included, 2.3.5.
In order to have my resolve.conf updated after switching to some wifi provider I needed the "usepeerdns".
It is not included in version 2.3.5.
Finding out that NetBSD is using a patched version of 2.4.4, I modified that for my OpenBSD. 
It worked for my purpose.
After that it was quite easy to upgrade it to your 2.4.7 level.
If it is of any use for you, I can provide diffs, new sys-bsd.c and new Makefile.bsd for 2.4.7
It works on OpenBSD and compiles on FreeBSD and NetBSD.
 -- 
oht <at> openbsd.se <ole.hellqvist <at> openbsd.se>
--
To unsubscribe from this list: send the line "unsubscribe linux-ppp" in
the body of a message to majordomo <at> vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

fernalynbuendia | 23 Dec 02:33 2014

A recommendation from Fernalyn Buendia


Hello,

How Does $1,853.72/day sound? (It's $45K/mo)
-------------



MCB gives YOU a rare opportunity to 
multiply YOUR GAINS by 10X with its 
completely automated app. 

YOU can now CASH IN BIG TIME without 
having to move a finger....

...As MCB will not just show how to 
multiply your income 10x but also it 
will do it for you.

So from now on, you can relax and forget 
about how to increase your income, 
MCB will do it for you...

Now that’s something I say...
But you don’t have to trust my words...

You can actually VIEW what 223 ordinary 
people are obtaining each from this 
amazing app...

(Continue reading)

arthurpaulino | 18 Dec 21:49 2014
Picon

PPP compression

Hello,

I saw this e-mall address at http://ppp.samba.org/resources.html.
We do have some questions about ppp. About ppp compression, to be more
specific.

We need to decompress the payload of some packets to verify if they are
encrypted on Android devices.

We configured a PPTP VPN server with no encryption. The compression
algorithm negotiated during the connection phase is Deflate.

For instance, in these packets

19:59:09.883213 IP 191.10.97.74 > 200.129.43.196: GREv1, call 1152, seq
106, length 51: compressed PPP data
	0x0000:  4500 0047 cc42 4000 402f 59ab bf0a 614a
	0x0010:  c881 2bc4 3001 880b 0027 0480 0000 006a
	0x0020:  ff03 00fd 005c 02f7 1e3f 8327 ce85 cfc1
	0x0030:  13e8 4b86 80ff 8d1c 6eb0 dee3 7f23 e4de
	0x0040:  e3ef 4258 ef11 00
19:59:09.884437 IP 191.10.97.74 > 200.129.43.196: GREv1, call 1152, seq
107, length 43: compressed PPP data
	0x0000:  4500 003f cc43 4000 402f 59b2 bf0a 614a
	0x0010:  c881 2bc4 3001 880b 001f 0480 0000 006b
	0x0020:  ff03 00fd 005d 026b 5e04 4edd 294b e09a
	0x0030:  5f31 04e8 0547 0ac0 34d7 4fc3 ae19 00
19:59:09.885609 IP 191.10.97.74 > 200.129.43.196: GREv1, call 1152, seq
108, length 44: compressed PPP data
	0x0000:  4500 0040 cc44 4000 402f 59b0 bf0a 614a
(Continue reading)

luv2charitys | 14 Dec 03:03 2014
Picon

charity message

Hello,this is Mr Paul N,i sent you an email on charity work but i am yet
to hear fom you,do reply with this code CHA-2015 to my email address
paulcharity <at> qq.com  i Look forward to hearing from you this time,God
bless  Brother Paul 
--
To unsubscribe from this list: send the line "unsubscribe linux-ppp" in
the body of a message to majordomo <at> vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

ryd994 | 12 Dec 07:36 2014

Is it possible to use secret file to assign each user an ip while auto negociate?

To whom can help with this uncommon case:

I'm setting up a pptp server for a small group of users. For security,
I want all activity across my server can be traced,
so I want username one-to-multi mapped to address assigned.

I first tried with only one static address for each user. It works out
well until second connection with same username joined.
All clients used same username to authenticate got same address negotiated.

Then I used a subnet range, e.g. 192.168.2.128/25 . It failed because
pppd can't propose an address
to client while client didn't requesting one either. The log shows:
"
Could not determine remote IP address: defaulting to 10.64.64.65
Peer is not authorized to use remote address 10.64.64.65
"
Then server disconnected.

I also tried add a plus sign 192.168.2.128/25+ , and it didn't work
either, pppd can't determine a remote address.

What is the typical use of the "plus sign" format? and how should I
build a server-assigned one-to-multi mapping
from user to address?

Thank you,

--
To unsubscribe from this list: send the line "unsubscribe linux-ppp" in
(Continue reading)


Gmane