Stas Sergeev | 20 Sep 19:27 2014
Picon

merge devel and release something

Hi.

I think enough is enough, and I am going to merge
devel branch into master and then perhaps upload
the tarballs.
People do not know about the devel branch, but it
works much better than master.

The only reason I didn't merge devel before, is because
it has this commit:
https://sourceforge.net/p/dosemu/code/ci/a1dff2a15698efc4f400812993ec819ea7091439/
which Bart called a re-licensing. I of course do not
want to do any re-licensing, but the intention of that
change is to allow contributing under "GPLv2 or later".
We already have enough of such a code (all my code,
and not only that), so that clause I removed, was
invalidated long ago. There is simply no other way than
to remove it.

So if there is no evidence this is something that should
not be done, I am going to merge things. devel right
now includes over a year of development! It can't be
allowed to rot.

------------------------------------------------------------------------------
Slashdot TV.  Video for Nerds.  Stuff that Matters.
http://pubads.g.doubleclick.net/gampad/clk?id=160591471&iu=/4140/ostg.clktrk
Stas Sergeev | 3 Jun 21:32 2014
Picon

Re: Running win.com from Chicago (alpha version of Win95)

03.06.2014 22:31, Eric Auer пишет:
> Hi!
>
>> The proper win31 support happened because an author of hx
>> extender shared a few tricks with us how to do that. That even
>> involved things contradicting with the dpmi specs. He wrote
>> hdpmi server that was able to run win31 before dosemu did.
> Interesting! When was that and which anti-specs features
> were required? Maybe you can email details to the list?
Eric, there is no secret here, but this was so long ago
that it is mostly lost.
What do you want to do with that info? Write your own
dpmi server?
For example he suggested to alter the exception routing
rules. While dpmi spec says unhandled exceptions 1..5 and 7
should generate real-mode interrupts, he suggested to
call the protected-mode handlers instead, and if there
are none - terminate the client, but never call the real-mode
interrupt the way spec does.
Also there are many undocumented things, for instance,
the limit of LDT selector must dynamically grow when
you allocate the descriptors in LDT.
There is a summary on undocumented DPMI:
ftp://ifctfvax.harhan.org/pub/micro/msdos/above640k/TrueDPMI/dpmiext.txt
but it documents actually nothing of what we didn't know
ourselves. The most important and difficult to discover
things are not in that doc.

After that, I did an attempt to port dosemu's PM api
translator to DOS. The idea was to make it runnable
(Continue reading)

Stas Sergeev | 1 Jun 10:35 2014
Picon

Re: Running win.com from Chicago (alpha version of Win95)

30.05.2014 01:39, Julius Schwartzenberg пишет:
> Yes, of course. But it'd still be really cool if it could work in 
> DOSEMU :) 
Were you running it after booting in its own DOS?
It will not work with freedos or even MS-DOS other
than its own.

Also, are you aware about HX dos extender?
It has a win32 support built-in and works in dosemu.
Of course I admit that running a kind of win95 would
be a good demo of dosemu's abilities. :)

------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
_______________________________________________
Dosemu-devel mailing list
Dosemu-devel <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/dosemu-devel
Julius Schwartzenberg | 29 May 12:22 2014
Picon

Running win.com from Chicago (alpha version of Win95)

Hi,

When I run win.com from Chicago in DOSEMU, I immediately get my prompt
back. It seems nothing happens then. Could it be possible that some
detection that Windows is already running is triggered and that win.com
is written to not do anything then?

Did anybody every try to run Chicago in DOSEMU?

Best regards,
Julius

------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
Frantisek Hanzlik | 28 May 10:14 2014
Picon

DPMI in

Hello Stas,

if I understand it from Your last devel branch changes, from Linux
kernel 3.14+ will no longer be possible to use DPMI on i386 systems
in VM86 mode?
It would be annoying thing for me, because I use 32-bit systems for
all my DOS apps, due to significantly higher performance over both
emulation modes.
Please, what is reason for this step? Linux kernel developers have
always emphasized the need for kernel API preservation, what happened
in this case?
It will affect other emulators (wine, qemu) too?

Thanks, Franta

------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
Frantisek Hanzlik | 5 May 14:26 2014
Picon

updated DOSEMU-FreeDOS package

Hi Bart and all,

Luční 502           Linux/Unix/LAN/Internet       Tel: +420-372-222302
33209 Štěnovice    e-mail:franta@...      Fax: +420-372-222302
hoping that it will be useful, I have mapped and updated some
dosemu-freedos utilities to their current versions.
Thanks to the peoples of dosemu and FreeDOS mailing list for their
comments.
Updated package may be downloaded at:
http://www.hanzlici.cz/packages/dosemu-freedos/dosemu-freedos-1.1-pre1-bin.tgz

Changes between dosemu-freedos-1.0 and this updated version may be described
as (if isn't new version, then component remained the same):

COMPONENT     CurVers   NewVers   COMMENT
assign          1.4
attrib          2.1
bwbasic         2.20 -> 2.50    (with OpenWatcom patch?)
choice          4.4
command         0.84-pre2 XMS_Swap [Aug 28 2006 00:29:00]
comp            1.03    #retained, current 1.04 has only copyright added)
cpidos          2.0 -> 3.0
debug.com       0.98 -> 1.26
deltree         1.02f -> 1.02g
diskcomp        06jun2003
diskcopy        0.94 beta -> 0.95 beta
display         0.13b
edit            0.7d -> 0.9a            # 0.7d was UPXed, 0.9a not
edlin           2.8 -> 2.15
exe2bin         1.0 -> 1.5      # Copying-policy: GPL -> OW Public License
(Continue reading)

Stas Sergeev | 4 May 18:39 2014
Picon

vbios imported

Hi.

In a hope to get some VGA-related bugs fixed for
free, I have imported the vgabios code from here:
http://savannah.nongnu.org/projects/vgabios

The bugs I was hoping for, are however not being
fixed by that, and in fact likely a couple more is added...
But I like to have a clean separation between vga emulation
and vga bios, so I think this is a good thing to do in
general. And it works surprisingly well for the such a
quick port, it took only one day to get the things working.

Would like to hear what others think.
The experimental git branch is called 'vbios_tweaks'

------------------------------------------------------------------------------
"Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
Instantly run your Selenium tests across 300+ browser/OS combos.  Get 
unparalleled scalability from the best Selenium testing platform available.
Simple to use. Nothing to install. Get started now for free."
http://p.sf.net/sfu/SauceLabs
Frantisek Hanzlik | 4 May 00:33 2014
Picon

more compute rows badly, or dosemu not set correct video page size?

Hi DOSEMU and FreDOS developers,

FreeDOS 'more' command (tried both 4.2 and 4.3 versions) isn't working
correctly under DOSEMU when used in screen resolutions other than 80
columns x 25 rows. From its code (function GetScreenSize() in more.c)
it seems as more compute no. of screen rows from BIOS data area, from
40h:4Ah (Columns on screen) and 40h:4Ch (Video page size) values,
using formula:
ROWS=Video page size / Columns on screen / 2

which in this case give bad results, as Video page sizes are multiples
of 4k (number of columns is OK). Here is what Video page size values
are returned in certain text modes:

80x25	- 40:4C=0x1000=4096, more has 25 rows. 80x25x2=4000=0xFA0
80x43	- 40:4C=0x2000=8192, more has 51 rows. 80x43x2=6880=0x1AE0
80x50	- 40:4C=0x2000=8192, more has 51 rows. 80x50x2=8000=0x1F40
80x60	- 40:4C=0x3000=12288, more has 76 rows. 80x60x2=9600=0x2580
132x25	- 40:4C=0x2000=8192, more has 31 rows. 132x25x2=6600=0x19C8
132x43	- 40:4C=0x3000=12288, more has 46 rows. 132x43x2=11352=0x2C58
132x60	- 40:4C=0x4000=16384, more has 62 rows. 132x60x2=15840=0x3DE0

>From some informations on net (e.g. here:
http://marc.info/?l=freedos-dev&m=106291977718089&w=2
) it seems as video page size isn't reliable/suitable for no. of rows
on screen computing - but I'm not sure, as this may be DOSEMU bug
as well. I want to report a bug, but what? DOSEMU, or 'more' command?

Note that 'mode con' properly report no. of cols/rows, and when I in
'more' use 40h:84h (Rows on screen minus one) value (i.e. patch as
(Continue reading)

Frantisek Hanzlik | 21 Apr 01:37 2014
Picon

FreeDOS freecom not know 'loadhi', display not know 'vga' (?)

Just when I tried pure autoexec.bat file from latest dosemu-devel,
I bump to problem with loading display.exe. Line 14 in autoexec.bat
is 'rem loadhi display con=(vga,437,2)', but when uncommented, then
give me two errors:

1) 'FreeCom version 0.84-pre2 XMS_Swap [Aug 28 2006 00:29:00]' which
is in dosemu-freedos-1.0-bin.tgz tarball referenced at:

http://prdownloads.sourceforge.net/dosemu/dosemu-freedos-1.0-bin.tgz?download

not know 'loadhi' command; only 'lh' may be used.

2) display-0.13b report error:

FreeDOS DISPLAY ver. 0.13b
Syntax error (006) Unknown hardware device name

when I retain its parameters. But when I use 'ega' instead of 'vga',
then all is fine. I not know, when it is display.exe problem (it's
documentation say that 'vga' is allowed) or dosemu problem (e.g.
it emulate only EGA card and not VGA).

According this, and as this autoexec.bat file has in its head that
it should be for DOSEMU + FreeDOS, maybe this change should be better:

--- dist/autoexec.bat.old	2014-04-21 00:38:46.273663431 +0200
+++ dist/autoexec.bat	2014-04-21 00:50:12.053661641 +0200
 <at>  <at>  -11,7 +11,7  <at>  <at> 
 lredir d: linux\fs%DOSDRIVE_D%
 :nodrived
(Continue reading)

Frantisek Hanzlik | 20 Apr 18:36 2014
Picon

weird lines in boot.log after 'g_printf("CONSOLE MSG:...'

Hello, I (want minimize boot.log for bug report) noticed a strange
lines in boot.log, that I can not explain. They begins with '3d4 '
string, then is character '{' (mostly, but sometimes also '>' or '<')
and then 1-4 hexadecimal digits. These lines occurs after INT10
debug output (then are usually two):

Do INT0x10: Using caller_function()
INT10: near fc00:00000114
INT10: AH=0e AL=53 'S'
3d4 { 30e
3d4 { 210f
...
Do INT0x10: Using caller_function()
INT10: near fc00:00000114
INT10: AH=0e AL=72 'r'
3d4 { 30e
3d4 { 230f

but I see more also:

INT10: cleared screen: screen_adr b8000
3d4 { e
3d4 { f
3d4 { e
3d4 { f
3d4 { e
3d4 { f
3d4 { e
3d4 { f
3d4 { e
(Continue reading)

Frantisek Hanzlik | 20 Apr 13:07 2014
Picon

dosemu devel from git start DOS only from C:?

Hello, I just trying compile and run last dosemu devel branch, with
dosemu dosemu-freedos-1.0-bin.tgz and it see as now dosemu starts dos
from drive C: (resp from '~/.dosemu/drives/c', which is symlink to
 '~/.dosemu/drive_c' - where are only autoexec.bat, config.sys and
tmp/). Thus dosemu will not find DOS and ends with message:

Sorry, there is no operating system here:
/home/hanzlik/.dosemu/drives/c

Please try to install FreeDOS from dosemu-freedos-*-bin.tgz

Just when I copy FreeDOS 'kernel.sys' (from 'D:', which is symlink
'~/.dosemu/drives/d' pointing to '/usr/share/dosemu/drive_z', where
dosemu-freedos-1.0-bin is installed/unpackaged) to 'C:'
('~/.dosemu/drives/c') and dosemu starts fine.

Please, it is intended to be DOS started from C: now? IMO in earlier
(maybe 'stable' version) was DOS started from drive D: (and this is
perhaps still supposed in config.sys, where commands refer to D: and
as lately as its end is DOS lredir-ed to Z:)
Or I'm doing some mistake?

Thanks, Franta

------------------------------------------------------------------------------
Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and their
applications. Written by three acclaimed leaders in the field,
this first edition is now available. Download your free book today!
http://p.sf.net/sfu/NeoTech
(Continue reading)


Gmane