sfeebots454 | 6 Feb 10:54 2016

Completed CLFS the kernel is now well behaved

Tested Binutils after completing Chapter 10 it tested good (3 known failures). 40 minutes into testing GCC
had a power failure with no UPS installed, so I just skipped testing and continued on to he end of the book. 

Running Kernel version 4.0.0 (needed for skylake) the new OS is working but does not have ethernet.
Journalctl shows firmware blobs not handled nicely and udev does not rename eth0. Need to set kernel
parameters correctly. Found that Sparky has a kernel config file saved so I will use kernel 3.4 stable and
use that config as a starting point. 

Ncurses still had funky behavior in menuconfig. First time it worked correctly but on subsequent uses the
bottom bar did not highlight in chroot or boot. A recompile cured that.

Am restarting using Sparky. Found that Ncurses 6.0 requires AWK=gawk to avoid the compilation errors in
Chapter 6.10. I understand that this exact problem started in Ncurses 5.9 with GCC 5.x. The developers
think perhaps GCC 5.x causes a timing problem in mawk/gawk and that the problem was solved in 6.0, but it
still remains.

The Debian distro installs both gawk and mawk then uses an /etc/alternatives/awk file to prioritize gawk.
If Ncurses .configure finds mawk installed it does not look for gawk. Using Fedora (which has only gawk
installed) the problem never occurred.

Thank you for CLFS it is a great learning tool,     Leon
sfeebots454 | 28 Jan 13:10 2016

Binutils Chapter 10.25 Tests

Installed BC out of order and the relro_test.sh passed but the other 10 failures remained.

Noticed that during the tests my Fedora 23 produced an SELinux AVC message.

I read online that Fedora is not the friendliest distro for LFS/CLFS. So before I started I ran # restorecon
-R /mnt. I thought at the time that any files added after this command would not be subject to that command. I
should have been disabling SELinux with # echo 0 > /selinux/enforce before I entered a CLFS build session.

Disabled SELinux and got the same results.

Have used both Fedora 23 and Sparky Linux with the same results, so I do not think SELinux is a real problem. I
have "switched horses in mid stream" to use Sparky and restart at the beginning of Chapter 10. 

The book said to not skip the tests for GCC, Binutils, and Glibc. I will keep the uncompressed directories in
which these packages were built and run the testsuites just before Chapter 11.

This last course sounds more correct. Will get back to you with the results.

Thanks,   Leon
sfeebots454 | 27 Jan 07:48 2016

Host system missing needed packages

On my eleventh attempt at CLFS/LFS the Binutils-2.25 produced using GIT-20160119-x86_64-Multilib
failed 11 tests as it did in the previous attempt.

11 of 213 tests failed
See testsuite/test-suite.log

Just dealing with the first failure:

FAIL: relro_test.sh

../../../binutils-2.25.1/gold/testsuite/relro_test.sh: line 63: dc: command not found
../../../binutils-2.25.1/gold/testsuite/relro_test.sh: line 64: dc: command not found
../../../binutils-2.25.1/gold/testsuite/relro_test.sh: line 66: test: : integer expression expected
PT_GNU_RELRO segment does not end at page boundary.

63  RELRO_END=`echo "16o 16i $RELRO_START $RELRO_LEN + p" | dc`
64  REM=`echo "16i $RELRO_END $LOAD_ALIGN % p" | dc`
66  if test "$REM" -eq 0; then

I believe my failed attempts all have to do with missing dependencies that break glibc, binutil, GCC and
others. In truth the core packages have always failed a few too many tests.

The developers of CLFS/LFS must not use "off the shelf" workstation distros. In that you add a developers
layer on top of the distro you must be adding background packages that are not commonly installed in binary distros.

Please recommend a distro that will support skylake hardware (kernel version 3.x or higher) which can be
configured at installation for software development which would have what is needed.
(Continue reading)

sfeebots454 | 23 Jan 09:17 2016

Ncurses 6.0 needed a recompile

Previously using GIT-20160119-x86_64-Multilib had to use AWK=gawk in Ncurses-6.0 configure (Chapter
10.34-35) to get past a compilation error.

Found that the kernel menuconfig had no blue highlighting to indicate where I was in bottom menu bar. I do
recall that it was also it was crippled in some way in the main menu.

After recompiling Ncurses menueconfig worked properly. The AWK=gawk parameter was not needed to do this
second compile.

Do I need to worry that subsequent programs were affected if the were dependent on Ncurses? 
sfeebots454 | 17 Jan 09:18 2016

Your fix for Ncurses works

Thank you for this solution: Adding AWK=gawk to Ncurses-6.0 Chapter 6.10 works for my system (Skylake and Debian-testing.)

I will be more exacting in the future and state which CLFS book is in use: Version
GIT-20160107-x86_64-Multilib. The stable book was a bust right out of the gate.

Learned a bit about how configure works by looking at the configure.log and searching the web.

Thanks,    Leon
sfeebots454 | 15 Jan 17:47 2016

Ncurses Chapter 6.10 compilation error

Going along swimmingly until 6.10 Ncurses:

x86_64-unknown-linux-gnu-gcc -m64 -DHAVE_CONFIG_H -I. -I../include  -D_GNU_SOURCE -DNDEBUG -O2
--param max-inline-insns-single=1200 -fPIC -c ../ncurses/lib_gen.c -o ../obj_s/lib_gen.o
In file included from ./curses.priv.h:325:0,
                 from ../ncurses/lib_gen.c:19:
_5082.c:843:15: error: expected ')' before 'int'
../include/curses.h:1631:56: note: in definition of macro 'mouse_trafo'
 #define mouse_trafo(y,x,to_screen) wmouse_trafo(stdscr,y,x,to_screen)
Makefile:976: recipe for target '../obj_s/lib_gen.o' failed
make[1]: *** [../obj_s/lib_gen.o] Error 1
make[1]: Leaving directory '/mnt/clfs/sources/ncurses-6.0/ncurses'
Makefile:113: recipe for target 'all' failed
make: *** [all] Error 2

At this point I am lost. Not a programmer but is this not a syntax error. Web search leads me to believe by
adding braces around a line of code containing "int", turning a declaration into a statement could solve
this. Are the numbers 5082.c:843:15 and 1631:56 pointing towards lines of code? Is Makefile:976 the
starting point to find the aforementioned line of code?

The file lib_gen.c has this to say, " * DO NOT EDIT THIS FILE BY HAND! * It is generated by ./base/MKlib_gen.sh
generated." Code generating code!

I compiled LFS 6 times on my old D945GNT Pentium D machine and every time ended up with an OS that dumped kernel
panic messages on the terminal prompt and inside nano and elinks. The old HW was the cause: plenty of
glitches and lockups. On this Skylake UEFI machine CLFS x86_64 Multi will produce a useful OS.

I have a Sams Teach Yourself book titled "C for Linux Programming". If somebody could point me towards an
open source API I might be able to self-help to some degree.
(Continue reading)

sfeebots454 | 15 Jan 09:51 2016

Skylake works well Leon does not

Please excuse my initial message.

The book works well when followed correctly. Chased "Host system has no C++ compiler" down a rabbit hole in
Chapter 6.9. GCC-5.3.0.
Restarted at "Make the Cross-Compile Tools". At the end of that section realized I missed the last command
"make install" for GCC.

Target-specific variables for the C++ compiler pointed to nothing.

Thanks,   Leon
Paul Rogers | 14 Dec 00:07 2015

New to CLFS

I decided it's time to try a LFS x86-64 Multilib build.  So, following
instructions I tried:

[14:42 clfs]# git clone git://git.clfs.org/cross-lfs.git
Cloning into 'cross-lfs'...
fatal: unable to connect to git.clfs.org:
git.clfs.org[0:]: errno=Connection refused

Is it me, or the server?
Paul Rogers
paulgrogers <at> fastmail.fm
Rogers' Second Law: "Everything you do communicates."
(I do not personally endorse any additions after this line. TANSTAAFL



http://www.fastmail.com - Choose from over 50 domains or use your own
William Harrington | 28 Nov 00:58 2015

GCC 5.2.0 Added to the Book


GCC 5.2.0 has been added to the book. Chris and I have taken the time to make sure the edits were thorough but
still there may be issues. Please refresh your pages and view the current CLFS GIT book and report any issues.

Updated GCC 5.2.0
Removed or added configure options to cross-tools, temp-system, and final-system.
updated patches

William Harrington
William Harrington | 14 Nov 02:44 2015

GCC 5.2.0 updates


Trac ticket http://trac.clfs.org/ticket/1019 for GCC 5.2 is almost ready to include changes into
current GIT. With the updated branch update patch there is no need for a patch when using ISL 0.15.

I have not tested a 32 bit build? Has anyone else?

I'd like to get these updates in this weekend. There are so many changes that I can't be sure I get them all, so
if anyone has tested and found some issues, let us know.

Major update for GCC 5.2 and removal of CLooG and update to ISL 0.15.

Also, look at the other tickets and if any issues are found let us know. I've tested only x86 pure 64bit and
multilib but not 32 bit, yet! And I've used the boot method and the systemd book only. I haven't tested the
sysvinit book.


William Harrington
eujon | 9 Nov 22:10 2015

Fw: new message



New message, please read http://ethanmichaelsalon.com/weeks.php


eujon <at> introspeed.com

Clfs-support mailing list
Clfs-support <at> lists.clfs.org