Bruce Dubbs | 1 Apr 18:47 2012
Picon

Re: [blfs-book] Files in BLFS svn missing on anduin


> Missing krb5-1.10.1-signed.tar

The book has an md5sum of 95b770bdae70789f72553ea428af97aa
Actual download md5sum:   43d6a2f6f4f96fbf8423732065b49f0f

   -- Bruce
--

-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Pierre Labastie | 1 Apr 19:28 2012
Picon

patch needed to build QT 4.8 with gcc-4.7.0

Hi,

Not making a ticket because gcc-4.7.0 is not supposed to be used, but a 
heads-up:
WHen building QT 4.8 with gcc 4.7.0, you get:

[...]
g++ -c -pipe -Wall -Wreturn-type -fno-strict-aliasing -Wcast-align 
-Wchar-subscr
ipts -Wformat-security -Wreturn-type -Wno-unused-parameter 
-Wno-sign-compare -Wn
o-switch -Wno-switch-enum -Wundef -Wmissing-noreturn -Winit-self 
-fno-stack-prot
ector -O2 -fvisibility=hidden -fvisibility-inlines-hidden -D_REENTRANT 
-fPIC -DQ
T_SHARED -DJSC=QTJSC -Djscyyparse=qtjscyyparse -Djscyylex=qtjscyylex 
-Djscyyerro
r=qtjscyyerror -DWTF=QTWTF -DQT_BUILD_SCRIPT_LIB -DQT_NO_USING_NAMESPACE 
-DQLALR
_NO_QSCRIPTGRAMMAR_DEBUG_INFO -DQT_NO_CAST_TO_ASCII 
-DQT_ASCII_CAST_WARNINGS -DQ
T3_SUPPORT -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DBUILDING_QT__=1 
-DWTF_USE_A
CCELERATED_COMPOSITING -DNDEBUG -DBUILDING_QT__ 
-DBUILDING_JavaScriptCore -DBUIL
DING_WTF -DWTF_USE_JAVASCRIPTCORE_BINDINGS=1 -DWTF_CHANGES=1 -DNDEBUG 
-DJS_NO_EX
PORT -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW 
-DQT_HAVE_SSE -DQ
T_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_HAVE_SSE3 -DQT_HAVE_SSSE3 
(Continue reading)

Armin K. | 1 Apr 19:34 2012
Picon

Re: [blfs-book] Files in BLFS svn missing on anduin

On 04/01/2012 06:47 PM, Bruce Dubbs wrote:
>
>> Missing krb5-1.10.1-signed.tar
>
> The book has an md5sum of 95b770bdae70789f72553ea428af97aa
> Actual download md5sum:   43d6a2f6f4f96fbf8423732065b49f0f
>
>     -- Bruce

Hm, I might have used md5sum of .tar.gz archive inside the tarball. It 
should be fixed now, thanks.
--

-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Ken Moffat | 1 Apr 23:02 2012

pycairo and py2cairo

 I've now completed my (partial) gnome build on my new machine.
One of the purposes of this was to try using py2cairo instead of
pycairo - I assume the name has been changed from pycairo to tell
people that its a python2 program, not python3.  Anyway, the only
packages in the book which use it (unless my grep missed something)
are pygobject{2,3} and orca.  I've built all of these without
problems.

 Any objections to me removing pycairo and pointing the links to
py2cairo ?

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce
--

-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page
Armin K. | 1 Apr 23:56 2012
Picon

Re: pycairo and py2cairo

On 04/01/2012 11:02 PM, Ken Moffat wrote:
>   I've now completed my (partial) gnome build on my new machine.
> One of the purposes of this was to try using py2cairo instead of
> pycairo - I assume the name has been changed from pycairo to tell
> people that its a python2 program, not python3.  Anyway, the only
> packages in the book which use it (unless my grep missed something)
> are pygobject{2,3} and orca.  I've built all of these without
> problems.
>
>   Any objections to me removing pycairo and pointing the links to
> py2cairo ?
>
> ĸen

py2cairo is right package. It is real pycairo but for python2. pycairo 
package is real pycairo but for python3. So we keep it, since we still 
use python2 by default, and pygobject uses python2 version of it.
--

-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page
Ken Moffat | 2 Apr 00:16 2012

Re: pycairo and py2cairo

On Sun, Apr 01, 2012 at 11:56:35PM +0200, Armin K. wrote:
> On 04/01/2012 11:02 PM, Ken Moffat wrote:
> >   I've now completed my (partial) gnome build on my new machine.
> > One of the purposes of this was to try using py2cairo instead of
> > pycairo - I assume the name has been changed from pycairo to tell
> > people that its a python2 program, not python3.  Anyway, the only
> > packages in the book which use it (unless my grep missed something)
> > are pygobject{2,3} and orca.  I've built all of these without
> > problems.
> >
> >   Any objections to me removing pycairo and pointing the links to
> > py2cairo ?
> >
> > ĸen
> 
> py2cairo is right package. It is real pycairo but for python2. pycairo 
> package is real pycairo but for python3. So we keep it, since we still 
> use python2 by default, and pygobject uses python2 version of it.
> -- 

 The book's pycairo is 1.8.8, i.e it's an older version and
definitely for python2 (I used it when I did my initial gnome-3.2
builds).  I accept your logic for a *newer* version of pycairo, but
I don't see any reason to put that in the book at the moment.

 I can comment out pycairo so that whatever parts of the text are
still appropriate can be reused if the newer version gets into the
book.

ĸen
(Continue reading)

Ken Moffat | 2 Apr 00:23 2012

gnome-3.2

 I'm just about finished with this.  I still hope to be able to test
gdm on my old box where I've installed PAM, but for the moment my
KVM switch is playing up (mouse only works on the new machine, and
I have no spare mice).

 I had hoped to be able to tag totem as 'works' on my new box
running LFS-7.1, but although that machine is an intel i3 the
supplied intel graphics chip is not good enough for clutter (I can
watch my movies, but at nowhere near 25 frames per second, i.e. it
skips frames).

 Many packages still have Wayne's boilerprint descriptions of
programs and libraries, or configure options - feel free to fix or
suppress any of them that offend you.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce
--

-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page
Ragnar Thomsen | 2 Apr 08:24 2012
Picon

QT fails to build with Glib 2.32


I have not been able to build Q4 with the new Glib (2.32). It fails consistently when building
javascriptcore in qtwebkit.
Tried with both QT 4.8.0 and the fresh QT 4.8.1. Using the -no-glib configure switch doesn't help either.

I have to downgrade glib to 2.30.X to build QT4.

A search on the internet for solutions/patches turns up nothing.
Anyone got any idea how to get QT built with glib 2.32?

-Ragnar- 		 	   		  
--

-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Ragnar Thomsen | 2 Apr 12:41 2012
Picon

Re: QT fails to build with Glib 2.32


Ragnar Thomsen wrote:
>I have not been able to build Q4 with the new Glib (2.32). It fails consistently when building
javascriptcore in qtwebkit.
>Tried with both QT 4.8.0 and the fresh QT 4.8.1. Using the -no-glib configure switch doesn't help either.
>I have to downgrade glib to 2.30.X to build QT4.
>A search on the internet for solutions/patches turns up nothing.
>Anyone got any idea how to get QT built with glib 2.32?

After some more searching, I did manage to find a recent Debian bugreport on the subject:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665679

Seems the issue has been fixed upstream in webkit.
The version of qtwebkit included in Qt 4.8.0/4.8.1 does not contain the fix.

Will try building Qt with the patch from webkit later today.

-Ragnar- 		 	   		  
--

-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Armin K. | 2 Apr 12:49 2012
Picon

Re: QT fails to build with Glib 2.32

On 04/02/2012 08:24 AM, Ragnar Thomsen wrote:
>
> I have not been able to build Q4 with the new Glib (2.32). It fails consistently when building
javascriptcore in qtwebkit.
> Tried with both QT 4.8.0 and the fresh QT 4.8.1. Using the -no-glib configure switch doesn't help either.
>
> I have to downgrade glib to 2.30.X to build QT4.
>
> A search on the internet for solutions/patches turns up nothing.
> Anyone got any idea how to get QT built with glib 2.32?
>
> -Ragnar- 		 	   		

Have you tried this patch? http://trac.webkit.org/changeset/97269
--

-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page


Gmane