Mr. Lassine Diawara | 31 Aug 23:54 2015

Confidential Business Negotiation!!

Greetings from Dr. Lassine Diawara.

Assalamu Alaikum,

             Permit me to inform you of my desire of going into
business relationship with you, I know this message will sounds very
strange to you, but I have no choice than to risk my life to choose a
stranger like you I have never seen before. We leave in a global
world today, and with the help of internet technology one can easily
communicate with one  another all around the world without knowing him
or she in person, what matters will be  the trust and the
Information’s you got about the person. In this case we can understand
our self and work like one family.

My Name is Dr. Lassine Diawara, the senior Auditor In charge of
Foreign Remittance Unit, Bank of Africa (BOA). I'm from Ouagadougou,
Burkina Faso, West Africa. My reason for contacting you is to transfer
an abandoned $15.5M to your account.

The owner of this fund died since 2003 with his Next Of Kin. I want to
present you to the bank as the Next of Kin/beneficiary of this fund.

Further details of the transaction shall be forwarded to you as soon
as I receive your return mail indicating your interest.

I will like you to provide immediately the below information's, to
enable me use it and get you next of kin application form from my

(Continue reading)

Pratyush Anand | 31 Aug 08:34 2015

[PATCH V2] watchdog: Add watchdog device control through sysfs attributes

This patch adds following attributes to watchdog device's sysfs interface.

* state - reads whether device is active or not
* identity - reads Watchdog device's identity string.
* timeout - reads current timeout.
* timeleft - reads timeleft before watchdog generates a reset
* bootstatus - reads status of the watchdog device at boot
* status - reads watchdog device's  internal status bits
* nowayout - reads whether nowayout feature was set or not

Testing with iTCO_wdt:
 # cd /sys/class/watchdog/watchdog1/
 # ls
bootstatus  dev  device  identity  nowayout  power  state
subsystem  timeleft  timeout  uevent
 # cat identity
 # cat timeout
 # cat state
 # echo > /dev/watchdog1
 # cat timeleft
 # cat state
 # cat bootstatus
 # cat nowayout
(Continue reading)

Clément Vuchener | 29 Aug 16:03 2015

[PATCH 1/1] Corsair Vengeance K90 driver

  Documentation/ABI/testing/sysfs-class-k90_profile  |  55 ++
  .../ABI/testing/sysfs-driver-hid-corsair-k90       |  15 +
  drivers/hid/Kconfig                                |  10 +
  drivers/hid/Makefile                               |   1 +
  drivers/hid/hid-core.c                             |   1 +
  drivers/hid/hid-corsair-k90.c                      | 690 
  drivers/hid/hid-ids.h                              |   3 +
  7 files changed, 775 insertions(+)
  create mode 100644 Documentation/ABI/testing/sysfs-class-k90_profile
  create mode 100644 Documentation/ABI/testing/sysfs-driver-hid-corsair-k90
  create mode 100644 drivers/hid/hid-corsair-k90.c

diff --git a/Documentation/ABI/testing/sysfs-class-k90_profile 
new file mode 100644
index 0000000..3275c16
--- /dev/null
+++ b/Documentation/ABI/testing/sysfs-class-k90_profile
 <at>  <at>  -0,0 +1,55  <at>  <at> 
+What:		/sys/class/k90_profile/<profile>/profile_number
+Date:		August 2015
+KernelVersion:	4.2
+Contact:	Clement Vuchener <clement.vuchener@...>
+Description:	Get the number of the profile.
+What:		/sys/class/k90_profile/<profile>/bindings
+Date:		August 2015
+KernelVersion:	4.2
(Continue reading)

Clément Vuchener | 29 Aug 16:03 2015

[PATCH 0/1] Corsair Vengeance K90 driver

This patch implements a HID driver for the Corsair Vengeance K90 keyboard.

This keyboard has a backlight, macro keys (G1 to G18) and some other 
special keys (macro recording, profile switching, changing the light 
level or disabling the super/meta/"windows logo" keys). The macro 
playback can be switched between hardware or software (from the driver 
not a key). Using the generic HID driver, the macro keys and special 
keys send wrong key code or no key code at all (because of the HID usage 
code used by the keyboard).
The purpose of this driver is to fix the behaviour of the keys using 
incorrect HID usage codes and expose the other features to the user space.

This is my first Linux driver and I would like to get feedback for both 
my code and my choices for the user space interface.

For the keyboard to work in software mode, a user program needs to be 
able to get key events. I am not sure about which key codes should be 
used for that. I choose the BTN_TRIGGER_HAPPY* as they seem to be used 
for devices with extra buttons.

The other special keys does send any key codes. They are used to change 
the hardware state and user space should not need them directly.

Playback mode and current profile can be read and written through simple 
sysfs attributes.

The backlight is managed through a LED class device.

Hardware macro profiles (there are three of them) are managed thanks to 
devices of the new k90_profile class. Data is sent through binary 
(Continue reading)

Mathieu Desnoyers | 27 Aug 06:04 2015

Allocating sys_membarrier syscall number on other archs

Hi Andrew,

The sys_membarrier patches you have in your tree target
x86 32-64 and generic, but I did not allocate the system call
number on other architectures to minimize the amount of
collisions, and because I do not have all those architectures

How would you recommend to proceed to allocate those ?

sys_membarrier is pretty much architecture agnostic: it
takes two integer parameters, and the only function it calls,
synchronize_sched(), is available on all architectures.




Mathieu Desnoyers
EfficiOS Inc.
Chistinam Hammock | 26 Aug 20:02 2015


Bună dragă prietene,
 Do you speak English
I'M Christina M Hammock. Sunt o REGATUL militare de stat / NASA.
De la stat Unite ale Americii. Sunt de susținere și îngrijire,
așteaptă cu nerăbdare pentru a obține
un prieten frumos. Am citit profilul dvs. de la și alege
interes pe tine. Voi dori să
stabili prietenie reciprocă cu tine. Vă rugăm să continuați conversația
prin cutia mea de e-mail privat. Aici este adresa mea de e-mail
{christinamhammock2@...} Voi mă prezint mai bine și vă va
trimite poza mea, cât mai curând am primit
Christina M Hamac.
Christoph Hellwig | 26 Aug 18:56 2015

Persistent Reservation API V3

This series adds support for a simplified Persistent Reservation API
to the block layer.  The intent is that both in-kernel and userspace
consumers can use the API instead of having to hand craft SCSI or NVMe
command through the various pass through interfaces.  It also adds
DM support as getting reservations through dm-multipath is a major
pain with the current scheme.

NVMe support currently isn't included as I don't have a multihost
NVMe setup to test on, but Keith offered to test it and I'll have
a patch for it shortly.

The ioctl API is documented in Documentation/block/pr.txt, but to
fully understand the concept you'll have to read up the SPC spec,
PRs are too complicated that trying to rephrase them into different
terminology is just going to create confusion.

Note that Mike wants to include the DM patches so through the DM
tree, so they are only included for reference.

I also have a set of simple test tools available at:


Changes since V2:
  - added an ignore flag to the reserve opertion as well, and redid
    the ioctl API to have general flags fields
  - rebased on top of the latest block layer tree updates
Changes since V1:
  - rename DM ->ioctl to ->prepare_ioctl
  - rename dm_get_ioctl_table to dm_get_live_table_for_ioctl
(Continue reading)

Andy Lutomirski | 25 Aug 01:03 2015

[PATCH -mm] selftests/capabilities: Add tests for capability evolution

This test focuses on ambient capabilities.  It requires either root
or the ability to create user namespaces.  Some of the test cases
will be skipped for nonroot users.

Signed-off-by: Andy Lutomirski <luto@...>

I took taking advantage of the extra week to make my test case work :)

 tools/testing/selftests/capabilities/.gitignore    |   2 +
 tools/testing/selftests/capabilities/Makefile      |  19 +
 tools/testing/selftests/capabilities/test_execve.c | 427 +++++++++++++++++++++
 .../testing/selftests/capabilities/validate_cap.c  |  73 ++++
 4 files changed, 521 insertions(+)
 create mode 100644 tools/testing/selftests/capabilities/.gitignore
 create mode 100644 tools/testing/selftests/capabilities/Makefile
 create mode 100644 tools/testing/selftests/capabilities/test_execve.c
 create mode 100644 tools/testing/selftests/capabilities/validate_cap.c

diff --git a/tools/testing/selftests/capabilities/.gitignore b/tools/testing/selftests/capabilities/.gitignore
new file mode 100644
index 000000000000..b732dd0d4738
--- /dev/null
+++ b/tools/testing/selftests/capabilities/.gitignore
 <at>  <at>  -0,0 +1,2  <at>  <at> 
diff --git a/tools/testing/selftests/capabilities/Makefile b/tools/testing/selftests/capabilities/Makefile
new file mode 100644
index 000000000000..5b90ed14cccb
(Continue reading)

Maria-Elisabeth Schaeffler | 21 Aug 20:41 2015


I intend to give to you a portion of my Wealth as a free-will financial donation to you. Respond now to partake.

Maria-Elisabeth Schaeffler

This email has been checked for viruses by Avast antivirus software.

Sean O. Stalley | 20 Aug 18:59 2015

[PATCH 0/2] PCI: Add support for PCI Enhanced Allocation "BARs"

PCI Enhanced Allocation is a new method of allocating MMIO & IO
resources for PCI devices & bridges. It can be used instead
of the traditional PCI method of using BARs.

EA entries are hardware-initialized to a fixed address.
Unlike BARs, regions described by EA are cannot be moved.
Because of this, only devices which are permanently connected to
the PCI bus can use EA. A removable PCI card must not use EA.

This patchset adds support for using EA entries instead of BARs.

The Enhanced Allocation ECN is publicly available here:

Sean O. Stalley (2):
  PCI: Add Enhanced Allocation register entries
  PCI: Add parsing of Enhanced Allocation entries

 drivers/pci/pci.c             | 219 ++++++++++++++++++++++++++++++++++++++++++
 drivers/pci/pci.h             |   1 +
 drivers/pci/probe.c           |   3 +
 include/uapi/linux/pci_regs.h |  40 +++++++-
 4 files changed, 262 insertions(+), 1 deletion(-)



David Drysdale | 13 Aug 11:32 2015

[PATCHv4 0/3] fs: add O_BENEATH flag to openat(2)

A couple of questions with this iteration:
 - Should we create a new errno (say ENOTBENEATH) for this policing, to
   make it easier to distinguish this case from other EPERM failures?
   (The FreeBSD implementation is considering this approach.)
 - Al, does the code look OK for (in particular) integrating with the
   shiny new re-worked fs/namei.c code?

This change adds a new O_BENEATH flag for openat(2) which restricts the
provided path, rejecting (with -EPERM) paths that are not beneath
the provided dfd.

This functionality was originally implemented as part of the internals
of the Capsicum security framework, which is available in FreeBSD 10.x
and which has previously had a Linux kernel port proposed [1].

However, as this behaviour is potentially useful as an independent feature,
this change exposes it via an openat(2) flag.  (This variant was not
originally exposed in FreeBSD, but is currently being proposed there
too [2].)

Various folks from Chrome[OS] have indicated an interest in having this
functionality -- when combined with a seccomp filter it allows a directory
to be more safely accessed by a sandboxed process.  Other folk have also
expressed an interest [3].


(Continue reading)