Harry Putnam | 30 Aug 18:15 2015

Advantages or disadvantages of use package.use as directory

I see there have been a change in how we list our specific use flags.

I'm seeing /etc/portage/package.use/ pkg1 pkg2 ... etc rather than
package.use as a file that contains the specific pkgs and use flags.

I wonder if there is some advantage to leaving things as my
installation has created them or should I revert to the old way where
package.use is file... not a directory.

If directory is better then how would I list USE flags for emacs-vcs?

Just create a file `/etc/portage/package.use/emacs-vcs' with USE flags
Or do I need to create another direrctorry within like:
   /etc/portage/package.use/app-editors/emacs-vcs?

I tried the later like so:
   /etc/portage/package.use/app-editors/emacs-vcs
where emacs-vcs contains:

   emacs-vcs Xaw3d athena gnutls imagemagick toolkit-scroll-bars

and this way:

   >=app-editors/emacs-vcs-25.0.50_pre20150731 Xaw3d athena gnutls imagemagick toolkit-scroll-bars

But when I attempt emerging... the USE flags do not reflect those
choices and shows and error:

--- Invalid atom in /etc/portage/package.use/app-editors/emacs-vcs:
    >=app-editors/emacs-vcs
(Continue reading)

Harry Putnam | 30 Aug 08:37 2015

emerge fails with `Suspicious PERL5LIB setting's

Setup: running gentoo inside vbox on Solaris (x86)
Very new install

Running `emerge -v dev-vcs/git' when it comes to installing several dev-perl
pkgs begining with dev-perl/Digest-HMAC-1.30.0-r1::gentooi, it fails with a
brief explanation:

  >>> Configuring source in
/var/tmp/portage/dev-perl/Digest-HMAC-1.30.0-r1/work/Digest-HMAC-1.03 ...
   * perl-module.eclass: Suspicious environment values found.
   *     PERL5LIB="/usr/local/cpan-perl:/usr/local/cpan-perl/lib:/usr/local/cpan-perl/lib/perl5"
   * Your environment settings may lead to undefined behavior and/or build failures.
   * ERROR: dev-perl/Digest-HMAC-1.30.0-r1::gentoo failed (configure phase):
   *   Please fix your environment ( ~/.bashrc, package.env, ... ), see above for details.
   * 

I've been building cpan packages and have them installed at the locations
mentioned above.  Then, to get perl to include them in ` <at> INC', I've utilized
the PERL5LIB variable in one of my login scripts, just as it appears in the
error.

Its not clear to me why setting these directories with PERL5LIB is
`Suspicious', or how to proceed from here. 

Philip Webb | 30 Aug 06:04 2015
Picon

system uptime

How long do desktop users typically leave their systems between reboots ?
How long between power off/on's ?

I've long been in the habit of switching everything off while I sleep,
then restarting after I've woken & got going again myself.
However recently, I've run into delays getting my router
(only  1  device attached) to shake hands successfully with my ISP's server,
which have been requiring several power off/on's before it works.
As a result, I've started rebooting only after my weekly system update
-- it means I get to use the new versions of everything --
& not powering off at all ; the monitor + Xscreensaver are off
whenever I'm away from the machine for  >= 1 hr  (approx).

Are there any pro's/con's I sb aware of ?

--

-- 
========================,,============================================
SUPPORT     ___________//___,   Philip Webb
ELECTRIC   /] [] [] [] [] []|   Cities Centre, University of Toronto
TRANSIT    `-O----------O---'   purslowatchassdotutorontodotca

neu pat | 29 Aug 22:02 2015
Picon

emerge --oneshot portage - conflict


I emerge python3.4 set as active:

eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3
  [3]   python3.4 *

but it still complain


[ebuild     U  ] sys-apps/portage-2.2.20.1 [2.2.14] PYTHON_TARGETS="python3_4* -python3_3*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-2.2.20.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.2.14:0/0::gentoo, installed) pulled in by
    sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-)] required by (app-admin/webapp-config-1.52-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                           
    sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)

What is it looking for?
neu pat | 29 Aug 21:36 2015
Picon

emerge --oneshot portage - conflict



I emerge python3.4 set as active:

eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3
  [3]   python3.4 *

but it still complain about Multiple package instances

[ebuild     U  ] sys-apps/portage-2.2.20.1 [2.2.14] PYTHON_TARGETS="python3_4* -python3_3*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-2.2.20.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.2.14:0/0::gentoo, installed) pulled in by
    sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-)] required by (app-admin/webapp-config-1.52-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                          
    sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)

How to fix it?

#joseph
walt | 28 Aug 15:19 2015
Picon

ncurses: reductio ad absurdum

I avoided yesterday's downgrade from ncurses-6.0 to ncurses-5.9-r4
because it was obviously(?) a mistake.

This morning I just upgraded(?) ncurses-6.0 to ncurses-6.0-r1 and
immediately after doing that, portage wants to downgrade(?) from
6.0-r1 back to 6.0.

This comedy of errors would be funny if it weren't emblematic of the
larger and very scary problem we all face in real life:  computers now
dominate every aspect of everything we do and what is expected of us by
our employers, friends, family, and our government.  (I refer to the
government here in the US.  Your government may vary.)

Note that /usr/portage/sys-libs/ncurses/Changelog was last updated on
April 6, several months ago.

Rhetorical question:  what is the purpose of a Changelog?  Or any log,
anywhere, like the captain's log on an oil tanker, for example, or an
airliner, or in the IT department of the bank where your life savings
are stored.  Who last rebooted that server, and why?

Who last updated ncurses, and why?  Yes, I looked at the ebuild, which
cites a bug report, which may or may not serve as the log I'm asking
for, but doesn't this all seem too complicated to work smoothly for
years without frequent fsck-ups?

Now I have to go to work and face exactly the same fsck-ups there that
I face when I update my gentoo machines, and that puts me in a bad mood.

Mick | 28 Aug 13:55 2015
Picon

OneDrive access from Linux using webdavs

Hi All,

Apparently OneDrive, the Microsoft cloud storage, is using the webdav 
protocol.  However, to effect authentication OneDrive uses redirection to a 
different URL, which breaks Linux connections to it.  This page explains 
someone's attempts using the previous MS offering of SkyDrive:

http://blog.lazut.in/2012/12/skydrive-webdav-access.html

I've tried the suggestions using both cadaver and dolphin.  Both failed to 
connect.  I have not used net-fs/davfs2 to mount OneDrive, but I read in the 
above link that davfs2 does not handle redirects either.

Would you know of some trick to allow me to access onedrive from Linux?  Read 
only access will do for the use case I have in mind, which is to browse and 
download some files from a customer's shared folder.

PS. I've also found 'onedrive-d' a python script/program, which does not seem 
to be available in portage, or any overlays.  Do you know if there's an ebuild 
somewhere for it?  However, I think that this is for synch'ing a local fs to 
OneDrive - something I am not necessarily interested in.

--

-- 
Regards,
Mick
José Romildo Malaquias | 28 Aug 01:25 2015
Picon

Java plugin in Midori web browser

I need help getting java plugin working in the Midori web browser.

I have dev-java/oracle-jdk-bin-1.8.0.51 installed on my ~amd64
system.

The plugin works with Firefox.

Romildo

James | 27 Aug 17:28 2015
Picon

LXQT (~0.9.0-r2)

Hello,

So on a recently upgraded system, I removed KDE and I'm attempting to
install LX!T-meta-0.9.0-r2. Any advise on that is most welcome. The system
had not been upgraded for several years (an old laptop) but all
seems fine now with portage, compilers,  <at> system and  <at> world all current.

Last sync :: Timestamp of repository gentoo: Wed, 26 Aug 2015 22:30:02 +0000

I removed all of the kde*meta packages and have been slowly cleaning
out the residual kde kruft via this resource's suggestions [1]. 

So far ncurses* and libcaca seem to be the only packages motivating
extreme creativity on installation. Right now I have ncurses-6.0 
installed and I'm working on finding a compatible version of libcaca.
(I did not want to post to the current ncurses post but surely
ncurses  issues are part of this compatibility issue.

Any tidbits, suggestions or package flag/tricks are most welcome
on the latest version of LXQT-meta.

Ok and libcaca just failed (again)::
 "
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/../../../../x86_64-pc-linux-gnu/bin/ld:
cannot find -lGLU 

collect2: error: ld returned 1 exit status
distcc[1382] ERROR: compile (null) on localhost failed
Makefile:689: recipe for target 'libcaca.la' failed
make[2]: *** [libcaca.la] Error 1   "

I'm using distcc. I have turned distcc off (/etc/init.d/distcc stop)
on both the host and the other (8 core) system;  and also used 
" MAKEOPTS="-j1" USE="qt5 ".  Distcc has not had any other issues
on this setup (same arch, compiler and key packages) for hundreds 
of other compiles. So I'm  a bit stumped.

What would be keen is the for somebody running the latest version 
of lxqt-meta to list the files and flags they use. Hunches also
warmly received.  Lafilefixer? (I thought all those tricks were
integrated into portage PM now?

[1] https://wiki.gentoo.org/wiki/KDE/Removal

gevisz | 27 Aug 16:34 2015
Picon

curses of ncurses :(

I do not understand:
1) why portage wants to upgrade ncurses-5.9-r3 to ncurses-5.9-r101
    (because it is marked),
2) why it can not,
3) what to do with this block.

$ eix ncurses

[I] sys-libs/ncurses
     Available versions:
     (0)    5.9-r3 ~5.9-r4 ~6.0(0/6)
     (5)    ~5.9-r101(5/5)
       {ada +cxx debug doc gpm minimal profile static-libs test
threads tinfo trace unicode ABI_MIPS="n32 n64 o32" ABI_PPC="32 64"
ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  5.9-r3(10:48:01 PM 03/29/2015)(cxx gpm
unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace
ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64"
ABI_X86="32 64 -x32")
     Homepage:            https://www.gnu.org/software/ncurses/
http://dickey.his.com/ncurses/
     Description:         console display library

# emerge --update --deep --with-bdeps=y --newuse --backtrack=90 --ask world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-util/diffstat-1.60 [1.58]
[ebuild     U  ] dev-libs/libnl-3.2.26 [3.2.25]
[ebuild     U  ] dev-libs/openssl-1.0.2d [1.0.1p] USE="asm%* -sctp%"
[ebuild  NS   ~] sys-libs/ncurses-5.9-r101 [5.9-r3] USE="gpm unicode
-tinfo" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] www-client/firefox-38.2.0 [38.1.1]
[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is
blocking sys-libs/ncurses-5.9-r101)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/ncurses-5.9-r101:5/5::gentoo, ebuild scheduled for merge)
pulled in by
    >=sys-libs/ncurses-5.7-r7[unicode?]
(>=sys-libs/ncurses-5.7-r7[unicode]) required by
(sys-process/procps-3.3.9-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(app-editors/vim-7.4.273:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(app-editors/gvim-7.4.273:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.1 required by
(app-shells/zsh-5.0.5:0/0::gentoo, installed)
    sys-libs/ncurses required by
(dev-lang/ruby-1.9.3_p551-r1:1.9/1.9::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.2-r5 required by
(sys-boot/grub-2.02_beta2-r7:2/2::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(sys-kernel/gentoo-sources-4.0.5:4.0.5/4.0.5::gentoo, installed)
    >=sys-libs/ncurses-5.2:5/5= required by
(app-emulation/wine-1.6.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5[unicode?]
(>=sys-libs/ncurses-5.2-r5[unicode]) required by
(dev-util/dialog-1.2.20150528:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(dev-lang/python-3.4.1:3.4/3.4::gentoo, installed)
    >=sys-libs/ncurses-5.2:= required by
(app-emulation/wine-1.6.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:5/5=[abi_x86_32(-),abi_x86_64(-)]
required by (sys-devel/llvm-3.5.0:0/3.5::gentoo, installed)
    >=sys-libs/ncurses-5.1 required by
(mail-client/alpine-2.00-r5:0/0::gentoo, installed)
    sys-libs/ncurses required by
(sys-devel/gettext-0.19.4:0/0::gentoo, installed)
    sys-libs/ncurses[unicode] required by
(dev-lang/ghc-7.6.3-r1:0/7.6.3::gentoo, installed)
    sys-libs/ncurses required by (sys-libs/slang-2.2.4-r1:0/0::gentoo,
installed)
    sys-libs/ncurses:5/5= required by
(sci-mathematics/octave-3.8.2:0/3.8.2::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by
(sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by
(dev-libs/xmlrpc-c-1.32.05-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by
(www-client/links-2.8-r1:2/2::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)] required by
(app-emulation/wine-1.6.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(app-shells/bash-4.3_p39:0/0::gentoo, installed)

  (sys-libs/ncurses-5.9-r3:0/0::gentoo, installed) pulled in by
    sys-libs/ncurses required by (app-text/hunspell-1.3.3:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.7-r7:0= required by
(media-sound/lame-3.99.5-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by
(sys-block/parted-3.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by
(media-sound/alsa-utils-1.0.29:0.9/0.9::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0= required by
(sys-devel/gdb-7.7.1:0/0::gentoo, installed)
    sys-libs/ncurses:0=[unicode] required by
(media-video/vlc-2.1.5-r1:0/5-7::gentoo, installed)
    sys-libs/ncurses:0= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed)
    sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo,
installed)
    sys-libs/ncurses:0= required by
(sci-mathematics/octave-3.8.2:0/3.8.2::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by
(dev-libs/libcdio-0.92:0/15::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by
(sys-apps/gptfdisk-0.8.10:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]
(>=sys-libs/ncurses-5.9-r3[abi_x86_32(-),abi_x86_64(-)]) required by
(sys-libs/gpm-1.20.7-r2:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by
(dev-lang/ruby-2.0.0_p645:2.0/2.0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(sys-apps/texinfo-5.2:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]
(>=sys-libs/ncurses-5.9-r3[abi_x86_32(-),abi_x86_64(-)]) required by
(sys-libs/readline-6.3_p8-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(dev-lang/python-2.7.9-r1:2.7/2.7::gentoo, installed)
    sys-libs/ncurses:0= required by
(app-crypt/pinentry-0.9.0:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]
(>=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-),abi_x86_64(-)]) required
by (sys-devel/llvm-3.5.0:0/3.5::gentoo, installed)
    sys-libs/ncurses:0=[unicode?] (sys-libs/ncurses:0=[unicode])
required by (www-client/lynx-2.8.8_p2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:0= required by
(app-text/aspell-0.60.6.1-r1:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.2 required by
(sys-devel/bc-1.06.95-r1:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by
(x11-libs/vte-0.28.2-r207:0/0::gentoo, installed)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-emulation/wine-1.6.2::gentoo
# required by  <at> selected
# required by  <at> world (argument)
=sys-libs/ncurses-5.9-r101 ~amd64

Would you like to add these changes to your config files? [Yes/No] n

Any thoughts?

P.S. Adding =sys-libs/ncurses-5.9-r101 ~amd64 to package.accept_keywords
      does not help at all.

Harry Putnam | 27 Aug 09:53 2015

about updating gcc & wiki pages

Can anyone offer an informed opinion as to whether the wiki pages at:
   https://wiki.gentoo.org/wiki/Upgrading_GCC

Are current and apply as well to the newest gcc versions?

I am not having any problem so far (only just compiling as I wrrite)
but I have a hunch those pages may be getting a bit long in the tooth,
and just hoping to head off any problems that may have occured in newest
versions.


Gmane