Víctor Orozco | 1 Feb 05:26 2010
Picon

Re: Forgetting to set root password

On Sun, Jan 31, 2010 at 4:35 PM, Lennart Ramberg
<ramberg.lennart@...> wrote:
> Hi,
>
> New here and curious about Funtoo (and Metro later), I followed the
> Funtoo Linux Quick Install Guide using SystemRescueCd.
> It all went well until
>  emerge grub
> where i got:
> ...- sys-boot/grub-1.97.2 (masked by: package.mask)...
> So I went for LILO instead.
>
> Next halt was at login.
> Now, I suggest a note in the Funtoo Linux Quick Install Guide that you
> should set the root password before you reboot.
> I don't think I'm the first to run into that trap.
> Incidently, how do I chroot to recover from that, please?
>
> Greetings
> Lennart
>

It's a normal chroot, just use a live CD (whatever distro that
supports your filesystem) and chroot to change the password

Then . . .

# mkdir /media/funtoo
# mount /dev/sdaX /media/funtoo (your / partition)
# chroot /media/funtoo /bin/bash
(Continue reading)

Mike Peterson | 1 Feb 13:20 2010
Picon

can't install xorg-server ~phenom

new install. went round and round with this about a week ago and
finally installed stable.
giving it another shot.
i can install stable version but not ~phenom.
i have amd64/10.0/desktop * profile.

# emerge xorg-server -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=net-
misc/curl-7.16.7[gnutls]".
!!! One of the following packages is required to complete your
request:
- net-misc/curl-7.19.7 (Change USE: +gnutls)
(dependency required by "dev-util/cmake-2.8.0-r1" [ebuild])
(dependency required by "app-text/poppler-0.12.3-r3" [ebuild])
(dependency required by "virtual/poppler-utils-0.12.3-r1" [ebuild])
(dependency required by "net-print/cups-1.4.2-r1" [ebuild])
(dependency required by "x11-libs/gtk+-2.18.6" [ebuild])
(dependency required by "media-video/nvidia-settings-190.53" [ebuild])
(dependency required by "x11-drivers/nvidia-drivers-190.53-
r1" [ebuild])
(dependency required by "x11-base/xorg-drivers-1.7" [ebuild])
(dependency required by "x11-base/xorg-server-1.7.4.901" [ebuild])
(dependency required by "xorg-server" [argument])

so i add gnutls to make.conf.
(Continue reading)

Bruce Wang | 1 Feb 13:28 2010
Picon

Re: coreboot 1.3/grub 1.97.2 boot-update error


On Feb 1, 6:41 am, Daniel Robbins <drobb...@...> wrote:
> On Jan 31, 2010, at 3:08 AM, Bruce Wang wrote:
>
> > Trying to migrate to coreboot/grub2 today, everything is good until I
> > run boot-update:
>
> > here is the error:
>
> If you could do me a favor, edit /usr/lib/python2.6/site-packages/funtoo/bootr/resolver.py, and on
line 71, replace "return [ ok, allmsgs, defpos, defnames[defpos] ]" with "break", and see if that fixes
it. It should.
>
> -Daniel

After the change,  no exception thrown and just complained about the
root(my fstab is using LABEL=gentoo format):

* ERROR:   (root=auto) grub - cannot find a valid / entry in /etc/
fstab.
* ERROR:   No matching kernels or boot entries found in /etc/
boot.conf.

and after I changed the line root=auto rootfstype=auto to root=/dev/
sda2 rootfstype=ext3,  it generated grub.cfg properly only failed to
detect the default menu item.

PS: what's the proper way to install a kernel? When I using 'make
install' under /usr/src/linux, it always copy bzImage as vmlinuz-xxxx
to /boot directory
(Continue reading)

Jacob Godserv | 1 Feb 19:26 2010
Picon

Re: can't install xorg-server ~phenom

On Mon, Feb 1, 2010 at 07:20, Mike Peterson <petersonm321@...> wrote:
> but i have only set the gnutls USE flag.

You personally have only set gnutls, but your profile has set much
more. See "emerge --info".

Try adding "-cups" to make.conf and see if that helps. You can add
cups back in (by removing "-cups") and "emerge -uDNav world system"
once xorg-server finishes.

-- 
    Jacob

    "For then there will be great distress, unequaled
    from the beginning of the world until now — and never
    to be equaled again. If those days had not been cut
    short, no one would survive, but for the sake of the
    elect those days will be shortened."

    Are you ready?

--

-- 
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev@...
To unsubscribe from this group, send email to funtoo-dev+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.

Daniel Robbins | 1 Feb 19:38 2010

sunrise sunset

Hi All,

Just a quick note that SCH 2010.1 (
http://www.funtoo.org/en/funtoo/events/changes/sch-2010.1.html )
happened today, early AM, and Sunrise has been officially removed from
the Funtoo Portage tree.

Regards,

Daniel

--

-- 
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev@...
To unsubscribe from this group, send email to funtoo-dev+unsubscribe@...
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.

Rajat Vig | 1 Feb 21:59 2010
Picon

Re: sunrise sunset

A quick question, how do I find out which packages installed on my system are now no longer present in the Portage tree?

I did see a bunch of them when I did eix-sync but have since lost that output - they were marked by eix as [D].
And I can't seem to get good search results on how to go about doing it.

Regards
Rajat


On Tue, Feb 2, 2010 at 12:08 AM, Daniel Robbins <drobbins <at> funtoo.org> wrote:
Hi All,

Just a quick note that SCH 2010.1 (
http://www.funtoo.org/en/funtoo/events/changes/sch-2010.1.html )
happened today, early AM, and Sunrise has been officially removed from
the Funtoo Portage tree.

Regards,

Daniel

--
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev-/JYPxA39Uh5TLH3MbocFFw@public.gmane.org.
To unsubscribe from this group, send email to funtoo-dev+unsubscribe-/JYPxA39Uh5TLH3MbocFFw@public.gmane.org.
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.


--
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev-/JYPxA39Uh5TLH3MbocFF+G/Ez6ZCGd0@public.gmane.org
To unsubscribe from this group, send email to funtoo-dev+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.
mikehunt | 1 Feb 22:04 2010
Picon

Re: coreboot 1.3/grub 1.97.2 boot-update error

Generally, in a manual configuration, something like this is the
command to copy the new kernel to /boot on x86. Make sure /boot is
mounted first please:
Of course the PWD is /usr/src/linux. Modify to suit your architecture:

# cp arch/i386/boot/bzImage /boot

See these for more information:

Modify to suit your architecture:
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=7#doc_chap3

Ans http://swift.siphos.be/linux_sea/ch07.html#id2999450

--

-- 
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev@...
To unsubscribe from this group, send email to funtoo-dev+unsubscribe@...
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.

Piotr Karbowski | 1 Feb 22:06 2010
Picon

Re: sunrise sunset

Try emerge -e  <at> world -pv, on the end should show info about 'there is
no ebuild to cat/appname-version'.

--

-- 
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev@...
To unsubscribe from this group, send email to funtoo-dev+unsubscribe@...
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.

Rajat Vig | 1 Feb 22:13 2010
Picon

Re: sunrise sunset

Thanks. That works.


-Rajat

On Tue, Feb 2, 2010 at 2:36 AM, Piotr Karbowski <jabberuser-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org> wrote:
Try emerge -e <at> world -pv, on the end should show info about 'there is
no ebuild to cat/appname-version'.

--
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev-/JYPxA39Uh5TLH3MbocFFw@public.gmane.org.
To unsubscribe from this group, send email to funtoo-dev+unsubscribe-/JYPxA39Uh5TLH3MbocFFw@public.gmane.org.
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.


--
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev-/JYPxA39Uh5TLH3MbocFF+G/Ez6ZCGd0@public.gmane.org
To unsubscribe from this group, send email to funtoo-dev+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/Ez6ZCGd0@public.gmane.org
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.
reg reg | 1 Feb 22:35 2010

Re: Forgetting to set root password


When you get to grub on bootup. Change your kernel line by adding "single". It'll log you in as root automatically and there you can change/set the password.

2010/2/1 Víctor Orozco <caballerodelmetal-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>
On Sun, Jan 31, 2010 at 4:35 PM, Lennart Ramberg
<ramberg.lennart-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org> wrote:
> Hi,
>
> New here and curious about Funtoo (and Metro later), I followed the
> Funtoo Linux Quick Install Guide using SystemRescueCd.
> It all went well until
>  emerge grub
> where i got:
> ...- sys-boot/grub-1.97.2 (masked by: package.mask)...
> So I went for LILO instead.
>
> Next halt was at login.
> Now, I suggest a note in the Funtoo Linux Quick Install Guide that you
> should set the root password before you reboot.
> I don't think I'm the first to run into that trap.
> Incidently, how do I chroot to recover from that, please?
>
> Greetings
> Lennart
>

It's a normal chroot, just use a live CD (whatever distro that
supports your filesystem) and chroot to change the password

Then . . .

# mkdir /media/funtoo
# mount /dev/sdaX /media/funtoo (your / partition)
# chroot /media/funtoo /bin/bash
# passwd

That's all.

--
Victor Leonel Orozco (tuxtor)

--
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev-/JYPxA39Uh5TLH3MbocFFw@public.gmane.org.
To unsubscribe from this group, send email to funtoo-dev+unsubscribe-/JYPxA39Uh5TLH3MbocFFw@public.gmane.org.
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.


--
You received this message because you are subscribed to the Google Groups "Funtoo" group.
To post to this group, send email to funtoo-dev-/JYPxA39Uh5TLH3MbocFF+G/Ez6ZCGd0@public.gmane.org
To unsubscribe from this group, send email to funtoo-dev+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/funtoo-dev?hl=en.

Gmane