Adrian Bunk | 1 May 15:56 2005
Picon

[-mm patch] net/ieee80211/: remove pci.h #include's

I was wondering why editing pci.h triggered the rebuild of three files 
under net/, and as far as I can see, there's no reason for these three 
files to #include pci.h .

Signed-off-by: Adrian Bunk <bunk <at> stusta.de>

---

 net/ieee80211/ieee80211_module.c |    1 -
 net/ieee80211/ieee80211_rx.c     |    1 -
 net/ieee80211/ieee80211_tx.c     |    1 -
 3 files changed, 3 deletions(-)

--- linux-2.6.12-rc3-mm1-full/net/ieee80211/ieee80211_module.c.old	2005-04-30
23:23:14.000000000 +0200
+++ linux-2.6.12-rc3-mm1-full/net/ieee80211/ieee80211_module.c	2005-04-30 23:23:18.000000000 +0200
 <at>  <at>  -40,7 +40,6  <at>  <at> 
 #include <linux/kernel.h>
 #include <linux/module.h>
 #include <linux/netdevice.h>
-#include <linux/pci.h>
 #include <linux/proc_fs.h>
 #include <linux/skbuff.h>
 #include <linux/slab.h>
--- linux-2.6.12-rc3-mm1-full/net/ieee80211/ieee80211_tx.c.old	2005-04-30 23:23:25.000000000 +0200
+++ linux-2.6.12-rc3-mm1-full/net/ieee80211/ieee80211_tx.c	2005-04-30 23:23:32.000000000 +0200
 <at>  <at>  -33,7 +33,6  <at>  <at> 
 #include <linux/kernel.h>
 #include <linux/module.h>
 #include <linux/netdevice.h>
(Continue reading)

Ryan Sorensen | 2 May 08:05 2005
Picon

TinyPEAP and wpa_supplicant

Just in case anyone is trying to do TinyPEAP and wpa_supplicant, the
configuration on the tinyPEAP website needs to be amended to this:

phase1="include_tls_length=1 peaplabel=0"

instead of

phase1="peaplabel=0"

I still haven't figured out how to get the certificate in the right
format, but that'll come later.

-rcs
Pedro Ramalhais | 2 May 18:55 2005
Picon

Re: wpa_supplicant, ipw2200, association timeouts and other allegations

On Fri, 2005-04-29 at 03:21, Petros Kolyvas wrote:
> Hi! This is my first post to the list. It was suggested I try my luck 
> here by some kind folks at #ipw2200 and #wireless on freenode.
> 
> My problems involve wpa_supplicant and my inability to get it to 
> associate with my access point. The hardware involved is an Intel 
> Pro/Wireless 2200BG (on a dell inspiron 700m) and a D-Link 2100AP 
> (currently running with WPA-PSK using CCMP/AES encryption). The setup 
> works fine under *cough* that other OS. I would like to be completely 
> free of it though.
> 
> The laptop is currently running FC3 and today I compiled and installed 
> 2.6.11.7 with the appropriate modules and options successfully. I'm also 
> using wpa_supplicant 0.4.0 and the latest (1.0.3 at the time of posting) 
> ipw2200 drivers. The wireless card will associate correctly with any 
> open networks, so at least that much is functioning.
> 
> "iwlist eth1 scanning" outputs:
> 
> #start
> Scan completed :
>       Cell 01 - Address: 00:11:95:BF:A6:4F
>                 ESSID:"ShiftFocus"
>                 Protocol:IEEE 802.11bg
>                 Mode:Master
>                 Channel:3
>                 Encryption key:on
>                 Bit Rate:54 Mb/s
>                 Extra: Rates (Mb/s): 1 2 5.5 9 11 6 12 18 24 36 48 54
>                 Quality=93/100  Signal level=-34 dBm
(Continue reading)

Christian Bünnig | 2 May 22:13 2005
Picon

Re: Using monitor mode

No idea what's the reason for ethereal's behaviour, but have a try with 
'kismet'! It generally sniffs all packets and is able to store them in a 
libpcap file you can later open with ethereal to inspect it.
It further gives you some infos on seen nodes and networks.

christian

Johnny Choque wrote:
> Hi all,
> 
> I have two laptop which are set to ad-hoc mode and ping from one laptop to
> another. Also, I have a third laptop which is set to monitor mode in order
> to sniff all traffic between laptops in ad-hoc mode. My problem is that
> running ethereal in the third laptop not capture data traffic (ping packets)
> and only capture 802.11 management frames. I had tried to use monitor mode 2
> and 3 but the problem is the same.
> 
> Please, someone tell me how should configure my laptops in order to capture
> simultaneously both data packets and 802.11 management frames?
> 
> Thanks in advance,
> 
> Johnny
> 
> _______________________________________________
> HostAP mailing list
> HostAP <at> shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
Randall Ross | 2 May 22:20 2005

No messages when card inserted (FC3, 2.6.10)

My system is Fedora Core 3 with (my own) kernel 2.6.10. I'm trying to 
use hostap-driver-0.3.7, (*have also tried 0.4.0 with same results.)

I successfully ran 'make' and 'make install'. No error messages.

Upon insertion of my  Netgear MA401 PC card, I get *no messages at all* 
in /var/log/messages.

This card has been verified to work in this machine with FC3, and kernel 
2.6.10. In fact I had been using it previously and recently. I suspect 
that this recent failure might have something to do with SELinux, as 
I've recently turned on that feature in my kernel, however I cannot say 
for sure if that is the cause. I have another PC wifi card (Buffalo) 
that uses Linuxant drivers, and functions normally. I also have a USB 
wifi dongle (D-link) that uses wlan-ng drivers and also functions normally.)

Can someone shed some light on how I could debug what's happening? What 
should I look for?

Thanks in advance.
Nicolas Labrosse | 3 May 15:10 2005
Picon

Problem with WPA-PSK

Hi everyone,
I've tried to sort this out on the gentoo forum but without success.
I want to use Wifi on my laptop and I use wpa_supplicant with atheros card AR5212. It works if I choose WEP
encryption but I can't get it to work if I choose WPA-PSK.
I use wpa_supplicant v0.3.8, madwifi-driver-0.1_pre20050224, and madwifi-tools-0.1_pre20050106
from portage
System: Linux laptop 2.6.11-gentoo-r6 #5 SMP Tue Apr 26 23:29:55 BST 2005 i686 Mobile Intel(R) Pentium(R)
4     CPU 3.06GHz GenuineIntel GNU/Linux

Here is the output of running 'wpa_supplicant -iath0 -c/etc/wpa_supplicant.conf -Dmadwifi -dd'
***
Initializing interface 'ath0' conf '/etc/wpa_supplicant.conf' driver 'madwifi'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0
eapol_version=1
ap_scan=1
Line: 187 - start of a new network block
ssid - hexdump_ascii(len=10):
     obscured                     my_ssid
PSK (ASCII passphrase) - hexdump_ascii(len=18): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='my_ssid'
Initializing interface (2) 'ath0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
(Continue reading)

Tilman Schoop | 3 May 15:08 2005
Picon

WPA with Cisco PCMCIA card?

Hi all,

I would like to know if there is a possibility to setup eap/tls and tkip
with wpa_supplicant and a Cisco 350 PCMCIA WLAN card.

I have seen that my card does not fall into one of the categories of
supported drivers for wpa_supplicant, but from Jean Tourilhes howto
website I have learned that the Cisco driver 2.1 can do AES(host) and
MIC. Is there a possibility to use this driver with wpa_supplicant?
Has anybody already configured this setup? Or am I misunderstanding
something?

Thanks

Tilman
martin.p.bradley | 3 May 17:14 2005

How to use eapol_test

Folks,

I have got eapol_test compiled thanks to Jouni but I don't know how to
use it.  Could someone tell me where the documentation is or how to use
it.

I have searched www.google.com for eapol_test and my last message came
as the first hit.  This was a first for me :-)

Thanks for any help.
Martin.

On Wed, Apr 06, 2005 at 09:44:10AM +0100, martin.p.bradley at bt.com
wrote:

> Yes it looks like I'm using the wrong openssl library.  How can I
select
> the on that's installed in the directory /usr/local/openssl-0.9.7b/.
> Does the line below do what I need?  Probably not but that was what I
> tried...
> 
> export LDFLAGS=-L/usr/local/openssl-0.9.7b/

I use following lines in .config to select another openssl version:

CFLAGS += -I/home/jm/openssl/include
LIBS += -L/home/jm/openssl/lib

> eapol_test includes a file called radius.h.   I guessed that this was
> the radius.h but it looks like its not the correct one.
(Continue reading)

Pavel Roskin | 3 May 23:50 2005
Picon

[PATCH] Warning fix for 64-bit platforms

Hello!

The patch fixes following warning seen on 64-bit platforms (in my case -
x86_64, gcc-4.0):

In file included from /usr/local/src/hostap/driver/modules/hostap_cs.c:203:
/usr/local/src/hostap/driver/modules/hostap_hw.c: In function ‘prism2_transmit_cb’:
/usr/local/src/hostap/driver/modules/hostap_hw.c:1674: warning: cast from pointer to integer of
different size
/usr/local/src/hostap/driver/modules/hostap_hw.c: In function ‘prism2_transmit’:
/usr/local/src/hostap/driver/modules/hostap_hw.c:1758: warning: cast to pointer from integer of
different size

prism2_transmit_cb uses a (void *) argument to get an integer.   A
simple fix would be to use double cast from pointer to long and then to
int (and vice versa when int is passed as a pointer).  But I prefer a
slightly longer patch.

I believe that whenever an argument can hold both a pointer and an
integer, it should be declared long.  long can hold both pointers and
integers (except win64, but we are not coding for Windows), it can be
cast to both of them and it's never assumed to be a valid pointer, which
could be useful for some automatic code checkers.

Signed-off-by: Pavel Roskin <proski <at> gnu.org>

--- driver/modules/hostap_hw.c
+++ driver/modules/hostap_hw.c
 <at>  <at>  -510,9 +510,9  <at>  <at>  static int hfa384x_cmd(struct net_device
  */
(Continue reading)

Tony Espy | 4 May 01:29 2005

HostAP, iwconfig power and SIOCSIWPOWER

I have two questions regarding HostAP and SIOCSIWPOWER/iwconfig power.

1. Since the Prism firmware has default settings for MaxSleepDuration 
and HolderoverDuration ( ie. timeout ), is there anyway to enable power 
save without setting a value for one these two parameters?  From looking 
at the source in hostap_ioctl.c, it doesn't appear so...

2. Why does the HostAP prism2_ioctl_siwpower() method divide the given 
sleep and timeout values by 1024?  Shouldn't this be 1,000?
I took a peek at the WirelessTools iwconfig code and it multiplies the 
PS parameters by the constant MEGA ( == 1e6 ) if no specifier suffix is 
supplied.

Tony Espy
Pepper Computer, Inc.

Gmane