Rüdiger Beck | 1 Aug 13:30 2011
Picon

Re: Sophomorix: Benutzer löschen schlägt fehl (log not ready for archive)

Hallo,

so wie ich das am Quellcode nachvollziehe, sollte der user gelöscht
werden und wenn es was in /var/log/sophomorix/user-modify.log
steht, wird es in /var/log/sophomorix/user-modify-archive.log
verschoben. Wenn nichts steht, kommt untenstehende Meldung 'not ready
for archive'.

Könnten sie bitte testen:

erscheint der user mit sophomorix-kill -i ?

wird der user wirklich nicht gelöscht?

id loging
sophomorix-user -u login

gibt es Eintrage zu dem user in /var/log/sophomorix/user-modify.log?

Falls sophomorix-kill den angezeigen user nicht löscht wäre  die Ausgabe
von

sophomorix-kill -vv

interessant.

Viele Grüße, Rüdiger Beck

Am 29.07.2011 14:40, schrieb Frerk-Sasa Popovic:
> Hallo zusammen,
(Continue reading)

Jochen Rupp | 1 Aug 16:24 2011
Picon

Linbo: Windows startet nicht, da hal.dll fehlt oder beschädigt

Hallo Liste,

wir haben gerade auf Linbo umgestellt (paedML 5.02 und Linbo 1.99-17-28) und nun ein Problem mit einer
Hardwareklasse: beim Versuch, Windows zu starten, kommt immer folgende Fehlermeldung:

Windows konnte nicht gestartet werden, da folgende Datei fehlt oder beschädigt ist
<Windows root>\system32.hal.dll.
Installieren Sie ein Exemplar der oben angegebenen Datei erneut.

Nach Recherche im Listenarchiv haben wir das Image bereits nocheinmal hochgeladen für den Fall, dass es
defekt gewesen sein sollte (Tipp von Holger), außerdem haben wir die Tipps von Thorsten Koslowski
umgesetzt, alle Partitionen des Clients von der Linbo-Konsole aus zu löschen, neu zu partitionieren
und es dann nochmals mit Neu+Start zu versuchen: alles vergeblich.

Ich meine, dass das Auspacken des cloop dabei gar nicht bis 100% durchläuft, kann das aber nicht mit
Sicherheit sagen. Habt Ihr das auch beobachtet?

Habt Ihr noch einen Tipp? Kann man die angemahnte hal.dll irgendwie reinkopieren/patchen?

Das Ganze hat in einer Testumgebung schon wunderbar funktioniert (allerdings haben wir dort das Image
auch auf denselben Rechner zurückgespielt und nicht auf einen anderen.)

Danke und Gruß,

Jochen Rupp
KKS Esslingen

_______________________________________________
 Hinweis:
 Bitte melden Sie sich unter http://www.support-netz.de/hotline.html
(Continue reading)

Alois Raunheimer | 1 Aug 17:14 2011
Picon

Re: [linuxmuster] Linbo: Windows startet nicht, da hal.dll fehlt oder beschädigt

Hallo Jochen,

Am 01.08.2011 16:24, schrieb Jochen Rupp:
> Hallo Liste,
>
> wir haben gerade auf Linbo umgestellt (paedML 5.02 und Linbo 1.99-17-28) und nun ein Problem mit einer
Hardwareklasse: beim Versuch, Windows zu starten, kommt immer folgende Fehlermeldung:
>
> Windows konnte nicht gestartet werden, da folgende Datei fehlt oder beschädigt ist
> <Windows root>\system32.hal.dll.
> Installieren Sie ein Exemplar der oben angegebenen Datei erneut.
>
> Nach Recherche im Listenarchiv haben wir das Image bereits nocheinmal hochgeladen für den Fall, dass es
defekt gewesen sein sollte (Tipp von Holger), außerdem haben wir die Tipps von Thorsten Koslowski
umgesetzt, alle Partitionen des Clients von der Linbo-Konsole aus zu löschen, neu zu partitionieren
und es dann nochmals mit Neu+Start zu versuchen: alles vergeblich.
>
ich hatte das Problem auch einmal. Bei mir war es eine alte Patchdatei. 
Mit einer neuen Datei funktionierte es dann. Die neuen Dateien liegen 
irgendwo unter /var/linbo/exaples oder so ähnlich (ich kann im Moment 
nicht nachsehen, weil der Server Ferien hat ;-) ).

Gruß

Alois

_______________________________________________
 Hinweis:
 Bitte melden Sie sich unter http://www.support-netz.de/hotline.html
 an der Hotline des Support-Netzes an.
(Continue reading)

Jochen Rupp | 1 Aug 22:05 2011
Picon

Re: Linbo: Windows startet nicht, da hal.dll fehlt oder beschädigt

Hallo Alois,

>> Nach Recherche im Listenarchiv haben wir das Image bereits nocheinmal hochgeladen für den Fall, dass
es defekt gewesen sein sollte (Tipp von Holger), außerdem haben wir die Tipps von Thorsten Koslowski
umgesetzt, alle Partitionen des Clients von der Linbo-Konsole aus zu löschen, neu zu partitionieren
und es dann nochmals mit Neu+Start zu versuchen: alles vergeblich.
>>
>ich hatte das Problem auch einmal. Bei mir war es eine alte Patchdatei.
>Mit einer neuen Datei funktionierte es dann. Die neuen Dateien liegen
>irgendwo unter /var/linbo/exaples oder so ähnlich (ich kann im Moment
>nicht nachsehen, weil der Server Ferien hat ;-) ).

Da wir ganz neu auf Linbo umgestellt haben und die aktuellste Version haben, gehe ich davon aus, dass die
Patchdatei ok ist. Funktioniert auch mit einer anderen HW-Klasse. Aber ich schau mir das nochmal an.

Viele Grüße,

Jochen Rupp
KKS Esslingen

_______________________________________________
 Hinweis:
 Bitte melden Sie sich unter http://www.support-netz.de/hotline.html
 an der Hotline des Support-Netzes an.
 Nur so koennen wir eine langfristige Weiterentwicklung und einen
 nachhaltigen und guten Support gewaehrleisten. Vielen Dank.
Holger Baumhof | 1 Aug 23:47 2011
Picon

Re: [linuxmuster] Linbo: Windows startet nicht, da hal.dll fehlt oder beschädigt

Hallo Jochen,

> Da wir ganz neu auf Linbo umgestellt haben und die aktuellste Version haben, gehe ich davon aus, dass die
Patchdatei ok ist. Funktioniert auch mit einer anderen HW-Klasse. Aber ich schau mir das nochmal an.

auch ich tippe auf die Patchdatei.
Das Problem ist, dass die Windows registry eine "esoterischer Mist" ist.
Da steht immer mal was anderes drin.
Ganz Bitter wird es, wenn es ein Vorinstalliertes Windows durch einen 
großen OEM ist (DELL HP ...).

Versuch erstmal das Image zurück zu spielen, nachdem du die .reg Datei 
einfach verschoben hast, damit eben nicht gepatched wird.

Außerdem: schau in die Logadateien unter /var/linbo/log/
Das hilft (auch hier posten).

viele Grüße

Holger

PS: ich bin im Urlaub und nur sehr sporadisch im Netz.

_______________________________________________
 Hinweis:
 Bitte melden Sie sich unter http://www.support-netz.de/hotline.html
 an der Hotline des Support-Netzes an.
 Nur so koennen wir eine langfristige Weiterentwicklung und einen
 nachhaltigen und guten Support gewaehrleisten. Vielen Dank.
(Continue reading)

Thorsten Koslowski | 2 Aug 09:12 2011
Picon

Re: Linbo: Windows startet nicht, da hal.dll fehlt oder beschädigt

Hallo Jochen!

> > Da wir ganz neu auf Linbo umgestellt haben und die aktuellste Version
> > haben, gehe ich davon aus, dass die Patchdatei ok ist. Funktioniert auch
> > mit einer anderen HW-Klasse. Aber ich schau mir das nochmal an.
> 
> auch ich tippe auf die Patchdatei.
> Das Problem ist, dass die Windows registry eine "esoterischer Mist" ist.
> Da steht immer mal was anderes drin.
> Ganz Bitter wird es, wenn es ein Vorinstalliertes Windows durch einen
> großen OEM ist (DELL HP ...).
> 
> Versuch erstmal das Image zurück zu spielen, nachdem du die .reg Datei
> einfach verschoben hast, damit eben nicht gepatched wird.

Schliesse mich Alois und Holger an, auf alle Fälle eine neue patch-Datei aus 
den Beispielen nehmen.

Auch gibt es etwas im Wiki zu dem Thema, zwecks Fehlersuche!

  http://www.linuxmuster.net/version3:neuehardwareneustart

Allerdings der Hinweis: " Ich hoffe das Linbo um so eine Funktion erweitert 
wird ... " ist veraltet. 

> Außerdem: schau in die Logadateien unter /var/linbo/log/
> Das hilft (auch hier posten).

 <at>  Holger und alle anderen die im Urlaub sind.
Geniesst die Zeit und findet die Ruhe für das was kommt. :-)
(Continue reading)

Jochen Rupp | 2 Aug 09:45 2011
Picon

Re: Linbo: Windows startet nicht, da hal.dll fehlt oder beschädigt

Hi all,

>Schliesse mich Alois und Holger an, auf alle Fälle eine neue patch-Datei aus
>den Beispielen nehmen.

ich hab' die Patch-Datei jetzt mal weggemoved -> selbes Ergebnis!

Was mir aber beim Anschauen der logs aufgefallen ist: das cloop wird gar nicht vollständig entpackt, kurz
nach 49% ist Schluss und er meldet: input corrupt.

Also doch ein defektes Image!? Hab das aber auch schon zweimal hochgeladen, was kann dabei jeweils
schiefgehen? Ich werde das jetzt noch ein drittes Mal hochladen, während im Netz und auf dem Server
ansonsten 0,0 passiert, die nächste Idee wäre, mal eine gescheite NIC einzubauen und es damit zu
versuchen, da die Onboard-NIC ganz miese Transferraten bietet, vielleicht liegt ja auch hier was im Argen.
Melde mich wieder....

Bis dahin vielen Dank für Eure Tipps!

Viele Grüße,

Jochen Rupp
KKS Esslingen

_______________________________________________
 Hinweis:
 Bitte melden Sie sich unter http://www.support-netz.de/hotline.html
 an der Hotline des Support-Netzes an.
 Nur so koennen wir eine langfristige Weiterentwicklung und einen
 nachhaltigen und guten Support gewaehrleisten. Vielen Dank.
(Continue reading)

Frerk-Sasa Popovic | 2 Aug 11:32 2011
Picon
Picon

Re: [linuxmuster] Linbo: Windows startet nicht, da hal.dll fehlt oder beschädigt

Hi,

du kannst auf dem Client (vom Server aus) im Cache nachsehen, wie groß 
das Image ist:

ssh -p 2222 -l root <IP-Adresse>
mount /dev/sda6 /cache     //anstelle von sda6 ggf. ...
cd /cache
ls -la

und dann auf dem Server unter /var/linbo nachsehen, ob das Image dort 
die gleiche Größe hat.

Du kannst natürlich auch die Dateien im Cache löschen und das Image neu 
erstellen und danach hochladen.

lg Frerk

Am 02.08.2011 09:45, schrieb Jochen Rupp:
> Also doch ein defektes Image!? Hab das aber auch schon zweimal hochgeladen, was kann dabei jeweils schiefgehen?

--

-- 
email:	frerk@...
url:	http://popovic.info

_______________________________________________
 Hinweis:
 Bitte melden Sie sich unter http://www.support-netz.de/hotline.html
 an der Hotline des Support-Netzes an.
 Nur so koennen wir eine langfristige Weiterentwicklung und einen
(Continue reading)

Frerk-Sasa Popovic | 2 Aug 11:40 2011
Picon
Picon

Re: Sophomorix: Benutzer löschen schlägt fehl (log not ready for archive)

Hallo Herr Beck,

vielen Dank für Ihre ausführliche Antwort. Die Benutzer (es waren wohl 
ca. 50 von >1000, die ich löschen wollte) tauchen nun kurioser Weise 
nicht mehr auf?!

Ich kann mir das nicht erklären und entschuldige mich!

lg Frerk Popovic

Am 01.08.2011 13:30, schrieb Rüdiger Beck:
> id login
User gibt es nicht mehr.
> sophomorix-user -u login
dito
> gibt es Eintrage zu dem user in /var/log/sophomorix/user-modify.log?
Nein, die letzten Einträge sind ein Jahr alt.

--

-- 
Frerk-Sasa Popovic

Kepler-Gymnasium
Johanna-Kohlund-Str. 5
79111 Freiburg
+49 761 201-7676 (Sek.)
+49 761 201-7439 (Fax)

email:	f_popovic@...
url:	http://kepler-freiburg.de

(Continue reading)

Jochen Rupp | 2 Aug 12:12 2011
Picon

Re: Linbo: Windows startet nicht, da hal.dll fehlt oder beschädigt

Hi all,

dieses Problem wäre nun gelöst! Es lag tatsächlich an einem defekten Image. Wir haben das Image nun zum
dritten Mal hochgeladen, dieses Mal
- ohne dass der Server sonst irgendwas gemacht hat
- ohne dass im Netz sonst irgendwas lief
- ohne dass wir während des Uploads die start.conf über die Schulkonsole geändert haben
- mit gelegentlichem Kopfkratzen

und was soll ich sagen: jetzt funktionierts. Auch mit Patch. Woran's lag: ??? Vielleicht kann man die o.g.
Tipps ja ins Handbuch aufnehmen ;-)

Vielen Dank Euch allen für die Tipps! Da sieht man halt mal wieder, was man an der Mailingliste hat!!!

Viele Grüße,

Jochen Rupp
KKS Esslingen

P.S.: eine dritte HW-Klasse scheint auch noch Probleme zu machen aber eins nach dem anderen. Eventuell
gibt's dazu gleich nen anderen Thread....?

_______________________________________________
 Hinweis:
 Bitte melden Sie sich unter http://www.support-netz.de/hotline.html
 an der Hotline des Support-Netzes an.
 Nur so koennen wir eine langfristige Weiterentwicklung und einen
 nachhaltigen und guten Support gewaehrleisten. Vielen Dank.

Gmane