David Christensen | 1 Sep 01:44 2008

RE: Debian 4.0 on VMware Player 2.0.5 on WinXP Pro SP3 keybounce,network, clock issues

Steve Kemp wrote:
> When it failed what was the symptoms from the Debian side?

The Debian machine cannot access the network.

> I'd guess that it came up as eth1, eth2, etc.  See if that is the
> case by running "ifconfig -a".

$ cat ifconfig-a-eth0-dead.txt
eth0      Link encap:Ethernet  HWaddr 00:0C:29:5A:F3:3A
          inet6 addr: fe80::20c:29ff:fe5a:f33a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:1494 (1.4 KiB)
          Interrupt:10 Base address:0x1400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
(Continue reading)

Alex Samad | 1 Sep 02:24 2008
Picon

Re: udev and partitioning

On Sun, Aug 31, 2008 at 07:16:54AM -0700, - Xian wrote:
> Hi all,
> 
> I just setup a machine with an ide disk for / and two sata disks I intend to mirror for storage. There were two
partitions on the sata disks I wiped out to turn into one big linux raid autodetect partition. With
/dev/sda, the processes worked just fine. I cfdisk'ed the drive and it's device node showed /dev/sda and
/dev/sda1. The second disk I partitioned and udev never updated and continued to show /dev/sdb,
/dev/sdb1, and /dev/sdb2. 
> 
> I tried echo'ing "- - -" into the proc scsci scan file to try to get the change to kick. dmesg showed that the
kernel saw sdb correctly, but udev never updated. I even ran udevmonitor and did the echo rescan thing, but
udev never even got the hotplug notification.
> 
> I've since rebooted the box and all was well, so I built my mirror. But I'm a bit nervous that I had to reboot.
If I loose a drive, will I have to reboot to get hotplug to work then too? Should I have had to rebooted to get
the partition table rescanned? Is there a way to force udev to start over and rescan everything? Is there a
reason why the kernel saw /dev/sdb1, but udev did not manage the nodes properly?

I usually run udevtrigger  or /etc/init.d/udev restart if I want udev to
re look at the system (not sure if thats the right way, its just worked
for me)

> 
> Thanks,
> Christian
> 
> 
>       
> 
> 
(Continue reading)

David L. Craig | 1 Sep 02:32 2008
Picon
Picon

Re: Oddity In stty

On Sun, 2008-08-31 at 17:35 -0400, David L. Craig wrote:
> I can't figure this out.  Why does the first pipeline suceed but the second fails?
> I'm running an up-to-date Sid.
> 
> dlc <at> muse:~$                 fold -w `stty -a | head -1 | awk '{print $7}' | tr -d ';'` < /dev/null
> dlc <at> muse:~$ cat /dev/null | fold -w `stty -a | head -1 | awk '{print $7}' | tr -d ';'`
> stty: standard input: Invalid argument
> fold: option requires an argument -- w
> Try `fold --help' for more information.
> dlc <at> muse:~$ 

Well, I figured out a way around it:  stty -a </dev/tty
Solaris behaves similarly.  I'm surprised this isn't
documented behavior.

David Christensen | 1 Sep 05:16 2008

RE: Debian 4.0 on VMware Player 2.0.5 on WinXP Pro SP3 keybounce, network, clock issues

debian-user:

Blindly calling ifdown/ifup from /etc/rc.local was cheesy, and sure enough it
didn't work reliably.  So I wrote a Bash shell script to ping my gateway and do
ifdown/ifup only if needed (three times maximum).  I call that from rc.local
instead:

    /root/bin/kick-eth0

David

#!/bin/bash
#######################################################################
# $Id: kick-eth0,v 1.2 2008/09/01 03:13:47 dpchrist Exp $
#
# Wake up interface eth0 as a work-around on Debian GNU/Linux virtual
# machines running under VMware Player.  Called by /etc/rc.local.
#
# Copyright 2008 by David Paul Christensen dpchrist <at> holgerdanske.com
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; version 2.
#
# This program is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public License
(Continue reading)

David Christensen | 1 Sep 05:50 2008

RE: Debian 4.0 on VMware Player 2.0.5 on WinXP Pro SP3 keybounce,network, clock issues

Steve Kemp wrote:
> Use the open-vm-tools package.  Edited that would look something like
> this:
>     apt-get install module-assistant open-vm-tools open-vm-source

Aptitude sees module assistant, but not the others:

    # aptitude search module-assistant open-vm
    p   module-assistant                - tool to make module package creation
easie

http://packages.debian.org/search?keywords=open-vm-tools shows the module
open-vm-tools in etch-backports, lenny, and sid.

http://www.backports.org/dokuwiki/doku.php?id=instructions tells me how to add
etch-backports to package management system.

Running 'aptitude update' finds a bunch of stuff.

Running 'aptitude install module-assistant' installs just that one module.

Running 'aptitude -t etch-backports install open-vm-tools open-vm-source' blows
up (see below) and takes out eth0.  Logging in on the VMware console -- the
network connection is dead.  Running kick-eth0 script -- lots of errors.
Reboot.  Network is toast.  Shut down virtual machine, move folder aside, unzip
last backup...

Any suggestions?

David
(Continue reading)

Robert Jerrard | 1 Sep 05:18 2008
Picon

Re: network restart

On Fri, 2008-08-29 at 09:30 +0300, Andrei Popescu wrote:
> On Wed,27.Aug.08, 21:34:38, Robert Jerrard wrote:
> > I just got a new Siemens modem for the Telus high speed enhanced
> > service. If I turn off the modem then turn it back on my Debian amd64
> > system has an IP address of 169.... when it should be a 192.... address
> > from the DHCP set-up. No problem, just restart the network, right?
> > However, when I do a
> > 
> > /etc/init.d/networking restart
> > 
> > it claims to have reconfigured the network but the IP address is not
> > changed. I still have the 169... address. A reboot resets the IP
> > properly but I should not have to reboot. Any idea why the soft
> > networking restart does not re-do the IP properly?
>  
> Check if you have zeroconf or network-manager installed and purge them.

Thanks Andrei, I had network-manager installed, purging it fixed the
problem.

Bob

--

-- 
Dr. Robert J. Jerrard, Professor of Mathematics,
Concordia University College of Alberta,
7128 Ada Blvd., Edmonton, Alberta, T5B 4E4, Canada.
Phone: (780) 479-9291, Fax: (780) 474-1933.

gary turner | 1 Sep 06:27 2008
Picon

Re: Does anyone know where to find mod_auth_form

Alan Chandler wrote:
> I quite like the idea of making my web site use the facilities described 
> for mod_auth_form (see apache2 manual).
> 
> But I can't find where to get this module from.  There doesn't appear to 
> be a debian package.  Why? 

These appear to be (at least session module) in Apache 2.3.  Current 
Lenny version is 2.2.9-7

Would that be the difference?

cheers,

gary
--

-- 
Anyone can make a usable web site. It takes a graphic
designer to make it slow, confusing and painful to use.
Attachment (gary_kk5st.vcf): text/x-vcard, 291 bytes
Mumia W.. | 1 Sep 06:10 2008
Picon
Picon

Re: Sound volume user specific?

On 08/31/2008 01:00 PM, Michal R. Hoffmann wrote:
> [...]
> Thanks to few other responses I know I can use alsactl; I tried as a 
> mere user (not a root) and it allows me to store / restore the settings; ie
> /usr/sbin/alsactl -f /home/userA/.alsa-config store
> /usr/sbin/alsactl -f /home/userA/.alsa-config restore
> 
> Now, what are the ideal places to put these commands in? So it would 
> store on switch user/logout and restore on login? I'm afraid that if I 
> just modify the gdm configuration files (like gdm.conf) they will be 
> overridden soon with some gdm update (quite possible in sid). On the 
> other hand I'd prefer to get it working globally (not to add a script on 
> each user's account).
> 

If you're using IceWm or KDE, you can put the appropriate commands into 
~/.icewm/startup or ~/.kde/Autostart/. Gnome has a sessions system that 
might let you specify a startup script; for scripts that quickly 
configure something then exit, this is tricky, but you can try going 
into "Settings-> Sessions" (from memory). The dialog may or may not 
allow you to add your script to the session.

Other options are ~/.bash_profile and ~/.bashrc; however, the commands 
would then execute at either each login or each new subshell creation 
event. It's possible to write the code so that the script that sets the 
volume only executes once per login or session or day.

Mumia W.. | 1 Sep 05:53 2008
Picon
Picon

Re: Debian 4.0 Etch apache-perl "File does not exist: ... /server-info"

On 08/31/2008 05:24 PM, David Christensen wrote:
> debian-user:
> 
> I have a Debian 4.0 Etch virtual machine and have installed apache-perl.  I
> would like to be able to obtain server information by browsing to /server-info.
> [...]
> My guess is that mod_info.c isn't loaded (or compiled in).
> 
> 
> 'locate mod_info' returns nothing.
> 
> 
> http://www.debian.org/distrib/packages#search_contents makes me wonder if I need
> to install apache-common?
> [...]

Yes, install apache-common and perform whatever procedure you use to 
enable Apache 1.3 modules.

Daniel Dickinson | 1 Sep 04:06 2008
X-Face
Picon

Exim4 SMTP direct send, blocked incoming port 25

Is it possible to use exim4 to send mail if port 25 is blocked by the
ISP (incoming)?  I can receive mail by using easyDNS and getting them
to forward my mail to another port, but I'm not sure outgoing
will work. 

I tried doing that a while back and I had issues, but there was
also list trouble at the time, so I don't know if it was a
misconfiguration, the blocked port, or external misconfiguration that
was the problem.  Rather than mess around with my settings before
having answers, I want to find some things out in advance this time.

Oh yes, I'm using dynamic DNS, and at that time I had and SPF TXT
record on the name server.

Regards,

Daniel

--

-- 
And that's my crabbing done for the day.  Got it out of the way early, 
now I have the rest of the afternoon to sniff fragrant tea-roses or 
strangle cute bunnies or something.   -- Michael Devore
GnuPG Key Fingerprint 86 F5 81 A5 D4 2E 1F 1C      http://gnupg.org
The C Shore: http://www.wightman.ca/~cshore

Gmane