cbarn | 1 Mar 07:57 2011
Picon

Bug#589404:

Hi
Sorry to do this and the timing just fell this way.
The 7 year old HD on the box started giving signs of problems so I loaded Squeeze on a new HD and that bug is still there.

I have more info and haven't loaded anything over Squeeze (yet)
I booted into recovery mode and then tried to run startx which freezes things.
When I get back to a console the following text is displayed above the prompt (I have omitted 3 or 4 lines shown
by dots)

X Org X Server 1.7.7
Release Date  2010-05-04
X Protocol Version 11, Revision 0
Build Operation System: Linux 2.6.32.28-dsa-ia32 i686 Debian
Current Operating System Linux xxxx 2.6.32-5-686 #1 SMP wed jan 12 04:01:41 UTC 2011 i686
Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-5-686
root=UUID=c5ea98ad-860d-45c8-8319-9893cd73d8cf ro single
Build Date: 12 January 2011  03:44:48AM
xorg-server 2:1.7.7-11 (Cyril Brulebois <kibi <at> debian.org>)
Current version of pixman: 0.16.4
.....
.....
.....
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 28 18:37:16 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
SELinux: Disabled on system, not enabling in X server
(EE) AIGLX error: dlopen of /usr/lib/dri/nouveau_vieux_dri.so failed
(/usr/lib/dri/nouveau_vieux_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering 
re size called 1600 900

(Continue reading)

Uwe Kleine-König | 1 Mar 09:28 2011
Picon

Bug#615945: xserver-xorg: window not properly repainted

Package: xserver-xorg
Version: 1:7.5+8
Severity: normal

Hello,

after sending a window that covered the terminal before to the
background the terminal wasn't repainted correctly (see attachment).
After switching virtual desktops it was displayed correctly again.

I already saw that with a .37 based kernel and sometimes the damage
doesn't occupy the whole window but only a rectangular part of it.

Best regards
Uwe

-- Package-specific info:
X server symlink status:
------------------------
lrwxrwxrwx 1 root root 13 Oct 27  2009 /etc/X11/X -> /usr/bin/Xorg
-rwxr-xr-x 1 root root 1733468 Feb 19 15:43 /usr/bin/Xorg

VGA-compatible devices on PCI bus:
----------------------------------
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03)

/etc/X11/xorg.conf does not exist.

/etc/X11/xorg.conf.d does not exist.

(Continue reading)

Neil Youngman | 1 Mar 09:58 2011

Bug#609490: xserver-xorg: X totally hung in screensaver. Possibly i915 related?

On Saturday 26 Feb 2011 13:40:24 Cyril Brulebois wrote:
> Hi,
> 
> Neil Youngman <n.s.youngman <at> btinternet.com> (09/01/2011):
> > Several times I have found the system hung in the screensaver. It
> > would not respond to CTRL_ALT-Fn or CTRL-ALT-Backspace. Absent any
> > way to remotely access the system I have been forced to do a hard
> > reset. Following the most recent incident, I have observed the
> > following messages in the log (/var/log/messages). The references to
> > i915_gem_retire_work_handler lead me to belive that this is i915
> > related.
> 
> might be a kernel bug. Any chance you could give 2.6.37 or 2.6.38rc* a
> try? Those are available in sid and experimental respectively.
> 
> KiBi.

I have tried to install 2.6.37, but not all the dependencies are available. I 
will try again when that has been resolved.

Neil

Stephen Kitt | 1 Mar 11:33 2011

Bug#613593: xserver-xorg-video-radeon: [regression] X fails to start

On Mon, 28 Feb 2011 16:10:39 +0100, Michel Dänzer <daenzer <at> debian.org> wrote:
> > ==19774== Source and destination overlap in memcpy(0x5c84c70, 0x5c84c70,
> > 408) ==19774==    at 0x40258E5: memcpy (mc_replace_strmem.c:497)
> > ==19774==    by 0x49BD3EA: exaMemcpyBox (exa_migration_classic.c:59)
> > ==19774==    by 0x49BD8C4: exaCopyDirty (exa_migration_classic.c:234)
> > ==19774==    by 0x49BDDF3: exaCopyDirtyToFb (exa_migration_classic.c:298)
> > ==19774==    by 0x49C0048: exaDoMigration_mixed
> > (exa_migration_mixed.c:113) ==19774==    by 0x49BB75C: exaDoMigration
> > (exa.c:1131) ==19774==    by 0x49C6E08: exaTryDriverComposite
> > (exa_render.c:734) ==19774==    by 0x49C75C7: exaComposite
> > (exa_render.c:1033) ==19774==    by 0x811E11C: damageComposite
> > (damage.c:640) ==19774==    by 0x810F3BF: CompositePicture
> > (picture.c:1710) ==19774==    by 0x49C6933: exaTrapezoids
> > (exa_render.c:1181) ==19774==    by 0x810F0A7: CompositeTrapezoids
> > (picture.c:1751)
> 
> The only way I think this could happen is if the UploadToScreen hook
> fails. Indeed, I've only noticed now that you have 
> 
>         Option          "EXANoDownloadFromScreen" "on"
>         Option          "EXANoUploadToScreen" "on"
> 
> in xorg.conf. Does it work better without these options? The driver
> doesn't really support running without these hooks anymore.

Nice catch, thanks! Removing the options does indeed allow the server to
start, and so far everything is working correctly.

Would you like a patch to ignore (with a warning) these options if they're
set?
(Continue reading)

Michel Dänzer | 1 Mar 11:50 2011
Face
Picon

Bug#613593: xserver-xorg-video-radeon: [regression] X fails to start

On Die, 2011-03-01 at 11:33 +0100, Stephen Kitt wrote: 
> On Mon, 28 Feb 2011 16:10:39 +0100, Michel Dänzer <daenzer <at> debian.org> wrote:
> > > ==19774== Source and destination overlap in memcpy(0x5c84c70, 0x5c84c70,
> > > 408) ==19774==    at 0x40258E5: memcpy (mc_replace_strmem.c:497)
> > > ==19774==    by 0x49BD3EA: exaMemcpyBox (exa_migration_classic.c:59)
> > > ==19774==    by 0x49BD8C4: exaCopyDirty (exa_migration_classic.c:234)
> > > ==19774==    by 0x49BDDF3: exaCopyDirtyToFb (exa_migration_classic.c:298)
> > > ==19774==    by 0x49C0048: exaDoMigration_mixed
> > > (exa_migration_mixed.c:113) ==19774==    by 0x49BB75C: exaDoMigration
> > > (exa.c:1131) ==19774==    by 0x49C6E08: exaTryDriverComposite
> > > (exa_render.c:734) ==19774==    by 0x49C75C7: exaComposite
> > > (exa_render.c:1033) ==19774==    by 0x811E11C: damageComposite
> > > (damage.c:640) ==19774==    by 0x810F3BF: CompositePicture
> > > (picture.c:1710) ==19774==    by 0x49C6933: exaTrapezoids
> > > (exa_render.c:1181) ==19774==    by 0x810F0A7: CompositeTrapezoids
> > > (picture.c:1751)
> > 
> > The only way I think this could happen is if the UploadToScreen hook
> > fails. Indeed, I've only noticed now that you have 
> > 
> >         Option          "EXANoDownloadFromScreen" "on"
> >         Option          "EXANoUploadToScreen" "on"
> > 
> > in xorg.conf. Does it work better without these options? The driver
> > doesn't really support running without these hooks anymore.
> 
> Nice catch, thanks! Removing the options does indeed allow the server to
> start, and so far everything is working correctly.
> 
> Would you like a patch to ignore (with a warning) these options if they're
(Continue reading)

Michel Dänzer | 1 Mar 13:04 2011
Face
Picon

Bug#615491: xserver-xorg-core: does not fill correctly for complex boundaries

On Mon, 2011-02-28 at 12:03 -0800, Alan W. Irwin wrote: 
> On 2011-02-28 14:15+0100 Michel Dänzer wrote:
> 
> > On Sam, 2011-02-26 at 13:52 -0800, Alan W. Irwin wrote:
> >> Package: xserver-xorg-core
> >> Version: 2:1.7.7-11
> >> Severity: normal
> >>
> >>
> >> The PLplot development team have just implemented a demanding 2D fill
> >> rendering test for the X stack where we modify our standard example 27
> >> (see http://plplot.sourceforge.net/examples.php?demo=27) to change
> >> from drawing the boundary line of "spirographic" (e.g., hypotrochoid
> >> and epitrochoid) curves to filling those curves.  The boundaries
> >> of the 9 test curves are illustrated in the first attachment.
> >
> > [...]
> >
> >> 	Driver      "intel"
> >
> > Does the problem also occur with other drivers, e.g. fbdev or vesa (will
> > only work if booting with i915.modeset=0 to disable KMS)?
> 
> Thanks, Michel, for your reply.
> 
> Following your suggestion, I tried the EvenOddRule fill rule case for
> both fbdev and vesa, and the results were consistent (i.e., many fill
> rendering errors) with what happens for the intel driver. This has
> been the first time I have ever tried fbdev or vesa so in each case I
> confirmed those were the drivers I was running by checking
(Continue reading)

matsche | 1 Mar 14:25 2011
Picon

Bug#615975: xserver-xorg: Xorg server segfaults after starting some xclients (xterm, skype...)

Package: xserver-xorg
Version: 1:7.6+4
Severity: important

Xorg server segfaults after starting some xclients (xterm,skype etc.).
Here is the tail of the relevant log (Xorg.0.log.old) after starting xterm:

Backtrace:
[  8328.352] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80adddb]
[  8328.352] 1: /usr/bin/X (0x8048000+0x59a65) [0x80a1a65]
[  8328.352] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb775940c]
[  8328.352] 3: /usr/bin/X (ProcessWorkQueue+0x30) [0x808b0e0]
[  8328.352] 4: /usr/bin/X (WaitForSomething+0x56) [0x80a0bf6]
[  8328.352] 5: /usr/bin/X (0x8048000+0x2bc6e) [0x8073c6e]
[  8328.352] 6: /usr/bin/X (0x8048000+0x1e63a) [0x806663a]
[  8328.352] 7: /lib/i686/cmov/libc.so.6 (__libc_start_main+0xe6) [0xb745dc76]
[  8328.352] 8: /usr/bin/X (0x8048000+0x1e211) [0x8066211]
[  8328.352] Segmentation fault at address 0x705780f0
[  8328.352] 
Fatal server error:
[  8328.352] Caught signal 11 (Segmentation fault). Server aborting
[  8328.352] 
[  8328.352] 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  8328.352] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  8328.352] 
[  8328.353] (II) Power Button: Close
[  8328.353] (II) UnloadModule: "evdev"
(Continue reading)

Debian Bug Tracking System | 1 Mar 14:33 2011
Picon

https://bugs.freedesktop.org/show_bug.cgi?id=30647

Processing commands for control <at> bugs.debian.org:

> forwarded 613593 https://bugs.freedesktop.org/show_bug.cgi?id=30647
Bug #613593 [xserver-xorg-video-radeon] xserver-xorg-video-radeon: [regression] X fails to start
Set Bug forwarded-to-address to 'https://bugs.freedesktop.org/show_bug.cgi?id=30647'.
> thanks
Stopping processing here.

Please contact me if you need assistance.
--

-- 
613593: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=613593
Debian Bug Tracking System
Contact owner <at> bugs.debian.org with problems

Cyril Brulebois | 1 Mar 14:56 2011
Picon

Bug#615975: xserver-xorg: Xorg server segfaults after starting some xclients (xterm, skype...)

Hi,

matsche <thematsche <at> gmail.com> (01/03/2011):
> Xorg server segfaults after starting some xclients (xterm,skype
> etc.).  Here is the tail of the relevant log (Xorg.0.log.old) after
> starting xterm:
> 
> Backtrace:
> [  8328.352] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80adddb]
> [  8328.352] 1: /usr/bin/X (0x8048000+0x59a65) [0x80a1a65]
> [  8328.352] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb775940c]
> [  8328.352] 3: /usr/bin/X (ProcessWorkQueue+0x30) [0x808b0e0]
> [  8328.352] 4: /usr/bin/X (WaitForSomething+0x56) [0x80a0bf6]
> [  8328.352] 5: /usr/bin/X (0x8048000+0x2bc6e) [0x8073c6e]
> [  8328.352] 6: /usr/bin/X (0x8048000+0x1e63a) [0x806663a]
> [  8328.352] 7: /lib/i686/cmov/libc.so.6 (__libc_start_main+0xe6) [0xb745dc76]
> [  8328.352] 8: /usr/bin/X (0x8048000+0x1e211) [0x8066211]
> [  8328.352] Segmentation fault at address 0x705780f0

please get a full backtrace as described here:
  http://pkg-xorg.alioth.debian.org/howto/use-gdb.html

(Besides that, yay, nvidia…)

KiBi.
Chase Douglas | 1 Mar 16:40 2011
Picon

xserver-xorg-input-evdev: Changes to 'ubuntu'

 debian/changelog               |    6 ++
 debian/patches/100-xi2.1.patch |   83 ++++++++++++++++++++++-------------------
 2 files changed, 51 insertions(+), 38 deletions(-)

New commits:
commit 2e0433c5685391f835210b15aa8eb65fbe6cf9a7
Author: Chase Douglas <chase.douglas <at> canonical.com>
Date:   Tue Mar 1 09:13:29 2011 -0500

    Fix evdev when handling devices with full array of abs axes (LP: #725202)

diff --git a/debian/changelog b/debian/changelog
index d8905ed..37aa16b 100644
--- a/debian/changelog
+++ b/debian/changelog
 <at>  <at>  -1,3 +1,9  <at>  <at> 
+xserver-xorg-input-evdev (1:2.6.0-1ubuntu9) UNRELEASED; urgency=low
+
+  * Fix evdev when handling devices with full array of abs axes (LP: #725202)
+
+ -- Chase Douglas <chase.douglas <at> ubuntu.com>  Tue, 01 Mar 2011 09:10:35 -0500
+
 xserver-xorg-input-evdev (1:2.6.0-1ubuntu8) natty; urgency=low

   * Make xserver-xorg-input-evdev-udeb depend on xserver-xorg-core-udeb, not
diff --git a/debian/patches/100-xi2.1.patch b/debian/patches/100-xi2.1.patch
index 4d07e16..10598f1 100644
--- a/debian/patches/100-xi2.1.patch
+++ b/debian/patches/100-xi2.1.patch
 <at>  <at>  -124,7 +124,7  <at>  <at>  index 9a53211..715f8d1 100644
(Continue reading)


Gmane