Brice Goglin | 1 Aug 01:23 2009
Picon

xserver-xorg-video-mach64: Changes to 'upstream-unstable'

 COPYING               |  109 ++++++++++++++++++++++++++++++++++++++++++++++----
 README                |   13 ++++-
 configure.ac          |    6 ++
 src/atibus.c          |    3 -
 src/atimach64.c       |    5 ++
 src/atimach64render.c |    6 ++
 src/atipreinit.c      |   18 +++++++-
 src/atistruct.h       |    8 ++-
 8 files changed, 149 insertions(+), 19 deletions(-)

New commits:
commit 2013b64cf19fce32edb052ee6d8529d3ce69d409
Author: Dave Airlie <airlied <at> redhat.com>
Date:   Thu Jul 30 12:04:28 2009 +1000

    mach64: bump for release 6.8.2

diff --git a/configure.ac b/configure.ac
index 68e2a5f..2e6bc91 100644
--- a/configure.ac
+++ b/configure.ac
 <at>  <at>  -22,7 +22,7  <at>  <at> 

 AC_PREREQ(2.57)
 AC_INIT([xf86-video-mach64],
-        6.8.1,
+        6.8.2,
         [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
         xf86-video-mach64)

(Continue reading)

Brice Goglin | 1 Aug 01:23 2009
Picon

xserver-xorg-video-mach64: Changes to 'debian-unstable'

 COPYING               |  109 +++++++++++++++++++++++++++++++++++++++++---
 ChangeLog             |   54 ++++++++++++++++++++++
 README                |   13 +++--
 configure.ac          |    6 ++
 debian/README.source  |   73 +++++++++++++++++++++++++++++
 debian/changelog      |    7 +-
 debian/control        |    3 -
 debian/copyright      |  122 ++++++++++++++++++++++----------------------------
 debian/rules          |    4 -
 debian/xsfbs/xsfbs.sh |   12 ----
 src/atibus.c          |    3 -
 src/atimach64.c       |    5 ++
 src/atimach64render.c |    6 ++
 src/atipreinit.c      |   18 ++++++-
 src/atistruct.h       |    8 ++-
 15 files changed, 338 insertions(+), 105 deletions(-)

New commits:
commit ae5ac9d3cab04e087368c1c11ff70f0254a7d8eb
Author: Brice Goglin <bgoglin <at> debian.org>
Date:   Sat Aug 1 01:17:08 2009 +0200

    Prepare changelog for upload

diff --git a/debian/changelog b/debian/changelog
index 9daf644..e63557e 100644
--- a/debian/changelog
+++ b/debian/changelog
 <at>  <at>  -1,4 +1,4  <at>  <at> 
-xserver-xorg-video-mach64 (6.8.2-1) UNRELEASED; urgency=low
(Continue reading)

Brice Goglin | 1 Aug 01:23 2009
Picon

xserver-xorg-video-mach64: Changes to 'refs/tags/xserver-xorg-video-mach64-6.8.2-1'

Tag 'xserver-xorg-video-mach64-6.8.2-1' created by Brice Goglin <bgoglin <at> debian.org> at 2009-07-31
23:23 +0000

Tagging upload of xserver-xorg-video-mach64 6.8.2-1 to unstable.

Changes since xserver-xorg-video-mach64-6.8.0+git20090201.d394e0b8-2:
Aaron Plattner (1):
      Make sure the screen is a mach64 screen before doing anything in ATIMach64XVInitialiseAdaptor.

Adam Jackson (1):
      Don't print the resource list on failure.

Alan Coopersmith (5):
      Add README with pointers to mailing list, bugzilla & git repos
      Convert to XORG_CWARNFLAGS & XORG_CHANGELOG
      Version 6.8.1
      Doublecheck pictFormat is a supported format
      Fill in COPYING file, add SubmittingPatches URL to README

Brice Goglin (10):
      Move -dbg package to section debug
      Merge tag 'xf86-video-mach64-6.8.1' into debian-unstable
      New upstream release
      The X server now uses a built-in table to choose drivers.
      Merge branch 'debian-unstable' of git://git.debian.org/pkg-xorg/xsfbs into debian-unstable
      Bump Standards-Version to 3.8.2 now that we have README.source
      Bring back the patching system
      New upstream release
      Update debian/copyright from upstream COPYING
      Prepare changelog for upload
(Continue reading)

Archive Administrator | 1 Aug 01:26 2009
Picon

Processing of xserver-xorg-video-mach64_6.8.2-1_i386.changes

xserver-xorg-video-mach64_6.8.2-1_i386.changes uploaded successfully to localhost
along with the files:
  xserver-xorg-video-mach64_6.8.2-1.dsc
  xserver-xorg-video-mach64_6.8.2.orig.tar.gz
  xserver-xorg-video-mach64_6.8.2-1.diff.gz
  xserver-xorg-video-mach64_6.8.2-1_i386.deb
  xserver-xorg-video-mach64-dbg_6.8.2-1_i386.deb

Greetings,

	Your Debian queue daemon

Archive Administrator | 1 Aug 01:33 2009
Picon

xserver-xorg-video-mach64_6.8.2-1_i386.changes ACCEPTED


Accepted:
xserver-xorg-video-mach64-dbg_6.8.2-1_i386.deb
  to pool/main/x/xserver-xorg-video-mach64/xserver-xorg-video-mach64-dbg_6.8.2-1_i386.deb
xserver-xorg-video-mach64_6.8.2-1.diff.gz
  to pool/main/x/xserver-xorg-video-mach64/xserver-xorg-video-mach64_6.8.2-1.diff.gz
xserver-xorg-video-mach64_6.8.2-1.dsc
  to pool/main/x/xserver-xorg-video-mach64/xserver-xorg-video-mach64_6.8.2-1.dsc
xserver-xorg-video-mach64_6.8.2-1_i386.deb
  to pool/main/x/xserver-xorg-video-mach64/xserver-xorg-video-mach64_6.8.2-1_i386.deb
xserver-xorg-video-mach64_6.8.2.orig.tar.gz
  to pool/main/x/xserver-xorg-video-mach64/xserver-xorg-video-mach64_6.8.2.orig.tar.gz

Override entries for your package:
xserver-xorg-video-mach64-dbg_6.8.2-1_i386.deb - extra debug
xserver-xorg-video-mach64_6.8.2-1.dsc - source x11
xserver-xorg-video-mach64_6.8.2-1_i386.deb - optional x11

Announcing to debian-devel-changes <at> lists.debian.org

Thank you for your contribution to Debian.

--

-- 
To UNSUBSCRIBE, email to debian-x-REQUEST <at> lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster <at> lists.debian.org

Mario 'BitKoenig' Holbe | 1 Aug 05:18 2009
Picon
Picon

Bug#539455: libdrm-intel1: crashes glxgears

Package: libdrm-intel1
Version: 2.4.9-1

Hello,

starting with 2.4.9-1 and up to 2.4.12-1 libdrm-intel1 crashes glxgears:
$ glxgears
Failed to initialize GEM.  Falling back to classic.
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
../../../libdrm/intel/intel_bufmgr_gem.c:689: Error preparing buffer map -1211144498 ((null)):
Invalid argument .
glxgears: vbo/vbo_save_api.c:216: map_vertex_store: Assertion `vertex_store->buffer' failed.

Newer versions even dump a core. I found this on 2.4.12-1 first and
successively downgraded libdrm2 and libdrm-intel1 (and only them). The
problem persists down to 2.4.9-1. 2.4.5-2 was the first version where
glxgears did work:
$ glxgears
2429 frames in 5.0 seconds = 485.743 FPS

Other packages probably of interest:
$ COLUMNS=72 dpkg -l linux-image-2.6.30-1-686-bigmem xserver-xorg-video-intel libgl1-mesa-dri
libgl1-mesa-glx libglu1-mesa mesa-utils | grep ^.i
ii  libgl1-mesa-dr 7.5-3          A free implementation of the OpenGL API -- D
ii  libgl1-mesa-gl 7.5-3          A free implementation of the OpenGL API -- G
ii  libglu1-mesa   7.5-3          The OpenGL utility library (GLU)
ii  linux-image-2. 2.6.30-4       Linux 2.6.30 image on PPro/Celeron/PII/PIII/
ii  mesa-utils     7.5-3          Miscellaneous Mesa GL utilities
hi  xserver-xorg-v 2:2.7.1-1      X.Org X server -- Intel i8xx, i9xx display d
(Continue reading)

Lee Begg | 1 Aug 06:31 2009
Picon

Bug#539457: drm-modules-source: Fails to uninstall drm-modules, dpkg-divert: mismatch on package

Package: drm-modules-source
Version: 2.4.11+git+20090630+de1ed01-1
Severity: normal

The drm-modules package can not be uninstalled due to a mismatch of package 
name on
diversions created.

Removing drm-modules-2.6.30-1-686 ...
Removing `diversion of /lib/modules/2.6.30-1-686/kernel/drivers/gpu/drm/drm.ko 
to /lib/modules/2.6.30-1-686/kernel/drivers/gpu/drm/drm.ko.linux by drm-
modules-2.6.30-1-686'
dpkg-divert: mismatch on package
  when removing `diversion of 
/lib/modules/2.6.30-1-686/kernel/drivers/gpu/drm/i810/i810.ko to 
/lib/modules/2.6.30-1-686/kernel/drivers/gpu/drm/i810/i810.ko.linux by drm-
modules-2.6.30-1-686'
  found `diversion of 
/lib/modules/2.6.30-1-686/kernel/drivers/gpu/drm/i810/i810.ko to 
/lib/modules/2.6.30-1-686/kernel/drivers/gpu/drm/i810/i810.ko.linux by drm-
modules-2.6.30-1-686-amd64'
dpkg: error processing drm-modules-2.6.30-1-686 (--remove):
 subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
 drm-modules-2.6.30-1-686
E: Sub-process /usr/bin/dpkg returned an error code (1)

The diversion involved are below. Note that it was the drm-
modules-2.6.30-1-686 
package that created the diversions, but dpkg-divert thinks 
(Continue reading)

Brice Goglin | 1 Aug 08:43 2009

Bug#539455: libdrm-intel1: crashes glxgears

retitle 539455 libdrm-intel1: assert vertex_store->buffer failed on
non-GEM kernel
thank you

Mario 'BitKoenig' Holbe wrote:
> Package: libdrm-intel1
> Version: 2.4.9-1
>
> Hello,
>
> starting with 2.4.9-1 and up to 2.4.12-1 libdrm-intel1 crashes glxgears:
> $ glxgears
> Failed to initialize GEM.  Falling back to classic.
> Running synchronized to the vertical refresh.  The framerate should be
> approximately the same as the monitor refresh rate.
> ../../../libdrm/intel/intel_bufmgr_gem.c:689: Error preparing buffer map -1211144498 ((null)):
Invalid argument .
> glxgears: vbo/vbo_save_api.c:216: map_vertex_store: Assertion `vertex_store->buffer' failed.
>
> Newer versions even dump a core. I found this on 2.4.12-1 first and
> successively downgraded libdrm2 and libdrm-intel1 (and only them). The
> problem persists down to 2.4.9-1. 2.4.5-2 was the first version where
> glxgears did work:
> $ glxgears
> 2429 frames in 5.0 seconds = 485.743 FPS
>   

I guess this does not happen if you use a GEM kernel (ie not your bigmem
kernel), right? Note that you don't have direct rendering here since
Intel driver 2.8 doesn't support DRI1, and DRI2 requires UXA/GEM.
(Continue reading)

Debian Bug Tracking System | 1 Aug 08:48 2009
Picon

Processed (with 1 errors): Re: Bug#539455: libdrm-intel1: crashes glxgears

Processing commands for control <at> bugs.debian.org:

> retitle 539455 libdrm-intel1: assert vertex_store->buffer failed on
Bug #539455 [libdrm-intel1] libdrm-intel1: crashes glxgears
Changed Bug title to 'libdrm-intel1: assert vertex_store->buffer failed on' from 'libdrm-intel1:
crashes glxgears'
> non-GEM kernel
Unknown command or malformed arguments to command.

> thank you
Stopping processing here.

Please contact me if you need assistance.

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Brice Goglin | 1 Aug 09:12 2009
Picon

xorg-server: Changes to 'upstream-unstable'

 Xext/xselinux.c                  |    4 ++++
 config/hal.c                     |   37 ++++++++++++++++++++++++++-----------
 configure.ac                     |    6 +++---
 hw/xfree86/modes/xf86EdidModes.c |    5 +++++
 4 files changed, 38 insertions(+), 14 deletions(-)

New commits:
commit f274e595ed56722450f6ecebad70500c92e50c58
Author: Keith Packard <keithp <at> keithp.com>
Date:   Fri Jul 31 23:37:53 2009 -0700

    Bump release number to 1.6.3

    Signed-off-by: Keith Packard <keithp <at> keithp.com>

diff --git a/configure.ac b/configure.ac
index c8aedc9..fe7978f 100644
--- a/configure.ac
+++ b/configure.ac
 <at>  <at>  -26,12 +26,12  <at>  <at>  dnl
 dnl Process this file with autoconf to create configure.

 AC_PREREQ(2.57)
-AC_INIT([xorg-server], 1.6.2.901,
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xorg-server)
+AC_INIT([xorg-server], 1.6.3, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xorg-server)
 AC_CONFIG_SRCDIR([Makefile.am])
 AM_INIT_AUTOMAKE([dist-bzip2 foreign])
 AM_MAINTAINER_MODE

(Continue reading)


Gmane